Autor Tópico: Instalação do Ubuntu não cria shimx64 e nem mesmo grubx64.efi após desfazer dual  (Lida 441 vezes)

Offline luanptta

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Olá, pessoal.

Fui instalar o Ubuntu em dual boot com o Windows 10 ontem e como referência de particionamento utilizei um vídeo (Como fazer DUAL BOOT com Windows 10 e Linux - Tutorial FÁCIL - 2020 - YouTube) do Diolinux.

A instalação do Ubuntu foi feita em um HD SATA 2.5, e o Windows 10 está em um SSD M2.

Após terminar a instalação, reiniciei removendo a mídia como o Ubuntu solicita, e estranhamente bootou direto no Windows.

Fui ver a BIOS como estava, e não havia criado nenhuma opção de GRUB. Mudei a ordem pra esse HD do Ubuntu e bootou naquela tela falando que não tinha SO e era pra inserir um disco.

No Windows, testei o EasyUEFI pra analisar e:

  • O Ubuntu estava em última opção, com o status “hidden” (apesar de no print estar normal pela alteração) e o file path estava para o EFI/ubuntu/shimx64, mas quando fui editar e ver a pasta EFI, esse arquivo não estava lá.
  • Editei para o bootx64 como diz no print. Não sei do que é esse arquivo mas pra testar.
    Mesmo assim, o boot ficava em loop. Tentava bootar e desligava.
  • Detalhe importante: Antes de fazer esse dual boot, eu havia desfeito outro dual boot que possuía o Kubuntu, e além de excluir as partições do Linux no Disk Manager excluí o grub via CMD (no diretório /EFI mesmo), então acho que foi isso.

Porém, como faço para recuperar, recriar ou por o shimx64 ou grubx64.efi lá?

Importante:

  • O Secure Boot está DESATIVADO (então poderia/deveria ser o grubx64.efi);
  • O Fast boot também está desativado;
  • Já tentei o Boot Repair do Ubuntu, mas ao rodar tudo ele exibe uma mensagem:

Acontece que nas pesquisas que fiz todas as mensagens de erro do Boot Repair falam “current session is in LEGACY mode.”, quando aqui mostra em bios-compatibility, que nem sei o que é e não achei opção pra isso na Bios.

Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 285
    • Ver perfil
    • CHANGAN Auto
Re:Instalação do Ubuntu não cria shimx64 e nem mesmo grubx64.efi após desfazer dual
« Resposta #1 Online: 19 de Fevereiro de 2021, 12:07 »
Tem que correr o Boot Repair em modo UEFI.