Autor Tópico: [Resolvido] Wifi parou após atualização Ubuntu Studio  (Lida 1650 vezes)

Offline Chedinho

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
[Resolvido] Wifi parou após atualização Ubuntu Studio
« Online: 10 de Dezembro de 2020, 19:31 »
Fala galera!

Sou muito leigo. Peço paciência... rsrs
Uso Ubuntu Studio (não sei onde olho a versão) e realizei uma atualização automática há uma semana.
Após reiniciar, o wifi não funcionou mais.  O ícone de wifi não aparece mais, ficando apenas o de conexão cabeada (com um "x" sem o cabo, mas ativo/ funciona quando conecto o cabo). Desde então, só consigo conectar via cabo.

Pesquisei alguns comandos de alguns tópicos e descobri que a interface sem fio está desabilitada. Tentei muitas coisas, mas não tive êxito. Ajudem, por favor?!

Comandos que usei + resultados:

sudo lshw -C network
 *-network                 
       descrição: Ethernet interface
       produto: RTL810xE PCI Express Fast Ethernet controller
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:02:00.0
       nome lógico: enp2s0
       versão: 01
       serial: 00:1d:92:7a:9b:a5
       tamanho: 100Mbit/s
       capacidade: 100Mbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8169 duplex=full ip=10.0.0.159 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       recursos: irq:17 porta de E/S:d800(tamanho=256) memória:feaff000-feafffff memória:feac0000-feadffff
  *-network DESABILITADO
       descrição: Interface sem fio
       produto: RT2561/RT61 802.11g PCI
       fabricante: Ralink corp.
       ID físico: 1
       informações do barramento: pci@0000:03:01.0
       nome lógico: wlp3s1
       versão: 00
       serial: 00:06:4f:69:29:d4
       largura: 32 bits
       clock: 33MHz
       capacidades: pm bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=rt61pci driverversion=5.4.0-56-lowlatency firmware=0.8 latency=64 link=no multicast=yes wireless=IEEE 802.11
       recursos: irq:17 memória:febf8000-febfffff


ifconfig -a
enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.159  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 2804:2f5c:400:15e0:fdcf:b610:398e:e013  prefixlen 64  scopeid 0x0<global>
        inet6 2804:2f5c:400:15e0:90a3:5a39:cd6c:cf3  prefixlen 64  scopeid 0x0<global>
        inet6 ::ffff:5c3f:f9d6:a8b9:24ba  prefixlen 64  scopeid 0x0<global>
        inet6 ::ffff:90a3:5a39:cd6c:cf3  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::c986:d6f2:1ecc:ebe2  prefixlen 64  scopeid 0x20<link>
        ether 00:1d:92:7a:9b:a5  txqueuelen 1000  (Ethernet)
        RX packets 8098  bytes 7022526 (7.0 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6713  bytes 989092 (989.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Loopback Local)
        RX packets 1003  bytes 97705 (97.7 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1003  bytes 97705 (97.7 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s1: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:06:4f:69:29:d4  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


iwconfig
enp2s0    no wireless extensions.

wlp3s1    IEEE 802.11  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
lo        no wireless extensions.


nmcli dev list (não reconheceu o 'list')
 nmcli dev

DEVICE  TYPE      STATE            CONNECTION       
enp2s0  ethernet  conectado        Conexão cabeada 1
wlp3s1  wifi      não disponível   --               
lo      loopback  não gerenciável  --
 
nmcli dev wifi list
IN-USE  BSSID  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY


rfkill list wifi
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no


route -n
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
0.0.0.0         10.0.0.1        0.0.0.0         UG    100    0        0 enp2s0
10.0.0.0        0.0.0.0         255.255.255.0   U     100    0        0 enp2s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp2s0


sudo apt -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  dkms gnome-software-common libappstream-glib8 libgspell-1-2
  libgspell-1-common libllvm9 python3-click
Utilize 'sudo apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 1 não atualizados.


sudo systemctl status NetworkManager.service --full
NetworkManager.service - Network Manager
     Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendo>
     Active: active (running) since Thu 2020-12-10 18:24:10 -03; 32min ago
       Docs: man:NetworkManager(8)
   Main PID: 920 (NetworkManager)
      Tasks: 3 (limit: 3514)
     Memory: 13.6M
     CGroup: /system.slice/NetworkManager.service
             └─920 /usr/sbin/NetworkManager --no-daemon

dez 10 18:24:41 chedinho-POS-MI945AA NetworkManager[920]: <warn>  [1607635481.8>
dez 10 18:24:41 chedinho-POS-MI945AA NetworkManager[920]: <error> [1607635481.8>
dez 10 18:24:41 chedinho-POS-MI945AA NetworkManager[920]: <info>  [1607635481.8>
dez 10 18:24:51 chedinho-POS-MI945AA NetworkManager[920]: <warn>  [1607635491.8>
dez 10 18:24:51 chedinho-POS-MI945AA NetworkManager[920]: <error> [1607635491.8>
dez 10 18:24:51 chedinho-POS-MI945AA NetworkManager[920]: <info>  [1607635491.8>
dez 10 18:25:01 chedinho-POS-MI945AA NetworkManager[920]: <warn>  [1607635501.8>
dez 10 18:25:01 chedinho-POS-MI945AA NetworkManager[920]: <error> [1607635501.8>
dez 10 18:25:01 chedinho-POS-MI945AA NetworkManager[920]: <info>  [1607635501.8>
dez 10 18:25:01 chedinho-POS-MI945AA NetworkManager[920]: <info>  [1607635501.8>
lines 1-20/20 (END)


--x--
« Última modificação: 12 de Janeiro de 2021, 17:00 por Chedinho »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Wifi parou após atualização Ubuntu Studio
« Resposta #1 Online: 11 de Dezembro de 2020, 08:29 »
Olá Chedinho,

Execute os comandos abaixo e cole o resultado aqui. Não deve consertar seu problema, mas espero que nos dê uma pista melhor sobre o que está acontecendo.

sudo modprobe -r rt61pci
sudo modprobe -v rt61pci
dmesg | tail
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Chedinho

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re:Wifi parou após atualização Ubuntu Studio
« Resposta #2 Online: 28 de Dezembro de 2020, 15:52 »
Opa!

Perdão pela demora (gigantesca) heheh

Aí vão os resultados:


sudo modprobe -r rt61pci
nada apareceu.

sudo modprobe -v rt61pci

insmod /lib/modules/5.4.0-56-lowlatency/kernel/lib/crc-itu-t.ko
insmod /lib/modules/5.4.0-56-lowlatency/kernel/drivers/misc/eeprom/eeprom_93cx6.ko
insmod /lib/modules/5.4.0-56-lowlatency/kernel/drivers/net/wireless/ralink/rt2x00/rt2x00lib.ko
insmod /lib/modules/5.4.0-56-lowlatency/kernel/drivers/net/wireless/ralink/rt2x00/rt2x00mmio.ko
insmod /lib/modules/5.4.0-56-lowlatency/kernel/drivers/net/wireless/ralink/rt2x00/rt2x00pci.ko
insmod /lib/modules/5.4.0-56-lowlatency/kernel/drivers/net/wireless/ralink/rt2x00/rt61pci.ko


dmesg | tail
[  420.017085] genirq: Flags mismatch irq 17. 00002080 (rt61pci) vs. 00010080 (enp2s0)
[  420.017097] ieee80211 phy1: rt2x00mmio_initialize: Error - IRQ 17 allocation failed (error -16)
[  430.016109] genirq: Flags mismatch irq 17. 00002080 (rt61pci) vs. 00010080 (enp2s0)
[  430.016127] ieee80211 phy1: rt2x00mmio_initialize: Error - IRQ 17 allocation failed (error -16)
[  430.019093] genirq: Flags mismatch irq 17. 00002080 (rt61pci) vs. 00010080 (enp2s0)
[  430.019108] ieee80211 phy1: rt2x00mmio_initialize: Error - IRQ 17 allocation failed (error -16)
[  440.012113] genirq: Flags mismatch irq 17. 00002080 (rt61pci) vs. 00010080 (enp2s0)
[  440.012129] ieee80211 phy1: rt2x00mmio_initialize: Error - IRQ 17 allocation failed (error -16)
[  440.015071] genirq: Flags mismatch irq 17. 00002080 (rt61pci) vs. 00010080 (enp2s0)
[  440.015082] ieee80211 phy1: rt2x00mmio_initialize: Error - IRQ 17 allocation failed (error -16)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Wifi parou após atualização Ubuntu Studio
« Resposta #3 Online: 30 de Dezembro de 2020, 11:09 »
Me parece que o kernel que você está usando (5.4.0-56-lowlatency) não está configurado para aceitar o dispositivo do wi-fi.

Eu não conheço o Ubuntu Studio. Sabe dizer se esse kernel é padrão dele, ou foi você que instalou essa versão?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 290
    • Ver perfil
    • CHANGAN Auto
Re:Wifi parou após atualização Ubuntu Studio
« Resposta #4 Online: 30 de Dezembro de 2020, 18:24 »
Me parece que o kernel que você está usando (5.4.0-56-lowlatency) não está configurado para aceitar o dispositivo do wi-fi.

Eu não conheço o Ubuntu Studio. Sabe dizer se esse kernel é padrão dele, ou foi você que instalou essa versão?
Kernel "low latency" é o padrão no Ubuntu Studio.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Wifi parou após atualização Ubuntu Studio
« Resposta #5 Online: 31 de Dezembro de 2020, 07:50 »
Kernel "low latency" é o padrão no Ubuntu Studio.
Hum-hum. Talvez seja o caso de testar outra linha de kernels. A começar pelo kernel padrão ("generic").
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Chedinho

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re:Wifi parou após atualização Ubuntu Studio
« Resposta #6 Online: 09 de Janeiro de 2021, 12:02 »
Kernel "low latency" é o padrão no Ubuntu Studio.
Hum-hum. Talvez seja o caso de testar outra linha de kernels. A começar pelo kernel padrão ("generic").

Estranho, pois estava funcionando antes da atualização.
Como faço isso?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Wifi parou após atualização Ubuntu Studio
« Resposta #7 Online: 11 de Janeiro de 2021, 14:52 »
Pra instalar o kernel genérico/padrão do Ubuntu, use:

sudo apt install linux-image-generic

Mas se você diz que antes de uma atualização o problema não existia, pode também voltar à versão anterior do próprio kernel "Low Latency" que funcionava. Infelizmente isso é um pouco mais complicado, bastante "tentativa-e-erro", e passa por entender que tipo de atualização foi feita. Se bem que, sendo uma atualização automática, é possível que o problema já tenha sido detectado e corrigido; talvez seja resolvido numa atualização posterior.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Chedinho

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re:Wifi parou após atualização Ubuntu Studio
« Resposta #8 Online: 12 de Janeiro de 2021, 16:50 »
Pra instalar o kernel genérico/padrão do Ubuntu, use:
sudo apt install linux-image-generic

Mas se você diz que antes de uma atualização o problema não existia, pode também voltar à versão anterior do próprio kernel "Low Latency" que funcionava. Infelizmente isso é um pouco mais complicado, bastante "tentativa-e-erro", e passa por entender que tipo de atualização foi feita. Se bem que, sendo uma atualização automática, é possível que o problema já tenha sido detectado e corrigido; talvez seja resolvido numa atualização posterior.

Foi exatamente isso!

Liguei a internet cabeada e fiz a atualização hoje. O problema foi corrigido! (enviando esta mensagem com conexão wifi e com alegria)

Esperei a atualização ser instalada para tentar o comando sugerido, mas não precisou.

Muito obrigado pelas ajudas!

Apesar de o problema ter se resolvido na atualização, vou dar o tópico como resolvido.

Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 290
    • Ver perfil
    • CHANGAN Auto
Re:[Resolvido] Wifi parou após atualização Ubuntu Studio
« Resposta #9 Online: 14 de Janeiro de 2021, 08:24 »
Melhor assim!

É que o Ubuntu Studio tem o kernel "low latency" por razões que se prendem com a a produção audivisual. É parte integrante e essencial dessa distro especializada.

Instalar o kernel genérico tal como foi sugerido poderia ter sido uma forma de diagnóstico (e tudo funcionaria também com este kernel) e poderia facilmente escolher com qual arrancar, mas na verdade o Studio está feito para funcionar com o kernel "low latency" mesmo, senão seria apenas uma coleção de software adicional preinstalado.