Autor Tópico: Kubuntu 20.04 não funciona com microfone boya M1  (Lida 2703 vezes)

Offline Niltonif

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Kubuntu 20.04 não funciona com microfone boya M1
« Online: 26 de Janeiro de 2021, 19:04 »
Olá a todos,

Adquiri um notebook Acer nitro 5, que veio com endless OS, mas formatei e instalei a distribuição kubuntu, da qual gostei bastante. No entanto, não consigo fazer  o microfone externo, da marca boya M1, funcionar no sistema. Já pesquisei no Google, mas nenhuma das possíveis soluções que encontrei resolve o problema. Ao plugar o microfone, o sistema reconhece como headset, no entanto, não capta o som, e não reproduz nenhum som de audio enquanto o microfone está conectado. Já mexi nas configurações de áudio, no alsamixer, mas nada de resolver. Desplugando o boya, o microfone interno e a saída de som funcionam, porém, o som gravado fica muito cheio de ruído e chiado.

Se alguém puder me ajudar...

Estou mantendo o win10 em dual boot, pois ele quem tá me salvando nas videoaulas com o microfone ( sou professor), no entanto, gostaria de usar apenas o Linux e não depender mais do windows.

Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 281
    • Ver perfil
    • CHANGAN Auto
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #1 Online: 26 de Janeiro de 2021, 20:31 »
O notebook só tem uma saída/entrada para áudio, certo? Similar a um tablet ou celular, certo?

Offline Niltonif

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #2 Online: 26 de Janeiro de 2021, 21:59 »
Sim. Somente um conector.
Já tentei também com um headphone bluetooth, mas não deu certo também. No caso do Headphone, ele aparece nas configurações de audio, eu coloco ele como padrão, dou ok, no entanto, assim como com o microfone Boya M1, ao tentar gravar, usando o audacity, não capta nenhuma som.
« Última modificação: 26 de Janeiro de 2021, 22:39 por Niltonif »

Offline jopeu

  • Usuário Ubuntu
  • *
  • Mensagens: 521
    • Ver perfil
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #3 Online: 27 de Janeiro de 2021, 08:41 »
Eu tive problema similar.
Resolvi colocando o jack audio pelo gerenciador Muon, mas pode ser feito pelo synaptic

Espero que resolva pronto

Offline Niltonif

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #4 Online: 27 de Janeiro de 2021, 09:51 »
Não entendi bem. Se puder me explicar melhor, como fez, ficarei agradecido.

Será que o problema afeta apenas o kde?

Se for o caso, mesmo gostando bastante da interface, poderia migrar para outra...


Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 281
    • Ver perfil
    • CHANGAN Auto
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #5 Online: 27 de Janeiro de 2021, 10:22 »
Sim. Somente um conector.
Já tentei também com um headphone bluetooth, mas não deu certo também. No caso do Headphone, ele aparece nas configurações de audio, eu coloco ele como padrão, dou ok, no entanto, assim como com o microfone Boya M1, ao tentar gravar, usando o audacity, não capta nenhuma som.
O microfone tem um seletor para "smartphone". Creio que é essa a posição para a entrada/saída única (que é igual).
Depois depende da placa de áudio integrada. Algumas automaticamente ativam o microfone conectado e desativam o interno e em outras é necessário selecionar explicitamente. Infelizmente não posso dar instruções mais precisas pois não uso KDE. No Ubuntu normal (Gnome) seria em Definições > Som > Entrada e aí selecionar no menu.

Quanto ao Bluetooh  esse é mais complicado. Por defeito auriculares Bluetooth estéreo usam o perfil A2DP (áudio HiFi estéreo, sem microfone) e é necessário alterar para HFP ("hands free", áudio mono + microfone) e nem sempre o suporte para este perfil está instalado e/ou não funciona bem com alguns dispositivos. Em suma, é complicado.

Offline Niltonif

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #6 Online: 27 de Janeiro de 2021, 10:36 »
Quando eu conector o microfone externo, ele reconhece automaticamente o dispositivo e muda as configurações, no entanto, quando uso aplicativos para gravar áudio, ou não grava nada ou apenas um chiado.
Eis o problema.

Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 281
    • Ver perfil
    • CHANGAN Auto
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #7 Online: 27 de Janeiro de 2021, 12:42 »
Já experimentou com as duas posições?

Offline Niltonif

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #8 Online: 27 de Janeiro de 2021, 15:14 »
Já experimentou com as duas posições?

Testei mudar para posição smartphone e captou som (finalmente). Estranho, pois no win10 ele só funciona na outra posição, ou seja, "ligado". A posição smartphone é a mesma coisa que desligado.

O som não saiu lá essas coisas, mas pelo menos saiu. Vou mexer nas configurações pra ver se melhora. No entanto, enquanto conectado o microfone externo, não sai som nos altofalantes internos do notebook. Olhei nas configurações e não me dá opção de escolher o microfone externo, como entrada, e os altofalantes do notebook, ao mesmo tempo.
Para ouvir o som, tenho que desconectar o microfone.

Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 281
    • Ver perfil
    • CHANGAN Auto
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #9 Online: 27 de Janeiro de 2021, 16:26 »
Isso acontece porque no Windows o driver proprietário e otimizado "re-assigna" as conexões (anéis) do conector.
O driver genérico e não otimizado não faz isso.

Offline Niltonif

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #10 Online: 27 de Janeiro de 2021, 17:00 »
Obrigado pela ajuda.

Agora já consigo gravar...

Apesar desse comportamento de não sair nenhum som, enquanto o microfone tá conectado, já consigo fazer algo.

Pensa, eu sofrendo há dias, e o problema era tão simples de resolver. Aconteceu algo semelhante com minha impressora Canon, mas com ela foi mais rápido achar a solução.

Valeu CelticWarrior.

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 627
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #11 Online: 28 de Janeiro de 2021, 16:58 »
Olá a todos,

Dá para colocar aqui a saída do seguinte comando?

Código: [Selecionar]
inxi -A
Ex:
Código: [Selecionar]
pcreto@pcreto:~$ inxi -A
Audio:
  Device-1: AMD Wrestler HDMI Audio driver: snd_hda_intel
  Device-2: AMD SBx00 Azalia driver: snd_hda_intel
  Sound Server: ALSA v: k5.10.11-xanmod1
pcreto@pcreto:~$

T+
A vida, é feito andar de bicicleta, se parar, você cai! (Gabriel Contino)
Blog do Paulo Corrêa Creto

Offline Niltonif

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #12 Online: 30 de Janeiro de 2021, 23:29 »
Olá,

O comando me reportou o seguinte:

Nitro-AN515-43:~$ inxi -A
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.4.0-65-generic

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 627
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #13 Online: 01 de Fevereiro de 2021, 17:32 »
Olá,

Posso estar errado mas,

Olá,

O comando me reportou o seguinte:

Nitro-AN515-43:~$ inxi -A
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.4.0-65-generic


Esse caso ai é mais ou menos o que eu tenho aqui, veja bem, cada caso é um caso, mas se reparar na sua saída do terminal verá que além de ser uma AMD e que nesses caso a coisa do áudio é estranha, porém não complicada, vou com comandos tentar abrir as idéias aqui certo?!

 - Primeiro veja só as imagens do meu computador:

Clique na imagem para ampliar

- No meu caso aqui que é uma AMD/ATI também tenho esse (digamos) pormenor, então:



Clique nas imagens para ampliar

- Depois de visto as imagens do meu alsamixer, é todo AMD/ATI tem isso ai tem que escolher com "F6" escolhe a segunda placa para ter os controles, mas ressalto, aqui não tenho HDMI, poréḿ mesmo assim escolha a segunda placa no alsamixer vá no controle microfone e olhe lá se não está marcado "MM" e tecle M e volte a testar seu microfone

Meu hardware:
Código: [Selecionar]
pbsc@pbsc:~$ inxi -AS
System:
  Host: pbsc Kernel: 5.10.12-xanmod1 x86_64 bits: 64 Desktop: KDE Plasma 5.20.4
  Distro: BigLinux based in Ubuntu 20.04 (Focal)
Audio:
  Device-1: AMD Wrestler HDMI Audio driver: snd_hda_intel
  Device-2: AMD SBx00 Azalia driver: snd_hda_intel
  Sound Server: ALSA v: k5.10.12-xanmod1
pbsc@pbsc:~$

Qualquer coisa posta ai para o fórum tentar ser útil de alguma forma, irei ficar atento ao teu tópico, tentando fazer você não desistir de ser feliz usando o GNU/Linux ;)

PS: Ah, quase ia esquecendo dê uma boa garimpada nesse tópico aqui: "[Resolvido] Placa mãe BioStar B350ET2 sem som"

T+
« Última modificação: 01 de Fevereiro de 2021, 17:40 por creto »
A vida, é feito andar de bicicleta, se parar, você cai! (Gabriel Contino)
Blog do Paulo Corrêa Creto

Offline Niltonif

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Kubuntu 20.04 não funciona com microfone boya M1
« Resposta #14 Online: 01 de Fevereiro de 2021, 19:33 »
Agradeço a ajuda.

Depois de quebrar a cabeça, eu já havia entendido que precisaria pressionar F6 para escolher a placa de vídeo correta. Eu já mexi em praticamente todos os controles do alsamixer e, ao mesmo tempo, fui testando, mas não consegui fazer sair som estando o microfone externo conectado.

Mais tarde estarei executando suas sugestões, daí postarei aqui as imagens e resultados.

De antemão, agradeço a todos pela ajuda.

Muito obrigado.