Autor Tópico: Dificuldade para instalar o phpMyAdmin, no UBUNTU 19.04  (Lida 613 vezes)

Offline pedromferreira

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Dificuldade para instalar o phpMyAdmin, no UBUNTU 19.04
« Online: 19 de Novembro de 2019, 17:07 »
Gostaria de uma ajuda da comunidade para o seguinte problema:

Não estou conseguindo instalar o phpMyAdmin, no UBUNTU 19.04

Já instalei, com sucesso o APACHE, o MySQL e o PHP, mas quando tento instalar o phpMyAdmin, pelo caminho tradicional: “sudo apt install phpmyadmin”

Retorna com  esse erro: <E: O pacote 'phpmyadmin' não tem candidato para instalação>

De uma pesquisa que fiz, encontrei referências de que o phpMyAdmin  não estaria mais disponível nos repositórios tradicionais e por isso essa solução por “apt” não estaria mais funcionando.

Também encontrei referências de que uma possível  solução seria fazer o download diretamente do site  <https://www.phpmyadmin.net/> mas não sei como fazer essa instalação diretamente do site.

Obrigado.
« Última modificação: 03 de Dezembro de 2019, 11:15 por pedromferreira »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.663
    • Ver perfil
Re:Dificuldade para instalar o phpMyAdmin, no UBUNTU 19.04
« Resposta #1 Online: 19 de Novembro de 2019, 18:54 »
Oi pedromferreira. Estranho isso, eu tenho o Ubuntu 19.04 com phpMyadmin instalado nele.  Usei os repositórios mesmo.

Se não tem candidato deve ser por você não ter todos os repositórios ativos ai.  Inclusive os tutorias que encontrei todos usam a versão do repositório do Ubuntu desde a versão 18.04. 

Certifique-se que todos os repositorios estejam ativos:

updates
main
universe
muiltverse
bakcports
partner
security

Aqui vai o exemplo da minha lista oficial:



Código: [Selecionar]
# deb cdrom:[Kubuntu 19.04 _Disco Dingo_ - Release amd64 (20190416)]/ disco main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu disco main restricted
# deb-src http://ie.archive.ubuntu.com/ubuntu/ disco main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu disco-updates main restricted
# deb-src http://ie.archive.ubuntu.com/ubuntu/ disco-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu disco universe
# deb-src http://ie.archive.ubuntu.com/ubuntu/ disco universe
deb http://archive.ubuntu.com/ubuntu disco-updates universe
# deb-src http://ie.archive.ubuntu.com/ubuntu/ disco-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu disco multiverse
# deb-src http://ie.archive.ubuntu.com/ubuntu/ disco multiverse
deb http://archive.ubuntu.com/ubuntu disco-updates multiverse
# deb-src http://ie.archive.ubuntu.com/ubuntu/ disco-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu disco-backports main restricted universe multiverse
# deb-src http://ie.archive.ubuntu.com/ubuntu/ disco-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu disco partner
# deb-src http://archive.canonical.com/ubuntu disco partner

deb http://archive.ubuntu.com/ubuntu disco-security main restricted
# deb-src http://security.ubuntu.com/ubuntu disco-security main restricted
deb http://archive.ubuntu.com/ubuntu disco-security universe
# deb-src http://security.ubuntu.com/ubuntu disco-security universe
deb http://archive.ubuntu.com/ubuntu disco-security multiverse
# deb-src http://security.ubuntu.com/ubuntu disco-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 
Kubuntu 19.04 64bits

Offline pedromferreira

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re:Dificuldade para instalar o phpMyAdmin, no UBUNTU 19.04
« Resposta #2 Online: 20 de Novembro de 2019, 11:06 »
Olá galactus,

Obrigado por seu comentário.

Essa é a minha lista pode , pode verificar e comentar, por favor?

Obrigado.

root@pedro-Inspiron-1545:/home/pedro#     gedit /etc/apt/sources.list


# deb cdrom:[Ubuntu 19.10 _Eoan Ermine_ - Release amd64 (20191017)]/ eoan main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://br.archive.ubuntu.com/ubuntu/ eoan main restricted
# deb-src http://br.archive.ubuntu.com/ubuntu/ eoan main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://br.archive.ubuntu.com/ubuntu/ eoan-updates main restricted
# deb-src http://br.archive.ubuntu.com/ubuntu/ eoan-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ eoan universe
# deb-src http://br.archive.ubuntu.com/ubuntu/ eoan universe
deb http://br.archive.ubuntu.com/ubuntu/ eoan-updates universe
# deb-src http://br.archive.ubuntu.com/ubuntu/ eoan-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://br.archive.ubuntu.com/ubuntu/ eoan multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ eoan multiverse
deb http://br.archive.ubuntu.com/ubuntu/ eoan-updates multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ eoan-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ eoan-backports main restricted universe multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ eoan-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu eoan partner
# deb-src http://archive.canonical.com/ubuntu eoan partner

deb http://security.ubuntu.com/ubuntu eoan-security main restricted
# deb-src http://security.ubuntu.com/ubuntu eoan-security main restricted
deb http://security.ubuntu.com/ubuntu eoan-security universe
# deb-src http://security.ubuntu.com/ubuntu eoan-security universe
deb http://security.ubuntu.com/ubuntu eoan-security multiverse
# deb-src http://security.ubuntu.com/ubuntu eoan-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.663
    • Ver perfil
Re:Dificuldade para instalar o phpMyAdmin, no UBUNTU 19.04
« Resposta #3 Online: 20 de Novembro de 2019, 11:53 »
Agora entendi!

Sua versão do Ubuntu não e a 19.04, mas sim a 19.10!!!!

Sim, o phpmyadmin foi removido dos repositórios do Ubuntu 19.10 e do Debian 10 por questões de segurança:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=916310

https://bugs.launchpad.net/ubuntu/+source/phpmyadmin/+bug/1837775

https://ubuntuforums.org/showthread.php?t=2428229

Se quiser instalar vai ter que usar PPA, como o dono do PPA avisa, ele e mantenedor do pacote no Ubuntu e  no Debian, não use essa versão em um  sistema em produção! Por sua conta e risco:

https://launchpad.net/~phpmyadmin/+archive/ubuntu/ppa

Outra alternativa seria baixar o pacote .deb do Ubuntu packages de uma versão anterior do Ubuntu.

Na sua lista não estão ativos os repositórios Partner e nem o backports! 

Kubuntu 19.04 64bits

Offline pedromferreira

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re:Dificuldade para instalar o phpMyAdmin, no UBUNTU 19.04
« Resposta #4 Online: 03 de Dezembro de 2019, 11:09 »
Olá galactus,

Mais uma vez obrigado por seus comentários. 

Peço desculpas pela demora em retornar e também pela mancada de ter feito confusão entre a versão 19.04 e 19.10.

Segui sua sugestão de fazer a instalação do phpMyAdmin pelo PPA e sucesso !!! Deu certo !!!

Obrigado !!!