Autor Tópico: Servidor de Repositório local - Erros [RESOLVIDO]  (Lida 846 vezes)

Offline tcboeira

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • “Revolução é mudar tudo o que deve ser mudado”
    • Ver perfil
    • .:: CABEÇA LIVRE ::. Um lugar livre, para se pensar fora da caixa
Servidor de Repositório local - Erros [RESOLVIDO]
« Online: 08 de Outubro de 2019, 15:58 »
Prezados,

Bem, mais uma vez, recorro a todos pedindo mais aquela luz ao fim do túnel. Depois de muitas pesquisas ainda estou meio perdido.
A questão gira em torno de um repositório local para atualização das estações Ubuntu na minha rede.
Antes de tudo, creio que seja interessante relatar, que montei a maquina, com Ubuntu Server, instalei o Apache, instalei o apt-mirror – fiz a sua configuração, conforme abaixo:


############# config ##################
#
 set base_path    /var/spool/apt-mirror
#
# set mirror_path  $base_path/mirror
# set skel_path    $base_path/skel
# set var_path     $base_path/var
 set cleanscript $var_path/clean.sh
# set defaultarch  <running host architecture>
# set postmirror_script $var_path/postmirror.sh
# set run_postmirror 0
set nthreads     40
set _tilde 0
#
############# end config ##############

# 18.04 mirroring
deb-amd64 http://archive.ubuntu.com/ubuntu bionic main main/debian-installer restricted restricted/debian-installer universe multiverse
deb-amd64 http://archive.ubuntu.com/ubuntu bionic-security main restricted universe multiverse
deb-amd64 http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
deb-amd64 http://archive.ubuntu.com/ubuntu bionic-proposed main restricted universe multiverse
deb-amd64 http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse

deb-i386 http://archive.ubuntu.com/ubuntu bionic main main/debian-installer restricted restricted/debian-installer universe multiverse
deb-i386 http://archive.ubuntu.com/ubuntu bionic-security main restricted universe multiverse
deb-i386 http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
deb-i386 http://archive.ubuntu.com/ubuntu bionic-proposed main restricted universe multiverse
deb-i386 http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse



Após, Server atualizado, executei o comando “apt-mirror”. Sem erros. Sem falhas, tudo certo. Gerei o novo source.list – conforme abaixo:

deb http://MEU_SERVER/ubuntu bionic main
deb http://MEU_SERVER/ubuntu bionic-security  main
deb http://MEU_SERVER/ubuntu bionic-updates main


Instalei uma nova maquina (uma VM), com instalação mínima do Ubuntu 18.04. Fiz as alterações no “apt.conf”, inserindo minha senha para autenticação do proxy. A maquina navega e se comunica com a Internet….

$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=50 time=15.6 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=50 time=15.7 ms
^C
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 15.689/15.732/15.776/0.132 ms
administrador@PRO-PAE-LIVE:~$ ping 8.8.4.4
PING 8.8.4.4 (8.8.4.4) 56(84) bytes of data.
64 bytes from 8.8.4.4: icmp_seq=1 ttl=52 time=15.8 ms
64 bytes from 8.8.4.4: icmp_seq=2 ttl=52 time=15.8 ms
^C
--- 8.8.4.4 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 15.800/15.821/15.843/0.127 ms
administrador@PRO-PAE-LIVE:~$ ping www.google.com.br
PING www.google.com.br (172.217.172.195) 56(84) bytes of data.
64 bytes from gru14s14-in-f3.1e100.net (172.217.172.195): icmp_seq=1 ttl=52 time=17.0 ms
64 bytes from gru14s14-in-f3.1e100.net (172.217.172.195): icmp_seq=2 ttl=52 time=16.8 ms
^C
--- www.google.com.br ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 16.800/16.912/17.025/0.171 ms



Quando faço o update, ela retorna da seguinte forma:

sudo apt-get update
[sudo] senha para administrador:
Atingido:1 http://MEU-SERVER/ubuntu bionic InRelease
Obter:2 http://MEU-SERVER/ubuntu bionic-security InRelease [88,7 kB]
Obter:3 http://MEU-SERVER/ubuntu bionic-updates InRelease [88,7 kB]
Ign:4 http://MEU-SERVER/ubuntu bionic-security/main amd64 DEP-11 Metadata
Ign:5 http://MEU-SERVER/ubuntu bionic-security/main DEP-11 48x48 Icons
Ign:6 http://MEU-SERVER/ubuntu bionic-security/main DEP-11 64x64 Icons
Ign:7 http://MEU-SERVER/ubuntu bionic-updates/main i386 Packages
Ign:8 http://MEU-SERVER/ubuntu bionic-updates/main amd64 Packages
Ign:9 http://MEU-SERVER/ubuntu bionic-updates/main amd64 DEP-11 Metadata
Ign:10 http://MEU-SERVER/ubuntu bionic-updates/main DEP-11 48x48 Icons
Ign:11 http://MEU-SERVER/ubuntu bionic-updates/main DEP-11 64x64 Icons
Obter:4 http://MEU-SERVER/ubuntu bionic-security/main amd64 DEP-11 Metadata [38,5 kB]
Obter:5 http://MEU-SERVER/ubuntu bionic-security/main DEP-11 48x48 Icons [17,6 kB]
Obter:6 http://MEU-SERVER/ubuntu bionic-security/main DEP-11 64x64 Icons [41,5 kB]
Obter:7 http://MEU-SERVER/ubuntu bionic-updates/main i386 Packages [591 kB]
Obter:8 http://MEU-SERVER/ubuntu bionic-updates/main amd64 Packages [750 kB]
Obter:9 http://MEU-SERVER/ubuntu bionic-updates/main amd64 DEP-11 Metadata [295 kB]
Obter:10 http://MEU-SERVER/ubuntu bionic-updates/main DEP-11 48x48 Icons [78,3 kB]
Obter:11 http://MEU-SERVER/ubuntu bionic-updates/main DEP-11 64x64 Icons [143 kB]
Baixados 2.133 kB em 4s (494 kB/s)   
Lendo listas de pacotes... Pronto


Mas quando tento faz a instalação de pacotes iniciais, para inserir essa maquina no meu dominio, ele já me reporta erro:

$ sudo apt install net-tools -y ; sudo apt-get install ntp -y ; sudo apt-get install ntpdate -y ; sudo apt-get install x3270 -y ; sudo apt-get install dialog -y ; sudo apt install -y realmd sssd sssd-tools libnss-sss libpam-sss krb5-user adcli samba-common-bin ssh ncurses-term samba libpam-ccreds libpam-krb5 auth-client-config smbclient libsmbclient python-smbc -y && sudo apt-get install -f && sudo apt-get update
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
net-tools is already the newest version (1.60+git20161116.90da8a0-1ubuntu1).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 366 não atualizados.
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
O pacote ntp não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'ntp' não tem candidato para instalação
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote ntpdate
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote x3270
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
O pacote dialog não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'dialog' não tem candidato para instalação
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
O pacote realmd não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

O pacote krb5-user não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

O pacote adcli não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'realmd' não tem candidato para instalação
E: O pacote 'krb5-user' não tem candidato para instalação
E: O pacote 'adcli' não tem candidato para instalação
E: Impossível encontrar o pacote libpam-ccreds
E: Impossível encontrar o pacote auth-client-config
E: Impossível encontrar o pacote python-smbc


Se mantenho o sources.list padrão, não há nenhum problema.
Então, segue minha duvida/questão/necessidade de ajuda?

- Como especifico para meu repositório local, os pacotes que ele deve fornecer a minha rede local?

- Onde encontro os endereços certos para as PPAs ou alternativas?

- Como forneço para meu repositório local, determinados pacotes que podem ser instalados pelos usuários de minha rede local? Seria só inserir o DEB correspondente no “/etc/apt/sources.list.d/programa.list”, como no exemplo:
/etc/apt/sources.list.d/libre.list
deb http://ppa.launchpad.net/libreoffice/libreoffice-6-3/ubuntu  bionic main

- Se eu quiser disponibilizar diretamente algum arquivo.DEB, como fazer?


Agradeço antes de tudo a atenção que derem a essa situação!!!!
Abraços!!!
« Última modificação: 10 de Outubro de 2019, 11:21 por tcboeira »
| Thiago Boeira | Redes & TIC | CREA/RS 200288 | E-mail: tcboeira@gmail.com | Mobile/Whats +55 XX (51) 99114-6030 |
| Porto Alegre - RS | Brasil |

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.302
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Servidor de Repositório local - Erros
« Resposta #1 Online: 08 de Outubro de 2019, 16:01 »
Olá Thiago, eu não entendo muito bem da estrutura dos repositórios. Mas, não deveria haver alguma divisão em repositório "universe" (pacotes nativos) e "multiverse" (pacotes vindos de outras distros)?

EDIT: Vc disse que se usar os repositórios padrão, não há problemas na instalação. Faça o seguinte, então: pegue um desses pacotes que deu problema pra instalar do seu repo, e, usando os repos padrão, peça pra ver de onde ele vem. O comando pra isso, até onde me lembro, é:

apt-cache policy <pacote>

P.ex:

Código: [Selecionar]
$ apt-cache policy ntp
ntp:
  Installed: (none)
  Candidate: 1:4.2.8p4+dfsg-3ubuntu5.9
  Version table:
     1:4.2.8p4+dfsg-3ubuntu5.9 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     1:4.2.8p4+dfsg-3ubuntu5 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
« Última modificação: 08 de Outubro de 2019, 16:06 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline tcboeira

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • “Revolução é mudar tudo o que deve ser mudado”
    • Ver perfil
    • .:: CABEÇA LIVRE ::. Um lugar livre, para se pensar fora da caixa
Re:Servidor de Repositório local - Erros
« Resposta #2 Online: 08 de Outubro de 2019, 16:16 »
Obrigado pela ajuda zekkerj ...

Bem... É a primeira vez que "toco" em um servidor de repositório. Ele "foi" entregue faz uns 6/7 meses mas nunca foi posto de fato em produção.
Tive de atualizar, bem como corrigir questões de certificados e essas coisas ...

Quando tu fala de " divisão em repositório "universe" (pacotes nativos) e "multiverse" (pacotes vindos de outras distros)?" realmente não havia percebido isto, mas pior... Não sei se é para corrigir em "mirror.list" que esta no Servidor, ou no "sources.list" que distribuo nas maquinas. Tanto o servidor quanto as estações são Ubuntu.

Fiz o teste, esse do "apt-cache policy ntp" como no exemplo e tive a seguinte resposta:

>>> No Servidor:

ntp:
  Installed: 1:4.2.8p10+dfsg-5ubuntu7.1
  Candidate: 1:4.2.8p10+dfsg-5ubuntu7.1
  Version table:
 *** 1:4.2.8p10+dfsg-5ubuntu7.1 500
        500 http://br.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     1:4.2.8p10+dfsg-5ubuntu7 500
        500 http://br.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages


>>> Na estação:

ntp:
  Instalado:  (nenhum)
  Candidato: (nenhum)
  Version table:


Mais uma vez, agradeço a atenção!


| Thiago Boeira | Redes & TIC | CREA/RS 200288 | E-mail: tcboeira@gmail.com | Mobile/Whats +55 XX (51) 99114-6030 |
| Porto Alegre - RS | Brasil |

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.302
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Servidor de Repositório local - Erros
« Resposta #3 Online: 08 de Outubro de 2019, 16:19 »
Então... olhando o meu sources.list (padrão), há linhas solicitando os repos "main", "restricted", "universe" e "multiverse". Talvez seja isso que está faltando no seu sources.list.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline tcboeira

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • “Revolução é mudar tudo o que deve ser mudado”
    • Ver perfil
    • .:: CABEÇA LIVRE ::. Um lugar livre, para se pensar fora da caixa
Re:Servidor de Repositório local - Erros
« Resposta #4 Online: 08 de Outubro de 2019, 16:45 »
Sim, sim sim... EU coloquei no sources.list e andou boa metade do caminho hehehehe
Isso é muito mais avanço ... Até vou tomar umas hoje de alegria hehehehe
Agora estou a revisar o pacote que deu problema... que acusa conexão expirada...

Ele retorna com erro no arquivo xxxx.deb...

É preciso baixar 191 kB/13,5 MB de arquivos.
Depois desta operação, 72,5 MB adicionais de espaço em disco serão usados.
Obter:1 http://MEU-SERVER/ubuntu bionic/universe amd64 realmd amd64 0.16.3-1 [191 kB]
Err:1 http://MEU-SERVER/ubuntu bionic/universe amd64 realmd amd64 0.16.3-1                                     
  Conexão expirou [IP: 10.10.10.210 3128]
E: Falhou ao buscar http://MEU-SERVER/ubuntu/pool/universe/r/realmd/realmd_0.16.3-1_amd64.deb  Conexão expirou [IP: 10.124.4.250 3128]
E: Impossível buscar alguns arquivos, talvez executar apt-get update ou tentar com --fix-missing?

| Thiago Boeira | Redes & TIC | CREA/RS 200288 | E-mail: tcboeira@gmail.com | Mobile/Whats +55 XX (51) 99114-6030 |
| Porto Alegre - RS | Brasil |

Offline tcboeira

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • “Revolução é mudar tudo o que deve ser mudado”
    • Ver perfil
    • .:: CABEÇA LIVRE ::. Um lugar livre, para se pensar fora da caixa
Re:Servidor de Repositório local - Erros
« Resposta #5 Online: 08 de Outubro de 2019, 16:58 »
sudo apt-cache show realmd
Package: realmd
Architecture: amd64
Version: 0.16.3-1
Priority: optional
Section: universe/admin
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 1109
Depends: libc6 (>= 2.14), libglib2.0-0 (>= 2.39.1), libkrb5-3 (>= 1.10+dfsg~alpha1), libldap-2.4-2 (>= 2.4.25), libpolkit-gobject-1-0 (>= 0.99), libsystemd0
Filename: pool/universe/r/realmd/realmd_0.16.3-1_amd64.deb
Size: 190680
MD5sum: 5de93cfcc83ce36c324794e5abea826b
SHA1: 7ce1eaa98fb3df1508c312ce8c14b79486467abe
SHA256: e07e8d734b0e7489819217f15c314914a4f9e83a009141f1c2acd12f3fb1a0ee
Homepage: https://www.freedesktop.org/software/realmd/
Description-en: DBus service for configuring kerberos and other online identities
 realmd is a D-Bus system service that manages discovery and enrollment in
 realms/domains like Active Directory or IPA.
 .
 realmd can configure either SSSD or Windbind as client software. It will also
 automatically install the required packages using PackageKit if needed.
Description-md5: af9e5e761d418dbb77663ac5c17d034d
| Thiago Boeira | Redes & TIC | CREA/RS 200288 | E-mail: tcboeira@gmail.com | Mobile/Whats +55 XX (51) 99114-6030 |
| Porto Alegre - RS | Brasil |

Offline tcboeira

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • “Revolução é mudar tudo o que deve ser mudado”
    • Ver perfil
    • .:: CABEÇA LIVRE ::. Um lugar livre, para se pensar fora da caixa
Re:Servidor de Repositório local - Erros
« Resposta #6 Online: 08 de Outubro de 2019, 17:54 »
Descobri... Não sei ao certo o motivo... mas o arquivo .deb estava com 0K... Isso o amd64. O outro, o 386 estava OK
Bem, fui ao http://archive.ubuntu.com/ubuntu/pool/universe/r/realmd/, baixei o arquivo e o coloquei diretamente no local...
Bem, teste com sucesso...

Vou manter o post aberto, pois ainda falta alguns itens para botar em operação
| Thiago Boeira | Redes & TIC | CREA/RS 200288 | E-mail: tcboeira@gmail.com | Mobile/Whats +55 XX (51) 99114-6030 |
| Porto Alegre - RS | Brasil |

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.043
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re:Servidor de Repositório local - Erros [RESOLVIDO]
« Resposta #7 Online: 19 de Outubro de 2019, 11:04 »
Bom dia!
Só entrei na discussão pra dizer que na rede que administro uso o "apt-cacher-ng". Ele é bem simples.
Vc configura todas as suas máquinas pra usar um cache apt. Quando elas vão atualizar, acessam esse servidor "apt-cacher-ng" e buscam o pacote que fica em cache para as outras máquinas que ainda não atualizaram.
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049