Autor Tópico: Não estou conseguindo instalar esse programa tar.gz  (Lida 841 vezes)

Offline Jose Emilio

  • Usuário Ubuntu
  • *
  • Mensagens: 258
  • Além da Imaginação
    • Ver perfil
Não estou conseguindo instalar esse programa tar.gz
« Online: 26 de MAR?O de 2019, 22:26 »
  O programa é:   PonyProg2000-2.08d.tar.gz

no arquivo de texto "install"  pluma está assim:
no arquico readme  só tem a versão do programa


-----------------
PREPARE FOR BUILD
-----------------
For compiling with Qt4 should be installed libqtcore4, libqtgui4, libqt4-dev, packages
Compiling with Qt5 needs qtbase5-dev, qtmultimedia5-dev, libqt5printsupport5, libqt5multimedia5
Name of packages can be different on distributions.

---------------
BUILD for Linux
---------------
On linux systems you need the following packages installed to build: cmake, make, g++ and selected Qt packages
To build the executable binary file run the script:

# ./create_elf_binary.sh

In this shell script you can change followed options in the line:
cmake -DUSE_DEBUGGER=ON -DUSE_QT5=OFF ..

USE_DEBUGGER ON/OFF: the debug information in binary file
USE_QT5      ON/OFF: select Qt5 or Qt4
USE_PROFILER ON/OFF: include the information for profiling


After compiling the linux binary you can test the executable:
# ./ponyprog

Or with debugger:
# gdb -ex run --args ./ponyprog

But for direct communication about TTY be sure, than you have access rights.
Your username must be added to the tty group. Same playing for the LPT case.
The other possibility tu run the program is 'sudo' tool.

To generate the debian installer file (deb) please run the script:
# ./create_deb_package.sh

Install the package
# sudo dpkg -i ./ponyprog*.deb


The installation set the capabilities from postinst script:
# setcap 'cap_sys_tty_config=+ep' /usr/bin/ponyprog


To generate the rpm file run the script :
# ./create_rpm_package.sh


-----------------------------
BUILD for Windows using mingw
-----------------------------
Install QT SDK 5.

To build the executable file run the script:
# create_exe_binary.bat

You will find ponyprog.exe in the build directory.



Tradução:

-----------------
PREPARE-SE PARA CONSTRUIR
-----------------
Para compilar com o Qt4 deve ser instalado pacotes libqtcore4, libqtgui4, libqt4-dev,
Compilar com o Qt5 precisa de qtbase5-dev, qtmultimedia5-dev, libqt5printsupport5, libqt5multimedia5
O nome dos pacotes pode ser diferente nas distribuições.

---------------
BUILD para Linux
---------------
Nos sistemas linux você precisa dos seguintes pacotes instalados para compilar: cmake, make, g ++ e pacotes Qt selecionados
Para construir o arquivo binário executável, execute o script:

# ./create_elf_binary.sh

Neste shell script você pode alterar as opções seguidas na linha:
cmake -DUSE_DEBUGGER = ON -DUSE_QT5 = OFF ..

USE_DEBUGGER ON / OFF: as informações de depuração no arquivo binário
USE_QT5 ON / OFF: selecione Qt5 ou Qt4
USE_PROFILER ON / OFF: inclui as informações para criação de perfil


Depois de compilar o binário do Linux você pode testar o executável:
# ./ponyprog

Ou com depurador:
# gdb -ex run --args ./ponyprog

Mas para uma comunicação direta sobre o TTY, certifique-se de ter direitos de acesso.
Seu nome de usuário deve ser adicionado ao grupo tty. O mesmo jogando para o caso LPT.
A outra possibilidade de executar o programa é a ferramenta 'sudo'.

Para gerar o debian installer file (deb) por favor execute o script:
# ./create_deb_package.sh

Instale o pacote
# sudo dpkg -i ./ponyprog*.deb


A instalação configurou os recursos do script postinst:
# setcap 'cap_sys_tty_config = + ep' / usr / bin / ponyprog


Para gerar o arquivo rpm, execute o script:
# ./create_rpm_package.sh


-----------------------------
Construir para Windows usando Mingw
-----------------------------
Instale o QT SDK 5.

Para construir o arquivo executável, execute o script:
# create_exe_binary.bat

Você encontrará o ponyprog.exe no diretório de compilação.



>  Não estou entendendo como instala esses pacotes Qt4 Qt5 etc

abs