Autor Tópico: Ao instalar a versão ubuntu 16 e 18 com Lamp -dúvidas no php 5.6 para 7.1  (Lida 161 vezes)

Offline ismaelbonifacio

  • Usuário Ubuntu
  • *
  • Mensagens: 140
    • Ver perfil
Bom dia!
Tenho o ubuntu 14.04 LTS com Lamp. Quero fazer upgrade para o ubuntu 16 ou 18LTS com Lamp. A última vez que tentei fazer esta ação, muitos dos meus materiais não funcionavam, porque não aceitaram o php 7, pois só funcionavam com o php5.6. Posso fazer o upgrade para a versão ubuntu 16 ou 18 e ficar com o php5.6? Ao fazer o upgrade automaticamente ele instala o php7.1. Neste momento tenho os dois php 5.6 e 7.1 e altero quando quero. Mas na versão ubuntu 18 ou 16 posso continuar a fazer esta ação? Outra situação. Não vou ter problemas com as bases de dados que fiz? Elas vão ser aceites no novo ubuntu?

Obrigado pessoal.


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.137
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Ao instalar a versão ubuntu 16 e 18 com Lamp -dúvidas no php 5.6 para 7.1
« Resposta #1 Online: 08 de Outubro de 2018, 14:56 »
Citar
Posso fazer o upgrade para a versão ubuntu 16 ou 18 e ficar com o php5.6?
Pode, mas não deve.

Sugestão... instale o PHP 7 em uma outra máquina (pode ser virtual) e use-a pra corrigir seus sistemas. Quando estiver tudo redondo, instale o PHP 7 no seu 14.04. Daí, novamente, corrija tudo que precisar.
Só depois que vc tiver certeza que a migração será indolor, vc atualiza seu sistema.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline ismaelbonifacio

  • Usuário Ubuntu
  • *
  • Mensagens: 140
    • Ver perfil
Re:Ao instalar a versão ubuntu 16 e 18 com Lamp -dúvidas no php 5.6 para 7.1
« Resposta #2 Online: 10 de Outubro de 2018, 03:25 »
Obrigado. Está espetáculo o ubuntu! Não há problema no upgrade da base de dados, porque ele até pergunta se quer manter a anterior e é só confirmar e fica tudo igual, na janela de instalação vemos a instalação da base de dados anteriores a correr. Este software fala com um gajo! Parabéns para a engenheirada da ubuntu está espetacular! Mais uma vez feliz com este software! Estava com um pouco receio de mudar, mas valeu a pena. Extraordinário!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.137
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Ao instalar a versão ubuntu 16 e 18 com Lamp -dúvidas no php 5.6 para 7.1
« Resposta #3 Online: 10 de Outubro de 2018, 14:27 »
Vou te contar um segredo... sabe quem faz o Ubuntu ser tão bom? Nós dois, que o usamos. ;) ;D
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline ismaelbonifacio

  • Usuário Ubuntu
  • *
  • Mensagens: 140
    • Ver perfil
Re:Ao instalar a versão ubuntu 16 e 18 com Lamp -dúvidas no php 5.6 para 7.1
« Resposta #4 Online: 13 de Outubro de 2018, 14:27 »
Viva! Com a atualização do ubuntu de 14.04, para o 16.04 está tudo a funcionar bem, mas existe um problema nos sites do Websitebaker...já estou também nos fóruns desta aplicação a pedir ajuda. Todavia, se existir alguém que me possa ajudar agradecia...
Problema:

Quando faço upload de ficheiros pelo site do websitebaker o ficheiro vai para a pasta que quero, mas não fica na página online. Isto tem um modulo que ativa e deixa uma galeria de ficheiros automaticamente online. Mas reparei agora que ao fazer upload ele fica na pasta e não anexado no modulo. Falaram-me de permissões. Já tentei colocar a pasta em www-data em grupo e outros em 777 e nada. Se alguém estiver por dentro disto uma ajudinha do forum era bem vinda. Estou a pensar que deve ser o meu ficheiro php.ini...estou a rodar em php5.6 e não php7.2 ou 7.1 (isto por causa de aplicações que não rodam no php.7, como o plogger (esta aplicação não aceita a não ser o php5.6.