Autor Tópico: Problema com ./configure ao instalar as bibliotecas do Qt  (Lida 66 vezes)

Offline felippeta

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Problema com ./configure ao instalar as bibliotecas do Qt
« Online: 15 de Setembro de 2018, 12:18 »
Pessoal estou tentando instalar o Qt seguindo o tutorial desse link (http://doc.qt.io/qt-5/linux-building.html), entretanto quando vou dar o comando ./configure recebo a seguinte mensagem de erro:

bash: ./configure: /bin/bash^M: interpretador inválido: Arquivo ou diretório não encontrado

Quando dou um ls na pasta obtenho os seguintes arquivos:

coin                        qtcharts            qtscxml
configure                   qtconnectivity      qtsensors
configure~                  qtdatavis3d         qtserialbus
configure.bat               qtdeclarative       qtserialport
configure.json              qtdoc               qtspeech
gnuwin32                    qtgamepad           qtsvg
LGPL_EXCEPTION.txt          qtgraphicaleffects  qttools
LICENSE.FDL                 qtimageformats      qttranslations
LICENSE.GPLv2               qtlocation          qtvirtualkeyboard
LICENSE.GPLv3               qtmacextras         qtwayland
LICENSE.LGPLv21             qtmultimedia        qtwebchannel
LICENSE.LGPLv3              qtnetworkauth       qtwebengine
LICENSE.PREVIEW.COMMERCIAL  qt.pro              qtwebsockets
qt3d                        qtpurchasing        qtwebview
qtactiveqt                  qtquickcontrols     qtwinextras
qtandroidextras             qtquickcontrols2    qtx11extras
qtbase                      qtremoteobjects     qtxmlpatterns
qtcanvas3d                  qtscript            README

O arquivo configure está lá, então qual seria esse problema?

Grato.

Offline sigur

  • Usuário Ubuntu
  • *
  • Mensagens: 1.101
    • Ver perfil
Re:Problema com ./configure ao instalar as bibliotecas do Qt
« Resposta #1 Online: 17 de Setembro de 2018, 13:46 »
Você realmente deseja compilar o  Qt? Pode instalar direto baixando o instalador.

https://www.qt.io/download-qt-installer