Autor Tópico: warsaw bb no 18.04  (Lida 15839 vezes)

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
warsaw bb no 18.04
« Online: 09 de Abril de 2018, 09:45 »
alguem já conseguiu instalar ?

com o 17.10 segui isto aqí e funcionou.

https://ubuntuforum-br.org/index.php?topic=121558.msg667917#msg667917

no 18.04 está dando erro de sokect e na instalação. algo relativo ao systemd

https://imgur.com/XVtdRjZ
« Última modificação: 09 de Abril de 2018, 10:07 por jrkamil »
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 50
  • Avante. sempre em frente
    • Ver perfil
vai ser dificil
« Resposta #1 Online: 14 de Abril de 2018, 18:27 »
Aqui eu consegui instalar em máquina virtual, utilizando uma iso antiga do 18.04,  antes de fazer o upgrade.  Depois de atualizado o sistema perde-se o acesso.   Não é mais possível  o warsaw core iniciar como root.

utilizando o comando
Código: [Selecionar]
ps -ef | grep warsaw
antes da atualização

usuario@usuario:~$ ps -ef | grep warsaw
root       968     1  0 17:08 ?        00:00:01 /usr/local/bin/warsaw/core
usuario   8330     1  2 18:09 ?        00:00:00 /usr/local/bin/warsaw/core
usuario   8350  8270  0 18:09 pts/0    00:00:00 grep --color=auto warsaw


depois da atualização

usuario@usuario:~$ ps -ef | grep warsaw
usuario   8330     1  2 18:09 ?        00:00:00 /usr/local/bin/warsaw/core
usuario   8350  8270  0 18:09 pts/0    00:00:00 grep --color=auto warsaw

ocorrendo o mesmo erro, quando o  upgrade é realizado antes de instalar o warsaw.

fica a pergunta: incompatibilidade de kernel, bibliotecas,  etc ???

DidBrother
« Última modificação: 14 de Abril de 2018, 21:40 por DidBrother »

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #2 Online: 15 de Abril de 2018, 10:09 »
este warsaw sempre foi complicado.  e estamos com um iso beta ainda...
vamos aguardar mais um pouco para as coisas estabilizarem.
mais para a frente deve aparecer uma solução.
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 50
  • Avante. sempre em frente
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #3 Online: 18 de Abril de 2018, 00:22 »

PS - Não use este tutorial.  Ele continuará aqui apenas para efeito historico. Atualmente recomendo o da resposta 25 do tópico atual.

Encontrei um tutorial do archlinux, na pagina - https://aur.archlinux.org/packages/warsaw/ - que funcionou perfeitamente no ubuntu 18.04, com as devidas adaptações.

Repassando a sequencia que usei:

1 - Instale o navegador Chrome, pois o warsaw não injeta o certificado na versão 58 ou superior do Firefox

2 - instale pacote libnss3-tools
sudo apt install libnss3-tools

3-  instale o warsaw com  o dpkg.   vai ocorrer o mesmo erro que consta no link https://imgur.com/XVtdRjZ da mensagem 1

4- veja se o warsaw/core está rodando como usuario
ps -ef |grep warsaw
 
5 -Abrir o navegador chrome e no endereço:  chrome://settings/certificates  acessar a aba autoridades e verificar a existência do certificado  "Warsaw Personal CA" .  Se não encontrou - Sudo apt purge warsaw  - e  instale novamente o warsaw. verifique e instale quantas vezes for necessário.

6 - abrir o terminal  e como Root rodar os comandos:

A - Acessando a pasta
# cd /usr/local/lib/warsaw

B. Substituindo os arquivos por links
# rm ld-linux-x86-64.so.2 && ln -s /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2
# rm libc.so.6 && ln -s /lib/x86_64-linux-gnu/libc.so.6
# rm libpthread.so.0 && ln -s /lib/x86_64-linux-gnu/libpthread.so.0
# rm libdl.so.2 && ln -s /lib/x86_64-linux-gnu/libdl.so.2

C: Defina o atributo do diretório /usr/local/lib/warsaw como append-only
# chattr +a /usr/local/lib/warsaw   

D: Ative e inicie o serviço do warsaw :
# systemctl enable warsaw
# systemctl start warsaw
# /usr/local/bin/warsaw/core

7: Verifique que os processos relacionados ao warsaw estão rodando corretamente:

# ps  -ef | grep warsaw
Você deve observar no mínimo 1 [...]/warsaw/core rodando como root e pelo menos um [...]/warsaw/core rodando como usuário.

8: reiniciar  o computador

DidBrother



 
« Última modificação: 20 de Maio de 2018, 11:10 por DidBrother »

Offline Marcopolo

  • Usuário Ubuntu
  • *
  • Mensagens: 682
  • Ubuntu forever, ever!!
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #4 Online: 18 de Abril de 2018, 11:50 »
Encontrei um tutorial do archlinux, na pagina - https://aur.archlinux.org/packages/warsaw/ - que funcionou perfeitamente no ubuntu 18.04, com as devidas adaptações.

Repassando a sequencia que usei:

1 - Instale o navegador Chrome, pois o warsaw não injeta o certificado na versão 58 ou superior do Firefox

2 - instale pacote libnss3-tools
sudo apt install libnss3-tools

3-  instale o warsaw com  o dpkg.   vai ocorrer o mesmo erro que consta no link https://imgur.com/XVtdRjZ da mensagem 1

4- veja se o warsaw/core está rodando como usuario
ps -ef |grep warsaw
 
5 -Abrir o navegador chrome e no endereço:  chrome://settings/certificates  acessar a aba autoridades e verificar a existência do certificado  "Warsaw Personal CA" .  Se não encontrou - Sudo apt purge warsaw  - e  instale novamente o warsaw. verifique e instale quantas vezes for necessário.

6 - abrir o terminal  e como Root rodar os comandos:

A - Acessando a pasta
# cd /usr/local/lib/warsaw

B. Substituindo os arquivos por links
# rm ld-linux-x86-64.so.2 && ln -s /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2
# rm libc.so.6 && ln -s /lib/x86_64-linux-gnu/libc.so.6
# rm libpthread.so.0 && ln -s /lib/x86_64-linux-gnu/libpthread.so.0
# rm libdl.so.2 && ln -s /lib/x86_64-linux-gnu/libdl.so.2

C: Defina o atributo do diretório /usr/local/lib/warsaw como append-only
# chattr +a /usr/local/lib/warsaw   

D: Ative e inicie o serviço do warsaw :
# systemctl enable warsaw
# systemctl start warsaw
# /usr/local/bin/warsaw/core

5: Verifique que os processos relacionados ao warsaw estão rodando corretamente:

# ps  -ef | grep warsaw
Você deve observar no mínimo 1 [...]/warsaw/core rodando como root e pelo menos um [...]/warsaw/core rodando como usuário.

6: reiniciar  o computador

DidBrother

Valeu muito, amigão! Assim que eu baixar a iso e instalar o 18.04 LTS, uso esse tutorial para poder usar minha conta corrente pelo Banco do Brasil! Um fraternal abraço,
Marcopolo!
"Quanto mais aumenta nosso conhecimento, mais evidente fica nossa ignorância" (JFK).http://ubuntuforum-br.org

Desktop, Intel Core i7, Win 7 64 bits, Windows10 e Ubuntu16.04.3 LTS, HD 500 GB, 4 GB. Dell14",  Core i3, HD 500 GB, 4 GB, Win10- 64 bits-Ununtu16.04. Vaio 15S 8GB -HD 1Tera-Ubuntu 18.04.

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 421
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:warsaw bb no 18.04
« Resposta #5 Online: 29 de Abril de 2018, 23:54 »
(...)
3-  instale o warsaw com  o dpkg.   vai ocorrer o mesmo erro que consta no link https://imgur.com/XVtdRjZ da mensagem 1
(...)
5 -Abrir o navegador chrome e no endereço:  chrome://settings/certificates  acessar a aba autoridades e verificar a existência do certificado  "Warsaw Personal CA" .  Se não encontrou - Sudo apt purge warsaw  - e  instale novamente o warsaw. verifique e instale quantas vezes for necessário.
(...)
B. Substituindo os arquivos por links
# rm ld-linux-x86-64.so.2 && ln -s /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2
# rm libc.so.6 && ln -s /lib/x86_64-linux-gnu/libc.so.6
# rm libpthread.so.0 && ln -s /lib/x86_64-linux-gnu/libpthread.so.0
# rm libdl.so.2 && ln -s /lib/x86_64-linux-gnu/libdl.so.2
(...)
# ps  -ef | grep warsaw

Dica interessante. Complementando:

=> Para instalar o pacote DEB do Warsaw sem precisar resolver dependências (digo: sem precisar resolver as dependências que estejam declaradas dentro do arquivo CONTROL do pacote DEB), basta usar o GDEBI para instalar o pacote, ao invés de usar o DPKG, pois o DPKG não resolve dependências de pacotes mas o GDEBI resolve dependências.
Para fazer o GDEBI instalar um pacote automaticamente (sem lhe fazer perguntas), basta executar um comando assim:
Código: [Selecionar]
sudo gdebi -n /caminho/para/nome-do-pacote.deb
=> Se o Warsaw for instalado mas o certificado não for instalado, não é necessário reinstalar o Warsaw só para conseguir instalar o certificado. Vide aqui como manualmente gerar e instalar o certificado em seu navegador. Mas essa dica só funciona caso o Warsaw esteja instalado (pois os dados para gerar o certificado ficam situados em uma das pastas do Warsaw, e para isso é evidentemente necessário que o Warsaw esteja instalado).

=> O comando rm não é necessário para deletar as bibliotecas, pois a opção f já força o comando ln a criar o link, se necessário gravando o arquivo-link por cima do arquivo-biblioteca. Consequentemente, aqueles quatro comandos de exclusão de biblioteca e posterior criação de link simbólico podem ser substituídos por este supercomando:
Código: [Selecionar]
ln -sf /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2 ; ln -sf /lib/x86_64-linux-gnu/libc.so.6 ; ln -sf /lib/x86_64-linux-gnu/libpthread.so.0 ; ln -sf /lib/x86_64-linux-gnu/libdl.so.2
=> Este comando:
Código: [Selecionar]
ps -ef |grep -v grep |grep -i warsaw...é um pouco mais preciso que o ps  -ef | grep warsaw, pois descarta a linha em que o próprio grep é mencionado junto com a palavra warsaw. :)

Todo lançamento do *Ubuntu vem com problemas, por isto eu sempre opto por aguardar no mínimo uns 6 meses antes de adotar a nova versão LTS ("suporte de longo termo") do *Ubuntu: procedi desse modo antes de migrar do XUbuntu 12.04 para o 14.04, idem para migrar do 14.04 para o 16.04, e assim pretendo fazer para migrar do 16.04 para o 18.04: só pretendo começar a analisar a possibilidade de migrar para o 18.04 a partir de outubro de 2018. Até lá o *Ubuntu 18.04 provavelmente estará funcionando melhor com o Warsaw (sem necessidade de tantos ajustes). Mas essa dica da comunidade do Arch Linux é interessante para quem prefere migrar logo para o *Ubuntu 18.04. Bacana.
Yuri Sucupira ("Sampayu")

Offline Ribeirão

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #6 Online: 01 de Maio de 2018, 23:07 »
Boa noite a todos...
Atualizei para o Kubuntu 18.04 e infelizmente do passando o perrengue com o módulo de segurança do Caixa.
Já instalei, reinstalei, segui dicas de outros sites e, por ultimo, a dica desse tópico aqui no fórum e até agora nada.
Se alguém tiver uma luz e puder ajudar, fico muito agradecido, desde já.
Um obrigado antecipado...

Offline Marcopolo

  • Usuário Ubuntu
  • *
  • Mensagens: 682
  • Ubuntu forever, ever!!
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #7 Online: 02 de Maio de 2018, 09:02 »
Boa noite a todos...
Atualizei para o Kubuntu 18.04 e infelizmente do passando o perrengue com o módulo de segurança do Caixa.
Já instalei, reinstalei, segui dicas de outros sites e, por ultimo, a dica desse tópico aqui no fórum e até agora nada.
Se alguém tiver uma luz e puder ajudar, fico muito agradecido, desde já.
Um obrigado antecipado...
Ribeirão, bom dia!
Somente para comentar, que eu consegui instalar e usar o módulo de segurança do Banco do Brasil no Ubuntu 16.04.1 LTS em todas três máquinas que possuo, sem problemas, com as dicas dos amigos Sampayu e Galactus!
Abraço,
Marcopolo
Editando:
Esqueci de citar, que ainda não estou usando a nova versão 18.04 LTS! Baixei a iso e vou fazer um Pendrive bootável e depois instalar! Por enquanto, vou mantendo a 16.04, por ter atualização até 2021, mas a qualquer momento, tendo experimentar a atual!
« Última modificação: 02 de Maio de 2018, 09:06 por Marcopolo »
"Quanto mais aumenta nosso conhecimento, mais evidente fica nossa ignorância" (JFK).http://ubuntuforum-br.org

Desktop, Intel Core i7, Win 7 64 bits, Windows10 e Ubuntu16.04.3 LTS, HD 500 GB, 4 GB. Dell14",  Core i3, HD 500 GB, 4 GB, Win10- 64 bits-Ununtu16.04. Vaio 15S 8GB -HD 1Tera-Ubuntu 18.04.

Offline Ribeirão

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #8 Online: 02 de Maio de 2018, 10:24 »
No Kubuntu 16.04 estava funcionando perfeitamente.
O problema ta sendo no 18.04.  Na aflição de instalar a nova versão, acabei  por ter essa surpresa ruim.
No 16.04 nunca tive problemas, funcionava tranquilo.

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 50
  • Avante. sempre em frente
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #9 Online: 02 de Maio de 2018, 10:38 »
Boa noite a todos...
Atualizei para o Kubuntu 18.04 e infelizmente do passando o perrengue com o módulo de segurança do Caixa.
Já instalei, reinstalei, segui dicas de outros sites e, por ultimo, a dica desse tópico aqui no fórum e até agora nada.
Se alguém tiver uma luz e puder ajudar, fico muito agradecido, desde já.
Um obrigado antecipado...
.

Caro Ribeiro,

Uma luz sem maiores informações fica muito díficil.
1 -Quais mensagens de erro ocorreram durante a instalação do warsaw. Qual modulo de segurança da caixa o sr. baixou. O do link https://cloud.gastecnologia.com.br/cef/warsaw/install/GBPCEFwr64.deb (arquivo de 17MB) ou do link https://imagem.caixa.gov.br/banner/fgr/GBPCEFwr64.deb (arquivo de 3MB).

2 - Verificou a presença  do certificado Warsaw Personal CA no navegador Chrome.

3 - Os comandos constantes na resposta 3  rodar como  Root

O tutorial da resposta 3 já foi testado no Ubuntu  Gnome  e Ubuntu Mate

DidBrother

Offline Ribeirão

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #10 Online: 02 de Maio de 2018, 15:05 »
Encontrei um tutorial do archlinux, na pagina - https://aur.archlinux.org/packages/warsaw/ - que funcionou perfeitamente no ubuntu 18.04, com as devidas adaptações.

Repassando a sequencia que usei:

1 - Instale o navegador Chrome, pois o warsaw não injeta o certificado na versão 58 ou superior do Firefox

2 - instale pacote libnss3-tools
sudo apt install libnss3-tools

3-  instale o warsaw com  o dpkg.   vai ocorrer o mesmo erro que consta no link https://imgur.com/XVtdRjZ da mensagem 1

4- veja se o warsaw/core está rodando como usuario
ps -ef |grep warsaw
 
5 -Abrir o navegador chrome e no endereço:  chrome://settings/certificates  acessar a aba autoridades e verificar a existência do certificado  "Warsaw Personal CA" .  Se não encontrou - Sudo apt purge warsaw  - e  instale novamente o warsaw. verifique e instale quantas vezes for necessário.

6 - abrir o terminal  e como Root rodar os comandos:

A - Acessando a pasta
# cd /usr/local/lib/warsaw

B. Substituindo os arquivos por links
# rm ld-linux-x86-64.so.2 && ln -s /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2
# rm libc.so.6 && ln -s /lib/x86_64-linux-gnu/libc.so.6
# rm libpthread.so.0 && ln -s /lib/x86_64-linux-gnu/libpthread.so.0
# rm libdl.so.2 && ln -s /lib/x86_64-linux-gnu/libdl.so.2

C: Defina o atributo do diretório /usr/local/lib/warsaw como append-only
# chattr +a /usr/local/lib/warsaw   

D: Ative e inicie o serviço do warsaw :
# systemctl enable warsaw
# systemctl start warsaw
# /usr/local/bin/warsaw/core

7: Verifique que os processos relacionados ao warsaw estão rodando corretamente:

# ps  -ef | grep warsaw
Você deve observar no mínimo 1 [...]/warsaw/core rodando como root e pelo menos um [...]/warsaw/core rodando como usuário.

8: reiniciar  o computador

DidBrother

Então

Fiz o procedimento acima. Dá tudo certinho, conforme explicado. Reiniciei a máquina, porém, ao tentar acessar a conta, dá sempre o mesmo problema.
A versão que baixei  é a que o próprio site sugere, no processo de login.
Só que entre as diversas tentativas, acabei ferrando com o sistema e achei melhor formatar e instalar do zero, já que após dar um apt-get update && apt-get upgrade, era me reportado que eu precisava remover o warsaw, porém, ao tentar removê-lo, sempre estava dando um erro que me impedia de fazê-lo. Tentei o "dpkg --configure -a", o "apt-get purge", etc, tudo sem sucesso.
Daí... foi o jeito fazer uma instalação nova.
Não tive tempo de mexer, pois estou no trabalho agora. Chegando em casa vou tentar por pra rodar de novo.
Alguma sugestão, pois a acima não funcionou.


Tento novamente, complementando com a dica do Sampayu?


Citação de: Sampayu
link=topic=122920.msg675277#msg675277 date=1525056889
(...)
3-  instale o warsaw com  o dpkg.   vai ocorrer o mesmo erro que consta no link https://imgur.com/XVtdRjZ da mensagem 1
(...)
5 -Abrir o navegador chrome e no endereço:  chrome://settings/certificates  acessar a aba autoridades e verificar a existência do certificado  "Warsaw Personal CA" .  Se não encontrou - Sudo apt purge warsaw  - e  instale novamente o warsaw. verifique e instale quantas vezes for necessário.
(...)
B. Substituindo os arquivos por links
# rm ld-linux-x86-64.so.2 && ln -s /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2
# rm libc.so.6 && ln -s /lib/x86_64-linux-gnu/libc.so.6
# rm libpthread.so.0 && ln -s /lib/x86_64-linux-gnu/libpthread.so.0
# rm libdl.so.2 && ln -s /lib/x86_64-linux-gnu/libdl.so.2
(...)
# ps  -ef | grep warsaw

Dica interessante. Complementando:

=> Para instalar o pacote DEB do Warsaw sem precisar resolver dependências (digo: sem precisar resolver as dependências que estejam declaradas dentro do arquivo CONTROL do pacote DEB), basta usar o GDEBI para instalar o pacote, ao invés de usar o DPKG, pois o DPKG não resolve dependências de pacotes mas o GDEBI resolve dependências.
Para fazer o GDEBI instalar um pacote automaticamente (sem lhe fazer perguntas), basta executar um comando assim:
Código: [Selecionar]
sudo gdebi -n /caminho/para/nome-do-pacote.deb
=> Se o Warsaw for instalado mas o certificado não for instalado, não é necessário reinstalar o Warsaw só para conseguir instalar o certificado. Vide aqui como manualmente gerar e instalar o certificado em seu navegador. Mas essa dica só funciona caso o Warsaw esteja instalado (pois os dados para gerar o certificado ficam situados em uma das pastas do Warsaw, e para isso é evidentemente necessário que o Warsaw esteja instalado).

=> O comando rm não é necessário para deletar as bibliotecas, pois a opção f já força o comando ln a criar o link, se necessário gravando o arquivo-link por cima do arquivo-biblioteca. Consequentemente, aqueles quatro comandos de exclusão de biblioteca e posterior criação de link simbólico podem ser substituídos por este supercomando:
Código: [Selecionar]
ln -sf /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2 ; ln -sf /lib/x86_64-linux-gnu/libc.so.6 ; ln -sf /lib/x86_64-linux-gnu/libpthread.so.0 ; ln -sf /lib/x86_64-linux-gnu/libdl.so.2
=> Este comando:
Código: [Selecionar]
ps -ef |grep -v grep |grep -i warsaw...é um pouco mais preciso que o ps  -ef | grep warsaw, pois descarta a linha em que o próprio grep é mencionado junto com a palavra warsaw. :)

Todo lançamento do *Ubuntu vem com problemas, por isto eu sempre opto por aguardar no mínimo uns 6 meses antes de adotar a nova versão LTS ("suporte de longo termo") do *Ubuntu: procedi desse modo antes de migrar do XUbuntu 12.04 para o 14.04, idem para migrar do 14.04 para o 16.04, e assim pretendo fazer para migrar do 16.04 para o 18.04: só pretendo começar a analisar a possibilidade de migrar para o 18.04 a partir de outubro de 2018. Até lá o *Ubuntu 18.04 provavelmente estará funcionando melhor com o Warsaw (sem necessidade de tantos ajustes). Mas essa dica da comunidade do Arch Linux é interessante para quem prefere migrar logo para o *Ubuntu 18.04. Bacana.


Estou meio receoso.

Ah, o problema que sempre dá e que o navegador sempre direciona para eu baixar o módulo de segurança. Como se não estivesse sido instalado. É isso.

Desde já, obrigado.
« Última modificação: 02 de Maio de 2018, 15:38 por Ribeirão »

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 50
  • Avante. sempre em frente
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #11 Online: 02 de Maio de 2018, 18:33 »



Então

Fiz o procedimento acima. Dá tudo certinho, conforme explicado. Reiniciei a máquina, porém, ao tentar acessar a conta, dá sempre o mesmo problema.
A versão que baixei  é a que o próprio site sugere, no processo de login.
Só que entre as diversas tentativas, acabei ferrando com o sistema e achei melhor formatar e instalar do zero, já que após dar um apt-get update && apt-get upgrade, era me reportado que eu precisava remover o warsaw, porém, ao tentar removê-lo, sempre estava dando um erro que me impedia de fazê-lo. Tentei o "dpkg --configure -a", o "apt-get purge", etc, tudo sem sucesso.
Daí... foi o jeito fazer uma instalação nova.
Não tive tempo de mexer, pois estou no trabalho agora. Chegando em casa vou tentar por pra rodar de novo.
Alguma sugestão, pois a acima não funcionou.

Ah, o problema que sempre dá e que o navegador sempre direciona para eu baixar o módulo de segurança. Como se não estivesse sido instalado. É isso.

Desde já, obrigado.

Caro Ribeirão,

......que eu precisava remover o warsaw, porém, ao tentar removê-lo, sempre estava dando um erro que me impedia de fazê-lo. Tentei o "dpkg --configure -a", o "apt-get purge", etc, tudo sem sucesso......

Para fazer a remoção do warsaw  é preciso retornar ao original o atributo do diretório /usr/local/lib/warsaw   com o comando
# chattr -a /usr/local/lib/warsaw.
 

inclusive nesta nova tentativa, sugiro que não use  o item C descrito abaixo.  Só o faço apos tudo estar funcionando corretamente.
C: Defina o atributo do diretório /usr/local/lib/warsaw como append-only
# chattr +a /usr/local/lib/warsaw   
   
Sim complemente com as dicas do mestre Sampayu. São perfeitas.

Estou baixando o Kubuntu.  Se o futebol da quarta-feira provocar insônia,  atualizarei o passo a passo,  dessa vez baseado estritamente no Kubuntu.

DidBrother

Offline bizkitt

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #12 Online: 02 de Maio de 2018, 18:43 »
Eu já tinha instalado o warsaw e o pepper-flash, mas não estava funcionando. Fiz o procedimento dos links simbólicos, do append (chmod) e reiniciei a máquina, funcionou! Obrigado pelo tópico e ao dono da resposta milagrosa!

Offline Ribeirão

  • Usuário Ubuntu
  • *
  • Mensagens: 183
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #13 Online: 02 de Maio de 2018, 22:27 »



Então

Fiz o procedimento acima. Dá tudo certinho, conforme explicado. Reiniciei a máquina, porém, ao tentar acessar a conta, dá sempre o mesmo problema.
A versão que baixei  é a que o próprio site sugere, no processo de login.
Só que entre as diversas tentativas, acabei ferrando com o sistema e achei melhor formatar e instalar do zero, já que após dar um apt-get update && apt-get upgrade, era me reportado que eu precisava remover o warsaw, porém, ao tentar removê-lo, sempre estava dando um erro que me impedia de fazê-lo. Tentei o "dpkg --configure -a", o "apt-get purge", etc, tudo sem sucesso.
Daí... foi o jeito fazer uma instalação nova.
Não tive tempo de mexer, pois estou no trabalho agora. Chegando em casa vou tentar por pra rodar de novo.
Alguma sugestão, pois a acima não funcionou.

Ah, o problema que sempre dá e que o navegador sempre direciona para eu baixar o módulo de segurança. Como se não estivesse sido instalado. É isso.

Desde já, obrigado.

Caro Ribeirão,

......que eu precisava remover o warsaw, porém, ao tentar removê-lo, sempre estava dando um erro que me impedia de fazê-lo. Tentei o "dpkg --configure -a", o "apt-get purge", etc, tudo sem sucesso......

Para fazer a remoção do warsaw  é preciso retornar ao original o atributo do diretório /usr/local/lib/warsaw   com o comando
# chattr -a /usr/local/lib/warsaw.
 

inclusive nesta nova tentativa, sugiro que não use  o item C descrito abaixo.  Só o faço apos tudo estar funcionando corretamente.
C: Defina o atributo do diretório /usr/local/lib/warsaw como append-only
# chattr +a /usr/local/lib/warsaw   
   
Sim complemente com as dicas do mestre Sampayu. São perfeitas.

Estou baixando o Kubuntu.  Se o futebol da quarta-feira provocar insônia,  atualizarei o passo a passo,  dessa vez baseado estritamente no Kubuntu.

DidBrother

Boa noite.
Vou tentar novamente o procedimento.
Gostaria de saber se há alguma diferença da origem de onde baixo o warsaw, já que me foi perguntado de que link baixei, se do 17mb ou se do de 3mb?
Respondido isso, vou começar o procedimento do zero e ver se agora dará certo.
Desde já, muito obrigado pela ajuda.

Offline DidBrother

  • Usuário Ubuntu
  • *
  • Mensagens: 50
  • Avante. sempre em frente
    • Ver perfil
Re:warsaw bb no 18.04
« Resposta #14 Online: 02 de Maio de 2018, 23:05 »
Caro Ribeirão,

vai a tela do sistema funcional no Kubuntu 18.04

https://imgur.com/a/5l0zp5P

Quanto ao warsaw, eu considero o melhor pacote o que é fornecida pela Caixa Economica Federal, através do link https://cloud.gastecnologia.com.br/cef/warsaw/install/GBPCEFwr64.deb 
Apresenta compatibilidade com o Banco do Brasil, CEF,  e Itaú.

DidBrother