Autor Tópico: Erro ao instalar Kodi  (Lida 1570 vezes)

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re:Erro ao instalar Kodi
« Resposta #15 Online: 14 de Novembro de 2017, 15:22 »
Voltando ao Kodi:

htpc@htpc-ULTRATOP-BRIX:~$ sudo apt-get install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libshairplay0 python-bluez python-simplejson
Utilize 'sudo apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.
htpc@htpc-ULTRATOP-BRIX:~$ sudo apt install kodi
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Pacotes sugeridos:
  kodi-pvr-mythtv kodi-pvr-vuplus kodi-pvr-vdr-vnsi kodi-pvr-njoy
  kodi-pvr-nextpvr kodi-pvr-mediaportal-tvserver kodi-pvr-tvheadend-hts
  kodi-pvr-dvbviewer kodi-pvr-argustv kodi-pvr-iptvsimple
  kodi-audioencoder-vorbis kodi-audioencoder-flac kodi-audioencoder-lame
Os NOVOS pacotes a seguir serão instalados:
  kodi
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.
É preciso baixar 0 B/20,1 MB de arquivos.
Depois desta operação, 37,1 MB adicionais de espaço em disco serão usados.
(Lendo banco de dados ... 191901 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb ...
A descompactar kodi (2:17.5+git20171027.2324-final-0artful) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb (--unpack):
 a tentar sobre-escrever '/usr/share/icons/hicolor/128x128/apps/kodi.png', que também está no pacote kodi-data 2:17.3+dfsg1-3
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
htpc@htpc-ULTRATOP-BRIX:~$


Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Erro ao instalar Kodi
« Resposta #16 Online: 14 de Novembro de 2017, 15:35 »
Não, @ maurente, não era fazer a correção antes, era fazer depois de instalar o kodi

Mas não há problema, faça agora.

Código: [Selecionar]
sudo apt-get install -f
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re:Erro ao instalar Kodi
« Resposta #17 Online: 14 de Novembro de 2017, 15:51 »
htpc@htpc-ULTRATOP-BRIX:~$ sudo apt install kodi
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Pacotes sugeridos:
  kodi-pvr-mythtv kodi-pvr-vuplus kodi-pvr-vdr-vnsi kodi-pvr-njoy
  kodi-pvr-nextpvr kodi-pvr-mediaportal-tvserver kodi-pvr-tvheadend-hts
  kodi-pvr-dvbviewer kodi-pvr-argustv kodi-pvr-iptvsimple
  kodi-audioencoder-vorbis kodi-audioencoder-flac kodi-audioencoder-lame
Os NOVOS pacotes a seguir serão instalados:
  kodi
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.
É preciso baixar 0 B/20,1 MB de arquivos.
Depois desta operação, 37,1 MB adicionais de espaço em disco serão usados.
(Lendo banco de dados ... 192166 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb ...
A descompactar kodi (2:17.5+git20171027.2324-final-0artful) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb (--unpack):
 a tentar sobre-escrever '/usr/share/icons/hicolor/128x128/apps/kodi.png', que também está no pacote kodi-data 2:17.3+dfsg1-3
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
htpc@htpc-ULTRATOP-BRIX:~$ sudo apt-get install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libshairplay0 python-bluez python-simplejson
Utilize 'sudo apt autoremove' para os remover.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.
htpc@htpc-ULTRATOP-BRIX:~$ sudo apt install kodi
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Pacotes sugeridos:
  kodi-pvr-mythtv kodi-pvr-vuplus kodi-pvr-vdr-vnsi kodi-pvr-njoy
  kodi-pvr-nextpvr kodi-pvr-mediaportal-tvserver kodi-pvr-tvheadend-hts
  kodi-pvr-dvbviewer kodi-pvr-argustv kodi-pvr-iptvsimple
  kodi-audioencoder-vorbis kodi-audioencoder-flac kodi-audioencoder-lame
Os NOVOS pacotes a seguir serão instalados:
  kodi
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.
É preciso baixar 0 B/20,1 MB de arquivos.
Depois desta operação, 37,1 MB adicionais de espaço em disco serão usados.
(Lendo banco de dados ... 192166 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb ...
A descompactar kodi (2:17.5+git20171027.2324-final-0artful) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb (--unpack):
 a tentar sobre-escrever '/usr/share/icons/hicolor/128x128/apps/kodi.png', que também está no pacote kodi-data 2:17.3+dfsg1-3
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/kodi_2%3a17.5+git20171027.2324-final-0artful_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
htpc@htpc-ULTRATOP-BRIX:~$


Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Erro ao instalar Kodi
« Resposta #18 Online: 14 de Novembro de 2017, 16:38 »
Não está resolvendo, ficou atrapalhado isso aí 

Mas creio que já sei onde está o problema, colocou-se dois trens no mesmo trilho, aí não dá certo mesmo.  >:(

Aqui instalei com grande facilidade, sem nenhum problema.

Acontece que parece que você habilitou antes uma ppa (ppa:team-xbmc/ppa) e instalou por ela e depois passei o roteiro para instalar usando apenas o repositório oficial do Ubuntu, possivelmente o problema está aí, colidiu-se fontes.

Como corrigir?  This is the question!

Limpar tudo e começar de novo.

Vou detalhar isso daqui a pouco, um pouco mais tarde que agora não posso.
« Última modificação: 14 de Novembro de 2017, 17:18 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Erro ao instalar Kodi
« Resposta #19 Online: 14 de Novembro de 2017, 20:15 »
Curioso, instalei aqui também a partir da ppa e não apresentou esse erro que você acusa aí, instalou normal e sem erros a partir da ppa e o Kodi funciona.

Bem, vamos adiante limpar isso aqui.

Quando se tem duas fontes possíveis, por exemplo, uma fonte externa que é uma ppa e o repositório oficial da distribuição, ou se escolhe um ou se escolhe outro para instalar determinado software.

No caso concreto existe a ppa:team-xbmc/ppa, que é do "Kodi" team, na qual obviamente estão os programas que compõem o Kodi, mas também existe uma versão que é mantida pela distribuição e que, portanto, faz parte dos repositórios oficiais, no caso, do Ubuntu.

Em algum momento, possivelmente seguindo algum roteiro por aí, você instalou a ppa, tanto assim que ela está listada lá no post #2.

O roteiro que havia postado lá no post #8, como mesmo está lá escrito, refere-se a instalar a partir do repositório oficial e não a partir da ppa, portanto, sendo essa a opção, a entrada da ppa na lista de repositórios precisa ser deletada.

A versão instalada a partir da ppa:team-xbmc/ppa é essa:

kodi:
  Installed: 2:17.6+git20171114.2125-final-0artful
  Candidate: 2:17.6+git20171114.2125-final-0artful
  Version table:
 *** 2:17.6+git20171114.2125-final-0artful 500
        500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status
     2:17.3+dfsg1-3 500
        500 http://archive.ubuntu.com/ubuntu artful/universe amd64 Packages


Como isso aí já embaralhou, então é melhor limpar o que possa ter sido instalado.

Instale o pacote ppa-purge

Código: [Selecionar]
sudo apt install ppa-purge
Depois faça:

Código: [Selecionar]
sudo ppa-purge ppa:team-xbmc/ppa
Código: [Selecionar]
sudo apt update
Para que não reste dúvidas, faça também:

Código: [Selecionar]
sudo apt-get --purge remove kodi*
Código: [Selecionar]
sudo rm /etc/apt/sources.list.d/team-xbmc-ubuntu-ppa-artful.list*
Código: [Selecionar]
sudo apt update
Código: [Selecionar]
sudo apt upgrade
Código: [Selecionar]
sudo apt autoremove
Isso supostamente deverá ser suficiente para limpar instalações anteriores e resíduos.

Agora repita a instalação, porém agora a partir do repositório oficial, fazendo:

Código: [Selecionar]
sudo apt install kodi
Siga o quanto está no post #8 para concluir a instalação

Ao final, depois de tudo instalado sem erros:

Código: [Selecionar]
apt-cache policy kodi
Deverá produzir:

kodi:
  Installed: 2:17.3+dfsg1-3
  Candidate: 2:17.3+dfsg1-3
  Version table:
 *** 2:17.3+dfsg1-3 500
        500 http://archive.ubuntu.com/ubuntu artful/universe amd64 Packages
        100 /var/lib/dpkg/status

E, claro, o Kodi deverá funcionar.
« Última modificação: 14 de Novembro de 2017, 20:17 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re:Erro ao instalar Kodi
« Resposta #20 Online: 15 de Novembro de 2017, 13:13 »
Realmente funcionou! Te agradeço mais uma vez, de coração. Pois este PCzinho na sala é só para diversão da família e você e o Galactus contribuíram para isso.
Abraço.