Autor Tópico: Emby para Ubuntu  (Lida 4724 vezes)

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Emby para Ubuntu
« Online: 05 de Novembro de 2017, 00:19 »
Olá para todos! É minha primeira semana fora da casca do Windows. Então me desculpem ao que possa ser trivial. Estou com dúvida com relação a indicar pastas ou discos a um determinado programa. Eu tinha instalado no Windows (migrei essa semana para o Ubuntu) o Emby, um gerenciador de mídia. Numa determinada parte da configuração ele pede para indicar onde estão as pastas com filmes, seriados, etc... Só que eu não encontro no Ubuntu, onde elas estão? E outra coisa, nessa mesma tela de adicionar itens à biblioteca, o Emby me diz: "Para Linux no Arch Linux, CentOS, Debian, Fedora, OpenSuse ou Ubuntu, você deve permitir que o usuário de sistema do Emby tenha ao menos acesso de leitura no seu storage." No fórum do Emby, eles me mandaram pesquisar.
Então eu pesquisei. Abri as referidas pastas e fiz os seguintes comandos:
htpc@htpc-ULTRATOP-BRIX:/media/htpc/FIlmes/Filmes$ sudo su - root
[sudo] senha para htpc:
root@htpc-ULTRATOP-BRIX:~# chmod 777 /media/htpc/FIlmes/Filmes
root@htpc-ULTRATOP-BRIX:~# chmod 777 /media/htpc/FIlmes/Coleções
root@htpc-ULTRATOP-BRIX:~# chmod 777 /media/htpc/FIlmes/Filmes3D
root@htpc-ULTRATOP-BRIX:~# chmod 777 /media/htpc/FIlmes
root@htpc-ULTRATOP-BRIX:~# chmod 777 /media/htpc/FIlmes -r
chmod: não foi possível acessar '777': Arquivo ou diretório não encontrado
root@htpc-ULTRATOP-BRIX:~# chmod 777 /media/htpc/FIlmes -R
root@htpc-ULTRATOP-BRIX:~#

E ainda assim o Emby não pode acessá-las?
« Última modificação: 12 de Novembro de 2017, 00:52 por maurente »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.612
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #1 Online: 05 de Novembro de 2017, 11:12 »
Bom, assumindo que os pontos de montagem indicados por você estejam corretos, o comando do Chmod está errado!

Seriam:


chmod -R 777 /media/htpc/FIlmes/Coleções
chmod -R 777 /media/htpc/FIlmes/Filmes3D
chmod -R 777 /media/htpc/FIlmes


Note que é preciso o "-R" para que não somente a pasta "Filmes", por exemplo, tenha permissão total de leitura e escrita por todos que acessarem essa pasta. A opção "-R" vai fazer que todos os arquivos dentro das respectivas pastas tenham permissão total!

Mas como eu disse antes, assumo que esse caminho esteja correto, se não estiver não vai funcionar!

Tenta aí e diz o que foi que virou!
Ubuntu  Mate 17.10 64bits

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #2 Online: 05 de Novembro de 2017, 21:34 »
Não funcionou, mas há um porém. Essas unidades externas são NTFS. Talvez eu devesse transformar em ext4?

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.612
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #3 Online: 05 de Novembro de 2017, 23:52 »
maurente, andei pesquisando um pouco sobre o Emby e com mais esse "detalhe" do sua configuração dos HDs, fica tudo ainda mais estranho.

Se os seus HDs estão formatados em NTFS, não deveria haver problema nenhum de acesso se você tiver o ntfs-3g instalado e você antes de usar o Emby já usava esse HD formatado com NTFS com permissões de leitura e escrita. Então não seria necessário o uso do chmod!

Então é preciso "contar essa história direito"!

Qual versão do Ubuntu?

Como está essa configuração dos seus HDs?

Seus arquivos de mídia estão todos em HDs com NTFS? 

O Emby no Linux suporta o HD em NTFS?

A instalação do Emby correu tudo bem?  Só tem erro na hora de adicionar a biblioteca?

Qual tutorial você seguiu?

O tutorial que eu vi ele usa o Emby pelo SAMBA e tem que fazer a motagem dos HDs no fstab do sistema, senão não funciona!

É este o seu caso?  Ele vai funcionar pela rede? Ou seja, os HDs com os arquivos estão em um PC e você vai acessar esses arquivos de outro PC? É isso?  Porque se for, muda tudo na sua configuração!

Então sem mais detalhes de como as coisas estão organizadas aí e o que você quer fazer, fica meio difícil de te ajudar.  Você abriu tópico no Fórum do Emby em Português? Foi você?

Favor colar aqui a saída dos seguintes comandos:

Código: [Selecionar]
sudo fdisk -l
Código: [Selecionar]
sudo df -hT
Código: [Selecionar]
lsb_release -a


No aguardo!



Ubuntu  Mate 17.10 64bits

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #4 Online: 06 de Novembro de 2017, 00:40 »
É um programa complexo, um servidor de arquivos que fornece inclusive serviço DLNA.
Se vê que possui vários arquivos de configuração.

Pela descrição do tópico inicial que indica um caminho debaixo do /media, faz supor que os arquivos de media estejam em outra partição/disco na mesma máquina.

De fato na configuração do localhost:8096 o caminho debaixo do /media aparece mas não vai adiante.

A única forma que funcionou foi montando manualmente a partição que se quer acessar, aí funcionou tudo e a congfiguração foi até o final.

Por exemplo, supondo que o diretório (=pasta) com os arquivos de filmes estejam na partição sda5, então se fizer:

sudo mount /dev/sda5 /mnt

Dessa forma vai funcionar e conseguirá fazer a configuração.

Pode voltar lá na pasta do localhost e ir clicando no caminho até encontrar a pasta que se quer, funciona.

Note que isso é apenas um exemplo, precisa adequar com os dados reais que tem aí no sistema concreto.

Talvez haja uma outra forma de se fazer isso, testei adicionando o usuário emby que é criado na instalação a vários grupos, ao menos os que pareciam mais razoáveis, mas não funcionou, o que funcionou mesmo foi fazer a montagem manual, aí dá certo, dessa forma vai em frente. mas não está descartado de forma absoluta que possa haver outro método, entretanto, nesse caso precisa estudar a documentação do software.

No teste que fiz aqui o sistema estava em uma partição e os arquivos de media (filmes, fotos) em outra partição.

No seu caso como você diz que se trata de partição ntfs, se o sistema não reconhecer automáticamente (geralmente reconhece), então indique o formato adicionando no comando, enfim, aí é só uma questão de adequar o comando.

Por exemplo, se precisar indicar que é ntfs, então vai ficar:

sudo mount -t ntfs /dev/sda5 /mnt

Mas teste primeiramente sem indicar, talvez funcione de forma direta como no primeiro exemplo.

Editando:

Adicionei uma partição ntfs num segundo disco onde está um Windows e não precisou fazer nanda, não precisou especificar o formato, foi direto também, sem problemas.



« Última modificação: 06 de Novembro de 2017, 01:02 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #5 Online: 06 de Novembro de 2017, 11:33 »
Antes de mais nada muito obrigado aos dois. Vocês não imaginam como procurei ajuda em outros fóruns e não havia ninguém disposto. O fato é que eu tentei primeiramente com o Deepin e agora tento com o Ubuntu. Meus amigos ligados no Emby e Kodi, me aconselharam fortemente a não deixar o Windows, porque era complicado demais e tal, mas eu fui em frente pois queria fazer mais com menos, e essa era a premissa do Linux. Não quero voltar lá no fórum que trata do assunto de media player sem ter um tutorial Linux, pra mostrar que é possível sim. Estou há uma semana nessa.

O Emby e o Kodi fazem a dobradinha. Um recolhe dados de mídia, permite DLNA, transforma teu HTPC num Netflix se você quiser. O Segundo lê todos os dados de mídia recolhidos como capas, fanart, trilha sonora, e outros, agrupa numa bela interface, ainda agrega o Retroarch, tornando um dos melhores no gênero. Quando descobri que todos existiam para Linux, fui de atrás. Agora tem que abrir a estrada para os outros.

Voltando ao assunto, abaixo está o resultado dos comandos sugeridos. Mas antes que digam alguma coisa, achei esse tutorial que não fui feliz em executar: https://emby.media/community/index.php?/topic/32218-file-permissions-guide-for-new-linux-users/
O que estou fazendo agora é formatar todos hds (que são externos) em ext4, pra ver se facilita alguma coisa. Para isso estou fazendo um backup, o que resultou numa trapalhada que o Galactus está me ajudando a resolver em outro tópico. Grato mais uma vez.

htpc@htpc-ULTRATOP-BRIX:~$ sudo mount /dev/sdb2 /mnt
[sudo] senha para htpc:
Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.
htpc@htpc-ULTRATOP-BRIX:~$

htpc@htpc-ULTRATOP-BRIX:~$ sudo mount -t ntfs /dev/sdb2 /mnt
[sudo] senha para htpc:
Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.
htpc@htpc-ULTRATOP-BRIX:~$



Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.612
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #6 Online: 06 de Novembro de 2017, 15:01 »
E os comando que eu pedi?   ::)

 :-\

Então vai precisar colocar as opções de montagem no fstab mesmo! Ao que tudo indica.  É isso druidaobelix?
Ubuntu  Mate 17.10 64bits

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #7 Online: 06 de Novembro de 2017, 19:03 »
Primeiramente deixe registrar aqui o processo de instalação e habilitação do Emby, porque na verdade como se trata apenas de um teste, fiz a instalação apenas num live-iso, sem modo persistente, ou seja, não tenho uma instalação fixa e definitiva do Emby, então cada vez que volto ao problema preciso ficar procurando a informação para poder produzir uma nova instalação.

De qualquer forma isto ainda pode ser útil para mais alguém que queira instalar.

Como disse, desconsidere este post, vez que você já instalou aí e está funcionando.

Deixei na forma de um pequeno script com o nome embyinstall.sh apenas para facilitar:

Código: [Selecionar]

#!/bin/bash

#instala e habilita o Emby Server para o Ubuntu 16.04 a partir de ppa

wget -nv http://download.opensuse.org/repositories/home:emby/xUbuntu_16.04/Release.key -O Release.key

apt-key add - < Release.key

apt-get update

sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/ /' > /etc/apt/sources.list.d/emby-server.list"

apt-get update

apt-get install emby-server -y

systemctl start emby-server

systemctl status --no-pager emby-server

systemctl enable emby-server

echo
echo "chame o servidor através do navegador colocando o endereço localhost:8096"
echo


Instalação a partir do binário .deb direto do site do Emby

Necessário para a versão 17.10 que ainda não tem ppa

Código: [Selecionar]

#!/bin/bash

#instala e habilita o Emby Server para o Ubuntu a partir do binário deb direto do site do desenvolvedor
#necessário instalar dessa forma para o Ubuntu versão 17.10 Artful
#os repositórios main universe restricted multiverse precisam estar habilitados

wget -c https://github.com/MediaBrowser/Emby/releases/download/3.2.36.0/emby-server-deb_3.2.36.0_amd64.deb

dpkg -i emby-server-deb_3.2.36.0_amd64.deb

apt install lubuntu-restricted-extras -y

apt-get install vlc -y

systemctl start emby-server

systemctl status --no-pager emby-server

systemctl enable emby-server

echo
echo "chame o servidor através do navegador colocando o endereço localhost:8096"
echo


« Última modificação: 07 de Novembro de 2017, 01:33 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #8 Online: 06 de Novembro de 2017, 19:28 »
Note, também, que neste seu tópico estamos tratando de uma particularidade do uso do Emby, vez que a instalação em si não é problema, ocorre normalmente, bem como o uso normal quando os arquivos das medias estão dentro da própria /home do usuário também não há nenhum problema no uso.

Como muito possivelmente você já deve ter testado aí exautivamente, se adicionar o caminho da pasta Vídeos ou Pictures ou qualquer outra que esteja dentro da home do usuário, tudo funciona de primeira, sem dificuldades, sem problemas, a biblioteca aparece de primeira na homepage local do Emby, enfim, tudo funciona sem dificuldades (se ainda não fez, faça e teste com o caso simples).

O problema só existe porque, ao que parece (cadê os resultados dos comandos antes pedidos pelo @galactus?) você está querendo adicionar um disco externo que é montado debaixo do /media e como no Ubuntu essa montagem não é feita diretamente pelo usuário e sim usando um recurso da interface gráfica, o Emby acaba não identificando que é o próprio usuário que está marcando aquela path (ou porgue está usando o fuse).

A forma de resolver, como disse no post anterior e aqui funcionou de primeira, é fazer a montagem manual.

Você tentou fazer mas o disco externo (é isso mesmo, disco externo?) está sendo usado por um outro processo, que por enquanto não sabemos qual seja.

Comece trazendo ao tópico (além dos comandos que o @galactus pediu e precisamos deles também):

Código: [Selecionar]
df -h
Isso permitirá ver qual é mais exatatamente o dispositivo que está montado.

Na mesma situação do erro, ou seja, com o disco externo plugado, tentou fazer e deu o erro, portanto, o quadro fático presente, traga também:

Código: [Selecionar]
cat /proc/mounts
Isso permitirá ver o que é que está montando naquele instante.

E agora por enquanto apenas um palpite, experimente fazer desmontar a unidade, se o caso force a desmontagem.

Pelo que você postou estou supondo que o tal disco/partição externo esteja em /dev/sdb2

Primeiro desmonte usando a própria interface gráfica, isto é, se montou antes pela interface gráfica (e portanto está debaixo do /media) comece desmontado também pela interface gráfica, usando o botão direito do mouse e clicando em desmontar.

Depois faça:

Código: [Selecionar]
sudo umount /dev/sdb2
Se não funcionar faça:

Código: [Selecionar]
sudo umount -f /dev/sdb2
Com o df -h você verifica se desmontou mesmo, pois se desmontou ele desaparece de lá.

Tendo conseguido desmontar agora tente novamente a montagem da forma antes mencionada:

Código: [Selecionar]
sudo mount /dev/sdb2 /mnt
Se o disco/partição ainda estiver em ntfs pode experimentar também assim:

Código: [Selecionar]
sudo mount -t ntfs /dev/sdb2 /mnt
ou assim:

Código: [Selecionar]
sudo mount -t ntfs-3g /dev/sdb2 /mnt
ou assim:

Código: [Selecionar]
sudo mount -t ntfs-3g /dev/sdb2 /mnt -o uid=1000,gid=1000

Em cada uma dessas tentivas você deixa o navegador aberto no localhost:8096 na página "Adicionar bibliotecas" e vai verificando se funciona.

« Última modificação: 06 de Novembro de 2017, 19:45 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #9 Online: 06 de Novembro de 2017, 20:03 »
Então vai precisar colocar as opções de montagem no fstab mesmo! Ao que tudo indica.  É isso druidaobelix?

Vocẽ tem razão, acho que é mesmo uma boa ideia, uma boa alternativa, experimentar vir com a unidade já montada a partir do fstab.

O @maurente disse que está formatando o disco, que parece ser um disco externo, para ext4, o que deverá facilitar, então aí se identifica o uuid e acrescenta no fstab e já deixe ele chegar montado no final do boot e carregamento da interface, para ver se o emby-server reconhece a path.



www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #10 Online: 06 de Novembro de 2017, 21:12 »
maurente, andei pesquisando um pouco sobre o Emby e com mais esse "detalhe" do sua configuração dos HDs, fica tudo ainda mais estranho.

Se os seus HDs estão formatados em NTFS, não deveria haver problema nenhum de acesso se você tiver o ntfs-3g instalado e você antes de usar o Emby já usava esse HD formatado com NTFS com permissões de leitura e escrita. Então não seria necessário o uso do chmod!

Então é preciso "contar essa história direito"!

Qual versão do Ubuntu?
Ubuntu 17.10

Como está essa configuração dos seus HDs?
Não sei se entendi direito essa pergunta. Estão todos ligados em USB.

Seus arquivos de mídia estão todos em HDs com NTFS? 
Agora não apenas NTFS. Já formatei 2 com ext4, e outros 3 (os maiores) continuam como NTFS. Mas o backup está em progresso.

O Emby no Linux suporta o HD em NTFS?
Segundo esse tutorial(https://emby.media/community/index.php?/topic/32218-file-permissions-guide-for-new-linux-users/), me corrija se estiver errado, sim, suporta.

A instalação do Emby correu tudo bem?  Só tem erro na hora de adicionar a biblioteca?
Sim a instalação foi normal, baixei do site do Emby. O erro é ao adicionar a biblioteca, quando vou procurar o HD, clicando de pasta em pasta, quando clico na /media depois, em htpc, a janela de navegação tranca, sendo só possível cancelar.

Qual tutorial você seguiu?
Na verdade estou(estava) fazendo como sempre fiz no Windows, até descobrir que existem permissões no Linux.

O tutorial que eu vi ele usa o Emby pelo SAMBA e tem que fazer a motagem dos HDs no fstab do sistema, senão não funciona!

É este o seu caso?  Ele vai funcionar pela rede? Ou seja, os HDs com os arquivos estão em um PC e você vai acessar esses arquivos de outro PC? É isso?  Porque se for, muda tudo na sua configuração!
Não está em outro PC. Os HDs externos estão todos espetados no mesmo PC com Ubuntu. São 5 HDs externos, 5Tb, 4Tb, 2Tb, 2Tb, 1Tb.

Então sem mais detalhes de como as coisas estão organizadas aí e o que você quer fazer, fica meio difícil de te ajudar.  Você abriu tópico no Fórum do Emby em Português? Foi você?
Abri um tópico no fórum do Emby, mas em inglês (do Google), quando ainda tentava com o Deepin. https://emby.media/community/index.php?/topic/52449-emby-for-deepin/

Favor colar aqui a saída dos seguintes comandos:

Código: [Selecionar]
sudo fdisk -lhtpc@htpc-ULTRATOP-BRIX:~$ sudo fdisk -l
Disk /dev/loop0: 83,1 MiB, 87089152 bytes, 170096 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 235,4 MiB, 246800384 bytes, 482032 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: F0317306-9057-453D-8360-4DD8D3292B09

Dispositivo   Start        Fim    Setores  Size Tipo
/dev/sda1      2048    1050623    1048576  512M EFI System
/dev/sda2   1050624 1953523711 1952473088  931G Linux filesystem


Disk /dev/sdb: 4,6 TiB, 5000981077504 bytes, 9767541167 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 33553920 bytes
Disklabel type: gpt
Disk identifier: 1A169237-70F9-455F-B7B1-947ED2A7422B

Dispositivo  Start        Fim    Setores  Size Tipo
/dev/sdb2   264192 9767540735 9767276544  4,6T Microsoft basic data


Disk /dev/sdc: 1,8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xa90bd3bd

Dispositivo Inicializar Start        Fim    Setores  Size Id Tipo
/dev/sdc1   *              64 3907024064 3907024001  1,8T 83 Linux


Disk /dev/sdd: 3,7 GiB, 4004511744 bytes, 7821312 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x4e2f9c27

Dispositivo Inicializar Start     Fim Setores  Size Id Tipo
/dev/sdd1   *            2048 7821311 7819264  3,7G  c W95 FAT32 (LBA)


Disk /dev/sde: 3,7 TiB, 4000787025920 bytes, 976754645 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xe7469026

Dispositivo Inicializar Start       Fim   Setores  Size Id Tipo
/dev/sde1   *              64 976752063 976752000  3,7T  7 HPFS/NTFS/exFAT


Disk /dev/sdf: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x68657c4a

Dispositivo Inicializar Start        Fim    Setores   Size Id Tipo
/dev/sdf1   *              64 1953520064 1953520001 931,5G  7 HPFS/NTFS/exFAT


Disk /dev/sdg: 1,8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x5a1671a9

Dispositivo Inicializar Start        Fim    Setores  Size Id Tipo
/dev/sdg1               16065 3907024064 3907008000  1,8T  f Win95 (LBA) Partiçã
/dev/sdg2                2048      16064      14017  6,9M 83 Linux
/dev/sdg5               16128 3907024064 3907007937  1,8T 83 Linux

Partition table entries are not in disk order.
htpc@htpc-ULTRATOP-BRIX:~$

Código: [Selecionar]
sudo df -hThtpc@htpc-ULTRATOP-BRIX:~$ sudo df -hT
Sist. Arq.     Tipo      Tam. Usado Disp. Uso% Montado em
udev           devtmpfs  1,9G     0  1,9G   0% /dev
tmpfs          tmpfs     378M   45M  333M  12% /run
/dev/sda2      ext4      916G  660G  210G  76% /
tmpfs          tmpfs     1,9G   19M  1,9G   1% /dev/shm
tmpfs          tmpfs     5,0M  4,0K  5,0M   1% /run/lock
tmpfs          tmpfs     1,9G     0  1,9G   0% /sys/fs/cgroup
/dev/loop0     squashfs   84M   84M     0 100% /snap/core/3247
/dev/loop1     squashfs  236M  236M     0 100% /snap/chromium/88
/dev/sda1      vfat      511M  4,6M  507M   1% /boot/efi
/dev/sdd1      vfat      3,8G  1,4G  2,4G  38% /media/htpc/UBUNTU 17_1
/dev/sdc1      ext4      1,8T  389G  1,4T  23% /media/htpc/Arquivos
/dev/sdf1      fuseblk   932G  408G  525G  44% /media/htpc/Desenhos
/dev/sde1      fuseblk   3,7T  2,4T  1,3T  66% /media/htpc/Animações
/dev/sdb2      fuseblk   4,6T  4,1T  492G  90% /media/htpc/FIlmes
tmpfs          tmpfs     378M   16K  378M   1% /run/user/121
/dev/sdg5      ext4      1,8T  934G  806G  54% /media/htpc/Outros
tmpfs          tmpfs     378M  2,5M  376M   1% /run/user/1000
htpc@htpc-ULTRATOP-BRIX:~$

Código: [Selecionar]
lsb_release -ahtpc@htpc-ULTRATOP-BRIX:~$ lsb_release -a
No LSB modules are available.
Distributor ID:   Ubuntu
Description:   Ubuntu 17.10
Release:   17.10
Codename:   artful
htpc@htpc-ULTRATOP-BRIX:~


No aguardo!

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #11 Online: 06 de Novembro de 2017, 21:29 »
O Emby no Linux suporta o HD em NTFS?
Segundo esse tutorial(https://emby.media/community/index.php?/topic/32218-file-permissions-guide-for-new-linux-users/), me corrija se estiver errado, sim, suporta.

Se o cidadão do link que você postou (que só agora estou lendo) estiver certo a resposta ao problema é essa:

If you are mounting the drive using the auto-mounting provided by the distro, you will need to add rw,uid=username,gid=groupname to the mount options for the auto-mounter.  In Gnome, this can be accomplished via Disks.

ou então, como disse o @galactus, vir com o disco montado já no fstab.
« Última modificação: 07 de Novembro de 2017, 00:09 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #12 Online: 06 de Novembro de 2017, 21:44 »
Note, também, que neste seu tópico estamos tratando de uma particularidade do uso do Emby, vez que a instalação em si não é problema, ocorre normalmente, bem como o uso normal quando os arquivos das medias estão dentro da própria /home do usuário também não há nenhum problema no uso.

Como muito possivelmente você já deve ter testado aí exautivamente, se adicionar o caminho da pasta Vídeos ou Pictures ou qualquer outra que esteja dentro da home do usuário, tudo funciona de primeira, sem dificuldades, sem problemas, a biblioteca aparece de primeira na homepage local do Emby, enfim, tudo funciona sem dificuldades (se ainda não fez, faça e teste com o caso simples).
O meu problema maior, e agora eu vejo isso, é de conhecimento de comandos.  :-\ Os comandos que o Galactus pediu, eu copiei e colei o caminho de um dos HDs, /dev/sdd1, e aparentemente ele aceitou. Meu problema é que devo indicar a pasta, pois no mesmo HD tenho filmes e seriados, que devem ser distintos para o Emby. E eu não sei achar a pasta por linha de comando...  :-[

O problema só existe porque, ao que parece (cadê os resultados dos comandos antes pedidos pelo @galactus?) você está querendo adicionar um disco externo que é montado debaixo do /media e como no Ubuntu essa montagem não é feita diretamente pelo usuário e sim usando um recurso da interface gráfica, o Emby acaba não identificando que é o próprio usuário que está marcando aquela path (ou porgue está usando o fuse).

A forma de resolver, como disse no post anterior e aqui funcionou de primeira, é fazer a montagem manual.

Você tentou fazer mas o disco externo (é isso mesmo, disco externo?) está sendo usado por um outro processo, que por enquanto não sabemos qual seja.

Comece trazendo ao tópico (além dos comandos que o @galactus pediu e precisamos deles também):

Código: [Selecionar]
df -hhtpc@htpc-ULTRATOP-BRIX:~$ df -h
Sist. Arq.      Tam. Usado Disp. Uso% Montado em
udev            1,9G     0  1,9G   0% /dev
tmpfs           378M   45M  333M  12% /run
/dev/sda2       916G  660G  210G  76% /
tmpfs           1,9G   19M  1,9G   1% /dev/shm
tmpfs           5,0M  4,0K  5,0M   1% /run/lock
tmpfs           1,9G     0  1,9G   0% /sys/fs/cgroup
/dev/loop0       84M   84M     0 100% /snap/core/3247
/dev/loop1      236M  236M     0 100% /snap/chromium/88
/dev/sda1       511M  4,6M  507M   1% /boot/efi
/dev/sdd1       3,8G  1,4G  2,4G  38% /media/htpc/UBUNTU 17_1
/dev/sdc1       1,8T  395G  1,4T  23% /media/htpc/Arquivos
/dev/sdf1       932G  408G  525G  44% /media/htpc/Desenhos
/dev/sde1       3,7T  2,4T  1,3T  65% /media/htpc/Animações
/dev/sdb2       4,6T  4,1T  492G  90% /media/htpc/FIlmes
tmpfs           378M   16K  378M   1% /run/user/121
/dev/sdg5       1,8T  934G  806G  54% /media/htpc/Outros
/dev/fuse       1,0T     0  1,0T   0% /home/htpc/Nuvem
tmpfs           378M  2,5M  376M   1% /run/user/1000
htpc@htpc-ULTRATOP-BRIX:~$

Isso permitirá ver qual é mais exatatamente o dispositivo que está montado.

Na mesma situação do erro, ou seja, com o disco externo plugado, tentou fazer e deu o erro, portanto, o quadro fático presente, traga também:

Código: [Selecionar]
cat /proc/mountshtpc@htpc-ULTRATOP-BRIX:~$ cat /proc/mounts
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev devtmpfs rw,nosuid,relatime,size=1906268k,nr_inodes=476567,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /run tmpfs rw,nosuid,noexec,relatime,size=386552k,mode=755 0 0
/dev/sda2 / ext4 rw,relatime,errors=remount-ro,data=ordered 0 0
securityfs /sys/kernel/security securityfs rw,nosuid,nodev,noexec,relatime 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
tmpfs /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0
cgroup /sys/fs/cgroup/unified cgroup2 rw,nosuid,nodev,noexec,relatime 0 0
cgroup /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,xattr,name=systemd 0 0
pstore /sys/fs/pstore pstore rw,nosuid,nodev,noexec,relatime 0 0
efivarfs /sys/firmware/efi/efivars efivarfs rw,nosuid,nodev,noexec,relatime 0 0
cgroup /sys/fs/cgroup/net_cls,net_prio cgroup rw,nosuid,nodev,noexec,relatime,net_cls,net_prio 0 0
cgroup /sys/fs/cgroup/cpu,cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpu,cpuacct 0 0
cgroup /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0
cgroup /sys/fs/cgroup/pids cgroup rw,nosuid,nodev,noexec,relatime,pids 0 0
cgroup /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0
cgroup /sys/fs/cgroup/hugetlb cgroup rw,nosuid,nodev,noexec,relatime,hugetlb 0 0
cgroup /sys/fs/cgroup/perf_event cgroup rw,nosuid,nodev,noexec,relatime,perf_event 0 0
cgroup /sys/fs/cgroup/memory cgroup rw,nosuid,nodev,noexec,relatime,memory 0 0
cgroup /sys/fs/cgroup/rdma cgroup rw,nosuid,nodev,noexec,relatime,rdma 0 0
cgroup /sys/fs/cgroup/blkio cgroup rw,nosuid,nodev,noexec,relatime,blkio 0 0
cgroup /sys/fs/cgroup/devices cgroup rw,nosuid,nodev,noexec,relatime,devices 0 0
systemd-1 /proc/sys/fs/binfmt_misc autofs rw,relatime,fd=27,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=604 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
mqueue /dev/mqueue mqueue rw,relatime 0 0
hugetlbfs /dev/hugepages hugetlbfs rw,relatime,pagesize=2M 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
configfs /sys/kernel/config configfs rw,relatime 0 0
/dev/loop0 /snap/core/3247 squashfs ro,nodev,relatime 0 0
/dev/loop1 /snap/chromium/88 squashfs ro,nodev,relatime 0 0
/dev/sda1 /boot/efi vfat rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0
/dev/sdd1 /media/htpc/UBUNTU\04017_1 vfat rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro 0 0
/dev/sdc1 /media/htpc/Arquivos ext4 rw,nosuid,nodev,relatime,data=ordered 0 0
/dev/sdf1 /media/htpc/Desenhos fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0
/dev/sde1 /media/htpc/Animações fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0
/dev/sdb2 /media/htpc/FIlmes fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0
tmpfs /run/user/121 tmpfs rw,nosuid,nodev,relatime,size=386548k,mode=700,uid=121,gid=127 0 0
/dev/sdg5 /media/htpc/Outros ext4 rw,nosuid,nodev,relatime,data=ordered 0 0
/dev/fuse /home/htpc/Nuvem fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
tmpfs /run/user/1000 tmpfs rw,nosuid,nodev,relatime,size=386548k,mode=700,uid=1000,gid=1000 0 0
gvfsd-fuse /run/user/1000/gvfs fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
htpc@htpc-ULTRATOP-BRIX:~$

Isso permitirá ver o que é que está montando naquele instante.

E agora por enquanto apenas um palpite, experimente fazer desmontar a unidade, se o caso force a desmontagem.
Já fiz isso, não rolou.

Pelo que você postou estou supondo que o tal disco/partição externo esteja em /dev/sdb2

Primeiro desmonte usando a própria interface gráfica, isto é, se montou antes pela interface gráfica (e portanto está debaixo do /media) comece desmontado também pela interface gráfica, usando o botão direito do mouse e clicando em desmontar.

Depois faça:

Código: [Selecionar]
sudo umount /dev/sdb2
Se não funcionar faça:

Código: [Selecionar]
sudo umount -f /dev/sdb2
Com o df -h você verifica se desmontou mesmo, pois se desmontou ele desaparece de lá.

Tendo conseguido desmontar agora tente novamente a montagem da forma antes mencionada:

Código: [Selecionar]
sudo mount /dev/sdb2 /mnt
Se o disco/partição ainda estiver em ntfs pode experimentar também assim:

Código: [Selecionar]
sudo mount -t ntfs /dev/sdb2 /mnt
ou assim:

Código: [Selecionar]
sudo mount -t ntfs-3g /dev/sdb2 /mnt
ou assim:

Código: [Selecionar]
sudo mount -t ntfs-3g /dev/sdb2 /mnt -o uid=1000,gid=1000
Espero que me desculpe, mas não posso executar esses comandos agora por causa do backup.

Em cada uma dessas tentivas você deixa o navegador aberto no localhost:8096 na página "Adicionar bibliotecas" e vai verificando se funciona.

Offline maurente

  • Usuário Ubuntu
  • *
  • Mensagens: 68
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #13 Online: 06 de Novembro de 2017, 21:50 »
 Uma dúvida, quando o Ubuntu entra em tela em espera, apesar de eu ter desativado isso, eu tenho que entrar de novo com minha senha, e noto que a cópia (backup) parou... Tenho que recomeçar de onde foi interrompido. É um parto! Aliás qualquer processo acontece isso.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Emby para Ubuntu
« Resposta #14 Online: 06 de Novembro de 2017, 22:36 »
Espero que me desculpe, mas não posso executar esses comandos agora por causa do backup.


Termine o backup, pois backup tem prioridade sobre qualquer outra coisa.
Depois de tudo pronto, avise que continuamos esmiuçando a questão.

O primeiro caminho é fazer a montagem manual, pois não é admissível que não se consiga montar um disco/partição.

« Última modificação: 06 de Novembro de 2017, 22:38 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.