Autor Tópico: REVOLTA  (Lida 7508 vezes)

Offline ass0mbracao

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
REVOLTA
« Online: 12 de Outubro de 2006, 13:17 »
Buenas pessoal, estou mais uma vez tentando instalar o driver da minha ATI....e acho que ja sei o que pode estar acontecendo de errado.
Fui atras de varios artigos na net vi que todos usam os mesmos passos salvo algumas distros diferentes....bom entao resolver marcar cada passo que eu executava.
Lendo os logs enfim.
Estou tentando instalar o driver proprietario da ATI versao ati-driver-installer-8.29.6.
Bom os passos sao ./ati-driver-installer-8.29.6 --buildpkg Ubunutu/dapper
dpkg -i *.deb
module-assi.... prepare
module-assi.... update
module-assi.... build fglrx
* module-assi.... install fglrx
quando rodo esse ultimo comando ele me da a seguinte mensagem
"Package fglrx-kernel-source was not built successfuly, see /var/cache/fglrx-kernel-source*buildlog* for details!"

Bom o conteudo do log esta abaixo

Código: [Selecionar]
dh_testroot
rm -f configure-stamp
rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
rm -rf .tmp_versions
rm -rf patch
dh_clean
rm /usr/src/modules/fglrx/debian/control
rm /usr/src/modules/fglrx/debian/dirs
if [ -f /usr/src/modules/fglrx/debian/control.template ]; then \
cat /usr/src/modules/fglrx/debian/control.template > /usr/src/modules/fglrx/debian/control; \
fi
if [ -f /usr/src/modules/fglrx/debian/postinst ]; then \
mv /usr/src/modules/fglrx/debian/postinst /usr/src/modules/fglrx/debian/fglrx-kernel-2.6.15-27-686.postinst; \
fi
dh_testdir
touch configure-stamp
dh_testdir
/usr/bin/make -C /usr/src/linux SUBDIRS=/usr/src/modules/fglrx modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.15-27-686'
Makefile:536: /usr/src/linux-headers-2.6.15-27-686/arch/i386/Makefile: No such file or directory
make[1]: *** No rule to make target `/usr/src/linux-headers-2.6.15-27-686/arch/i386/Makefile'.  Stop.
make[1]: Leaving directory `/usr/src/linux-headers-2.6.15-27-686'
make: *** [build] Error 2

[cite]
Correcao executei uns passos diferentes que encontrei na net
module...... build -k /usr/src/linux/ fglrx
module...... install -k /usr/src/linux fglrx

Funcionou nao deu nenhuma mensagem de erro.
Porem minha placa continua sem funcionar.

aranha@aranha-laptop:~$ lspci
Código: [Selecionar]
0000:00:00.0 Host bridge: ATI Technologies Inc Radeon 9100 IGP Host Bridge (rev 02)
0000:00:01.0 PCI bridge: ATI Technologies Inc Radeon 9100 IGP AGP Bridge
0000:00:13.0 USB Controller: ATI Technologies Inc OHCI USB Controller #1 (rev 01)
0000:00:13.1 USB Controller: ATI Technologies Inc OHCI USB Controller #2 (rev 01)
0000:00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 16)
0000:00:14.1 IDE interface: ATI Technologies Inc ATI Dual Channel Bus Master PCI IDE Controller
0000:00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 434c
0000:00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4342
0000:00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
0000:00:14.6 Modem: ATI Technologies Inc IXP AC'97 Modem (rev 01)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc RS300M AGP [Radeon Mobility 9100IGP]
0000:02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
0000:02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:04.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller (rev 01)
0000:02:04.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller (rev 01)
0000:02:07.0 USB Controller: NEC Corporation USB (rev 43)
0000:02:07.1 USB Controller: NEC Corporation USB (rev 43)
0000:02:07.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0000:03:00.0 Ethernet controller: Abocom Systems Inc ADMtek Centaur-C rev 17 [D-Link DFE-680TX] CardBus Fast Ethernet Adapter (rev 11)


[UPDATE]
NAO AGUENTO MAIS! JA LI TUDO QUANTO FOI ARTIGO NA INTERNET..INGLES, FRANCES, ATE UMA COISA LAH ALIENIGENA QUE EU NAO ENTENDI PEGUEI OS COMANDOS QUE TINHA E EXECUTEI.
E NADA DESSA PORCARIA DE DRIVER FUNCIONAR....
ESTOU PEDINDO POR FAVOR ALGUEM PODE ME AJUDAR A SOLUCIONAR ESSE MALDITO PROBLEMA?
OBRIGADO
[/UPDATE]
« Última modificação: 13 de Outubro de 2006, 19:36 por ass0mbracao »

Offline ass0mbracao

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Problema no module-assistant build/install para fglrx
« Resposta #1 Online: 12 de Outubro de 2006, 13:53 »
aranha@aranha-laptop:~$ dmesg|grep ATI
Código: [Selecionar]
[17179569.184000] ATI board detected. Disabling timer routing over 8254.
[17179569.184000] ACPI: FADT (v001 HP     Chinook  0x06040000 ATI  0x000f4240) @ 0x17f7ceed
[17179573.592000] ATIIXP: IDE controller at PCI slot 0000:00:14.1
[17179573.592000] ATIIXP: chipset revision 0
[17179573.592000] ATIIXP: not 100% native mode: will probe irqs later
[17179597.100000] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.

aranha@aranha-laptop:~$ dmesg|grep ati
Código: [Selecionar]
[17179569.184000] Using ACPI (MADT) for SMP configuration information
[17179569.184000] Allocating PCI resources starting at 30000000 (gap: 28000000:d6c00000)
[17179569.512000] Calibrating delay using timer specific routine.. 6405.01 BogoMIPS (lpj=12810034)
[17179569.528000] SMP alternatives: switching to UP code
[17179570.796000] SMP alternatives: switching to SMP code
[17179570.888000] Calibrating delay using timer specific routine.. 6400.76 BogoMIPS (lpj=12801521)
[17179571.032000] checking TSC synchronization across 2 CPUs: passed.
[17179571.036000] PCI: Using configuration type 1
[17179573.592000] ATIIXP: not 100% native mode: will probe irqs later
[17179593.540000] ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
[17179594.044000] 8139cp: pci dev 0000:02:03.0 (id 10ec:8139 rev 10) is not an 8139C+ compatible chip

aranha@aranha-laptop:~$ dmesg|grep fglrx
Código: [Selecionar]
[17179597.100000] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[17179597.104000] [fglrx] Maximum main memory to use for locked dma buffers: 313 MBytes.
[17179597.104000] [fglrx] module loaded - fglrx 8.29.6 [Sep 19 2006] on minor 0
[17179615.864000] [fglrx:firegl_init_mask_ram] *ERROR* maskram_type not detected
[17179615.864000] [fglrx] Internal AGP support requested, but kernel AGP support active.
[17179615.864000] [fglrx] Have to use kernel AGP support to avoid conflicts.
[17179615.864000] [fglrx] AGP detected, AgpState   = 0x1f00021b (hardware caps of chipset)
[17179615.868000] [fglrx] AGP enabled,  AgpCommand = 0x1f000312 (selected caps)
[17179615.884000] [fglrx] total      GART = 33554432
[17179615.884000] [fglrx] free       GART = 17559552
[17179615.884000] [fglrx] max single GART = 17559552
[17179615.884000] [fglrx] total      LFB  = 128020480
[17179615.884000] [fglrx] free       LFB  = 119828480
[17179615.884000] [fglrx] max single LFB  = 119828480
[17179615.884000] [fglrx] total      Inv  = 0
[17179615.884000] [fglrx] free       Inv  = 0
[17179615.884000] [fglrx] max single Inv  = 0
[17179615.884000] [fglrx] total      TIM  = 0
[17180391.628000] [fglrx:firegl_init_mask_ram] *ERROR* maskram_type not detected
[17180391.628000] [fglrx] Internal AGP support requested, but kernel AGP support active.
[17180391.628000] [fglrx] Have to use kernel AGP support to avoid conflicts.
[17180391.628000] [fglrx] AGP detected, AgpState   = 0x1f00021b (hardware caps of chipset)
[17180391.628000] [fglrx] AGP enabled,  AgpCommand = 0x1f000312 (selected caps)
[17180391.644000] [fglrx] total      GART = 33554432
[17180391.644000] [fglrx] free       GART = 17559552
[17180391.644000] [fglrx] max single GART = 17559552
[17180391.644000] [fglrx] total      LFB  = 128020480
[17180391.644000] [fglrx] free       LFB  = 119828480
[17180391.644000] [fglrx] max single LFB  = 119828480
[17180391.644000] [fglrx] total      Inv  = 0
[17180391.644000] [fglrx] free       Inv  = 0
[17180391.644000] [fglrx] max single Inv  = 0
[17180391.644000] [fglrx] total      TIM  = 0
« Última modificação: 12 de Outubro de 2006, 13:56 por ass0mbracao »

Offline ass0mbracao

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Problema no module-assistant build/install para fglrx
« Resposta #2 Online: 12 de Outubro de 2006, 13:58 »
aranha@aranha-laptop:~$ glxgears -printfps
Código: [Selecionar]
1300 frames in 5.5 seconds = 234.374 FPS
1260 frames in 5.6 seconds = 226.209 FPS
1260 frames in 5.6 seconds = 226.041 FPS
1260 frames in 5.6 seconds = 226.735 FPS
1260 frames in 5.6 seconds = 226.257 FPS
1260 frames in 5.6 seconds = 226.004 FPS
1120 frames in 5.1 seconds = 218.797 FPS
X connection to :0.0 broken (explicit kill or server shutdown).

aranha@aranha-laptop:~$ cat /etc/X11/xorg.conf
Código: [Selecionar]
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
        InputDevice    "stylus" "SendCoreEvents"
        InputDevice    "cursor" "SendCoreEvents"
        InputDevice    "eraser" "SendCoreEvents"
        InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"

        # path to defoma fonts
        FontPath     "/usr/share/X11/fonts/misc"
        FontPath     "/usr/share/X11/fonts/cyrillic"
        FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath     "/usr/share/X11/fonts/Type1"
        FontPath     "/usr/share/X11/fonts/100dpi"
        FontPath     "/usr/share/X11/fonts/75dpi"
        FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load  "bitmap"
        Load  "ddc"
        Load  "dri"
        Load  "extmod"
        Load  "freetype"
        Load  "glx"
        Load  "int10"
        Load  "type1"
        Load  "vbe"
EndSection

Section "InputDevice"
        Identifier  "Generic Keyboard"
        Driver      "kbd"
        Option      "CoreKeyboard"
        Option      "XkbRules" "xorg"
        Option      "XkbModel" "pc104"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Configured Mouse"
        Driver      "mouse"
        Option      "CorePointer"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "ExplorerPS/2"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
        Identifier  "Synaptics Touchpad"
        Driver      "synaptics"
        Option      "SendCoreEvents" "true"
        Option      "Device" "/dev/psaux"
        Option      "Protocol" "auto-dev"
        Option      "HorizScrollDelta" "0"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
        Identifier  "stylus"
        Driver      "wacom"
        Option      "Device" "/dev/wacom"          # Change to
        Option      "Type" "stylus"
        Option      "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
        Identifier  "eraser"
        Driver      "wacom"
        Option      "Device" "/dev/wacom"          # Change to
        Option      "Type" "eraser"
        Option      "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
        Identifier  "cursor"
        Driver      "wacom"
        Option      "Device" "/dev/wacom"          # Change to
        Option      "Type" "cursor"
        Option      "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
        Identifier   "HP Pavilion zv5000"
        HorizSync    30.0 - 60.0
        VertRefresh  50.0 - 75.0
        Option      "DPMS"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "ATI Technologies, Inc. Radeon Mobility 9100 U3 (R200 IGP)"
        Driver      "fglrx"
        BusID       "PCI:1:5:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        Option      "VideoOverlay" "on"
        Option      "OpenGLOverlay" "off"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device     "ATI Technologies, Inc. Radeon Mobility 9100 U3 (R200 IGP)"
        Monitor    "HP Pavilion zv5000"
        DefaultDepth     16
        SubSection "Display"
                Depth     1
                Modes    "1280x768" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     4
                Modes    "1280x768" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     8
                Modes    "1280x768" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     15
                Modes    "1280x768" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     16
                Modes    "1280x768" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth     24
                Modes    "1280x768" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "DRI"
        Mode         0666
EndSection


Eh isso ae pessoal espero que com essas infos voces possam me ajudar.

Abracos

Offline ass0mbracao

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Problema no modulo fglrx
« Resposta #3 Online: 13 de Outubro de 2006, 18:33 »
Nada??? Ninguem tem ideia do que pode estar acontecendo?

Offline Dindo

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: REVOLTA
« Resposta #4 Online: 13 de Outubro de 2006, 20:10 »
Caro amigo assOombraçao.
Ao que tudo indica o seu problema esta no suporte agp que e fornecido pelo kernel, tenta habilitar o suporte agp interno da placa colocando no seu xorg a linha  Option      "UseInternalAGPGART" "Yes",antes do "VideoOverlay" "on" e ve se funciona.
Abraços.

boi

  • Visitante
Re: REVOLTA
« Resposta #5 Online: 13 de Outubro de 2006, 20:40 »
Acho que a melhor definição dos drivers da ATI foi dada nesse post:

http://ubuntuforum-pt.org/index.php?topic=11423.msg60633#msg60633

Quer um conselho? Use o driver open source.

Offline ass0mbracao

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: REVOLTA
« Resposta #6 Online: 14 de Outubro de 2006, 11:49 »
Acho que a melhor definição dos drivers da ATI foi dada nesse post:

http://ubuntuforum-pt.org/index.php?topic=11423.msg60633#msg60633

Quer um conselho? Use o driver open source.

A comparacao foi boa hehehehe gostei.
Quanto ao driver opensource eu tentei tambem e nao tive sucesso....

Offline ass0mbracao

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: REVOLTA
« Resposta #7 Online: 14 de Outubro de 2006, 11:58 »
Quer um conselho? Use o driver open source.

Voce acha q o driver do proprio Ubuntu eh melhor que o da ATI?

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.320
  • @Ceará
    • Ver perfil
Re: REVOLTA
« Resposta #8 Online: 14 de Outubro de 2006, 15:43 »
Este tópico está desrespeitando a seguinte regra do fórum.

Citar
7 - Devem ser evitadas mensagens dizendo apenas "Legal!", "Valeu" (e suas derivações onomatopéicas atuais), "Comigo funciona..." e similares. Mensagens desse tipo incham os tópicos e atrapalham quem está procurando solução para algum problema. Mensagens com título de "SOCORRO", "URGENTE", "ME AJUDEM" (ou seja, todo em maiúsculas e sem explicitação do conteúdo da mensagem) e similares serão imediatamente apagadas.

Por isso será trancado na seção Alcatraz.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: REVOLTA
« Resposta #9 Online: 16 de Outubro de 2006, 10:13 »
O usuário foi avisado por MP em 13 de Outubro de 2006, às 18h58, e não apenas não atendeu à advertência, como continuou postando.
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |