Autor Tópico: [Resolvido] Servidor Apache erro 403 Forbidden  (Lida 27613 vezes)

Offline Guilherme Vader

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
[Resolvido] Servidor Apache erro 403 Forbidden
« Online: 31 de Outubro de 2014, 10:12 »
Olá amigos,
Estou começando a estudar PHP e ao configurar o ambiente no Ubuntu tudo funcionou muito bem, mas daí eu inventei de tentar atualizar o PHP e agora quando acesso o servidor pelo navegador tudo que aparece é o erro 403:

Forbidden

You don't have permission to access / on this server.
Apache/2.4.10 (Ubuntu) Server at localhost Port 80


Alguém pode me ajudar?

Obrigado
« Última modificação: 05 de Novembro de 2014, 09:13 por Guilherme Vader »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor Apache erro 403 Forbidden
« Resposta #1 Online: 31 de Outubro de 2014, 14:01 »
Citar
mas daí eu inventei de tentar atualizar o Apache
Como vc fez a "proeza"? De repente tem como reverter.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Guilherme Vader

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Servidor Apache erro 403 Forbidden
« Resposta #2 Online: 31 de Outubro de 2014, 14:14 »
Citar
mas daí eu inventei de tentar atualizar o Apache
Como vc fez a "proeza"? De repente tem como reverter.

Ops, eu errei na explicação, desculpas. Na verdade o que eu tentei atualiza foi o PHP de 5.3 para 5.5. Eu segui esse artigo:

http://phpave.com/upgrade-php-5-3-php-5-5-ubuntu-12-04-lts/

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor Apache erro 403 Forbidden
« Resposta #3 Online: 31 de Outubro de 2014, 14:56 »
Certo. Tente um novo acesso, depois cole aqui as 20 últimas linhas do arquivo /var/log/apache2/error_log. (Só as últimas 20 linhas!!!)

O comando abaixo pode te ajudar a gerar a saída necessária.

tail -20 /var/log/apache2/error_log
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Guilherme Vader

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Servidor Apache erro 403 Forbidden
« Resposta #4 Online: 31 de Outubro de 2014, 15:28 »
Certo. Tente um novo acesso, depois cole aqui as 20 últimas linhas do arquivo /var/log/apache2/error_log. (Só as últimas 20 linhas!!!)

O comando abaixo pode te ajudar a gerar a saída necessária.

tail -20 /var/log/apache2/error_log

As 20 ultimas linhas do log de erro:


[Fri Oct 31 10:21:51.628855 2014] [authz_core:error] [pid 10394] [client 127.0.0.1:54649] AH01630: client denied by server configuration: /home/guilherme/www/scrape
[Fri Oct 31 10:23:31.824350 2014] [authz_core:error] [pid 10396] [client 127.0.0.1:54666] AH01630: client denied by server configuration: /home/guilherme/www/scrape
[Fri Oct 31 11:41:41.273320 2014] [authz_core:error] [pid 10402] [client 127.0.0.1:56016] AH01630: client denied by server configuration: /home/guilherme/www/announce
[Fri Oct 31 11:42:12.686531 2014] [authz_core:error] [pid 10392] [client 127.0.0.1:56017] AH01630: client denied by server configuration: /home/guilherme/www/announce
[Fri Oct 31 12:22:12.105642 2014] [authz_core:error] [pid 10393] [client 127.0.0.1:56109] AH01630: client denied by server configuration: /home/guilherme/www/scrape
[Fri Oct 31 12:23:51.308867 2014] [authz_core:error] [pid 10395] [client 127.0.0.1:56112] AH01630: client denied by server configuration: /home/guilherme/www/scrape
[Fri Oct 31 13:42:22.146397 2014] [authz_core:error] [pid 10394] [client 127.0.0.1:58141] AH01630: client denied by server configuration: /home/guilherme/www/announce
[Fri Oct 31 13:42:43.001960 2014] [authz_core:error] [pid 10396] [client 127.0.0.1:58144] AH01630: client denied by server configuration: /home/guilherme/www/announce
[Fri Oct 31 14:23:02.531229 2014] [authz_core:error] [pid 10402] [client 127.0.0.1:58876] AH01630: client denied by server configuration: /home/guilherme/www/scrape
[Fri Oct 31 14:24:31.960315 2014] [authz_core:error] [pid 10392] [client 127.0.0.1:58890] AH01630: client denied by server configuration: /home/guilherme/www/scrape
[Fri Oct 31 15:20:16.700964 2014] [authz_core:error] [pid 10393] [client 127.0.0.1:59751] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:21:36.545672 2014] [authz_core:error] [pid 10395] [client 127.0.0.1:59752] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:21:38.752992 2014] [authz_core:error] [pid 10395] [client 127.0.0.1:59752] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:21:40.576640 2014] [authz_core:error] [pid 10395] [client 127.0.0.1:59752] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:21:41.998802 2014] [authz_core:error] [pid 10395] [client 127.0.0.1:59752] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:21:43.385078 2014] [authz_core:error] [pid 10395] [client 127.0.0.1:59752] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:21:44.833484 2014] [authz_core:error] [pid 10395] [client 127.0.0.1:59752] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:21:46.192492 2014] [authz_core:error] [pid 10395] [client 127.0.0.1:59752] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:23:53.270263 2014] [authz_core:error] [pid 10394] [client 127.0.0.1:59753] AH01630: client denied by server configuration: /home/guilherme/www/
[Fri Oct 31 15:23:55.364761 2014] [authz_core:error] [pid 10394] [client 127.0.0.1:59753] AH01630: client denied by server configuration: /home/guilherme/www/

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Re: Servidor Apache erro 403 Forbidden
« Resposta #5 Online: 31 de Outubro de 2014, 16:19 »
Qual o resultado do comando "ls -l /var/www"?
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor Apache erro 403 Forbidden
« Resposta #6 Online: 31 de Outubro de 2014, 17:19 »
Citar
client denied by server configuration

Isso significa que seu servidor está configurado para não permitir acessos ao diretório /home/guilherme/www/ a partir de localhost. O que leva a outra pergunta, como vc associou o acesso a "/home/guilherme/www"? Vc lembra de ter mexido em alguma configuração do apache nesse sentido?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Guilherme Vader

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Servidor Apache erro 403 Forbidden
« Resposta #7 Online: 31 de Outubro de 2014, 17:50 »
Citar
client denied by server configuration

Isso significa que seu servidor está configurado para não permitir acessos ao diretório /home/guilherme/www/ a partir de localhost. O que leva a outra pergunta, como vc associou o acesso a "/home/guilherme/www"? Vc lembra de ter mexido em alguma configuração do apache nesse sentido?

Sim, mas isso foi antes do problema acontecer. Eu mudei o diretório do Apache mas ele funcionou perfeitamente. Eu segui esses passos:

Mudar o diretório do Apache

O primeiro passo é, caso o servidor Apache esteja rodando é para-lo com o comando:

$ sudo /etc/init.d/apache2 stop

Procure e edite o arquivo  “/etc/apache2/sites-enabled/000-default”:

$ sudo gedit /etc/apache2/sites-enabled/000-default
   

Substitua as duas ocorrências de /var/www por /home/[usuário]/www.

Salve, feche o gedit e reinicie o Apache2:

$ sudo /etc/init.d/apache2 start
sudo /etc/init.d/apache2 restart

Pronto!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor Apache erro 403 Forbidden
« Resposta #8 Online: 01 de Novembro de 2014, 12:24 »
Certo. Confirme então que seu diretório Home tem permissão de execução pública.

chown o+x /home/guilherme
chown o+x /home/guilherme/www


Essa permissão é necessária para que outros usuários possam encontrar arquivos e sub-diretórios dentro do seu diretório Home.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Guilherme Vader

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Servidor Apache erro 403 Forbidden
« Resposta #9 Online: 02 de Novembro de 2014, 11:28 »
Certo. Confirme então que seu diretório Home tem permissão de execução pública.

chown o+x /home/guilherme
chown o+x /home/guilherme/www


Essa permissão é necessária para que outros usuários possam encontrar arquivos e sub-diretórios dentro do seu diretório Home.

Apareceu a mensagem:

chown: usuário inválido: “o+x”

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor Apache erro 403 Forbidden
« Resposta #10 Online: 03 de Novembro de 2014, 03:01 »
Falha minha, o comando deveria ser "chmod", não "chown".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Guilherme Vader

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Servidor Apache erro 403 Forbidden
« Resposta #11 Online: 03 de Novembro de 2014, 08:02 »
Falha minha, o comando deveria ser "chmod", não "chown".

Eu imaginei que fosse chmod mesmo =p. Fiz isso, mas nada mudou.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor Apache erro 403 Forbidden
« Resposta #12 Online: 03 de Novembro de 2014, 11:16 »
Hmm. Execute o comando abaixo pra gente confirmar as permissões do caminho.

namei -m /home/guilherme/www
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Guilherme Vader

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Servidor Apache erro 403 Forbidden
« Resposta #13 Online: 03 de Novembro de 2014, 13:00 »
Hmm. Execute o comando abaixo pra gente confirmar as permissões do caminho.

namei -m /home/guilherme/www


f: /home/guilherme/www
 drwxr-xr-x /
 drwxr-xr-x home
 drwxrwxrwx guilherme
 drwxrwxrwx www

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Servidor Apache erro 403 Forbidden
« Resposta #14 Online: 03 de Novembro de 2014, 15:51 »
cara, me diz que vc não deu um "chmod 777" em seu Home dir...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D