Autor Tópico: Ubuntu 14.04 LTS nao reconhece cabo ethernet  (Lida 68379 vezes)

Offline alimnez

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #30 Online: 18 de Maio de 2015, 18:03 »
Ola,

Ontem eu instalei o Ubuntu 14.04 LTS 64 bit no meu pc e já na instalação percebi algo estranho, ele não tava conectando na internet, mas imaginei que poderia conectar quando eu terminasse de instalar.
Quando terminou de instalar veio o problema...o ubuntu não conecta na internet, tentei de tudo, li dezenas de tópicos e não consegui resolver o problema, digitei dezenas de comandos do terminal também e nada  :-\
Vamos lá então, quando eu conecto o cabo no pc eh como se não tivesse conectado ( atrás do computador piscam os leds da entrada ethernet ) no canto superior direito, do lado do relógio não muda nada !! por favor se alguém tiver uma luz ai pra me ajudar

Minha placa mae eh uma N68-S3 FX.

Boa noite pessoal.
Desculpem a ignorância, mas eu realmente pesquisei bastante antes de vir solicitar a ajuda de vocês.
Eu sou novo na plataforma e o meu caso é bem parecido com o do amigo.
No meu caso, estou fazendo um dual boot (Windows 7 e Ubuntu). Eu achei parecido porque quando estou instalando o Ubuntu 14.04, ele já não reconhece a Internet.
Eu também havia pensado que poderia solucionar isso depois que foi instalado, e nada. Tentei a versão mint 17.1 e o erro era o mesmo.

Eu possuo um modem que é ligado ao roteador e o roteador possui um cabo que vai direto no meu PC.
O windows reconhece normalmente quando eu ligo a máquina. Só consigo entrar na configuração do roteador (D-Link DIR-600) pelo windows tbm.
E ele está com o DHCP liberado.
No Ubuntu, a configuração do ethernet 1 está com DHCP automático.


Eis aqui o teste que realizei:

Citar
alisson@alisson-desktop:~$ sudo lshw -C network
[sudo] password for alisson:
PCI (sysfs)
alisson@alisson-desktop:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr bc:5f:f4:85:31:22 
          inet6 addr: fe80::be5f:f4ff:fe85:3122/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:121 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:23993 (23.9 KB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:165 errors:0 dropped:0 overruns:0 frame:0
          TX packets:165 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11649 (11.6 KB)  TX bytes:11649 (11.6 KB)


Citar
alisson@alisson-desktop:~$ nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            forcedeth
  State:             disconnected
  Default:           no
  HW Address:        BC:5F:F4:85:31:22

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on


Citar
alisson@alisson-desktop:~$ ping -c 4 8.8.8.8
connect: Network is unreachable
alisson@alisson-desktop:~$ ping -c 4 www.google.com
ping: unknown host www.google.com

Tentei o route -n e não aparecia nenhuma rota pra mim.

Alguma clareada amigos?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #31 Online: 19 de Maio de 2015, 12:35 »
Olá alimnez,
Parece que há algum problema com o driver "forcedeth" usado pra sua interface cabeada. Não lembro de ter visto tal problema antes, então não tenho como te dar alguma dica no momento. Tente pesquisar por "forcedeth ubuntu 14.04", pra ver se alguma coisa ajuda.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #32 Online: 19 de Maio de 2015, 14:38 »
Então, /alimnez/,


Vi essa interessante dica do próprio /zekkerj/ em um outro tópico (tópico 103762), que talvez seja o seu caso:

"O problema aí é que essas placas com chipset nvidia fazem a rede por software, não há um "dispositivo de hardware" pra ser reconhecido. Veja inclusive que o hardware é chamado "forcedeth", ou seja, "forced eth" ou "ethernet à força"..."

Se o caso de ser mesmo um nvidia no seu sistema, esse link abaixo há uma indicação de solução, eventualmente pode ajudar:

NvNetInstallation

https://help.ubuntu.com/community/NvNetInstallation

===========

editando:

Isso aqui também pode ajudar, para entender a questão de um modo fácil, um artigo como sempre muito bom do Morimoto:

Driver para placas com chipset nForce

http://www.hardware.com.br/livros/ferramentas-linux/driver-para-placas-com-chipset-nforce.html

Não deixe de clicar no final da página no link "Próximo" para ir à página seguinte, ou:

Ativando o driver de rede

http://www.hardware.com.br/livros/ferramentas-linux/ativando-driver-rede.html

As informações desse artigo não são literais, talvez precisem ser adaptadas para o caso concreto do Ubuntu, mas a ideia geral é aquela.
« Última modificação: 19 de Maio de 2015, 15:47 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil

Offline alimnez

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #34 Online: 20 de Maio de 2015, 09:39 »
Bom dia amigos.
Obrigado pela atenção de todos.
Pela suposições de vcs, realmente parece ser um problema com o drive forcedeth. 
druidaobelix, assim que eu tiver a oportunidade, vou seguir esses tutoriais em casa.
Só por desencargo, se eu comprasse uma placa de rede, seria uma solução prática?

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #35 Online: 20 de Maio de 2015, 11:21 »
Só por desencargo, se eu comprasse uma placa de rede, seria uma solução prática?

Seria uma alternativa.

Você leu o link que passei, com a resolução do problema?

Offline alimnez

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #36 Online: 20 de Maio de 2015, 11:31 »
Só por desencargo, se eu comprasse uma placa de rede, seria uma solução prática?

Seria uma alternativa.

Você leu o link que passei, com a resolução do problema?

Tota,
Eu li sim, só que estou no trabalho agora.
Eu vou seguir as instruções, mas no caminho de casa eu posso comprar uma placa, como alternativa.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #37 Online: 20 de Maio de 2015, 19:24 »
Então, /alimnez/,

A solução apontada no link indicado pelo /Tota/ é bastante simples, consiste apenas em fazer no terminal:

Código: [Selecionar]
echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe.d/forcedeth.conf
Esse comando vai criar o arquivo forcedeth.conf dentro do diretório /etc/modprobe com a linha  options forcedeth msi=0 msix=0, apenas isso.

Depois é reiniciar o sistema e ver se funciona, ou seja, é mesmo muito simples.

Independentemente da aquisição de uma outra placa de rede, se puder testar o comando e nos dizer se funciona, seria útil como registro de solução para o Fórum.
 
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline João Vitor Mennezes

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #38 Online: 20 de Maio de 2015, 21:39 »
O meu Ubuntu 14.04 LTS não reconhece meu cabo Ethernet de jeito nenhum!!! Alguém pode me ajudar????

Offline alimnez

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #39 Online: 21 de Maio de 2015, 03:21 »
Boa noite amigos.
Falo com vocês pelo meu Ubuntu conectado à Internet.

druidaobelix, cheguei a inserir no terminal:
Citar
echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe.d/forcedeth.conf

Infelizmente não funcionou. Como eu estava precisando muito do acesso à internet, fiz a solução rápida.
Instalei uma placa de rede, rapidamente ele reconheceu.

Vou postar de novo a saída:

Citar
~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Ethernet connection 1] ----------------------------------------
  Type:              Wired
  Driver:            forcedeth
  State:             connecting (getting IP configuration)
  Default:           no
  HW Address:        BC:5F:F4:85:31:22

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on


- Device: eth1  [Ethernet connection 1] ----------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        00:1A:3F:B0:87:5E

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.0.108
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.1.254


Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #40 Online: 21 de Maio de 2015, 03:58 »
Citar
cheguei a inserir no terminal:
echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe.d/forcedeth.conf
Infelizmente não funcionou

Pois é, /alimnez/,

Obrigado por testar, mas veja que a eth0 do driver forcedeth passou a dar sinal de vida. :-)

No seu primeiro posto (#30  ), aparecia:

State:             disconnected

Agora temos:

State:             connecting (getting IP configuration)


Bem, a nova placa evidentemente resolveu a questão prática de obter imediatamente acesso internet, portanto, seguir adiante para resolver a questão do forcedeth é apenas no caso de querer (ou precisar) ter duas placas de rede no sistema ou ainda por uma questão lúdica, aumentar os conhecimentos.

Se não for seguir adiante com o forcedeth, remova o arquivo forcedeth.conf criado em /etc/modprobe.d, não há necessidade de deixá-lo lá.

Código: [Selecionar]
sudo rm /etc/modprobe.d/forcedeth.conf
Como esclarecimento, se ainda pretender tornar operacional o forcedeth, tem-se dois caminhos:

1) explorar melhor esse comando passado, como a placa passou a estar "viva", talvez seja possível fazê-lo funcionar;

2) seguir os procedimentos mencionados no post #32

Note que são coisas distintas, o comando usado trabalha o próprio driver forcedeth, que é nativo do sistema, porém a proposta do post #32 é instalar os drivers proprietários nvdia para tornar operacional o hardware.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline alimnez

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #41 Online: 21 de Maio de 2015, 09:24 »
Citar
Como esclarecimento, se ainda pretender tornar operacional o forcedeth, tem-se dois caminhos:

1) explorar melhor esse comando passado, como a placa passou a estar "viva", talvez seja possível fazê-lo funcionar;

2) seguir os procedimentos mencionados no post #32

druidaobelix, bom dia.

Acho que nesse caso, é mais apropriado eu seguir os procedimentos do post #32.
O lance do state, é porque eu mandei o comando na hora em que meu Ubuntu estava tentando conectar.
Assim que eu cancelo e mando novamente o comando, ele passa a ficar disconected.

Esse comando pode funcionar bem para outras pessoas, o erro está exatamente na simulação dessa placa.
Uma coisa que não vem ao caso nesse post, é que quando vou reiniciar para salvar as alterações, o meu Ubuntu fica na tela daquelas 5 bolinhas e não sai disso.
Isso me leva a pensar que eu preciso fazer várias configurações, "desintoxicar" a minha placa, já que esta funcionou a vida toda com windows.

Muito obrigado pela ajuda.

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #42 Online: 22 de Maio de 2015, 05:44 »
Olá! Boa noite. (quase dia já, rs)
Pois é! Comigo o problema ainda persiste. Fiz todo os paços desse tópico, inclusive tentei instalar o driver e não consegui. To até nervoso com isso, porque a minha placa de rede é o modelo 7025 da Nvidia 630a e, quando eu tento instalar o driver certo (304.125) o Ubuntu tem a pachorra de me dizer que eu não estou instalando o driver correto. To há mais de dias tentando configurar isso e quando acho esse tópico cheio de informações úteis... não funcionam. Só a revolta, minha gente...  >:(

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #43 Online: 22 de Maio de 2015, 12:27 »
Olá Mendoka,
Desculpe a franqueza, mas até prova em contrário, o Ubuntu está com a razão: você não está instalando o driver correto. Lá no início do tópico eu passei alguns comandos que podem comprovar qual é sua placa de rede, para que possamos decidir quem tem razão, você ou o Ubuntu. Só vou te sugerir que poste seu problema em outro tópico, pois se sua máquina não for absolutamente idêntica ao do (da?) alimmnez, as dicas passadas aqui serão inúteis pra você.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Mendoka

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Ubuntu 14.04 LTS nao reconhece cabo ethernet
« Resposta #44 Online: 22 de Maio de 2015, 12:49 »
Uai! Mas a minha placa mãe é a mesma do criador do tópico e a minha placa de rede é essa daí que eu falei. Quando eu coloco o lspci me vem isso:

NVIDIA Corporation MCP61 Ethernet

Um detalhe é que eu já consegui fazer a internet funcionar no Ubuntu 10.04, mas não consegui atualizar nada. (tá defasado)
Aí eu instalei o OpenSuse e ele reconheceu o driver, mas não instalou porque eu não consegui desativar o X Server. Aí resolvi instalar o Ubuntu 14.04 e tá me dando esses problemas. Vou continuar tentando. Não vou desistir tão cedo, rs...
E ah! No nm-tool aparece "connecting (getting IP configuration)". O que já é alguma coisa... espero.