Autor Tópico: Problemas com Gravador de telas SimpleScreenRecorder no Xubuntu 14.04  (Lida 9755 vezes)

Offline CGraf

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Olá, Pessoal,
Não consigo gravar com o Simple Screen Recorder ( instalado via ppa) no Xubuntu 14.04. O problema acontece quando tento gravar videos como mp4 usando codec H.264. O programa desaparece da tela ao clicar em gravar. Tenho o mesmo Xubuntu 14.04 noutra máquina onde não acontece isso. Já chequei pelo Synaptic e vi que libx264 123 e 142 estão instalados ( isso tem a ver?). O que pode ser isso? Alguém pode dar uma ajuda?
Esse programa é muito necessário para que eu grave tela e faça tutoriais. É o melhor que já encontrei. Tenho utilizado o kazam e o RecordMyDesktop, mas prefiro o outro e também não queria deixar isso assim, sem resolver.
Obrigado.

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Re: Problemas com Gravador de telas SimpleScreenRecorder no Xubuntu 14.04
« Resposta #1 Online: 23 de Junho de 2014, 08:16 »
No Terminal, execute:

Código: [Selecionar]
simplescreenrecorder

Tente gravar a tela e, depois do programa fechar, verifique as mensagens exibidas no Terminal. Cole as mesmas aqui.

Offline CGraf

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: Problemas com Gravador de telas SimpleScreenRecorder no Xubuntu 14.04
« Resposta #2 Online: 23 de Junho de 2014, 11:07 »
Aparece isso:
SimpleScreenRecorder 0.2.2
Compiled with GCC 4.8.2
Qt: header 4.8.6, lib 4.8.6
libavformat: header 54.20.3, lib 54.63.104
libavcodec: header 54.35.0, lib 54.92.100
libavutil: header 52.3.0, lib 52.18.100
libswscale: header 2.1.1, lib 2.2.100
[DetectCPUFeatures] Recursos da CPU: mmx sse sse2 sse3
QSystemTrayIcon::setVisible: No Icon set

(simplescreenrecorder:2670): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(simplescreenrecorder:2670): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
[PageRecord::StartPage] Iniciando a página...
[PageRecord::StartPage] Página iniciada.
[SimpleSynth::SynthThread] Fluxo do sintetizador iniciado.
[PageRecord::StartOutput] Iniciando a saída...
[Muxer::Init] Usando o formato mp4 (MP4 (MPEG-4 Part 14)).
[BaseEncoder::CreateCodec] Usando o codec libx264 (libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10).
[libx264 @ 0x21fbc80] using SAR=1/1
Falha de segmentação (imagem do núcleo gravada)

Eu tenho uma suspeita de que isso pode ter começado a ocorrer depois que escolhi para que ele desabilitasse 'sempre" a função flipping  do driver proprietário da nvidia. Então ele não me deu mais esse aviso. Mas começou a dar esse problema. Tem a ver?
« Última modificação: 23 de Junho de 2014, 11:17 por CGraf »

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Re: Problemas com Gravador de telas SimpleScreenRecorder no Xubuntu 14.04
« Resposta #3 Online: 23 de Junho de 2014, 11:24 »
Infelizmente a mensagem de erro é muito vaga.

Tente reverter isso que você fez e faça o teste.

Offline CGraf

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: Problemas com Gravador de telas SimpleScreenRecorder no Xubuntu 14.04
« Resposta #4 Online: 24 de Junho de 2014, 23:06 »
Problema é que não sei como reverter.
Pelo SimpleScreen não dá mais porque ele não mostra a tela.
Pela gui do driver da nvidia não achei nada diferente que pudesse mudar e que esteja fora do padrão que observo no mesmo driver instalado na minha outra máquina, também com Xubuntu trusty...

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problemas com Gravador de telas SimpleScreenRecorder no Xubuntu 14.04
« Resposta #5 Online: 24 de Junho de 2014, 23:26 »
Use o RecordMyDesktop!

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Re: Problemas com Gravador de telas SimpleScreenRecorder no Xubuntu 14.04
« Resposta #6 Online: 25 de Junho de 2014, 08:02 »
Tente desativar a composição (efeitos) do xfwm.

Offline CGraf

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: Problemas com Gravador de telas SimpleScreenRecorder no Xubuntu 14.04
« Resposta #7 Online: 04 de Julho de 2014, 10:32 »
É, pessoal,
Já tentei de tudo e não resolve mesmo. Até o SimpleScreenrecorder já foi atualizado e o H.264 e...NADA! Os erros continuam os mesmos. Então, estou usando  as outras opções de codecs para gravar no "SSR" pois ele é o gravador de telas que me atende melhor. Porém, não descarto a possibilidade de voltar ao kazam ou mesmo ao RecordMyDesktop.
De qualquer modo, obrigado aos que tentaram ajudar.