Autor Tópico: [RESOLVIDO] Problema com o comando sudo?  (Lida 3146 vezes)

Offline JuarezFranco

  • Usuário Ubuntu
  • *
  • Mensagens: 186
  • Seja livre, use ... o que vc quiser :-)
    • Ver perfil
[RESOLVIDO] Problema com o comando sudo?
« Online: 19 de Maio de 2014, 13:46 »
Galera fui iniciar meu notebook normalmente como de costume, e abri o terminal e dei o comando sudo su, o comando não funcionou, dei sudo apt-g... E tbm não funcionou.
Para todo comando que uso sudo acontece isso:
Citar
$sudo su
sudo: no válido sudoers sources found, quitting
sudo: não foi possível inicializar plug-in de política
« Última modificação: 19 de Maio de 2014, 22:18 por juarezfranco »
"Riem de mim por eu ser diferente, e eu rio de vocês por serem todos iguais." - Bob Marley

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Problema com o comando sudo?
« Resposta #1 Online: 19 de Maio de 2014, 15:01 »
Verifique seu arquivo sudoers

Offline JuarezFranco

  • Usuário Ubuntu
  • *
  • Mensagens: 186
  • Seja livre, use ... o que vc quiser :-)
    • Ver perfil
Re: Problema com o comando sudo?
« Resposta #2 Online: 19 de Maio de 2014, 22:17 »
vlw, ja descobri o problema, eu fiz uma cagada ontem agora que foi cair a ficha,

Eu fui dar permissões a uma pasta e seus sub-itens, e foi o seguinte.


posicionei na pasta pelo terminal usando cd .../pasta/
depois eu usei o codigo "sudo chmod -R 777 /*"
kkkkkkkk ferrei todo meu sistema, achei q ia dar permissões para a pasta em que estava posicionado.
enfim, ele deu permissão total para todas as pastas do sistema. pois se vc digitar "cd /" ele vai pra raiz
devia ter feito da seguinte forma posicionar antes da pasta edigitar "chmod -R 777 /pasta/*"

vou ter que formatar pois nao deu erro só no sudo, até no ping nao funciona mais.

Nunca mais uso esse comando com permissões 777. imagina a cagada se fosse  em um servidor, fica a dica cuidado!!
[RESOLVIDO]
« Última modificação: 19 de Maio de 2014, 23:01 por juarezfranco »
"Riem de mim por eu ser diferente, e eu rio de vocês por serem todos iguais." - Bob Marley

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.348
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [RESOLVIDO] Problema com o comando sudo?
« Resposta #3 Online: 23 de Maio de 2014, 12:35 »
Vc deu sorte que seu sistema chegou a iniciar depois disso.
Essa é uma das poucas situações onde vc tem que reinstalar um sistema do zero.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D