Autor Tópico: Travamento com o Ubuntu 14.04 64bits  (Lida 37770 vezes)

Offline danilofc

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Travamento com o Ubuntu 14.04 64bits
« Online: 26 de Abril de 2014, 00:38 »
Boa noite a todos.

Sou um usuário recente do Ubuntu, tenho tempo de uso de apenas 2 meses. Utilizo um notebook e essa semana atualizei para a versão 14.04. Ela rodaria perfeitamente, bem melhor do que 13.10, não fosse por um fato desagradável: está travando com frequência. O mouse para, o teclado para, tudo para, a tela permanece ligada com a imagen congelada no ponto onde travou. Eu abaixo a tampa do notebook, o sistema entra no modo "Suspensão" normalmente. Ao levantar a tampa, tudo volta ao normal do ponto onde travou, como se nada tivesse acontecido.

Quando estava usando a versão 13.10 não acontecia isso. Alguém poderia dar uma luz no fim do túnel? Só lembrando que sou totalmente leigo em computação/informática/etc.

Abaixo vai a configuração da máquina que eu uso:

Notebook Dell Inspiron 14R
Processador Intel® Core™ i5-3210M CPU @ 2.50GHz × 4
Memória 6Gb 1600 MHz DDR3 SODIMM
Vídeo Integrado Intel HD graphics (Inspiron 14R-5420)
Vídeo Discreto NVIDIA GeForce GT 630M/PCIe/SSE2

Uso o Ubuntu em dual boot com o Windows 8.

Agradeço desde já a atenção de vocês,
Abraços.

---------------------------------------------------------------

Atualização importante:

Assim que eu criei esse tópico, travou novamente. Então eu fiz um teste de "doido":
Apertei Ctrl + Alt + t para abrir o terminal e digitei "sudo reboot" em seguida digitei a senha. Tudo isso com a imagem congelada, sem saber no que iria dar. E o PC reiniciou normalmente. Portanto, aparentemente a imagem dá uma trava mas o sistema continua rodando normalmente.
« Última modificação: 26 de Abril de 2014, 00:46 por danilofc »

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #1 Online: 26 de Abril de 2014, 07:16 »
Estranho isso. Você tem 2 placas de vídeo, é tecnologia Optimus? Você instalou o driver da nvidia?

Quando travar, aperta Ctrl+Alt+F1, você deveria ir para um terminal com a tela toda preta, esperando entrar com senha e usuário.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline danilofc

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #2 Online: 26 de Abril de 2014, 13:31 »
Estranho isso. Você tem 2 placas de vídeo, é tecnologia Optimus? Você instalou o driver da nvidia?

Quando travar, aperta Ctrl+Alt+F1, você deveria ir para um terminal com a tela toda preta, esperando entrar com senha e usuário.

Não sei te dizer se é tecnologia Optimus, nem sei o que é isso na verdade hehehe. Apenas repassei as configurações que veio junto com o computador. O drive no NVIDIA está instalado, o Ubuntu reconheceu automaticamente. Quando eu usava a versão 13.10 ele não reconhecia o NVIDIA e usava o Intel HD graphics, e a parte gráfica era muito ruim. Agora está bem melhor, mas com esse problema de travamento da imagem.

Vou testar usar o Ctrl+Alt+F1, mas é provável que a tela continue congelada. Qualquer coisa volto pra aperriar hehehe

Valeu!

Offline danilofc

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #3 Online: 26 de Abril de 2014, 13:53 »
Estranho isso. Você tem 2 placas de vídeo, é tecnologia Optimus? Você instalou o driver da nvidia?

Quando travar, aperta Ctrl+Alt+F1, você deveria ir para um terminal com a tela toda preta, esperando entrar com senha e usuário.

Não sei te dizer se é tecnologia Optimus, nem sei o que é isso na verdade hehehe. Apenas repassei as configurações que veio junto com o computador. O drive no NVIDIA está instalado, o Ubuntu reconheceu automaticamente. Quando eu usava a versão 13.10 ele não reconhecia o NVIDIA e usava o Intel HD graphics, e a parte gráfica era muito ruim. Agora está bem melhor, mas com esse problema de travamento da imagem.

Vou testar usar o Ctrl+Alt+F1, mas é provável que a tela continue congelada. Qualquer coisa volto pra aperriar hehehe

Valeu!

Sergio, acabou de dar uma travada aqui. Aprtei Ctrl+Alt+F1 e funcionou, foi para uma tela preta. Coloquei meu login e minha senha. Só não sabia mais o que fazer, então dei um reboot novamente. Você poderia informar se tem algo que eu possa fazer próxima vez que fizer isso?

Abs.

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #4 Online: 26 de Abril de 2014, 14:20 »
Estranho isso. Você tem 2 placas de vídeo, é tecnologia Optimus? Você instalou o driver da nvidia?

Quando travar, aperta Ctrl+Alt+F1, você deveria ir para um terminal com a tela toda preta, esperando entrar com senha e usuário.

Não sei te dizer se é tecnologia Optimus, nem sei o que é isso na verdade hehehe. Apenas repassei as configurações que veio junto com o computador. O drive no NVIDIA está instalado, o Ubuntu reconheceu automaticamente. Quando eu usava a versão 13.10 ele não reconhecia o NVIDIA e usava o Intel HD graphics, e a parte gráfica era muito ruim. Agora está bem melhor, mas com esse problema de travamento da imagem.

Vou testar usar o Ctrl+Alt+F1, mas é provável que a tela continue congelada. Qualquer coisa volto pra aperriar hehehe

Valeu!

Sergio, acabou de dar uma travada aqui. Aprtei Ctrl+Alt+F1 e funcionou, foi para uma tela preta. Coloquei meu login e minha senha. Só não sabia mais o que fazer, então dei um reboot novamente. Você poderia informar se tem algo que eu possa fazer próxima vez que fizer isso?

Abs.

Ahh, esqueci de falar, tem que apertar Ctrl+Alt+F7 ou F8 para retornar à sua área de trabalho.

Tecnologia Optimus é esse conjunto de placa Intel onboard + Nvidia, onde à princípio pode ter a troca entre as duas placas automaticamente, para economia de energia (Intel) ou desempenho (Nvidia).

Qual driver exatamente está em uso (304 ou 331)? Eu tive um problema parecido com o seu, ao instalar o driver 319 + nvidia-prime (que é a implementação oficial da nvidia para o Optimus), isso no ubuntu 13.10. Se continuar travando, experimente acessar as configurações da Nvidia e desative essa placa, tem que fazer logout e login. Se parar de travar, é problema com o driver da nvidia. Se for o driver 304 que estiver instalado, tente atualizar para o nvidia-331-updates.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline danilofc

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #5 Online: 26 de Abril de 2014, 14:30 »
Estranho isso. Você tem 2 placas de vídeo, é tecnologia Optimus? Você instalou o driver da nvidia?

Quando travar, aperta Ctrl+Alt+F1, você deveria ir para um terminal com a tela toda preta, esperando entrar com senha e usuário.

Não sei te dizer se é tecnologia Optimus, nem sei o que é isso na verdade hehehe. Apenas repassei as configurações que veio junto com o computador. O drive no NVIDIA está instalado, o Ubuntu reconheceu automaticamente. Quando eu usava a versão 13.10 ele não reconhecia o NVIDIA e usava o Intel HD graphics, e a parte gráfica era muito ruim. Agora está bem melhor, mas com esse problema de travamento da imagem.

Vou testar usar o Ctrl+Alt+F1, mas é provável que a tela continue congelada. Qualquer coisa volto pra aperriar hehehe

Valeu!

Sergio, acabou de dar uma travada aqui. Aprtei Ctrl+Alt+F1 e funcionou, foi para uma tela preta. Coloquei meu login e minha senha. Só não sabia mais o que fazer, então dei um reboot novamente. Você poderia informar se tem algo que eu possa fazer próxima vez que fizer isso?

Abs.

Ahh, esqueci de falar, tem que apertar Ctrl+Alt+F7 ou F8 para retornar à sua área de trabalho.

Tecnologia Optimus é esse conjunto de placa Intel onboard + Nvidia, onde à princípio pode ter a troca entre as duas placas automaticamente, para economia de energia (Intel) ou desempenho (Nvidia).

Qual driver exatamente está em uso (304 ou 331)? Eu tive um problema parecido com o seu, ao instalar o driver 319 + nvidia-prime (que é a implementação oficial da nvidia para o Optimus), isso no ubuntu 13.10. Se continuar travando, experimente acessar as configurações da Nvidia e desative essa placa, tem que fazer logout e login. Se parar de travar, é problema com o driver da nvidia. Se for o driver 304 que estiver instalado, tente atualizar para o nvidia-331-updates.

Estou usando o NVIDIA binary driver - versão 331.38 (proprietário e testado). Tem outros drivers do NVIDIA disponíveis aqui, mas nenhum deles consta como testado, por isso estava usando esse. E também tem a opção X.Org X Server.

P.S: Enquanto escrevia essa mensagem, a tela congelou novamente. Fiz o que você disse (Ctrl+Alt+F1 e depois Ctrl+Alt+F7 e deu certo!). Mas seris interessante resolver o problema hahaha.

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #6 Online: 26 de Abril de 2014, 14:47 »
Estou usando o NVIDIA binary driver - versão 331.38 (proprietário e testado). Tem outros drivers do NVIDIA disponíveis aqui, mas nenhum deles consta como testado, por isso estava usando esse. E também tem a opção X.Org X Server.

P.S: Enquanto escrevia essa mensagem, a tela congelou novamente. Fiz o que você disse (Ctrl+Alt+F1 e depois Ctrl+Alt+F7 e deu certo!). Mas seris interessante resolver o problema hahaha.

Faz o que falei então, desativa a placa da nvidia lá nas configurações da mesma (Nvidia Settings). Você irá usar a placa onboard da Intel, se quiser deixar o sistema mais rápido abra o Gedit e copie isso nele:

Código: [Selecionar]
export UNITY_LOW_GFX_MODE=1
E salve como .xprofile (tem um ponto no começo do nome) na sua pasta pessoal, ao lado de Downloads, Vídeos, Músicas e etc. Faça logout e login para ter efeito.

Se for problema do driver da nvidia, não tem muito o que fazer, a não ser esperar atualização (ou será que tem alguma solução na web?). Eu desativaria a placa da nvidia, instalaria o Bumblebee e observaria se funciona, mesmo com o nvidia-prime instalado. Esse Bumblebee te permite usar a placa da nvidia apenas para alguns programas, você configura ele e pode chamar um emulador ou jogo pelo terminal com o comando primusrun ou optirun (pode editar os menus também, para ficar mais fácil). Eu acho que já postei à respeito, dá uma procurada aqui no fórum. Mas a última vez que testei no 14.04 (quando era beta), não funcionou.

Tenta reportar esse problema:

Código: [Selecionar]
sudo ubuntu-bug nvidia-prime
Precisa ter conta no Launchpad da Canonical.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline danilofc

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #7 Online: 26 de Abril de 2014, 14:53 »
Estou usando o NVIDIA binary driver - versão 331.38 (proprietário e testado). Tem outros drivers do NVIDIA disponíveis aqui, mas nenhum deles consta como testado, por isso estava usando esse. E também tem a opção X.Org X Server.

P.S: Enquanto escrevia essa mensagem, a tela congelou novamente. Fiz o que você disse (Ctrl+Alt+F1 e depois Ctrl+Alt+F7 e deu certo!). Mas seris interessante resolver o problema hahaha.

Faz o que falei então, desativa a placa da nvidia lá nas configurações da mesma (Nvidia Settings). Você irá usar a placa onboard da Intel, se quiser deixar o sistema mais rápido abra o Gedit e copie isso nele:

Código: [Selecionar]
export UNITY_LOW_GFX_MODE=1
E salve como .xprofile (tem um ponto no começo do nome) na sua pasta pessoal, ao lado de Downloads, Vídeos, Músicas e etc. Faça logout e login para ter efeito.

Se for problema do driver da nvidia, não tem muito o que fazer, a não ser esperar atualização (ou será que tem alguma solução na web?). Eu desativaria a placa da nvidia, instalaria o Bumblebee e observaria se funciona, mesmo com o nvidia-prime instalado. Esse Bumblebee te permite usar a placa da nvidia apenas para alguns programas, você configura ele e pode chamar um emulador ou jogo pelo terminal com o comando primusrun ou optirun (pode editar os menus também, para ficar mais fácil). Eu acho que já postei à respeito, dá uma procurada aqui no fórum. Mas a última vez que testei no 14.04 (quando era beta), não funcionou.

Tenta reportar esse problema:

Código: [Selecionar]
sudo ubuntu-bug nvidia-prime
Precisa ter conta no Launchpad da Canonical.

Como eu uso apenas o Ubuntu para coisas da faculdade, não será problema desativar o drive no nvidia. Vou tentar isso que você disse e deu um feedback depois.

Valeu Sergio,
Abraços.

Offline dutrintin

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #8 Online: 28 de Abril de 2014, 22:04 »
Estou com o mesmo problema do nosso colega!
De vez em quando o ambiente gráfico trava e preciso apertar Ctrl + Alt + F1, depois voltar com Ctrl + Alt + F7!
Lembrando que meu notebook tem a tecnologia nvidia optimus como o colega!

=/

Offline danilofc

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #9 Online: 02 de Maio de 2014, 16:35 »
Estou com o mesmo problema do nosso colega!
De vez em quando o ambiente gráfico trava e preciso apertar Ctrl + Alt + F1, depois voltar com Ctrl + Alt + F7!
Lembrando que meu notebook tem a tecnologia nvidia optimus como o colega!

=/

Cara, eu fiz o que o Sergio falou. Desativei a placa do nvidia e parou de travar.

Abs.

Offline Yokiro

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #10 Online: 02 de Maio de 2014, 18:56 »
Mesmo notebook e exatamente o mesmo problema. Vou desativar o drive do NVidia e ativar o X.Org X server. Além de escrever o código abaixo que foi sugerido pelo Sergio Benjamim pra ver se o problema continua. Daqui há uns dias reporto se o problema foi solucionado.

Faz o que falei então, desativa a placa da nvidia lá nas configurações da mesma (Nvidia Settings). Você irá usar a placa onboard da Intel, se quiser deixar o sistema mais rápido abra o Gedit e copie isso nele:

Código: [Selecionar]
export UNITY_LOW_GFX_MODE=1
E salve como .xprofile (tem um ponto no começo do nome) na sua pasta pessoal, ao lado de Downloads, Vídeos, Músicas e etc. Faça logout e login para ter efeito.

Também sou usuário novo do Ubuntu, sobre o código acima sugerido, pode explicar um pouco mais sobre o mesmo? Valeu.

Offline lhzefe

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #11 Online: 05 de Maio de 2014, 20:03 »
Solução com o notebook Asus k45VM: i7, 8GB, nVidia GT630m, utilizando a versão 331.38 tested, do Ubuntu 14.04 LTS (Unity interface):

 - Após o drive citado a cima instalado, ir até NVIDIA X Server Settings;
 - Ir até a opção FILE Profile e selecionar a opção: NVIDIA (Performace Mode);
 - Quit e reenicie o pc;
 - Após o reinicio, algo muito importante a se notar é que para que o travamento não ocorra e vc utilize o gráfico inclusive para jogar belamente é: o notebook tem que estar conectado a energia externa, ou seja, caso use-o na bateria e esteja em modo performace mode o travamento ocorrerá.

P.S.: Tive o mesmo problema que vocês e essa forma que encontrei após horas quebrando cabeça em casa sem internet (triste internet que me cai nessas horas, =P), como descrito a cima funcionará qqr jogo que seu hardware aguente sem problemas e o melhor sem travamentos(jogando meu DOTINHA full link a boss =P). Caso não queira jogar ou coisa assim, sugiro colocar no modo de economia de energia, dessa forma não terá problemas com uso da máquina com a bateria.

Espero ter ajudado ^^

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #12 Online: 05 de Maio de 2014, 23:41 »
Mesmo notebook e exatamente o mesmo problema. Vou desativar o drive do NVidia e ativar o X.Org X server. Além de escrever o código abaixo que foi sugerido pelo Sergio Benjamim pra ver se o problema continua. Daqui há uns dias reporto se o problema foi solucionado.

Faz o que falei então, desativa a placa da nvidia lá nas configurações da mesma (Nvidia Settings). Você irá usar a placa onboard da Intel, se quiser deixar o sistema mais rápido abra o Gedit e copie isso nele:

Código: [Selecionar]
export UNITY_LOW_GFX_MODE=1
E salve como .xprofile (tem um ponto no começo do nome) na sua pasta pessoal, ao lado de Downloads, Vídeos, Músicas e etc. Faça logout e login para ter efeito.

Também sou usuário novo do Ubuntu, sobre o código acima sugerido, pode explicar um pouco mais sobre o mesmo? Valeu.

Esse código desativa os recursos gráficos do Unity (o ambiente desktop do ubuntu, vai desativar vários efeitos gráficos desnecessários dele). É só abrir um editor de textos como o Gedit, copiar e colar, e salvar como .xprofile, como falei anteriormente. Simples assim. E fazer logout e login para que faça efeito no sistema, ele lerá esse arquivo toda vez que faz login e interpreta que é para desativar as firulas do ubuntu.

Esse comando não resolve o problema central deste tópico, apenas desabilita frescuras do sistema ao usar a outra placa gráfica disponível no notebook, pegou a ideia?

Com uma placa Nvidia ou AMD esses efeitos do Unity ficam lindos, mas como você vai desativar a placa da nvidia e ficar na placa onboard da Intel, os efeitos gráficos serão produzidos mais pelo processador da sua máquina do que pela placa de vídeo (que é Intel e é fraca), e isso é ruim, você por vezes pode sentir o notebook engasgando em um Alt+Tab ou ao clicar no Dash (no símbolo do ubuntu, nessa barra lateral esquerda). Eu tenho um core i7 quad core de 4ª geração e mesmo assim acho que fica lento os efeitos gráficos do Unity do ubuntu 13.10, por isso que desativo com esse comando salvo em um arquivo.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline mkevsison

  • Usuário Ubuntu
  • *
  • Mensagens: 96
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #13 Online: 06 de Maio de 2014, 10:11 »
O meu também tá assim, deve ser algum bug do sistema, já que ele foi lançado recentemente.

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Travamento com o Ubuntu 14.04 64bits
« Resposta #14 Online: 06 de Maio de 2014, 10:33 »
O meu também tá assim, deve ser algum bug do sistema, já que ele foi lançado recentemente.

É bug da nvidia mesmo. Eu reportei faz um tempão, parece que não corrigiram até hoje. Ou pode ter sido corrigido no driver 331.67, mas ele não chegou oficialmente no ubuntu ainda.

Contando comigo, são 6 pessoas afetadas? Já é um número considerável. Mandem email para linux-bugs@nvidia.com e sandipt@nvidia.com, foi esse sandipt que respondeu meu último email.

Comigo a tela travava quando eu estava mexendo no touchpad, mas eu não sei se está relacionado ou era apenas coincidência.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !