Autor Tópico: Ubuntu 14.04 LTS não reconhece Ralink RT2561 st  (Lida 4001 vezes)

Offline Crazy Cat

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
Ubuntu 14.04 LTS não reconhece Ralink RT2561 st
« Online: 19 de Abril de 2014, 18:15 »
Não estou conseguindo instalar os drives da placa de rádio Ralink RT2561 st, que faz com conecto à Internet (no meu provedor via rádio) :(
Interessante que a versão 12.04 LTS reconhece na hora a placa, mas a nova versão, que teoricamente deveria vir mais completa, informa que não há nenhum dispositivo instalado :(
Procurei no site da realteck e só achei os drives para os kernel 2.4  e 2.6 (2008 e 2010). Tentei mesmo assim instalar usando os comandos para o 2.6 e não consegui a instalação.
Após descompactar o arquivo e seguir as instruções, quando chego no item
sudo Makefile
aparece "command not found"
tentei ainda sudo make, e sudo make.6, etc... e dá o mesmo resultado.
Baixei os pacotes .deb do firmware-non-free e instalei, e deu no mesmo, não localiza a placa.
Preciso de ajuda urgente, pois não me agrada ficar fazendo boot pelo windows xp rsrsrs

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 14.04 LTS não reconhece Ralink RT2561 st
« Resposta #1 Online: 19 de Abril de 2014, 23:12 »
Tente ver qual é o driver dessa placa no 12.04, depois tente forçar a carga do mesmo módulo no 14.04.

Eu tenho uma máquina com uma placa parecida com essa e rodou de primeira no 14.04, provavelmente é só algum pequeno detalhe que falta.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Crazy Cat

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
Re: Ubuntu 14.04 LTS não reconhece Ralink RT2561 st
« Resposta #2 Online: 21 de Abril de 2014, 08:09 »
Depois de algumas lambanças (instalar drives e nonfree etc) cheguei a este ponto.
Entre vários itens, o comando lspci retorna
01:08.0 Network controller: Ralink corp. RT2561/RT61 802.11g PCI

Isso que dizer que a placa está instalada.
Mas o icone Network Manager informa "Networking disabled"
e o icone Conexão de Rede informa apenas os itens
ppp0 (erro)
e
Io (inativo)

E ao clicar em lo o item ppp0 não parece mais.

Como faço para ativar a placa eth0?

O comando ifconfig retorna
ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:480 errors:0 dropped:0 overruns:0 frame:0
          TX packets:480 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:38208 (38.2 KB)  TX bytes:38208 (38.2 KB)


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 14.04 LTS não reconhece Ralink RT2561 st
« Resposta #3 Online: 21 de Abril de 2014, 12:43 »
Vc por acaso em algum momento usou o comando "pppoeconf"? Isso pode ser a origem do seu problema.

Ativar a placa eth0 não vai te ajudar em nada no momento, pois eth0 é a placa cabeada, e a placa RT2561 é uma placa wireless.

No momento, eu peço que você observe o conteúdo do arquivo "/etc/network/interfaces", veja se há alguma referência à interface ppp0 nele. Se houver, edite o arquivo (como root) e certifique-se de deixá-lo assim:

Código: [Selecionar]
auto lo
iface lo inet loopback
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Crazy Cat

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
Re: Ubuntu 14.04 LTS não reconhece Ralink RT2561 st
« Resposta #4 Online: 22 de Abril de 2014, 14:21 »
Sim, usei o comando pppoeconf pois é  a forma que configuro a eth0 para receber a internet via sinal de rádio do meu provedor... sempre fiz assim... na verdade não sei se utiliza a interface eth0, pois o comando que uso é
sudo pppoeconf -wlan0

após configurar tudo, vou no NM e edito os IPs etc, e por fim edito os arquivos /etc/peers/... dsl-provider e /etc/resolv.conf
após fazer isso rodo o comando
sudo pon dsl-provider
e a minha internet já navega.
Ontem, apenas uma vez e não entendi o porque, a internet funcionou! Mas ao reiniciar o sistema novamente sumiu. É que andei mexendo em algumas coisas e aí funcionou ontem... me lembro de que as opções de configuração da rede estão "inativas" (cinza) como se eu não podesse mexer nelas.... futucando aqui e acolá achei uma opção de conceder ao meu usuário a permissão para editar a rede (coisa nunca antes necessária nas versões anteriores, eu já logava com autorização, mas precisava normalmente digitar a minha senha de acesso ao "finalizar" as configurações da rede).
Estou começando a achar que nesta nova versão, 14.04, veio por padrão que o usuário não pode editar a rede (que coisa sinistra).

Offline Crazy Cat

  • Usuário Ubuntu
  • *
  • Mensagens: 45
    • Ver perfil
Re: Ubuntu 14.04 LTS não reconhece Ralink RT2561 st
« Resposta #5 Online: 22 de Abril de 2014, 17:20 »