Autor Tópico: Aos que utilizam a programação LaTex.  (Lida 4593 vezes)

Offline JoaoDamasceno.ufc

  • Usuário Ubuntu
  • *
  • Mensagens: 1.241
    • Ver perfil
Aos que utilizam a programação LaTex.
« Online: 05 de Dezembro de 2013, 21:06 »
Bem, faz tempo que tento modificar o tipo de fonte utilizada como padrão em projetos LaTex, porém, sempre ocorre um tipo de erro que não sei interpretar.

LaTeX Warning: There were multiply-defined labels.

 )
(see the transcript file for additional information)
Output written on cat.dvi (596 pages, 2926892 bytes).
Transcript written on cat.log.
joao@joao:~/Documentos/Apologética Cristã/catholic$ latex cat.tex
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian)
 restricted \write18 enabled.
entering extended mode
(./cat.tex
LaTeX2e <2011/06/27>
Babel <3.9f> and hyphenation patterns for 3 languages loaded.
(/usr/share/texlive/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size11.clo))
(/usr/share/texlive/texmf-dist/tex/latex/base/inputenc.sty
(/usr/share/texlive/texmf-dist/tex/latex/base/utf8.def
(/usr/share/texlive/texmf-dist/tex/latex/base/t1enc.dfu)
(/usr/share/texlive/texmf-dist/tex/latex/base/ot1enc.dfu)
(/usr/share/texlive/texmf-dist/tex/latex/base/omsenc.dfu)))
(/usr/share/texlive/texmf-dist/tex/generic/babel/babel.sty
(/usr/share/texlive/texmf-dist/tex/generic/babel-portuges/portuges.ldf
(/usr/share/texlive/texmf-dist/tex/generic/babel/babel.def)))
(/usr/share/texlive/texmf-dist/tex/latex/base/fontenc.sty
(/usr/share/texlive/texmf-dist/tex/latex/base/t1enc.def))

! LaTeX Error: File `antiqua.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name:


Vocês podem me ajudar com esse problema?



Obs. Aparentemente seria só utilizar os comandos:
\usepackage[T1]{fontenc}
\usepackage{nome da fonte}

Porém, nunca funciona com nenhuma fonte.
« Última modificação: 05 de Dezembro de 2013, 21:07 por JoaoDamasceno.ufc »

Darcamo

  • Visitante
Re: Aos que utilizam a programação LaTex.
« Resposta #1 Online: 05 de Dezembro de 2013, 23:40 »
Uso bastante o Latex, mas nunca tenho necessidade real de mudar a fonte.
Em geral é assim, mesmo. Basta dar um usepackage para incluir um pacote que muda alguma das fontes utilizadas pelo Latex.

Nesse seu caso, o erro é claro, o arquivo antiqua.sty não existe, o que indica que essa fonte não vem instlada no Tex Live. Logo, o jeito é procurar na internet onde baixar. No entanto, depois de pesquisar um pouco descobri que essa fonte é sim incluída no Tex Live, mas por algum motivo o arquivo ".sty" não foi incluído. Para resolver o problema, na pasta contendo o seu arquivo .tex crie um arquivo com o nome de antiqua.sty e cole o conteúdo abaixo (fonte: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=570993)
\NeedsTeXFormat{LaTeX2e}
\ProvidesPackage{antiqua}
\renewcommand{\rmdefault}{uaq}
\endinput


Agora deve funcionar.

Offline JoaoDamasceno.ufc

  • Usuário Ubuntu
  • *
  • Mensagens: 1.241
    • Ver perfil
Re: Aos que utilizam a programação LaTex.
« Resposta #2 Online: 07 de Dezembro de 2013, 11:47 »
LaTeX Warning: You have requested package `',
               but the package provides `antiqua'.

)
*

Vixe rapaz e o que deve ser esse erro?!
Obs. Apliquei o que você disse logo abaixo no preâmbulo do documento que estou criando.

Offline sigur

  • Usuário Ubuntu
  • *
  • Mensagens: 1.175
    • Ver perfil
Re: Aos que utilizam a programação LaTex.
« Resposta #3 Online: 07 de Dezembro de 2013, 15:25 »
LaTeX Warning: You have requested package `',
               but the package provides `antiqua'.

)
*

Vixe rapaz e o que deve ser esse erro?!
Obs. Apliquei o que você disse logo abaixo no preâmbulo do documento que estou criando.

Não! Os comandos que ele passou são para você colocar em um arquivo novo, chamado antiqua.sty e salvar na mesma pasta que o seu cat.tex.

Offline sigur

  • Usuário Ubuntu
  • *
  • Mensagens: 1.175
    • Ver perfil
Re: Aos que utilizam a programação LaTex.
« Resposta #4 Online: 07 de Dezembro de 2013, 15:28 »
Aqui você deve encontrar o que precisa

http://www.ctan.org/tex-archive/fonts/psfonts/urwvf/

Você provavelmente não instalou o TeXlive full. Então, tem muita coisa que não consegue carregar. Especialmente fontes não padrão.


Também, tem vários pacotes do texlive pra instalar, como por exemplo,

Código: [Selecionar]
sudo apt-get install texlive-fonts-extra

Darcamo

  • Visitante
Re: Aos que utilizam a programação LaTex.
« Resposta #5 Online: 08 de Dezembro de 2013, 02:13 »
Sim, é necessário instalar o pacote texlive-fonts-extra pois a fonte é instalada por esse pacote. Contudo, como eu disse antes por algum error (bug nesse pacote) o arquivo antiqua.sty não é instalado quando o pacote texlive-fonts-extra é instalado. Por isso é necessário criar um arquivo novo com o nome antiqua.sty contendo o conteúdo que mencionei antes na mesma pasta contendo o arquivo .tex que você deseja compilar.