Autor Tópico: Problema com VisualBoy Advanced  (Lida 6780 vezes)

Offline Vitvit88

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Problema com VisualBoy Advanced
« Online: 13 de Janeiro de 2013, 16:08 »
E ai pessoal, tudo bem?

Bom, hoje eu estou com um problema com o Emulador de GBA VisualBoy

http://imageshack.us/photo/my-images/593/semttuloeyx.png/

Queria saber uma solução pra isso

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #1 Online: 13 de Janeiro de 2013, 16:21 »
Qual versão do Ubuntu vc está usando? Qual a sua placa de vídeo (se não sabe o modelo, digite lscpi em um terminal, ou instale o HardInfo)? Qual versão do VBA? Está usando OpenGL?

Aqui eu uso o VBA-M, nunca dá problema. Eu já usei o Visual Boy Advance, mas já deu uns problemas aqui. O VBA-M é praticamente uma evolução do VBA, dá uma olhada aqui.

Eu instalei ele por meio do repositório GetDeb Games. Atualmente ele está fora do ar, mas há um mirror para instalar ele. Siga as dicas deste site: http://www.ubuntudicas.com.br/blog/2012/04/usando-o-repositorio-getdeb-net-no-ubuntu-12-04/

Depois atualize o sistema (pode ser pelo terminal, sudo apt-get update, ou pelo Gerenciador de Atualizações), depois procure o vbam lá na Central de Programas.
« Última modificação: 13 de Janeiro de 2013, 16:37 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Vitvit88

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #2 Online: 13 de Janeiro de 2013, 16:45 »
Estou usando o 12.10, minha placa de video é NVidia GT218, VisualBoy Advanced 1.8.0, não sei se estou usando o OpenGL.

Será que vc pode dar uma explicação mais detalhada de como instalar o VBA-M?

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #3 Online: 13 de Janeiro de 2013, 18:00 »
Estou usando o 12.10, minha placa de video é NVidia GT218, VisualBoy Advanced 1.8.0, não sei se estou usando o OpenGL.

Será que vc pode dar uma explicação mais detalhada de como instalar o VBA-M?

Tirei isso lá do link (adaptei algumas coisas):

Código: [Selecionar]
sudo gedit /etc/apt/sources.list.d/playdeb.list
Vai abrir o Gedit, cole isso:

Código: [Selecionar]
# deb http://archive.getdeb.net/ubuntu precise-getdeb games #GetDeb Games
# deb-src http://archive.getdeb.net/ubuntu precise-getdeb games #GetDeb Games (Código Fonte)
deb http://mirrors.dotsrc.org/getdeb/ubuntu precise-getdeb games #GetDeb Games - Mirror
deb-src http://mirrors.dotsrc.org/getdeb/ubuntu  precise-getdeb games #GetDeb Games - Mirror (Código Fonte)

Reparou que as duas primeiras linhas estão comentadas (com o #)? Quando o GetDeb voltar a ficar on-line, dá para tirar o # dessas linhas e comentar (colocar #) no Mirror, de maneira que seus programas sejam baixados diretamente do site oficial do getdeb. Não precisa abrir o gedit para isso depois, dá para alterar pelos Canais de Software, lá na Central de Programas.

Salve, feche a janela, e faça:

Código: [Selecionar]
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com A8A515F046D7E7CF
sudo apt-get update
sudo apt-get install vbam

Quando abrir o VBA-M, vá no menu Options -> Display... e verifique se está escolhida a opção OpenGL em Output Module.

Edit: Só um detalhe, qual driver da NVidia vc está usando? O opensource, nouveau, ou o proprietário? Se estiver usando o nouveau, use a opção Cairo, se estiver usando o driver proprietário, use a opção OpenGL. Essa dica serve para qualquer outro emulador, como Gens-GS e Snes9x (neste é a opção Cairo é "Rodar por software"). Se não souber o driver, rode o VBA-M com essas duas opções, e veja qual delas dá o melhor desempenho aí para vc.
« Última modificação: 13 de Janeiro de 2013, 18:13 por Sergio Benjamim »
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Vitvit88

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #4 Online: 13 de Janeiro de 2013, 19:19 »
Muito obrigado, só não vou fazer agora pq eu sou medroso [:P] Vou esperar um amigo vim pra me ajudar

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #5 Online: 13 de Janeiro de 2013, 19:53 »
Muito obrigado, só não vou fazer agora pq eu sou medroso [:P] Vou esperar um amigo vim pra me ajudar

Ué, é só seguir passo a passo, não vai queimar nada... eu ainda verifiquei, pra ver se não tem nada errado.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Fósforo

  • Usuário Ubuntu
  • *
  • Mensagens: 94
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #6 Online: 26 de MAR?O de 2013, 15:22 »
Galera,

estou com o mesmo problema, só que na realidade, um pouco diferente.
A diferença consiste em que antes o emulador funcionava com as cores normais
e agora não mais.

uso o visualboyadvance (VBA)
meu ubuntu é 0 precise pangolin
e com o comando achei isso ai abaixo.
fosforo@fosforo-laptop:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 IDE Controller (rev 01)
00:03.0 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 SATA controller: Silicon Integrated Systems [SiS] AHCI IDE Controller (0106) (rev 03)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #7 Online: 26 de MAR?O de 2013, 15:24 »
Código: (lspci) [Selecionar]
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
Parabéns amigo.. Você é um grande sortudo que tem a placa de vídeo com pior suporte ao Linux, SIS..!

Dê uma pesquisada aqui no Fórum, tem muito sobre ela..!

Offline adiaswin

  • Usuário Ubuntu
  • *
  • Mensagens: 979
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #8 Online: 26 de MAR?O de 2013, 15:48 »
ola

Código: [Selecionar]
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
nossa a maldita 771 da sis bem amigo

se não esta duro do bolso compre uma placa de video.
ubuntu 12.04

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #9 Online: 26 de MAR?O de 2013, 16:20 »
Código: (sudo lshw -C video) [Selecionar]
*-display               
       descrição: VGA compatible controller
       produto: RV710 [Radeon HD 4350]
       fabricante: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       informações do barramento: pci@0000:03:00.0
       versão: 00
       largura: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuração: driver=radeon latency=0
       recursos: irq:42 memória:d0000000-dfffffff memória:cffe0000-cffeffff ioport:e000(tamanho=256) memória:cffc0000-cffdffff

Não custa tão caro assim, essa ai custou R$:300,00

Offline Fósforo

  • Usuário Ubuntu
  • *
  • Mensagens: 94
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #10 Online: 26 de MAR?O de 2013, 17:35 »
kkkkkkkkkkkkkkkk
que derma em galera
mas então, gameboy ainda é o unico jogo que funciona no meu pc
e se vc pensar, ainda sim esse jogo funciona antes
deve ter como fazer funcionar de novo :D

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #11 Online: 26 de MAR?O de 2013, 22:13 »
kkkkkkkkkkkkkkkk
que derma em galera
mas então, gameboy ainda é o unico jogo que funciona no meu pc
e se vc pensar, ainda sim esse jogo funciona antes
deve ter como fazer funcionar de novo :D

Será que foi alguma atualização? Tenta iniciar o sistema com um kernel linux mais antigo, na tela do grub (aquela tela preta com várias opções), vá em Previous Linux versions e escolha uma opção mais antiga por lá.

Digita:

Código: [Selecionar]
uname -a
Para a gente saber qual kernel está instalado aí.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline adiaswin

  • Usuário Ubuntu
  • *
  • Mensagens: 979
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #12 Online: 27 de MAR?O de 2013, 12:11 »
Código: (sudo lshw -C video) [Selecionar]
*-display               
       descrição: VGA compatible controller
       produto: RV710 [Radeon HD 4350]
       fabricante: Hynix Semiconductor (Hyundai Electronics)
       physical id: 0
       informações do barramento: pci@0000:03:00.0
       versão: 00
       largura: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuração: driver=radeon latency=0
       recursos: irq:42 memória:d0000000-dfffffff memória:cffe0000-cffeffff ioport:e000(tamanho=256) memória:cffc0000-cffdffff

Não custa tão caro assim, essa ai custou R$:300,00
ola

e nessas horas que eu sinto a falta do meu desk....
ubuntu 12.04

Offline kenner

  • Usuário Ubuntu
  • *
  • Mensagens: 195
  • Xubutnu 14.04
    • Ver perfil
Re: Problema com VisualBoy Advanced
« Resposta #13 Online: 27 de MAR?O de 2013, 18:04 »
Sugiro que instale o mednafen. Ele é um pouco mais complicado para configurar mas apresenta um desempenho bem melhor no linux, além de emular outras plataformas.
Para iniciar o mesmo basta "abrir" a rom.