Autor Tópico: Cgi - Apache2  (Lida 10238 vezes)

Offline cefb

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Cgi - Apache2
« Online: 06 de Setembro de 2006, 12:00 »
 Instalei à pouco tempo o a versao 6.06. O problema agora é que nao consigo configurar o apache2 de maneira a que me permita correr ficheiro cgi ou pl. Tenho instalado o apache2 e o php5 e funcina bem. Como nao muito experiente que sou tentei arranjar o problema mas  criando a pasta ~/public_html/cgi-bin/ com as permissoes correctas mas o problema seguinte é que depois aparece me o erro  "Options ExecCGI is off in this directory: /home/cefb/public_html/cgi-bin/". tentei com os ficheiros .htaccess mas sem sucesso.

Vi tambem configuraçoes do ficheiro httpd.conf mas o problema é que no apache2 esse ficheiro é vazio apenas o apache2.conf tem conteudo mas nao sei o que mexer.

Peço ajuda porque me dava muito jeito conseguir por isto a funcionar para realizar trabalhos

Obrigado

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Cgi - Apache2
« Resposta #1 Online: 06 de Setembro de 2006, 15:47 »
A configuração está em:
/etc/apache2/sites-enabled
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Offline cefb

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Cgi - Apache2
« Resposta #2 Online: 07 de Setembro de 2006, 08:14 »
Quem nao percebe é assim..... Mas o que tenho de fazer para poder executar cgi na public_html/cgi-bin/?


Obrigado

Offline cefb

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Cgi - Apache2
« Resposta #3 Online: 07 de Setembro de 2006, 08:39 »
problema resolvido..... acrescentei umas coisas no apache2.conf esta a funcionar.

Obrigado

Offline GDA

  • Usuário Ubuntu
  • *
  • Mensagens: 92
    • Ver perfil
Re: Cgi - Apache2
« Resposta #4 Online: 13 de Setembro de 2006, 15:01 »
problema resolvido..... acrescentei umas coisas no apache2.conf esta a funcionar.

Obrigado

Seria ótimo se vc nos contasse como conseguiu resolver... Mas, em todo caso, parabéns... :-\
jabber: droopalong@jabber.org - Ubuntu'ser:
Interessado em aprender mais sobre o Ubuntu em português? Comece aqui

Offline cefb

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: Cgi - Apache2
« Resposta #5 Online: 20 de Setembro de 2006, 15:57 »
no fim do ficheiro apache2.conf acrescentei o seguinte

ScriptAlias /cgi-bin/ /usr/local/apache2/cgi-bin/
<Directory /home/*/public_html/cgi-bin>
AddHandler cgi-script .cgi .pl   
Options ExecCGI
SetHandler cgi-script
</Directory>         

depois foi so criar a pasta cgi-bin no dentro de ~/public_html/ fazer chmod 755 cgi-bin e as mesmas permissoes para ficheiros dentro
da pasta cgi-bin e ja esta

Offline rafasnn

  • Usuário Ubuntu
  • *
  • Mensagens: 611
    • Ver perfil
Re: Cgi - Apache2
« Resposta #6 Online: 02 de Junho de 2008, 14:28 »
no fim do ficheiro apache2.conf acrescentei o seguinte

ScriptAlias /cgi-bin/ /usr/local/apache2/cgi-bin/
<Directory /home/*/public_html/cgi-bin>
AddHandler cgi-script .cgi .pl   
Options ExecCGI
SetHandler cgi-script
</Directory>         

depois foi so criar a pasta cgi-bin no dentro de ~/public_html/ fazer chmod 755 cgi-bin e as mesmas permissoes para ficheiros dentro
da pasta cgi-bin e ja esta

cefb,

vc conseguiu rodar normalmente scripts cgi no apache2? quando tento utilizar o nagios ele tentar fazer o download do arquivo cgi, alguma dica de como corrigir isso?
Macbook Pro 2,33 4GB 250GB
iPhone 8GB