Autor Tópico: [Resolvido] problema em ' apt-get update '  (Lida 11350 vezes)

Offline viniciiusribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
[Resolvido] problema em ' apt-get update '
« Online: 07 de Junho de 2012, 00:23 »
Olá, eu usei o comando 'sudo apt-get update' no terminal e no finalzinho sempre ta aparecendo essa mensagem abaixo


W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-amd64_Packages)
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages)
W: Você terá que executar apt-get update para corrigir estes problemas

O ultimo aviso diz que tem que executar o update pra corrigir, mas sempre que dou o update aparece isso e não corrige nada, alguém sabe me dizer qual é o problema ?
« Última modificação: 07 de Junho de 2012, 16:38 por viniciiusribeiro »

Offline EdvaldoSCruz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.327
  • Deus é bom e JESUS CRISTO é o filho dEle.(Jo14:23)
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #1 Online: 07 de Junho de 2012, 09:59 »
Olá, eu usei o comando 'sudo apt-get update' no terminal e no finalzinho sempre ta aparecendo essa mensagem abaixo


W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-amd64_Packages)
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages)
W: Você terá que executar apt-get update para corrigir estes problemas

O ultimo aviso diz que tem que executar o update pra corrigir, mas sempre que dou o update aparece isso e não corrige nada, alguém sabe me dizer qual é o problema ?


Entra no gerenciador de pacotes synaptic e recarrega ele e após fechá-lo, vá em gerenciador de atualizações e veja se volta ao normal.


Não era pra ter falado sobre Windows, e muito menos XP tem a ver com o assunto.

O que eu quero saber é se tem algum programa para ubuntu que tenha opção de mudar a saída da áudio padrão da placa de som

Agora sim, você explicou o que quer.

Veja esse tópico que após instalação do pavucontrol, há opção que você necessita: Gravando vídeo com áudio ou som da rádio online, com áudio da placa de som


Espero que supra as suas necessidades.

Observação: caso tenha resolvido, não esqueça de colocar no seu tópico "Resolvido" e como você resolveu, para que todos que tenham o mesmo problema nesse excelente Fórum Ubuntu, solucionem também. A comunidade agradece

  Viva o Ubuntu !!!!!!!  :D


e vamos que vamos.

Ignorância é não aceitar e não submeter-se a CRISTO JESUS.
Para os Iniciantes, como eu, links de solucionar problemas rapidamente.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #2 Online: 07 de Junho de 2012, 10:22 »
Olá, eu usei o comando 'sudo apt-get update' no terminal e no finalzinho sempre ta aparecendo essa mensagem abaixo


W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-amd64_Packages)
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages)
W: Você terá que executar apt-get update para corrigir estes problemas

O ultimo aviso diz que tem que executar o update pra corrigir, mas sempre que dou o update aparece isso e não corrige nada, alguém sabe me dizer qual é o problema ?


Você usa o Ubuntu 64bits ou 32bits?

Pelo erro relatado aí na sua lista de repositórios (sources.list) o repositório parceiro (partner) está duplicado.

Sendo que uma entrada é para sistema 32bits:

http://archive.canonical.com/ubuntu/ precise/partner i386 Packages

e a outra entrada é para 64bits:

http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages

Portanto abra o arquivo sources.list que fica em /etc/apt como root e veja as linhas sobre o repositório partner e se realmente estiverem duplicadas, uma para 32bits e outra para 64bits, deixe somente a que for adequada para seu tipo de sistema. Com a outra linha coloque o símbolo # no inicio da linha que contém o texto em duplicidade para que ela seja completamente ignorada. Isso de chama comentar (= #) a linha.
« Última modificação: 07 de Junho de 2012, 10:33 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline viniciiusribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #3 Online: 07 de Junho de 2012, 11:08 »
Você usa o Ubuntu 64bits ou 32bits?

Pelo erro relatado aí na sua lista de repositórios (sources.list) o repositório parceiro (partner) está duplicado.

Sendo que uma entrada é para sistema 32bits:

http://archive.canonical.com/ubuntu/ precise/partner i386 Packages

e a outra entrada é para 64bits:

http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages

Portanto abra o arquivo sources.list que fica em /etc/apt como root e veja as linhas sobre o repositório partner e se realmente estiverem duplicadas, uma para 32bits e outra para 64bits, deixe somente a que for adequada para seu tipo de sistema. Com a outra linha coloque o símbolo # no inicio da linha que contém o texto em duplicidade para que ela seja completamente ignorada. Isso de chama comentar (= #) a linha.

Eu abri esse arquivo só que não contém nenhuma linha duplicada não :/

O meu sistema é 64 bits

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #4 Online: 07 de Junho de 2012, 13:17 »
Post o conteudo do arquivo

/etc/apt/source.list

Para abrir digite no terminal

sudo gedit /etc/apt/source.list

Offline viniciiusribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #5 Online: 07 de Junho de 2012, 14:04 »
Post o conteudo do arquivo

/etc/apt/source.list

Para abrir digite no terminal

sudo gedit /etc/apt/source.list

Aqui está  >

# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ dists/precise/main/binary-i386/

# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://br.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://br.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://br.archive.ubuntu.com/ubuntu/ precise universe
deb http://br.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://br.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://br.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://br.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #6 Online: 07 de Junho de 2012, 14:29 »
Certo, sua sources.list está ok o problema não é aí. Vendo direito seu erro o problema é aqui:

Vá para pasta /var/lib/apt/lists/ e lá veja se tem uma pasta ou arquivo (acho que deve ser arquivo mesmo) com esses nomes:

archive.canonical.com_ubuntu_dists_precise_partner_binary-amd64_Packages

e

archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages

volte aqui com a informação.

Se tiver faça um teste, mova o arquivo archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages como root para sua pasta de usuário e no terminal digite:

sudo apt-get update

veja se o erro continua aparecendo. Mandei tirar o que contém i386 no nome, pois você informa que usa 64bits então acho que o i386 não deveria estar aí. Qualquer coisa você põe o arquivo que removeu para o seu usuário de volta em /var/lib/apt/lists/, como root outra vez.
« Última modificação: 07 de Junho de 2012, 14:38 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline viniciiusribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #7 Online: 07 de Junho de 2012, 15:24 »
Certo, sua sources.list está ok o problema não é aí. Vendo direito seu erro o problema é aqui:

Vá para pasta /var/lib/apt/lists/ e lá veja se tem uma pasta ou arquivo (acho que deve ser arquivo mesmo) com esses nomes:

archive.canonical.com_ubuntu_dists_precise_partner_binary-amd64_Packages

e

archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages

volte aqui com a informação.

Se tiver faça um teste, mova o arquivo archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages como root para sua pasta de usuário e no terminal digite:

sudo apt-get update

veja se o erro continua aparecendo. Mandei tirar o que contém i386 no nome, pois você informa que usa 64bits então acho que o i386 não deveria estar aí. Qualquer coisa você põe o arquivo que removeu para o seu usuário de volta em /var/lib/apt/lists/, como root outra vez.


Fiz como você disse, movi o que tem i386 para dentro de /home , só que quando eu dei o update, apareceu o mesmo problema e quando fui ver na pasta /var/lib/apt/lists/ o arquivo tinha sido criado la de novo.

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #8 Online: 07 de Junho de 2012, 15:43 »
Faz um teste para mim abre o central de programas e vá para o menu Editar > Canais de software na barra superior quando  o central é a janela ativa na sua área de trabalho. Na janela que abrir e na aba Outro software desmarque as opções que falam em parceiros (São duas, uma é relativa ao código fonte). Depois feche todas as janelas vá ao terminal e digite:

sudo apt-get clean
sudo apt-get update


Atenção que o primeiro comando vai limpar o cache de todos .deb baixados da internet e dos repositórios. Se você não quiser limpar o cache, não use o primeiro comando ok.

Anote qualquer mensagem de erro do segundo comando.

Antes de fazer esses procedimentos vá para a pasta /etc/apt/sources.list.d/ e me informe quais são os arquivos que contém nela. Veja se tem algo referente a partner ou parceiros.
« Última modificação: 07 de Junho de 2012, 15:50 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline viniciiusribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #9 Online: 07 de Junho de 2012, 16:02 »
Faz um teste para mim abre o central de programas e vá para o menu Editar > Canais de software na barra superior quando  o central é a janela ativa na sua área de trabalho. Na janela que abrir e na aba Outro software desmarque as opções que falam em parceiros (São duas, uma é relativa ao código fonte). Depois feche todas as janelas vá ao terminal e digite:

sudo apt-get clean
sudo apt-get update


Atenção que o primeiro comando vai limpar o cache de todos .deb baixados da internet e dos repositórios. Se você não quiser limpar o cache, não use o primeiro comando ok.

Anote qualquer mensagem de erro do segundo comando.

Antes de fazer esses procedimentos vá para a pasta /etc/apt/sources.list.d/ e me informe quais são os arquivos que contém nela. Veja se tem algo referente a partner ou parceiros.

Fiz o que você disse na central de programas, dei o clean e o update, e não apresentou mais o problema de antes e dentro da /etc/apt/sources.list.d/ tem um arquivo que se chama 'precise-partner.list' e outro 'precise-partner.list.save

e agora eu posso marcar de novo aquelas caixas da Central de Programas, o problema ta resolvido ? o que era ?

Offline linuser104

  • Usuário Ubuntu
  • *
  • Mensagens: 838
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #10 Online: 07 de Junho de 2012, 16:06 »
Fiz o que você disse na central de programas, dei o clean e o update, e não apresentou mais o problema de antes e dentro da /etc/apt/sources.list.d/ tem um arquivo que se chama 'precise-partner.list' e outro 'precise-partner.list.save

e agora eu posso marcar de novo aquelas caixas da Central de Programas, o problema ta resolvido ? o que era ?

Seu problema era em /etc/apt/sources.list.d/, senão vejamos. Mova os arquivos que tem a palavra partner no nome (precise-partner.list e outro precise-partner.list.save) da pasta /etc/apt/sources.list.d/ para o seu usuário como root e depois desfaça o procedimento no central de programas, ou seja, pelo canais de software marque novamente as duas entras referentes a parceiros (partner). Depois vá ao terminal e digite:

sudo apt-get update

Não deverá apresentar erro.

O erro é que na sua sources.list em /etc/apt/ tinha as entradas para os repositórios partner e em /etc/apt/sources.list.d/ tinha algo também sendo que nesse último não deveria ter, por isso o erro de entradas duplicadas. A confirmar isso ok.
« Última modificação: 07 de Junho de 2012, 16:30 por linuser104 »
Linux = Quem realmente gosta de computador; Mac = Artista Digital; Windows = A maioria que votou no Tiririca [pior que tá não fica].

Offline viniciiusribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 39
    • Ver perfil
Re: problema em ' apt-get update '
« Resposta #11 Online: 07 de Junho de 2012, 16:37 »
Seu problema era em /etc/apt/sources.list.d/, senão vejamos. Mova os arquivos que tem a palavra partner no nome (precise-partner.list e outro precise-partner.list.save) da pasta /etc/apt/sources.list.d/ para o seu usuário como root e depois desfaça o procedimento no central de programas, ou seja, pelo canais de software marque novamente as duas entras referentes a parceiros (partner). Depois vá ao terminal e digite:

sudo apt-get update

Não deverá apresentar erro.

O erro é que na sua sources.list em /etc/apt/ tinha as entradas para os repositórios partner e em /etc/apt/sources.list.d/ tinha algo também sendo que nesse último não deveria ter, por isso o erro de entradas duplicadas. A confirmar isso ok.

Fiz como você disse e realmente não apresentou mais o erro, muito obrigado pela sua ajuda, e a todos os que ajudaram  :)

Offline mori solutions

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: [Resolvido] problema em ' apt-get update '
« Resposta #12 Online: 21 de Agosto de 2012, 19:54 »
Valeu, resolveu meu problema também...