Autor Tópico: Como desativar a verificação de dependencias no instaldor de pacotes deb?  (Lida 5922 vezes)

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Eu estou tendo alguns problemas que não consigo entender.

O openjdk me pede para instalar "openjdk-6-jre-headless_6b16-1.6.1-3ubuntu1_i386". é o openjdk-6-jre-headless me pede para instalar "openjdk-6-jre-lib_6b16-1.6.1-3ubuntu1_all".
Outro problema que eu tive foi com o gnucash o mesmo problema acima.

Só que os dois dependem um do outro então como vou instalar assim?

Se tiver algum jeito de instalar, editando o pacote deb, desativando a verificação de dependencias eu queria saber como, para tentar instalar.


Aqui tem imagens do problema:

Primeira imagem:





Segunda imagem:





Tem algum jeito de avisar alguem para corrigir este pacote?

« Última modificação: 22 de Dezembro de 2009, 01:03 por livre1 »

Offline sboorbou

  • Usuário Ubuntu
  • *
  • Mensagens: 385
  • LPIC 2 - LPI 000180523 - Linux user 490229 - MCITP
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #1 Online: 22 de Dezembro de 2009, 08:40 »
se você der um sudo apt-get install openjdk-6-jre-headless openjdk-6-jre-lib  ????
ou sudo apt-get install openjdk-6-*

caso não funcione, tente pelo sinaptic, ele costuma resolver as dep tambem.......
duvida eu em você sinto... duvida a raiva leva, raiva ao ódio leva, ódio é o lado negro da força - Mestre Yoda

Offline Alyscom

  • Usuário Ubuntu
  • *
  • Mensagens: 774
  • Apenas me dê o feijão!
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #2 Online: 22 de Dezembro de 2009, 09:13 »
Pelo que eu entendi você está tentando instalar direto pelos pacotes .deb e não pelo synaptic
Tente fazer assim
Citar
cd nome_do_diretorio_onde_estão_os_arquivos
E depois
Citar
dpkg -i --forget-old-unavail *.deb
Acho que é assim! ;D


[]'s



Alyscom
« Última modificação: 22 de Dezembro de 2009, 09:15 por Alyscom »
O álcool é o photoshop da vida real
 

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #3 Online: 23 de Dezembro de 2009, 02:53 »
E eu quero instalar pelo pacote deb, porque estou sem internet no ubuntu...


Vou ter que baixar os pacotes tudo denovo, para tentar, provavelmente eu consigo em dois dias...


Alyscom no comando "dpkg -i --forget-old-unavail *.deb" se eu quero instalkar o pacote exemplo.deb eu coloco assim:

dpkg -i --forget-old-unavail exemplo.deb


E isto?


Ele vai forçar a instalar sem as dependencias?



Offline sboorbou

  • Usuário Ubuntu
  • *
  • Mensagens: 385
  • LPIC 2 - LPI 000180523 - Linux user 490229 - MCITP
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #4 Online: 23 de Dezembro de 2009, 08:34 »
E eu quero instalar pelo pacote deb, porque estou sem internet no ubuntu...


Vou ter que baixar os pacotes tudo denovo, para tentar, provavelmente eu consigo em dois dias...


Alyscom no comando "dpkg -i --forget-old-unavail *.deb" se eu quero instalkar o pacote exemplo.deb eu coloco assim:

dpkg -i --forget-old-unavail exemplo.deb


E isto?


Ele vai forçar a instalar sem as dependencias?




Isso é perigoso, você tem certeza que quer fazer isso?
acho melhor pesquizar bem antes...

Instalar um software sem as devidas dependências quase sempre levam o mesmo a não funcioanr ou perder muitas funcinoalidades... em alguns casos o sistema todo pode ficar instavel ou até parar de funcionar ( não vai ser o caso com o java... mas fica a dica... )
duvida eu em você sinto... duvida a raiva leva, raiva ao ódio leva, ódio é o lado negro da força - Mestre Yoda

Offline Alyscom

  • Usuário Ubuntu
  • *
  • Mensagens: 774
  • Apenas me dê o feijão!
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #5 Online: 23 de Dezembro de 2009, 11:47 »
O <*> na frente é para não ter que digitar o nome inteiro do pacote um por um, Ele vai instalar todos os .deb que tem na pasta... Então é melhor fazer isso com cuidado! :)
Faz assim...
Citar
sudo dpkg -i --ignore-depends=*.deb
E pronto! O comando "--ignore-depends=" é para ignorar dependências envolvendo <pacote>

O outro comando que citei
Citar
--forget-old-unavail
É para esquecer pacotes indisponíveis, não-instalados.

Creio que qualquer um dos dois exemplos que citei, darão certo! :)



[]'s



Alyscom
« Última modificação: 23 de Dezembro de 2009, 11:50 por Alyscom »
O álcool é o photoshop da vida real
 

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #6 Online: 24 de Dezembro de 2009, 01:38 »
Mesmo sendo inseguro é a unica forma que vejo de instalar o java.


O meu modem parece não funcionar nesta versão do kernel.

Para mim tanto o pacote do openjdk, java, gnucash estão com bugs.


Bom hoje eu tirei o wubi, é instalei na partição (Perdi o medo que tinha de não conseguir remover o grub), então vou tentar.

Offline sboorbou

  • Usuário Ubuntu
  • *
  • Mensagens: 385
  • LPIC 2 - LPI 000180523 - Linux user 490229 - MCITP
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #7 Online: 24 de Dezembro de 2009, 13:00 »
se você usa o windows na máquina tambem e  tem a licença dele, faz uma vm para windows no linux compartilha a conexão e baixa o que precisa.... depois verifica como arrumar a conexão no linux e quais pacotes precisa, etc.......
duvida eu em você sinto... duvida a raiva leva, raiva ao ódio leva, ódio é o lado negro da força - Mestre Yoda

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #8 Online: 25 de Dezembro de 2009, 00:52 »
Veja o que deu quando instalei o pacote:


livre@livre-desktop:~$ sudo dpkg -i --ignore-depends= openjdk-6-jre-lib_6b16-1.6.1-3ubuntu1_all.deb
Selecionando pacote previamente não selecionado openjdk-6-jre-lib.
(Lendo banco de dados ... 113846 arquivos e diretórios atualmente instalados).
Desempacotando openjdk-6-jre-lib (de openjdk-6-jre-lib_6b16-1.6.1-3ubuntu1_all.deb) ...
dpkg: problemas de dependência impedem a configuração de openjdk-6-jre-lib:
 openjdk-6-jre-lib depende de openjdk-6-jre-headless (>= 6b16); porém:
  Pacote openjdk-6-jre-headless não está instalado.
dpkg: erro processando openjdk-6-jre-lib (--install):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 openjdk-6-jre-lib
livre@livre-desktop:~$








livre@livre-desktop:~$ sudo dpkg -i --ignore-depends= openjdk-6-jre-headless_6b16-1.6.1-3ubuntu1_i386.deb
Selecionando pacote previamente não selecionado openjdk-6-jre-headless.
(Lendo banco de dados ... 114351 arquivos e diretórios atualmente instalados).
Desempacotando openjdk-6-jre-headless (de openjdk-6-jre-headless_6b16-1.6.1-3ubuntu1_i386.deb) ...
dpkg: problemas de dependência impedem a configuração de openjdk-6-jre-headless:
 openjdk-6-jre-headless depende de openjdk-6-jre-lib (>= 6b16-1.6.1-3ubuntu1); porém:
  Pacote openjdk-6-jre-lib não está configurado ainda.
 openjdk-6-jre-headless depende de ca-certificates-java; porém:
  Pacote ca-certificates-java não está instalado.
 openjdk-6-jre-headless depende de tzdata-java; porém:
  Pacote tzdata-java não está instalado.
 openjdk-6-jre-headless depende de rhino; porém:
  Pacote rhino não está instalado.
 openjdk-6-jre-headless depende de java-common (>= 0.28); porém:
  Pacote java-common não está instalado.
dpkg: erro processando openjdk-6-jre-headless (--install):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 openjdk-6-jre-headless
livre@livre-desktop:~$


O comando deu certo, mais acho que não vou conseguir instalar nem openjdk, nem java  :'(

Quanto a maquina virtual eu olhei no site da sun é diz que para um bom funcionamento precisa ter 1 GB para instalar windows xp é linux.

E eu só tenho 512 MB, então nem tentei.

E o vmware também precisa de um numero auto de memoria.

A solução mais facil é mudar minha internet, mais isto só quando eu for maior de idade...


Obrigado, é feliz natal.

Offline Alyscom

  • Usuário Ubuntu
  • *
  • Mensagens: 774
  • Apenas me dê o feijão!
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #9 Online: 25 de Dezembro de 2009, 08:23 »
Brother... Posta uma lista com todos os nomes "completos" dos arquivos que você quer instalar, pode ser?? :)

Feliz natal!! ;)



[]'s



Alyscom
O álcool é o photoshop da vida real
 

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #10 Online: 25 de Dezembro de 2009, 08:41 »
Basicamente eu quero instalar estes pacotes:


Java (já tentei pelos pacotes deb é bin é não consegui...)


A tentei o "Openjdk" também não consegui, o openjdk desde que funcione no openoffice, é meus aplicativos já está bom, porque não vou usar ele na internet.


Gnucash


Por exemplo o pacote exemplo.deb pede a dependencia "exemplolib.deb", é o pacote exemplolib.deb depende do exemplo.deb.

Ai pela interface grafica fica sem ter como instalar, este foi o motivo que criei para procurar uma alternativa para instalar.


O site que estou baixando estes pacotes é:

openjdk:
http://packages.ubuntu.com/karmic/openjdk-6-jre


gnucash: http://packages.ubuntu.com/karmic/gnucash


Eu pensei em baixar o openjdk pelo codigó fonte, mais minhas tentativas de instalar programas por codigó fonte nunca são boas...


alarcon

  • Visitante
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #11 Online: 25 de Dezembro de 2009, 12:03 »
Se você não tem acesso a internet e que instalar esses pacotes aí, uma alternativa que pode dar certo seria o seguinte, vá no menu Sistema > Administração > Synaptic lá procure pelos pacote que vc quer instar selecionando-os para instalação, mas não clique no botão Aplicar. Ao invés disso vá no menu Arquivos do Synaptic e escolha lá a opção Gerar script de download do(s) pacote(s) e depois dê um nome para esse script, por exemplo Opdenjdk&Gnucash e salve.

Depois vc pode ir ao windows ou qualquer outro PC que vc possa usar a internet abrir esse script (arquivo de texto) e copiar e colar todos os endereços de pacotes e suas dependências para serem baixados em um aplicativo de download.

O bom desse script é que ele já coloca todos os pacotes e suas dependências na sequência de instalação, depois é só vc levar tudo que baixou ao Ubuntu e instalar na sequência indicada no script ou então colocar todos os .deb numa pasta e digitar sudo dpkg *.deb dentro desta pasta pelo terminal.

Um porém que pode ocorrer nesta solução é que talvez a sua lista de repositórios esteja defasada, o mais provável, e aí os pacotes gerados por esse script seriam de versões mais antigas dos que as realmente existentes neste momento nos repositórios.


Exemplificando, aqui no meu Ubuntu 9.10 32 bits fui ao synaptic e procurei pelos programas que vc quer instalar e marquei para instalação e depois mandei gerar o script e o resultado foi esse:

Citar
#!/bin/sh
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openjdk-6/openjdk-6-jre-lib_6b16-1.6.1-3ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/c/ca-certificates-java/ca-certificates-java_20090928_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/t/tzdata/tzdata-java_2009s-0ubuntu0.9.10_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/j/jline/libjline-java_0.9.94-5~ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/r/rhino/rhino_1.7R2-1ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openjdk-6/openjdk-6-jre-headless_6b16-1.6.1-3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/j/java-access-bridge/libaccess-bridge-java_1.26.2-1ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/j/java-access-bridge/libaccess-bridge-java-jni_1.26.2-1ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openjdk-6/openjdk-6-jre_6b16-1.6.1-3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/openjdk-6/icedtea-6-jre-cacao_6b16-1.6.1-3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libg/libgwenhywfar/libgwenhywfar47_3.10.0-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking-data_4.1.2-1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking29_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqhbci16_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqofxconnect5_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libk/libktoblzcheck/libktoblzcheck1c2a_1.22-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking29-plugins_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/aqbanking-tools_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/libguile-ltdl-1_1.6.8-6.3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/libqthreads-12_1.6.8-6.3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/r/readline5/libreadline5_5.2-6_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/guile-1.6-libs_1.6.8-6.3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/guile-1.6_1.6.8-6.3ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/s/slib/slib_3b1-3_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/guile-1.6/guile-1.6-slib_1.6.8-6.3ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking-plugins-libgwenhywfar47_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libqbanking8_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/liba/libaqbanking/libaqbanking29-plugins-qt_4.1.2-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/c/crypt-ssleay/libcrypt-ssleay-perl_0.57-1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/libd/libdate-manip-perl/libdate-manip-perl_5.54-1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libh/libhtml-tableextract-perl/libhtml-tableextract-perl_2.10-3_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libf/libfinance-quote-perl/libfinance-quote-perl_1.16-4_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/g/goffice/libgoffice-0-8-common_0.7.8-1ubuntu1_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/g/goffice/libgoffice-0-8_0.7.8-1ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/o/opensp/libosp5_1.5.2-7ubuntu1_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libo/libofx/libofx4_0.9.0-3ubuntu2_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnucash/gnucash-common_2.2.9-0ubuntu4_all.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnucash/gnucash_2.2.9-0ubuntu4_i386.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnucash-docs/gnucash-docs_2.2.0-3_all.deb

portanto tudo que esses dois pacotes (Openjdk e Gnucash)  necessitam para se instalarem no meu sistema com os repositórios atualizados até o dia de hoje.

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #12 Online: 25 de Dezembro de 2009, 12:25 »
Qualquer gerenciador de downloads dá para fazer isto?



Vou em um cyber ai consiguirei baixar para tentar.


Primeiramente vou tentar obter estes pacotes aqui em casa mesmo.
« Última modificação: 25 de Dezembro de 2009, 12:30 por livre1 »

alarcon

  • Visitante
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #13 Online: 25 de Dezembro de 2009, 16:00 »
Qualquer gerenciador de downloads dá para fazer isto?



Vou em um cyber ai consiguirei baixar para tentar.


Primeiramente vou tentar obter estes pacotes aqui em casa mesmo.

você pode sim usar qualquer gerenciador de downloads do windows para baixar cada um dos pacotes, bastando copiar e colar os links de cada pacote.

Veja que o wget -c presente em cada linha do script é um comando de terminal via linux para baixar pacotes e com continuação do pondo de onde parou (o parâmetro -c) se vc pausar o download por qualquer motivo.

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Como desativar a verificação de dependencias no instaldor de pacotes deb?
« Resposta #14 Online: 25 de Dezembro de 2009, 16:05 »
Hehe eu viajei kkkkk.


Eu pensei que este script era pra um programa baixar todos os pacotes em um só comando por isto perguntei se podia usar em qualquer gerenciador de download.


Vou baixar estes pacotes e instalar assim consigo forçar a instalação mais facilmente.


Obrigado.