Autor Tópico: Como inserir argumentos no wvdial? [Resolvido]  (Lida 4101 vezes)

kErNeL_sCrIpT

  • Visitante
Como inserir argumentos no wvdial? [Resolvido]
« Online: 07 de Maio de 2008, 18:57 »
Bom galera, eu criei este tópico - http://ubuntuforum-br.org/index.php/topic,22895.0.html - porém não estou satisfeito em usar o KPPP, eu gostaria de utilizar o wvdial que é bem mais simples, mas só que quando conecta, desconecta logo em seguida :-\
Com o GNOME PPP (Uma Front End para o wvdial) acontece a mesma situação.
Eu acredito ser por que não sei como inserir o argumento noccp nas configurações do wvdial, pois o KPPP só conecta com este argumento.
Se alguém puder ajudar, desde já agradeço.

Meu arquivo wvdial.conf:

Citar


[Dialer vivo]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 9600
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = xxxxxxxx
Password = xxxxxxxx
Username = xxxxxxxx


O que acontece quando eu disco:

Citar
kernel-script@ubuntu-hardy-heron:~$ sudo su
root@ubuntu-hardy-heron:/home/kernel-script# wvdial vivo
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDTxxxxxxxx
--> Waiting for carrier.
ATDTxxxxxxxx
CONNECT
--> Carrier detected.  Waiting for prompt.
--> Connected, but carrier signal lost!  Retrying...
--> Sending: ATDTxxxxxxxx
--> Waiting for carrier.
~[7f]}#@!}!}!} }4}"}&} } } } }#}$@#}%}&;ok}3kK~~[7f]}#@!}!}"} }4}"}&} } } } }#}$@#}%}&;ok}3!v~~[7f]}#@!}!}#} }4}"}&} } } } }#}$@#}%}&;ok}3he~~[7f]}#@!}!}$} }4}"
« Última modificação: 07 de Maio de 2008, 22:38 por kErNeL_sCrIpT »

Offline tfmoraes

  • Usuário Ubuntu
  • *
  • Mensagens: 444
    • Ver perfil
Re: Como inserir argumentos no wvdial?
« Resposta #1 Online: 07 de Maio de 2008, 21:51 »
kErNeL_sCrIpT, adicione a linha abaixo ao seu arquivo wvdial.conf
Stupid Mode = 1

O kppp não é um frontend para o wvdial, o gnome ppp é.

kErNeL_sCrIpT

  • Visitante
Re: Como inserir argumentos no wvdial?
« Resposta #2 Online: 07 de Maio de 2008, 22:34 »
kErNeL_sCrIpT, adicione a linha abaixo ao seu arquivo wvdial.conf
Stupid Mode = 1

O kppp não é um frontend para o wvdial, o gnome ppp é.


Opa, obrigado pela dica e pela correção. Já vou acertar o texto sobre o KPPP - wvdial e tentar a dica e posto aqui se deu certo.

Editado
AEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
FUNCIONÔ!!!!!!!!!!!!!!!!!!!!!!!!!
MUITO OBRIGADO tfmoraes!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 :D :D :D :D :D :D :D :D :D :D
Bicho, tu não sabe como eu tô feliz!!!!
Caramba, depois de cerca de oito meses eu tentando conectar em modo texto, finalmente consegui! Tu colocô a cereja no bolo amigo!!!!
Valeu mesmo cara, muito obrigado! :D
Acabou o sofrimento!! ;D
« Última modificação: 08 de Maio de 2008, 00:40 por kErNeL_sCrIpT »

Offline tfmoraes

  • Usuário Ubuntu
  • *
  • Mensagens: 444
    • Ver perfil
Re: Como inserir argumentos no wvdial? [Resolvido]
« Resposta #3 Online: 08 de Maio de 2008, 20:01 »
kErNeL_sCrIpT, eu também só fui descobrir este macete do wvdial a umas duas semanas, antes eu conectava usando o comando pon. Mais uma dica para você, ao invés de usar o comando "wvdial provedor", use o comando "pon.wvdial provedor", pois com o primeiro comando ao fechar o terminal onde você iniciou o wvdial a conexão cairá, com o segundo não.

kErNeL_sCrIpT

  • Visitante
Re: Como inserir argumentos no wvdial? [Resolvido]
« Resposta #4 Online: 08 de Maio de 2008, 20:49 »
kErNeL_sCrIpT, eu também só fui descobrir este macete do wvdial a umas duas semanas, antes eu conectava usando o comando pon. Mais uma dica para você, ao invés de usar o comando "wvdial provedor", use o comando "pon.wvdial provedor", pois com o primeiro comando ao fechar o terminal onde você iniciou o wvdial a conexão cairá, com o segundo não.

Obrigado novamente por mais esta dica :)
Mas eu não preciso, pois coloquei o wvdial provedor pra iniciar junto ao GDM pra encerrar com o rc.local, daí o processo todo de conexão e desconexão ocorre em "Background" (Plano de Fundo) e automaticamente! :D
Muito irado 8)
Mas fica ai registrada a tua dica, valeu.

Curiosidade: Aqui o meu tudo - http://ubuntuforum-br.org/index.php/topic,35209.0.html

Abraço e até mais.

Offline tfmoraes

  • Usuário Ubuntu
  • *
  • Mensagens: 444
    • Ver perfil
Re: Como inserir argumentos no wvdial? [Resolvido]
« Resposta #5 Online: 09 de Maio de 2008, 21:00 »
kErNeL_sCrIpT, tudo bem?
Eu acho que mesmo assim é melhor você usar o comando "pon.wvdial provedor" ao invés do "wvdial". No seu caso para finalizar a conexão, você matou o wvdial, se você usasse o pon.wvdial você usaria o comando poff para finalizar a conexão, que eu acho mais elegante, mas isto é só outra dica.

kErNeL_sCrIpT

  • Visitante
Re: Como inserir argumentos no wvdial? [Resolvido]
« Resposta #6 Online: 09 de Maio de 2008, 23:33 »
kErNeL_sCrIpT, tudo bem?
Eu acho que mesmo assim é melhor você usar o comando "pon.wvdial provedor" ao invés do "wvdial". No seu caso para finalizar a conexão, você matou o wvdial, se você usasse o pon.wvdial você usaria o comando poff para finalizar a conexão, que eu acho mais elegante, mas isto é só outra dica.

Tudo tranquilo tfmoraes.
Hmm, agora saquei, eu queria mesmo era fazer isso, finalizar a conexão ao invéz de matar o wvdial, só não sabia o comando. Obrigado novamente.



O comando pon.wvdial provedor não funcionou pra desconectar.
Já o comando poff sozinho funcionou.
Posso fazer assim?:

pon.wvdial provedor para conectar e poff para desconectar.

Se você considerar que ta beleza assim eu vou fazer a conexão e desconexão dessa forma e atualizar o meu tutorial.
« Última modificação: 10 de Maio de 2008, 00:04 por kErNeL_sCrIpT »

Offline tfmoraes

  • Usuário Ubuntu
  • *
  • Mensagens: 444
    • Ver perfil
Re: Como inserir argumentos no wvdial? [Resolvido]
« Resposta #7 Online: 10 de Maio de 2008, 16:56 »
kErNeL_sCrIpT,

Citar
pon.wvdial provedor para conectar e poff para desconectar.

É isto mesmo, eu uso deste modo para conectar.

kErNeL_sCrIpT

  • Visitante
Re: Como inserir argumentos no wvdial? [Resolvido]
« Resposta #8 Online: 10 de Maio de 2008, 17:54 »
kErNeL_sCrIpT,

Citar
pon.wvdial provedor para conectar e poff para desconectar.

É isto mesmo, eu uso deste modo para conectar.

Beleza, valeu, obrigado mais uma vez por mais essa dica.
Vou atualizar o meu tópico.

Abraço e até mais.

Offline prchakal

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Como inserir argumentos no wvdial? [Resolvido]
« Resposta #9 Online: 26 de Novembro de 2008, 05:05 »
Vamos lá galera(estou postando novamente pois ainda não resolvi - desculpe),

Acho que isso só da comigo, estou fazendo algo de errado, já li dezenas de tutoriais mas só acontece comigo.

Tenho um aiko76E e estou tentando fazer ele funfar do ubuntu.

Eu ponho o CD do ubuntu.

Ele inicia.

Abro o console, digito: sudo gedit

Colo as configurações no arquivo wvdial.conf:

[Dialer vivo]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 115200
New PPPD = yes
Modem = /dev/ttyUSB0
ISDN = 0
Phone = #777
Password = vivo
Username = XXXXXXXX@vivozap.com.br
Stupid Mode = 1

E salvo o arquivo.

No terminal digito:
modprobe usbserial vendor=0x19d2 product=0xfffe (sim, esses são so dados do meu modem)

No terminal digito:
sudo pon.wvdial vivo

Ai aparece:
ubuntu@ubuntu:~$ sudo pon.wvdial vivo
--> WvDial: Internet dialer version 1.60
ubuntu@ubuntu:~$ --> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Wed Nov 26 04:42:45 2008
--> Pid of pppd: 9895
--> Using interface ppp0
--> pppd: X[18]� �[15]�
--> pppd: X[18]� �[15]�
--> pppd: X[18]� �[15]�
--> pppd: X[18]� �[15]�
--> pppd: X[18]� �[15]�
--> local  IP address 200.220.229.253
--> pppd: X[18]� �[15]�
--> remote IP address 200.220.227.241
--> pppd: X[18]� �[15]�
--> primary   DNS address 200.220.227.100
--> pppd: X[18]� �[15]�
--> secondary DNS address 200.142.130.10
--> pppd: X[18]� �[15]�  ( <- última linha )

E fica nessa última linha ai parado.

E tento abrir algo no firefox, mas nada abre, (página não encontrada.).

Se alguém POR FAVOR puder me ajudar eu agradeço muito. Não sei mais o que fazer.