Autor Tópico: Ubuntuzilla - Usando sempre a última versão do Firefox  (Lida 77767 vezes)

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.493
    • Ver perfil
Ubuntuzilla - Usando sempre a última versão do Firefox
« Online: 21 de Setembro de 2007, 02:39 »
Eu não achei aqui nada sobre isso e resolvi postar.

Instalar "na mão" uma nova versão do Firefox não é algo simples, já que é preciso descompactar o pacote, copiá-lo para /opt e criar/substituir links. Mas, graças ao "ubuntuzilla", fica muito fácil manter o Firefox atualizado.

O "ubuntuzilla" é um script em python que possibilita a instalação automática (incluído o download) da última versão do Mozilla Firefox, do Mozilla SeaMonkey e do Mozilla Thunderbird no Ubuntu.

Basta o download do script no site do projeto (link no final do post) e um duplo clique para instalá-lo no Ubuntu via gdebi.

Depois, para instalar o Firefox, abra um terminal e digite:

Código: [Selecionar]
ubuntuzilla.py
O comando acima procura uma nova versão, faz o download  (checando as assinaturas) e instala preservando suas configurações (idioma, extensões, temas, favoritos etc.). Ele também permite a instalação de um "update manager" exclusivo para o Firefox.

E para instalar os demais softwares da Mozilla, os comandos são:

Código: [Selecionar]
ubuntuzilla.py -a install -p thunderbird
Código: [Selecionar]
ubuntuzilla.py -a install -p seamonkey
Em suma, é uma mão-na-roda esse script, pois ele permite até mesmo voltar para a versão original (leia-se a instalada pelo Ubuntu) do Firefox.

link do "ubuntuzilla": http://ubuntuzilla.wiki.sourceforge.net/

Aproveitem.
:: Linux Registered User nº 439378 ::

Offline felipeett

  • Usuário Ubuntu
  • *
  • Mensagens: 238
  • http://img534.imageshack.us/img534/3922/eorf.jpg
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #1 Online: 22 de Setembro de 2007, 01:30 »
nossaaa muito bom e facil
eu uso o ubuntu 6.06, e o unico jeito q eu sabia ateh agora d atualizar era ficar com as duas versoes
instaladas, entao eu optei por nao instalar.
Mas agora ta muito facil e rapido, e da pra ficar sempre com a versao mais atual do firefox
 :D

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.493
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #2 Online: 22 de Setembro de 2007, 01:53 »
O ubuntuzilla está servindo até para quem usa o Feisty (7.04). Com a chegada próxima do Gutsy (7.10), o pessoal da Canonical esqueceu do update do Firefox do começo da semana, de 2.0.0.6 para 2.0.0.7.

Eu já atualizei o meu aqui, até porque se trata de um "update de segurança".
:: Linux Registered User nº 439378 ::

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #3 Online: 22 de Setembro de 2007, 09:18 »
Testei no Firefox e funciou muito bem. Parabéns pinduvoz. Os problemas acabaram !!!

De outra forma sempre há a possibilidade de alguma coisa sair errada.
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline fabiovalinhos

  • Usuário Ubuntu
  • *
  • Mensagens: 439
  • Vire a direita..para Valinhos-SP! Arch user
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #4 Online: 22 de Setembro de 2007, 10:15 »
Legal pinduvoz, parabéns.

Já vi várias pessoas, assim como o felipe, com versões antigas do Ubuntu e querendo colocar a versão mais nova do Fire.
E como vc bem disse, nessas andanças pelo fórum, isso não é uma tarefa simples de se fazer.

Isso vai ser uma mão na roda.
7355
sudo dpkg no seu quadrado ...sudo dpkg no seu quadrado ...
http://www.youtube.com/watch?v=tHmrq0FtczM

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #5 Online: 22 de Setembro de 2007, 11:32 »
Olá pessoal,
Eu pensava que a atualização do Firefox era automática, principalmente as atualizações de segurança. Lembro-me que quando eu utilizava o Windows era, de vez em sempre pipocava na tela.
Citar
Basta o download do script no site do projeto (link no final do post) e um duplo clique para instalá-lo no Ubuntu via gdebi.
Galera, de ramis ramis (inglês) eu não manjo nada, sou completamente "narfa", da pra por o link direto? ;D ;D
Abraços

Offline Evaristo

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #6 Online: 22 de Setembro de 2007, 12:30 »
Pinduvoz,

vi o wiki, mas não tem prá swiftweasel, que também usa a máquina do FF. Alguma idéia??

Abraços

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.493
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #7 Online: 22 de Setembro de 2007, 16:14 »
Olá pessoal,
Eu pensava que a atualização do Firefox era automática, principalmente as atualizações de segurança. Lembro-me que quando eu utilizava o Windows era, de vez em sempre pipocava na tela.
Citar
Basta o download do script no site do projeto (link no final do post) e um duplo clique para instalá-lo no Ubuntu via gdebi.
Galera, de ramis ramis (inglês) eu não manjo nada, sou completamente "narfa", da pra por o link direto? ;D ;D
Abraços

Links diretos para o pacote:

Ubuntu 32:

http://downloads.sourceforge.net/ubuntuzilla/ubuntuzilla-4.4.3-0ubuntu1-i386.deb?modtime=1190161681&big_mirror=0

Ubuntu 64:

http://downloads.sourceforge.net/ubuntuzilla/ubuntuzilla-4.4.3-0ubuntu1-amd64.deb?modtime=1190161660&big_mirror=0
:: Linux Registered User nº 439378 ::

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.493
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #8 Online: 22 de Setembro de 2007, 16:18 »
Pinduvoz,

vi o wiki, mas não tem prá swiftweasel, que também usa a máquina do FF. Alguma idéia??

Abraços

O Swiftweasel é o Swiftfox "a la Debian", não é?

Use o Automatix2 para instalar o Swiftfox, já que ele sempre instala a última versão disponível.
:: Linux Registered User nº 439378 ::

Offline Werton Franca

  • Usuário Ubuntu
  • *
  • Mensagens: 34
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #9 Online: 22 de Setembro de 2007, 16:22 »
gostaria de saber por que não funciona o ajuda/procurar atualizações... ou mesmo de forma automática, como no windows, com pop-up e tudo

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.493
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #10 Online: 22 de Setembro de 2007, 16:31 »
gostaria de saber por que não funciona o ajuda/procurar atualizações... ou mesmo de forma automática, como no windows, com pop-up e tudo

Na versão do FF do Ubuntu isso vem desabilitado.

Agora, se vc. usar o ubuntuzilla e instalar a versão da Mozilla, funcionará se o Firefox for aberto com "root" para ter permissão de escrita no respectivo diretório.

Com a versão da Mozilla instalada, use o comando:

Código: [Selecionar]
gksudo firefox (não use "sudo", mas "gksudo")

e atualize o FF pelo menu "ajuda > procurar atualizações" como no Windows.
« Última modificação: 22 de Setembro de 2007, 17:28 por pinduvoz »
:: Linux Registered User nº 439378 ::

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #11 Online: 22 de Setembro de 2007, 16:49 »
Olá pinduvoz,

Quais seriam:
Citar
E para instalar os demais softwares da Mozilla, os comandos são:

Código:

ubuntuzilla.py -a install -p thunderbird


Código:

ubuntuzilla.py -a install -p seamonkey

Baixei conforme o link direto, brigadão, hehehe... ;D ;D ;D
Instalei somente o primeiro comando e ele me retornou:
Citar
Enter your choice of localization (integer, from 0 to 43): Dei-lhe o numero 43 e Y,Y...

Preciso instalar os outros????

Offline pinduvoz

  • Usuário Ubuntu
  • *
  • Mensagens: 2.493
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #12 Online: 22 de Setembro de 2007, 17:27 »
Amigo Nelson,

O "enter your choice of localization" é para escolher o idioma da interface. Se vc. quer usar pt_BR (acho que quer) tem que colocar o número que está ao lado de pt_BR na lista (eu não lembro qual é, mas basta ler com cuidado e colocar o correto).

O comando "ubuntuzilla.py", sem complementos, instala o Firefox.

O comando "ubuntuzilla.py -a install -p thunderbird" instala o Thunderbird, programa de correio eletrônico da Mozilla.

O comando "ubuntuzilla.py -a install -p seamonkey" instala o Seamonkey, um browser (navegador web) leve da Mozilla.

Depende da sua escolha instalar um ou outro.

E, se vc. errou no idioma ao instalar, remova e instale de novo, colocando o idioma ("localization") correto.

Os comandos para desinstalar são:

ubuntuzilla.py -a remove -p firefox
 
ubuntuzilla.py -a remove -p thunderbird
 
ubuntuzilla.py -a remove -p seamonkey

Como visto, basta trocar "install" por "remove", como no apt-get.

[].
:: Linux Registered User nº 439378 ::

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #13 Online: 22 de Setembro de 2007, 17:44 »
Valeu pinduvoz,
Parece que você sabia o que eu tinha feito quando passou a receitinha de bolo para corrigir.
Eu achava inglês difícil, precisava conhecer o japonês ou chinês, hehehe ;D ;D ;D ;D
Abraço

Offline silvadouglas

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
Re: Ubuntuzilla - Usando sempre a última versão do Firefox
« Resposta #14 Online: 14 de Julho de 2009, 17:35 »
Eu instalei a versão mais recente no site que é a 4.6.1 e ta dando vários erros na hora de instalar o Firefox 3.5.

Vou postar só uma parte aqui, pois o erro é muito "grande":

Citar
gpg: erro de comunicação com o keyserver: erro geral
gpg: Recebimento de informação do keyserver falhou: erro geral
gpg --keyserver pgpkeys.mit.edu --recv 0E3606D9 812347DD
Previous command has failed to complete successfully. Exiting.
Process returned code 2
Unable to retrieve Mozilla Software Releases Public key from pgpkeys.mit.edu . Trying again...
gpg: AVISO: permissões inseguras no arquivo de configuração:
`/home/douglas/.gnupg/gpg.conf'
gpg: chamadas de programas externos são desabilitadas devido a opções de permissões de arquivo nocivas
gpg: erro de comunicação com o keyserver: erro geral
gpg: Recebimento de informação do keyserver falhou: erro geral
gpg --keyserver pgp.mit.edu --recv 0E3606D9 812347DD
Previous command has failed to complete successfully. Exiting.
Process returned code 2
Unable to retrieve Mozilla Software Releases Public key from pgp.mit.edu . Trying again...
gpg: AVISO: permissões inseguras no arquivo de configuração:
`/home/douglas/.gnupg/gpg.conf'
gpg: chamadas de programas externos são desabilitadas devido a opções de permissões de arquivo nocivas
gpg: erro de comunicação com o keyserver: erro geral
gpg: Recebimento de informação do keyserver falhou: erro geral
gpg --keyserver wwwkeys.pgp.net --recv 0E3606D9 812347DD
Previous command has failed to complete successfully. Exiting.
Process returned code 2
Unable to retrieve Mozilla Software Releases Public key from wwwkeys.pgp.net . Trying again...
gpg: AVISO: permissões inseguras no arquivo de configuração:
`/home/douglas/.gnupg/gpg.conf'
gpg: chamadas de programas externos são desabilitadas devido a opções de permissões de arquivo nocivas
gpg: erro de comunicação com o keyserver: erro geral
gpg: Recebimento de informação do keyserver falhou: erro geral
gpg --keyserver keymaster.veridis.com --recv 0E3606D9 812347DD
Previous command has failed to complete successfully. Exiting.
Process returned code 2
Unable to retrieve Mozilla Software Releases Public key from keymaster.veridis.com . Trying again...
Failed to retrieve Mozilla Software Releases Public key from any of the listed keyservers. Please check your network connection, and try again later.

Poderiam me dar uma luz?

Obrigado