Autor Tópico: Agere com o driver agrsm já funcionando em Feisty  (Lida 8190 vezes)

Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Agere com o driver agrsm já funcionando em Feisty
« Online: 06 de Fevereiro de 2007, 21:39 »
Meu lspci aposta o seguinte resultado: Agere Systems: Unknown device 0620

Eu recebi o fonte do modem no cd de instalação, mas imagino que que só tem parte

dele, pois existe um arquivo agrmodemlib.o, o que já deve ser o modem compilado.
Bem, os arquivos que vem com o fonte para o SuSe são: agr_auxinst, agr_softmodem,

agrinst, agrmodem, agrmodemlib.o, agrsoftmodem.c, agruninst, LICENCE, linuxf.h,

Makefile, README e serial26.c

Vou postar o começo do comentário do arquivo agrsoftmodem.c

/**************************************************************
 * File: agrsoftmodem.c
 *
 * Copyright (c) 2002, 2003, 2004, 2005 Agere Systems, Inc.  All rights reserved.
 *
 * Description:
 *   Agere Soft Modem driver interface functions for Linux
 *
 * Revision History:
 *   Name                   Date          Change
 *   Soumyendu Sarkar       12/03/2002    Initial as agrmodem.c
 *   Soumyendu Sarkar       03/11/2004    Adapted to kernel 2.6.x with PCI support
 *   Soumyendu Sarkar       11/16/2005    Adapted to kernel 2.6.14 with PCI PP modem

support
 *   Anthony Cheng          12/20/2005    Add SuSE 9.2 kernal 2.6.8-24 support
 *************************************************************/
 
#define LUCENT_MODEM
#ifndef AGERE_SOFT_MODEM
#define AGERE_SOFT_MODEM
#endif

Isso não funciona no ubuntu, pois só é fornecido o driver para Fedora3, Fedora4,

Mandrake10.1, RedHat8, RedHat9, SuSe9.1 e SuSe9.2, obviamente o agrmodemlib.o

compilado para cada kernel de uma específica distribuição.

Tentei o tutorial para dapper, mas dá erro inserting kernel... quando executo o

comando modprobe ltserial

Tentei instalar o driver martian, embora sucesso na instalação e modprobe

martian_dev, mas quando executo o comando martian_modem aponta para o erro de

dispositivo não encontrado.

Acho que o jeito vai ser usar uma das distribuições: Fedora3, Fedora4, Mandrake10.1,

RedHat8, RedHat9, SuSe9.1 ou SuSe9.2 por que no ubuntu não tem jeito :(
« Última modificação: 07 de Agosto de 2007, 01:24 por hugleo »

Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Agere mais informações
« Resposta #1 Online: 13 de Maio de 2007, 17:23 »
Parece que agora esse modem pode funcionar com o driver agrsm-alpha.tar.bz2
Legal, amanhã vou testar!

Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Agere mais informações
« Resposta #2 Online: 14 de Maio de 2007, 14:08 »
Consegui compialr e instalar e no modprob dá tudo ok, mas por que não detecta meu modem?

Offline cbridi

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Agere mais informações
« Resposta #3 Online: 14 de Maio de 2007, 23:26 »
Oi,
Tenho o mesmo modem, o lspci mostra o mesmo resultado, e tbem estou com problemas na instalação no Ubuntu 7.04, vc poderia passar o passos que usou para compilar o driver?
Baixei o agrsm-alpha.tar.bz2 mas não consigo rodar o make (sou novato nesse mundo...). Primeiro tentei:

Código: [Selecionar]
# sudo make module
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/xxxx/Desktop/agrsm modules
make: *** /lib/modules/2.6.20-15-386/build: Arquivo ou diretório inexistente.  Pare.
make: ** [module] Erro 2

Bom, pareceu-me que faltava o diretório build, então criei-o, passou a retornar o seguinte:

Código: [Selecionar]
# sudo make module
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/xxxx/Desktop/agrsm modules
make[1]: Entrando no diretório `/lib/modules/2.6.20-15-386/build'
make[1]: *** Sem regra para processar o alvo `modules'.  Pare.
make[1]: Saindo do diretório `/lib/modules/2.6.20-15-386/build'
make: ** [module] Erro 2

E então? O que faço?

[]'s agradecido por qquer sugestão

Bridi
Bridi
Acer 5630-6091 Intel(R) Core(TM)2 CPU T5500  @ 1.66GHz / HD 160GB / 2GB RAM
Dell Optiflex 745 Intel(R) Core(TM)2 CPU 4300  @ 1.80GHz / HD 80GB / 1GB RAM

Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Agere mais informações
« Resposta #4 Online: 15 de Maio de 2007, 19:10 »
Não sei se funciona nessa versão, eu só testei no Dapper.

Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Agere mais informações
« Resposta #5 Online: 17 de Maio de 2007, 00:34 »
Acho que já descobri o seu erro:
Instale os compiladores gcc e seus utilitários e também o source do kernel. Já tem tópicos aqui no fórum ensinando isso, mas é só usar seu gerenciador de pacotes. Esses arquivos já vem com o CD do ubuntu mas não são instalados por padrão.


Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Agere mais informações
« Resposta #6 Online: 07 de Julho de 2007, 15:34 »
Finalmente consegui usar esse modem.
Por enquanto só tentei no Dapper, quando chegar meu Ubuntu 7.04 eu tento.

Offline cbridi

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Agere mais informações
« Resposta #7 Online: 08 de Julho de 2007, 23:37 »
Blz! Eu deixei isso de lado por enquanto... qdo sobrar um tempo voltarei a carga...

[]'s
Bridi
Acer 5630-6091 Intel(R) Core(TM)2 CPU T5500  @ 1.66GHz / HD 160GB / 2GB RAM
Dell Optiflex 745 Intel(R) Core(TM)2 CPU 4300  @ 1.80GHz / HD 80GB / 1GB RAM

Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Agere mais informações
« Resposta #8 Online: 07 de Agosto de 2007, 01:23 »
Esse modem já está funcionando no Feisty.

Baixe e execute o script http://linmodems.technion.ac.il/packages/scanModem.gz
pra ver se seu modem é compatível.

Instruções de uso estão em: http://linmodems.technion.ac.il/

Leia o arquivo ModemData.txt  e veja se seu driver é o agrsm.


Se a resposta for sim, baixe um dos pacotes:

http://linmodems.technion.ac.il/packages/ltmodem/kernel-2.6/agrsm-20070804.tar.gz
http://linmodems.technion.ac.il/packages/ltmodem/kernel-2.6/agrsm-ubuntu-2.6.20-16-generic.tar.gz


As versões mais atuais podem ser encontradas em:

http://linmodems.technion.ac.il/packages/ltmodem/kernel-2.6/

Mais informações podem ser encontradas em:

http://linmodems.technion.ac.il/bigarch/archive-seventh/msg01908.html



Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil