Autor Tópico: HDMI  (Lida 26579 vezes)

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
HDMI
« Online: 08 de Novembro de 2012, 18:48 »
Galera, como faço pra reconhecer minha conexão HDMI com Vídeo e Som.?

Offline BrunoCarvalho

  • Usuário Ubuntu
  • *
  • Mensagens: 101
  • Sempre Aprendendo!!!!!!
    • Ver perfil
Re: HDMI
« Resposta #1 Online: 08 de Novembro de 2012, 22:04 »
Qual versão que vc esta usando? Qual Kernel?

No Ubuntu pra reconhecer de boa, conecte o cabo HDMI e reinicie o pc, logo que ele ligar ele vai funcionar com o Desktop extendido, o audio tem que mudar manualmente, nas configurações de som, so colocar o audio hdmi que funciona tudo normal.

Ja nos kernel atual, resolveram o problema parcialmente, não precisa mais reinicia o pc para reconhecer o audio.

Mas o melhor seria, se reconhece igual o Windows, aqui pelo menos o audio e video espelhado reconhece na hora, no Ubuntu ainda não consegui espelha o desktop

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: HDMI
« Resposta #2 Online: 08 de Novembro de 2012, 22:21 »
Ubuntu 12.04 Kernel 3.2 O Áudio HDMI não aparece nas configurações de Som... Será que se reiniciar reconhece.?

Offline BrunoCarvalho

  • Usuário Ubuntu
  • *
  • Mensagens: 101
  • Sempre Aprendendo!!!!!!
    • Ver perfil
Re: HDMI
« Resposta #3 Online: 08 de Novembro de 2012, 23:03 »
Na 3.2 so reiniciando

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: HDMI
« Resposta #4 Online: 08 de Novembro de 2012, 23:06 »
Beleza, ah, de fato eu poderia conectar o HDMI e depois ligar o notebook..?

Offline Sergio Benjamim

  • Usuário Ubuntu
  • *
  • Mensagens: 2.902
    • Ver perfil
Re: HDMI
« Resposta #5 Online: 09 de Novembro de 2012, 00:15 »
Arthur, por que vc não atualiza o kernel do 12.04 para o kernel do Quantal? Eu estou rodando o kernel 3.5 aqui no Precise.
É novo no Ubuntu? Já leu o Ubuntu – Guia do Iniciante 2.0 ?
Experimente o Xubuntu 14.04 !

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: HDMI
« Resposta #6 Online: 09 de Novembro de 2012, 09:38 »
Ubuntu 12.04 Kernel 3.2 O Áudio HDMI não aparece nas configurações de Som...

Ola

Só uma pequena observação:

Já tive este mesmo problema no ubuntu 9, e um dos fatores que impediam o som de funcionar era o cabo HDMI.

Comprei um cabo genérico e este não "passava" o som. Ao trocar o cabo por um certificado o processo se normalizou depois de uma longa configuração do sistema.

Fica o registro e este link, que talvez ajude => http://eudennis.tumblr.com/post/18214193469/atalho-para-ativar-desativar-som-hdmi-no-ubuntu

[]'s

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: HDMI
« Resposta #7 Online: 09 de Novembro de 2012, 13:01 »
Valeu Tota... Obrigado pela ajuda.  :)
Mas quando executo o comando xrandr para identificar o HDMI, ele me reporta isso:
Código: [Selecionar]
arthur@Arthur:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 175, current 1366 x 768, maximum 1366 x 768
default connected 1366x768+0+0 0mm x 0mm
   1366x768       50.0*
   1024x768       51.0     52.0 
   960x540        53.0 
   840x525        54.0 
   832x624        55.0 
   800x600        56.0     57.0     58.0     59.0     60.0 
   800x512        61.0 
   720x450        62.0 
   720x400        63.0 
   700x525        64.0 
   680x384        65.0     66.0 
   640x512        67.0     68.0 
   640x480        69.0     70.0     71.0     72.0     73.0 
   640x400        74.0 
   640x350        75.0 
   576x432        76.0     77.0     78.0     79.0     80.0     81.0 
   512x384        82.0     83.0     84.0     85.0     86.0 
   416x312        87.0 
   400x300        88.0     89.0     90.0     91.0     92.0 
   360x200        93.0 
   320x240        94.0     95.0     96.0     97.0 
   320x200        98.0 
   320x175        99.0 
« Última modificação: 09 de Novembro de 2012, 13:02 por Arthur Bernardes »

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: HDMI
« Resposta #8 Online: 13 de Novembro de 2012, 16:50 »
Parece que ele não me reconhece o vídeo HDMI...

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: HDMI
« Resposta #9 Online: 13 de Novembro de 2012, 16:52 »
Arthur, por que vc não atualiza o kernel do 12.04 para o kernel do Quantal? Eu estou rodando o kernel 3.5 aqui no Precise.

Ah Sergio, eu não gosto muito de atualizar o kernel, para mim ficar no kernel original da versão me dá mais desempenho e satisfação..!  :)

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: HDMI
« Resposta #10 Online: 14 de Novembro de 2012, 00:38 »
Qual o resultado destes comandos?

lspci | grep HDMI

dmesg | grep HDMI

« Última modificação: 14 de Novembro de 2012, 00:43 por Xterminator »

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: HDMI
« Resposta #11 Online: 14 de Novembro de 2012, 13:06 »
Qual o resultado destes comandos?

lspci | grep HDMI

dmesg | grep HDMI



Eles não me reportam nenhuma saída...!

Código: [Selecionar]
lspci | grep HDMI
Código: [Selecionar]
dmesg | grep HDMI

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: HDMI
« Resposta #12 Online: 23 de Novembro de 2012, 10:05 »
Olá desculpe na demora em responder, sabe como é feriado prolongado :-), é estranho estes comandos não retornarem nada.
Aí teriamos que achar um bom samaritano com a máquina igual a sua para que veja se os comandos retornam algo.
Eu entrei de gaiato no tópico, nem tinha percebido que estava em Notebooks e Handhelds, eu tenho um Desktop com placa mãe ASUS M2N68-AM SE2 e utilizo uma placa offboard, Sapphire Radeon HD 6670 no qual o HDMI funciona sem problemas desde versões anteriores do kernel, sem a necessidade de procedimento extra algum, seja com o driver proprietário instalado ou não, basta eu ligar a TV que, automáticamente o som e enviado para ela, esta placa possui 3 portas 1 VGA 1 DVI e 1 HDMI, sendo que utilizo a DVI para meu Monitor e deixo um cabo p2 ligado direto no Home Theater para ouvir o som do micro, e o HDMI deixo para a TV que só utilizo quando vou assistir filmes ou ver video clipes direto do micro que neste caso o som e enviado direto da TV para para o HT que tem tecnologia ARC (Audio Return Channel).

Você poderia passar todas informações do seu hardware?
assim quem sabe outra pessoa pode ter hardware igual e alguma dica extra para sanar seu problema.
Eis um screenshot das propriedades de som com o audio HDMI em funcionamento.



Infelizmente o note da minha patrõa esta longe, e logo não posso fazer os devidos testes, para ver se o mesmo problema ocorre.
Você pode tentar mais este comando.

Código: [Selecionar]
dmesg | grep audio
« Última modificação: 23 de Novembro de 2012, 10:16 por Xterminator »

Offline Arthur Bernardes

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re: HDMI
« Resposta #13 Online: 23 de Novembro de 2012, 11:54 »
Eles não reportam nada..! Com o VLC eu consegui usar a HDMI, mas não consigo alterar pelo gerenciador de Som do Ubuntu..  :-\

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: HDMI
« Resposta #14 Online: 23 de Novembro de 2012, 23:31 »
Código: [Selecionar]
lspci | grep HDMI
02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Turks/Whistler HDMI Audio [Radeon HD 6000 Series]

Código: [Selecionar]
dmesg | grep HDMI
[   15.452044] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:09.0/0000:02:00.1/sound/card1/input9

Só me confundi no último comando que seria dmesg | grep sound e não audio infelizmente as vezes a cabeça falha.

Código: [Selecionar]
dmesg | grep sound
[   15.446188] input: HDA NVidia Line as /devices/pci0000:00/0000:00:05.0/sound/card0/input4
[   15.446257] input: HDA NVidia Front Mic as /devices/pci0000:00/0000:00:05.0/sound/card0/input5
[   15.446299] input: HDA NVidia Rear Mic as /devices/pci0000:00/0000:00:05.0/sound/card0/input6
[   15.446338] input: HDA NVidia Front Headphone as /devices/pci0000:00/0000:00:05.0/sound/card0/input7
[   15.446376] input: HDA NVidia Line Out as /devices/pci0000:00/0000:00:05.0/sound/card0/input8
[   15.452044] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:09.0/0000:02:00.1/sound/card1/input9