Autor Tópico: [Resolvido] instalação do Modem ONDA : MSA 14.4 da Tim  (Lida 17473 vezes)

Offline marcelmsoares01

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
    • http://br.geocities.com/omundolinux
Re: instalação do Modem ONDA : MSA 14.4 da Tim
« Resposta #15 Online: 05 de Setembro de 2012, 08:48 »
 :D  Olá Camaradas do Linux. Estou reportando os acontecimento com relação a conexão do modem onda 14.4.
Para começar, fiquem sabendo que estou enviando esta mensagem com a internet proveniente dele, o que significa que ele agora está funcionando  corretamente, apesar da lentidão  das conexões TIM.

Segui de perto as instruções que foram dadas por nosso amigo Luis Fernando, consultando o site que ele me indicou ( http://www.ubuntero.com.br/2011/06/modem-onda-msa190up-no-ubuntu-natty-11-04/). Acabei inserindo dois arquivos:

1) /etc/usb_modeswitch.d/1ee8:0060

com a seguinte instrução, já citada pelo Luis:

Citar
###################
# Onda MSA 14.4 (TIM Brasil)

DefaultVendor = 0x1ee8
DefaultProduct = 0x0060
MessageEndpoint = 0x01
MessageContent="555342431849128600000000000008ff000000000000030000000000000000"

2) /etc/udev/rules.d/77-mm-zte-port-types.rules

Com as intruções citadas no site. Observem a modificação (em vermelho)  que se refere ao código do vendedor.

Citar
ACTION!="add|change", GOTO="mm_zte_port_types_end"
SUBSYSTEM!="tty", GOTO="mm_zte_port_types_end"
 
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1ee8", GOTO="mm_zte_port_types_vendorcheck"
GOTO="mm_zte_port_types_end"
 
LABEL="mm_zte_port_types_vendorcheck"
SUBSYSTEMS=="usb", ATTRS{bInterfaceNumber}=="?*", ENV{.MM_USBIFNUM}="$attr{bInterfaceNumber}"
 
ATTRS{idProduct}=="0091", ENV{.MM_USBIFNUM}=="04", ENV{ID_MM_ZTE_PORT_TYPE_MODEM}="1"
ATTRS{idProduct}=="0091", ENV{.MM_USBIFNUM}=="01", ENV{ID_MM_ZTE_PORT_TYPE_AUX}="1"
 
LABEL="mm_zte_port_types_end"

Após isto, conectei o modem, desconectei minha internet de fio e do  wireless e prossegui com as instruções do site, criando uma nova conexão como indicado.

Agora está tudo OK com o modem e estou pronto para a próxima.

Um abraço.

Senhores, bom dia.

Ontem (04/09/2012), comprei um modem Onde MSA 14.4 da Tim em uma loja dentro do Shopping Iguatemi - Salvador. Assim que cheguei, perguntei ao vendedor se o modem funcionava no Linux e a resposta foi não, mas ainda assim comprei. Conectei pelo meu celular (Nokia 5800) e em uma breve pesquisa no Google sobre o suporte desse modem no Ubuntu e localizei esse tópico. Segui à risca as dicas desse post citado, mas a princípio não funcionou. No entanto, ao dar o comando "lsusb" eu observei que o meu modem era reconhecido, mas faltava alguma coisa.

Foi então que eu segui a dica desse site, o qual também foi citado nessa postagem do Nolano: "Luis Fernando, consultando o site que ele me indicou (http://www.ubuntero.com.br/2011/06/modem-onda-msa190up-no-ubuntu-natty-11-04/)" apenas substituindo na configuração original o 1ee8 e após reiniciar o meu note o modem foi reconhecido, daí foi só seguir os passos de configuração de uma nova conexão e tudo funcionou muito bem.

Muito obrigado a todos você que contribuem com suas descobertas, tornando foruns como esse um verdadeiro refúgio.
Abraços a todos

Marcelo M. Soares
http://br.geocities.com/omundolinux

Offline FasFerrari

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: [Resolvido] instalação do Modem ONDA : MSA 14.4 da Tim
« Resposta #16 Online: 12 de Setembro de 2012, 21:36 »
Descobri a solução para o ubuntu 12.04 para o modelo MSA 14.4. Para mim deu certo pelo menos. Todos os passos estão certos até aqui porém é preciso uma última linha de comando
sudo /usr/sbin/usb_modeswitch -v -0x1ee8 -p 0x0060 -V 0x1ee8 -P 0x0091 -m 0x01 -M 555342431849128600000000000008ff000000000000030000000000000000

na verdade é uma função de três dicas desta mesma, da ( http://www.ubuntero.com.br/2011/06/modem-onda-msa190up-no-ubuntu-natty-11-04/) e da (http://ubuntuforum-pt.org/index.php?topic=46242.0).

Offline marcelodive

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: [Resolvido] instalação do Modem ONDA : MSA 14.4 da Tim
« Resposta #17 Online: 17 de Novembro de 2012, 02:26 »
Descobri a solução para o ubuntu 12.04 para o modelo MSA 14.4. Para mim deu certo pelo menos. Todos os passos estão certos até aqui porém é preciso uma última linha de comando
sudo /usr/sbin/usb_modeswitch -v -0x1ee8 -p 0x0060 -V 0x1ee8 -P 0x0091 -m 0x01 -M 555342431849128600000000000008ff000000000000030000000000000000

na verdade é uma função de três dicas desta mesma, da ( http://www.ubuntero.com.br/2011/06/modem-onda-msa190up-no-ubuntu-natty-11-04/) e da (http://ubuntuforum-pt.org/index.php?topic=46242.0).

Perdi um dia da minha vida por causa daquele "-" incorreto que você colocou na sua linha de comando, mas, mesmo assim, muito obrigado, pois se não fosse por isso, não teria conseguido fazer minha internet funcionar.  ;D

Enfim, abaixo o código correto:

$ sudo /usr/sbin/usb_modeswitch -v 0x1ee8 -p 0x0060 -V 0x1ee8 -P 0x0091 -m 0x01 -M 555342431849128600000000000008ff000000000000030000000000000000