Fórum Ubuntu Linux - PT
17 de Setembro de 2014, 14:32 *
Olá, Visitante. Faça o login ou registre-se.
Perdeu o seu e-mail de ativação?

Login com nome de usuário, senha e duração da sessão
Notícias: Sejam todos bem-vindos e fiquem atentos às regras de utilização do fórum e política de privacidade.
 
   Home   Ajuda Regras Pesquisa Login Registre-se  
Anúncios
Páginas: [1] 2   Ir para o fundo
  Imprimir  
Autor Tópico: Porque o java não vem junto com a instalação padrão?  (Lida 2014 vezes)
Nodles
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 3


Ver Perfil
« em: 19 de Maio de 2012, 15:10 »

Olá amigos. Sou usuário Linux a menos de um mês. Passei por outra distro que era muito instável e agora migrei para o Ubuntu, que até o momento tem atendido a maioria das minhas necessidades.

Bom, a dúvida já foi colocada: Porque o Java não vem junto com a instalação padrão, ou não tem uma maneira um pouco mais simples de instalar?

Assim que instalei o Ubuntu 12.04 já fui à central de programas e instalei o OpenJDK 7. Porém quando tentei acessar o site do Banco do Brasil não deu certo. Depois instalei o pacote da Oracle via terminal e neste momento ainda estou procurando a solução...

Enfim, era isso. Peço desculpas caso tenha dito alguma besteira, mas ainda existe uma névoa a respeito desse novo sistema, acredito que todo iniciante deve passar por situação semelhante.

Obrigado  Sorridente
« Última modificação: 19 de Maio de 2012, 18:57 por Nodles » Registrado
Diego.felipem
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 19



Ver Perfil
« Responder #1 em: 19 de Maio de 2012, 15:14 »

Instale o plugin Icedtea que funciona normalmente 
Código:
sudo apt-get install icedtea-plugin
Registrado
Nodles
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 3


Ver Perfil
« Responder #2 em: 19 de Maio de 2012, 15:22 »

Valeu, Diego, sua dica resolveu o meu problema!

Mas ainda fica a curiosidade, pq essas coisas já não vem de uma forma mais acessível?  Sem Graça
Registrado
Adriano R.N.
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 1.068



Ver Perfil
« Responder #3 em: 19 de Maio de 2012, 15:42 »

Simples... licenças proprietárias são restritivas, a Canonical não pode colocar por padrão software proprietário.
Registrado

Boa sorte e Muito AXÉ!!!
Ioca100
Equipe Ubuntu
Usuário Ubuntu
*****
Deslogado Deslogado

Mensagens: 2.854

Rio,Brasil


Ver Perfil
« Responder #4 em: 19 de Maio de 2012, 16:13 »

Agora mesmo estive na casa de uma amiga com Ubuntu 10.04 e o Chrome não estava instalando o Guardião 30hs do Itau, ela tinha o java da Oracle desatualizado, bastou instalar a nova versão.
Em atenção ao colega, existe um pacote com os codecs, plugins,fontes MS , Java(Open) etc. proprietários , pela central de programas Ubuntu-Restricted- Extras.
Registrado

Usuário Linux- 449417
Adriano R.N.
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 1.068



Ver Perfil
« Responder #5 em: 19 de Maio de 2012, 16:19 »

A partir do momento que nós buscamos o ubuntu-restricted estamos assumindo que vamos usar plugins, codecs e fontes proprietárias, agora vir por padrão é bem diferente, no caso do Brasil não haveria problemas, nos eua a Canonical teria sérios problemas.
Essa restrição acontece no ubuntu, suse, fedora, madriva...
Registrado

Boa sorte e Muito AXÉ!!!
Nodles
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 3


Ver Perfil
« Responder #6 em: 19 de Maio de 2012, 18:56 »

Imaginei que fosse ao relacionado a isso mesmo.

Também não sabia desse atalho dos plugins proprietários. Coisa de iniciante mesmo... Obrigado =]
Registrado
EdvaldoSCruz
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 2.240


Viva o Ubuntu !!! (iMAC Apple e Notebook Dell)


Ver Perfil WWW
« Responder #7 em: 20 de Maio de 2012, 08:09 »

34) Saibam o porque instalar o Oracle Java e não o OpenJDK

Espero que supra as suas necessidades.

Observação: caso tenha resolvido, não esqueça de colocar no seu tópico "Resolvido" e como você resolveu, para que todos que tenham o mesmo problema nesse excelente Fórum Ubuntu, solucionem também. A comunidade agradece

  Viva o Ubuntu !!!!!!!  Contente


e vamos que vamos.
Registrado

Jesus Cristo está voltando(Ap.1:7). PREPARE-SE !!!!!!! Meu JESUS CRISTO, tenhas misericórdia dessas Almas Viventes também *IPDA*
Para os Iniciantes, como eu, links de solucionar problemas rapidamente.
Lídia
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 47


Ver Perfil
« Responder #8 em: 04 de Junho de 2012, 17:52 »

O meu Note, está avisando que há uma atualização a ser feita conforme o meu "Gerenciador de atualizações" e um dos programas que consta na lista é o Oracle - Jave 7- Installer, porém eu estou receosa de fazer essa atualização porque no momento, eu estou conseguindo acessar a minha conta do Banco do Brasil, depois de ficar alguns meses sem conseguir acessar. De repente, começou a funcionar de novo e eu acho melhor não mexer. Alguém tem alguma sugestão a fazer? Tenho o Ubuntu 10.04 e Firefox 12.0.
P.S.: Não entendo, praticamente, nada de Ubuntu.

Grata
Registrado
Lídia
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 47


Ver Perfil
« Responder #9 em: 04 de Junho de 2012, 18:10 »

O meu pedido de sugestão  é pra saber se devo ou não fazer a atualização. O problema é que eu não posso ficar sem acessar a minha conta do banco porque eu comprei esse Notebook, exclusivamente, pela razão de poder acessar o banco em um ambiente seguro que é opensource e não vou, em hipótese alguma, acessar o meu banco pelo Windows do meu desktop. Eu não entendi o que ocorreu. De repente, apareceu um aviso na tela, há mais ou menos 15 dias, de que o problema do módulo de segurança do banco havia sido resolvida e resolveu e funcionou 3 dias até que parou de novo. Depois que eu atualizei o Firefox para a versão 12, consegui acessar o meu banco de novo. Achei que o sistema havia instalado o Oracle Jave 7 automaticamente, mas vejo agora, que não foi isso o que ocorreu, senão, ele não estaria listado no Gerenciador de atualizações para fazer atualização. Alguém sabe porque essas coisas aconteceram?
Registrado
eliseu_carvalho
Visitante
« Responder #10 em: 04 de Junho de 2012, 18:16 »

O meu Note, está avisando que há uma atualização a ser feita conforme o meu "Gerenciador de atualizações" e um dos programas que consta na lista é o Oracle - Jave 7- Installer, porém eu estou receosa de fazer essa atualização porque no momento, eu estou conseguindo acessar a minha conta do Banco do Brasil, depois de ficar alguns meses sem conseguir acessar. De repente, começou a funcionar de novo e eu acho melhor não mexer. Alguém tem alguma sugestão a fazer? Tenho o Ubuntu 10.04 e Firefox 12.0.
P.S.: Não entendo, praticamente, nada de Ubuntu.

Grata


O meu pedido de sugestão  é pra saber se devo ou não fazer a atualização. O problema é que eu não posso ficar sem acessar a minha conta do banco porque eu comprei esse Notebook, exclusivamente, pela razão de poder acessar o banco em um ambiente seguro que é opensource e não vou, em hipótese alguma, acessar o meu banco pelo Windows do meu desktop. Eu não entendi o que ocorreu. De repente, apareceu um aviso na tela, há mais ou menos 15 dias, de que o problema do módulo de segurança do banco havia sido resolvida e resolveu e funcionou 3 dias até que parou de novo. Depois que eu atualizei o Firefox para a versão 12, consegui acessar o meu banco de novo. Achei que o sistema havia instalado o Oracle Jave 7 automaticamente, mas vejo agora, que não foi isso o que ocorreu, senão, ele não estaria listado no Gerenciador de atualizações para fazer atualização. Alguém sabe porque essas coisas aconteceram?


Pode instalar o Oracle Java 7 sem medo. Inclusive os sites do BB e do Santander (não sei se a tua conta é em algum desses bancos) funcionam muito melhor com ele.
Registrado
danilonil
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 6



Ver Perfil
« Responder #11 em: 09 de Julho de 2012, 00:04 »

Olá,galera!

Seguindo o tuto do Edvaldo, a instalação me mostra o seguinte erro:

"Alguns arquivos index falharam ao ser baixados. Eles foram ignorados, ou cópias antigas são usadas ao invés."

e esse logo após o segundo comando:


Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Note, a seleccionar 'oracle-java7-installer' em vez de 'openjdk-7-jre-headless'
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 oracle-java7-installer : Depende: java-common (>= 0.24) mas não é instalável
                          Recomenda: gsfonts-x11 mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Alguém sabe o motivo? T.T
Registrado

geek's life mode: on
jkmsjq
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 2.988


Ubuntu Member


Ver Perfil
« Responder #12 em: 09 de Julho de 2012, 18:14 »

Existe uma solução extremamente simples para esse impasse de direitos de uso que é a utilização do Ubuntu Business Remix.

Basta um simples cadastro no site da Canonical (nada de mais...!!!  Contente), fazer o download, instalar um Live Pendrive, instalar, atualizar e terá todos os plugins, drivers e codecs instalados sem complicação e nem problema nenhum.

Tenho essa versão instalada no meu PC e notebook e não tenho nenhum problema em relação a essas "pendengas" que normalmente se tem no Ubuntu. E além disso, é muito mais leve de se usar e consome muito menos recursos, só de não ter o Ubuntu One e rede sociais instalado por padrão, para mim, já é uma enorme vantagem.
Registrado

LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz
Beto Pinheiro
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 135


Agora com avatar! he he!


Ver Perfil
« Responder #13 em: 09 de Julho de 2012, 18:37 »

Olá,galera!

Seguindo o tuto do Edvaldo, a instalação me mostra o seguinte erro:

"Alguns arquivos index falharam ao ser baixados. Eles foram ignorados, ou cópias antigas são usadas ao invés."

e esse logo após o segundo comando:

Tente assim:

sudo add-apt-repository ppa:webupd8team/java
 
Onde será adicionado no repositório ppa
 
em seguida:
 
sudo apt-get update
 
irá baixar as atualizações
 
em seguida:
 
sudo apt-get install oracle-java7-installer  
 
Registrado

"O problema com o mundo é que as pessoas inteligentes estão cheias de dúvidas, enquanto os estúpidos estão cheios de confiança."

Charles Bukowski
danilonil
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 6



Ver Perfil
« Responder #14 em: 11 de Julho de 2012, 13:10 »

Olá, Beto Pinheiro!

Segue o erro encontrado quando tentei instalar o repositório que vc passou:

"E: Alguns arquivos index falharam ao ser baixados. Eles foram ignorados, ou cópias antigas são usadas ao invés."

E a seguir vem o outro erro após tentar instalar com o segundo comando:

"Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 oracle-java7-installer : Depende: java-common (>= 0.24) mas não é instalável
                          Recomenda: gsfonts-x11 mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados."

Não sei se são pacotes que faltam ou arquivos, mas o sistema tá do jeito que baixei no site. Usei um LiveCD para fazer a instalação.

o.o
Registrado

geek's life mode: on
Páginas: [1] 2   Ir para o topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Tema desenvolvido por FaBMak e n3t0
Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines
© 2014 Canonical Ltd. Ubuntu e Canonical são marcas registradas da Canonical Ltd.
XHTML 1.0 válido! CSS válido!