Fórum Ubuntu Linux - PT
23 de Novembro de 2014, 03:41 *
Olá, Visitante. Faça o login ou registre-se.
Perdeu o seu e-mail de ativação?

Login com nome de usuário, senha e duração da sessão
Notícias: Atenção usuários de email com anti-spam (Uol e Bol).
 
   Home   Ajuda Regras Pesquisa Login Registre-se  
Anúncios
Páginas: [1]   Ir para o fundo
  Imprimir  
Autor Tópico: Remover o navegador Chromium sem instalar nada no lugar  (Lida 1942 vezes)
Chernobyl_User
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 132


ChNPP RBMK-1000


Ver Perfil
« em: 05 de Janeiro de 2012, 04:47 »

ola a todos, instalei o chromium-browser para fazer uns testes e agora eu quero removê-lo, o problema é que ao marcar o software para remoção o firefox é instalado no lugar, sendo que eu uso o google chrome como navegador padrão, o pior é que se eu remover tudo e instalar o firefox e depois mandar removê-lo, ele manda instalar o rekonq, que é pior ainda (pois manda um monte de qt's).

deu de ver que o sistema não quer que eu fique sem um navegador, mas dai, onde esta minha liberdade de usar somente o google chrome, sem nenhum outro navegador instalado? já que o firefox é obrigatoriamente marcado para a instalação, mesmo eu tendo o google chrome?

cenário em questão:

mandando remover o chromium-browser

Citar
lessandro@aspire-5551:~$ sudo apt-get remove --purge chromium-browser
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os pacotes extra a seguir serão instalados:
  firefox
Pacotes sugeridos:
  firefox-gnome-support firefox-kde-support latex-xft-fonts
Pacotes recomendados:
  ubufox firefox-globalmenu
Os pacotes a seguir serão REMOVIDOS:
  chromium-browser* chromium-codecs-ffmpeg*
Os NOVOS pacotes a seguir serão instalados:
  firefox
0 pacotes atualizados, 1 pacotes novos instalados, 2 a serem removidos e 0 não atualizados.
É preciso baixar 0 B/15,2 MB de arquivos.
Depois desta operação, 35,7 MB de espaço em disco serão liberados.
Você quer continuar [S/n]? s
Selecionando pacote previamente não selecionado firefox.
(Lendo banco de dados ... 93494 ficheiros e directórios actualmente instalados.)
Desempacotando firefox (de .../firefox_8.0+build1-0ubuntu0.11.04.3_i386.deb) ...
Processando gatilhos para man-db ...
Processando gatilhos para python-gmenu ...
Rebuilding /usr/share/applications/desktop.pt_BR.utf8.cache...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para python-support ...
Configurando firefox (8.0+build1-0ubuntu0.11.04.3) ...
Please restart all running instances of firefox, or you will experience problems.
(Lendo banco de dados ... 93587 ficheiros e directórios actualmente instalados.)
Removendo chromium-browser ...
Expurgando arquivos de configuração de chromium-browser ...
Removendo chromium-codecs-ffmpeg ...
dpkg: aviso: ao remover chromium-codecs-ffmpeg, o directório '/usr/lib/chromium-browser' não estava vazio, por isso não foi removido.
Processando gatilhos para hicolor-icon-theme ...
Processando gatilhos para python-gmenu ...
Rebuilding /usr/share/applications/desktop.pt_BR.utf8.cache...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para man-db ...
Processando gatilhos para python-support ...

removendo o firefox

Citar
alessandro@aspire-5551:~$ sudo apt-get remove --purge firefox
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os pacotes extra a seguir serão instalados:
  docbook-xsl kdebase-bin kdebase-data kdebase-runtime kdebase-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools libattica0 libclucene0ldbl
  libdbusmenu-qt2 libgif4 libilmbase6 libiodbc2 libkatepartinterfaces4 libkcmutils4 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4
  libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4
  libktexteditor4 libnepomuk4 libnepomukquery4a libnepomukutils4 libntrack-qt4-1 libntrack0 libopenexr6 libplasma3 libpolkit-qt-1-1 libqca2 libqt4-declarative
  libqt4-script libqt4-sql libqt4-svg libqt4-xmlpatterns libsolid4 libsoprano4 libssh-4 libstreamanalyzer0 libstreams0 libthreadweaver4 libutempter0 libxml2-utils
  ntrack-module-libnl-0 oxygen-icon-theme plasma-scriptengine-declarative plasma-scriptengine-javascript rekonq shared-desktop-ontologies soprano-daemon
Pacotes sugeridos:
  docbook-xsl-doc-html docbook-xsl-doc-pdf docbook-xsl-doc-text docbook-xsl-doc libsaxon-java libxalan2-java docbook-xsl-saxon fop xalan dbtoepub djvulibre-bin hspell
  libqca2-plugin-cyrus-sasl libqca2-plugin-gnupg libqca2-plugin-ossl libqca2-plugin-pkcs11 libqt4-dev kget
Pacotes recomendados:
  virtuoso-minimal kubuntu-debug-installer icoutils libqt4-sql-mysql libqt4-sql-odbc libqt4-sql-psql libqt4-sql-sqlite libqt4-sql-sqlite2
Os pacotes a seguir serão REMOVIDOS:
  firefox*
Os NOVOS pacotes a seguir serão instalados:
  docbook-xsl kdebase-bin kdebase-data kdebase-runtime kdebase-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools libattica0 libclucene0ldbl
  libdbusmenu-qt2 libgif4 libilmbase6 libiodbc2 libkatepartinterfaces4 libkcmutils4 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4
  libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4
  libktexteditor4 libnepomuk4 libnepomukquery4a libnepomukutils4 libntrack-qt4-1 libntrack0 libopenexr6 libplasma3 libpolkit-qt-1-1 libqca2 libqt4-declarative
  libqt4-script libqt4-sql libqt4-svg libqt4-xmlpatterns libsolid4 libsoprano4 libssh-4 libstreamanalyzer0 libstreams0 libthreadweaver4 libutempter0 libxml2-utils
  ntrack-module-libnl-0 oxygen-icon-theme plasma-scriptengine-declarative plasma-scriptengine-javascript rekonq shared-desktop-ontologies soprano-daemon
0 pacotes atualizados, 66 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
É preciso baixar 44,5 MB de arquivos.
Depois desta operação, 122 MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? n
Abortar.

o google chrome esta atualmente definido como navegador padrão
Registrado

Sony Vaio VPCEH30EB/W @ Ubuntu 12.04 + Ubuntu 12.10 + Debian 6.0
garfo
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 859


KDE way of life! :)


Ver Perfil WWW
« Responder #1 em: 05 de Janeiro de 2012, 10:01 »

O Debian e suas dependências... sempre dando problemas.

E o pior é que o sistema pensa que você vai ficar sem navegador nenhum e sugere (na verdade obriga, né) a instalação de alguns para você.

Já tentou purgar os três navegadores sugeridos (chromium, firefox e reqonk) e depois instalar só o Google Chrome?
Registrado

Garfo - Kubuntu 14.04
Agnóstico, anti-socialismo/comunismo, pró-liberdade, pró-aborto, pró-open source
"Pra quê complicar? Facilidade e simplicidade é tudo!"
Chernobyl_User
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 132


ChNPP RBMK-1000


Ver Perfil
« Responder #2 em: 05 de Janeiro de 2012, 23:49 »

cara, eu nem instalei o rekonq, se eu instalasse ia encher o meu desktop de bugigangas do kde, pensa o transtorno.

ainda não tentei, acho que se eu fosse purgar o rekonq ele ia empurrar o iceweasel ou outro navegador que talvez eu nunca havia se quer ouvido falar.
Registrado

Sony Vaio VPCEH30EB/W @ Ubuntu 12.04 + Ubuntu 12.10 + Debian 6.0
Andreson Goveia
Equipe Ubuntu
Usuário Ubuntu
*****
Deslogado Deslogado

Mensagens: 1.986

Ubuntu14.10


Ver Perfil
« Responder #3 em: 05 de Janeiro de 2012, 23:51 »

Você tem o Java (ou JDK) instalado??

Pois ele pede ou o firefox ou chromium ou rekonq como dependência.
Registrado

Chernobyl_User
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 132


ChNPP RBMK-1000


Ver Perfil
« Responder #4 em: 06 de Janeiro de 2012, 01:31 »

sim, eu tenho, foi baixado do site da sun atraves de um arquivo ".run" e instalado em /opt/java com o link em $HOME/.mozilla/plugins

mas este exemplo do java foi somente um exemplo, ele não me afeta mais.

descobri a causa do problema: mozplugger, eu usava ele no google chrome para incluir o evince como leitor de pdf, antes mesmo de instalar o chromium browser, mas parece que ele se prendeu ao chromium de um jeito, so nao sei se removendo ele,eu consigo remover o firefox também, e caso eu instale novamente (por que eu preciso dele, o leitor nativo de pdf do chrome e meio bugado) o problema volte a acontecer.

dependências do mozplugger: iceweasel | iceape-browser | firefox | abrowser | galeon | rekonq | konqueror | opera | epiphany | chromium-browser | xulrunner-1.9 | xulrunner-1.9.1 | xulrunner-1.9.2 | xulrunner-2.0
Registrado

Sony Vaio VPCEH30EB/W @ Ubuntu 12.04 + Ubuntu 12.10 + Debian 6.0
Chernobyl_User
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 132


ChNPP RBMK-1000


Ver Perfil
« Responder #5 em: 07 de Janeiro de 2012, 17:34 »

removendo o mozplugger, consegui remover tanto o firefox quanto o chromium browser, so achei estranho o fato do apt-get não informar corretamente ao usuário qual pacote está por tras destas ações

recomendo usar o aptitude ao invés do apt-get para evitar problemas assim
Registrado

Sony Vaio VPCEH30EB/W @ Ubuntu 12.04 + Ubuntu 12.10 + Debian 6.0
Páginas: [1]   Ir para o topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Tema desenvolvido por FaBMak e n3t0
Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines
© 2014 Canonical Ltd. Ubuntu e Canonical são marcas registradas da Canonical Ltd.
XHTML 1.0 válido! CSS válido!