Fórum Ubuntu Linux - PT
24 de Novembro de 2014, 10:08 *
Olá, Visitante. Faça o login ou registre-se.
Perdeu o seu e-mail de ativação?

Login com nome de usuário, senha e duração da sessão
Notícias: Atenção usuários de email com anti-spam (Uol e Bol).
 
   Home   Ajuda Regras Pesquisa Login Registre-se  
Anúncios
Páginas: [1]   Ir para o fundo
  Imprimir  
Autor Tópico: Procedimentos para executar o Tibia no Ubuntu 14.04 LTS 64-bits [Tutorial]  (Lida 2110 vezes)
krokus
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 2



Ver Perfil
« em: 30 de Maio de 2014, 12:50 »

Muitos usuários do Ubuntu preferem a arquitetura de 64-bits porque utiliza todos os recursos do hardware
e permite programas com requisitos de memória intensiva. Acontece que o Ubuntu 64-bits já não disponibiliza
o pacote ia32-libs desde a versão 13.10, e como o cliente do Tibia foi compilado para sistemas 32 bits,
para que o jogo funcione numa instalação limpa do Ubuntu 14.04 LTS 64-bits é necessário realizar alguns
procedimentos:

1) Em primeiro lugar é necessário instalar o pacote ia32-libs:

  • Abrir o Synaptic, e ir em "Configurações > Repositórios"

  • Clicar em  "Outros softwares > Adicionar"

  • Inserir esta linha na caixa de dialogo:

    •    deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse

  • Clicar em Ok, e depois no botão Recarregar do Synaptic. Ou se preferir, digitar no terminal:

    •    sudo apt-get update

  • Agora já podemos instalar o pacote ia32-libs. Instalar pelo Synaptic mesmo, ou então digitar no terminal:

    •    sudo apt-get install ia32-libs


2) Em segundo lugar é preciso baixar o pacote libc6 na versão 2.17:

  • Carregar o pacote libc6_2.17-0ubuntu5.1_i386.deb do link abaixo:


  • Depois de carregado o pacote acima, abri-lo no Gerenciador de arquivos compactados.

  • Selecione a pasta i386-linux-gnu, que se encontra dentro da pasta libs, e depois clique em Extrair (extraia para dentro da pasta do Tibia).

  • Excluir a pasta libc6 que veio com o Tibia, e substitui-la pela pasta extraída acima, renomeando-a para libc6.


Pronto, após estes procedimentos, o cliente do Tibia deve funcionar normalmente no Ubuntu 14.04 LTS 64-bits.
Para iniciar o Tibia, execute o arquivo "StartTibia.sh" que se encontra dentro da pasta do Tibia.


-------
Editado pela moderação: remoção de parte do excesso de formatação.
« Última modificação: 24 de Junho de 2014, 09:06 por krokus » Registrado
Tota
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 14.186



Ver Perfil
« Responder #1 em: 30 de Maio de 2014, 13:43 »

Citar
1) Em primeiro lugar é necessário instalar o pacote ia32-libs:

Só para agregar, o pacote ia32libs não está disponível para o Ubuntu 14.04

Instalar os libs do Ubuntu Raring no Ubuntu 14.04 não é em teoria uma boa prática.

Assim, numa instalação nova do 14.04, esta dica não irá funcionar sem imstalar pacotes antigos do raring

As bibliotecas de compatibilidade de 32 bits continuam disponíveis no 14.04 mas não no pacote ia32libs que não existe mais.

[]'s
« Última modificação: 30 de Maio de 2014, 13:45 por Tota » Registrado
krokus
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 2



Ver Perfil
« Responder #2 em: 30 de Maio de 2014, 14:16 »

Citar
Só para agregar, o pacote ia32libs não está disponível para o Ubuntu 14.04

Instalar os libs do Ubuntu Raring no Ubuntu 14.04 não é em teoria uma boa prática.

Assim, numa instalação nova do 14.04, esta dica não irá funcionar sem imstalar pacotes antigos do raring

As bibliotecas de compatibilidade de 32 bits continuam disponíveis no 14.04 mas não no pacote ia32libs que não existe mais.

Olá Tota. Antes de utilizar os procedimentos que eu citei no tópico, eu tentei outras maneiras de fazer o Tíbia funcionar (por exemplo, usei os comandos: sudo dpkg --add-architecture i386; sudo apt-get update; sudo apt-get install libc6:i386; e também tentei sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0, etc.), mas nada funcionou. Somente com os procedimentos relatados neste tópico, eu consegui executar o Tibia.

Se outros usuários do Tíbia conseguiram fazer com que o Tibia funcionasse numa instalação limpa do Ubuntu 14.04 LTS 64-bits usando outros procedimentos, eu gostaria que publicassem aqui como procederam, e eu acrescentarei as suas sugestões ao tópico.

No entanto, eu aceito somente sugestões de procedimentos para uma instalação limpa do Ubuntu 14.04 LTS 64-bits. Porque se o usuário tem o Ubuntu 14.04 LTS 64-bits atualizado de versões anteriores, provavelmente seu sistema ainda conversa os arquivos do pacote ia32-libs das distribuições anteriores que ele foi atualizando. Neste caso, é provável que o Tibia funcione sem que seja necessário os procedimentos deste tópico.

Por isso ressalto que os procedimentos relatados neste tópico são exclusivamente para quem realizou uma instalação limpa do Ubuntu 14.04 LTS 64-bits. E sei que estes procedimentos funcionam porque eu mesmo executei-os para que o Tibia funcionasse, portanto já foram testados.

« Última modificação: 19 de Junho de 2014, 01:10 por krokus » Registrado
marciojr91
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 1


Ver Perfil
« Responder #3 em: 06 de Julho de 2014, 23:53 »

Para a versão do tibia 10.41 bastou instalar a biblioteca abaixo

Código:
sudo apt-get install libglu1-mesa:i386

Em seguida, só precisei executar o arquivo Tibia e funcionou normalmente.

OBS: Não sei se faz alguma diferença, mas utilizo os drivers da nvidia versão 331.38
Registrado
booodeee
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 37


Ver Perfil
« Responder #4 em: 03 de Novembro de 2014, 10:46 »

Para a versão do tibia 10.41 bastou instalar a biblioteca abaixo

Código:
sudo apt-get install libglu1-mesa:i386

Em seguida, só precisei executar o arquivo Tibia e funcionou normalmente.


Isso funcionou comigo, versão do Tibia 10.61.
Registrado
Páginas: [1]   Ir para o topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Tema desenvolvido por FaBMak e n3t0
Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines
© 2014 Canonical Ltd. Ubuntu e Canonical são marcas registradas da Canonical Ltd.
XHTML 1.0 válido! CSS válido!