Fórum Ubuntu Linux - PT
22 de Novembro de 2014, 13:16 *
Olá, Visitante. Faça o login ou registre-se.
Perdeu o seu e-mail de ativação?

Login com nome de usuário, senha e duração da sessão
Notícias: Sejam todos bem-vindos e fiquem atentos às regras de utilização do fórum e política de privacidade.
 
   Home   Ajuda Regras Pesquisa Login Registre-se  
Anúncios
Páginas: [1] 2 3 4   Ir para o fundo
  Imprimir  
Autor Tópico: ubuntu nao inicia depois da tela de login  (Lida 18360 vezes)
dex19dt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 76


Ver Perfil
« em: 14 de Agosto de 2010, 10:11 »

eu tenho o ubuntu lucid lynx com kde e ontem eu fiz algumas alterações na configuração de inicialização do sistema.
eu alterei a tela de inicialização, escolhi um outro estilo.
quando reiniciei o sistema, ele abre a tela de login onde digito a senha pra entrar no sistema depois q digito a senha a tela fica preta e depois ele volta pra tela de login de novo.
qndo escolho login por linha de comando ele exibe o modo texto mas as letras estão incompreensiveis, como se tivesse um problema de video.
nao consigo mais entrar no ubuntu pra fazer alguma alteração ou desfazer o q fiz.
alguem pode me ajudar?
Registrado
libonati
Visitante
« Responder #1 em: 14 de Agosto de 2010, 11:25 »

Como você fez essas alterações?
Se usando a linha de comando reveja o histórico.
Código:
history

poste aqui:
as últimas linhas do comando history(como root).    #Para ver o que você fez.
O conteúdo do arquivo /boot/grub/grub.cfg               #Para detectar possível equívoco.
O resultado do comando ls /                                     #Para confirmar imagem correta.
Registrado
dex19dt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 76


Ver Perfil
« Responder #2 em: 14 de Agosto de 2010, 12:23 »

nao usei a linha de comando pra fazer as alterações. Usei uma opção das Configurações do Sistema, nao me recordo o nome agora algo como Assistente de Inicialização.
como eu vou ver o "history" se nao consigo entrar no sistema?
Registrado
libonati
Visitante
« Responder #3 em: 14 de Agosto de 2010, 13:16 »

como eu vou ver o "history" se nao consigo entrar no sistema?

Por isso a pergunta inicial. Respeitando as particularidades de cada um resolver do modo que mais julgue correto proceder, peço que poste /boot/grub/grub.cfg e ls /.

Você tamb/em pode iniciar pelo live cd e chamar o gparted em Sistema/Administração/Gparted e mandar corrigir a partição problemática.
« Última modificação: 14 de Agosto de 2010, 13:21 por libonati » Registrado
dex19dt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 76


Ver Perfil
« Responder #4 em: 14 de Agosto de 2010, 14:22 »

entrei com o live cd e digitei os comandos conforme solicitado:

ubuntu@ubuntu:~$ /boot/grub/grub.cfg
bash: /boot/grub/grub.cfg: Arquivo ou diretório não encontrado
ubuntu@ubuntu:~$ ls /
bin   cdrom  etc   initrd.img  media  opt   rofs  sbin     srv  tmp  var
boot  dev    home  lib         mnt    proc  root  selinux  sys  usr  vmlinuz
ubuntu@ubuntu:~$

consegui abrir o arquivo grub.cfg:

Código:
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  set saved_entry=${prev_saved_entry}
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
set locale_dir=($root)/boot/grub/locale
set lang=pt
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, com Linux 2.6.32-24-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
linux /boot/vmlinuz-2.6.32-24-generic root=UUID=0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93 ro  vga=769  quiet splash
initrd /boot/initrd.img-2.6.32-24-generic
}
menuentry 'Ubuntu, com Linux 2.6.32-24-generic (modo de recuperação)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
echo 'Carregando Linux 2.6.32-24-generic ...'
linux /boot/vmlinuz-2.6.32-24-generic root=UUID=0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93 ro single  vga=769
echo 'Carregando ramdisk inicial ...'
initrd /boot/initrd.img-2.6.32-24-generic
}
menuentry 'Ubuntu, com Linux 2.6.32-23-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
linux /boot/vmlinuz-2.6.32-23-generic root=UUID=0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93 ro  vga=769  quiet splash
initrd /boot/initrd.img-2.6.32-23-generic
}
menuentry 'Ubuntu, com Linux 2.6.32-23-generic (modo de recuperação)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
echo 'Carregando Linux 2.6.32-23-generic ...'
linux /boot/vmlinuz-2.6.32-23-generic root=UUID=0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93 ro single  vga=769
echo 'Carregando ramdisk inicial ...'
initrd /boot/initrd.img-2.6.32-23-generic
}
menuentry 'Ubuntu, com Linux 2.6.32-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
linux /boot/vmlinuz-2.6.32-22-generic root=UUID=0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93 ro  vga=769  quiet splash
initrd /boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu, com Linux 2.6.32-22-generic (modo de recuperação)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
echo 'Carregando Linux 2.6.32-22-generic ...'
linux /boot/vmlinuz-2.6.32-22-generic root=UUID=0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93 ro single  vga=769
echo 'Carregando ramdisk inicial ...'
initrd /boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu, com Linux 2.6.31-14-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
linux /boot/vmlinuz-2.6.31-14-generic root=UUID=0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93 ro  vga=769  quiet splash
initrd /boot/initrd.img-2.6.31-14-generic
}
menuentry 'Ubuntu, com Linux 2.6.31-14-generic (modo de recuperação)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
echo 'Carregando Linux 2.6.31-14-generic ...'
linux /boot/vmlinuz-2.6.31-14-generic root=UUID=0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93 ro single  vga=769
echo 'Carregando ramdisk inicial ...'
initrd /boot/initrd.img-2.6.31-14-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 0df2e3e0-548f-4b5b-bd3c-66d5ac6ffd93
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows Vista (loader) (on /dev/sdb1)" {
insmod ntfs
set root='(hd1,1)'
search --no-floppy --fs-uuid --set de44625d44623903
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###
« Última modificação: 14 de Agosto de 2010, 14:33 por dex19dt » Registrado
libonati
Visitante
« Responder #5 em: 14 de Agosto de 2010, 17:12 »


nao consigo mais entrar no ubuntu pra fazer alguma alteração ou desfazer o q fiz.
alguem pode me ajudar?

Desculpe amigo. Acho que não me fiz entender e me escapou que você não está conseguindo entrar no sistema. Siga os procedimentos:
1 - Insira o live cd no computador
2 - Reinicie o computador
3 - Siga as instruções para "experimentar o ubuntu" ( não instale, é só para experimentar)
4 - Abra o gparted em  /Sistema/Administração/Gparted
5 - No gparted selecione a partição do seu linux (onde encontra-se os seus arquivos)
6 - Selecione a opção para corrigir
7 - Mande corrigir
8 - Reinicie o computador

Se as opções de menu de boot não aparecerem (windows e ubuntu):

1 - Entre no ubuntu normalmente
2 - Abra o terminal consola
3 - digite sudo su  <seu login>
4 - Digite update-grub
5 - Digite grub-install  /dev/sda
6 - Reinicie o computador

Poste aqui o resultado e execute todos os passos com muita atenção
« Última modificação: 14 de Agosto de 2010, 17:14 por libonati » Registrado
dex19dt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 76


Ver Perfil
« Responder #6 em: 14 de Agosto de 2010, 18:10 »

ok libonati, obrigado pela paciencia.
Eu andei fazendo algumas tentativas e vou postar com o maximo de clareza possivel o q eu fiz:

Eu tenho 2 HD's, um com Windows Vista e outro com o Ubuntu 10.4. O HD primario é o do Ubuntu, o qual tem o Grub (que de fato está funcionando normalmente) onde eu escolho por iniciar um dos dois sistemas q tenho. Quando escolho o Windows ele inicia sem problema nenhum, tudo absolutamente normal. Mas quando inicio o Ubuntu ele exibe a tela de login e qndo digito a senha ele aceita e parece q vai entrar no sistema, fica tudo escuro e alguns segundos depois ele volta pra tela de login de novo (como se o boot tivesse "falhado").
Isso ocorre independentemente do tipo de sessão que eu escolho (KDE, Gnome e até a "A Prova de falhas"). O unico resultado diferente acontece quando eu escolho a opção "Fazer o login do console". Ele mostra o terminal mas os caracteres aparecem completamente irreconheciveis (como manchas, eu diria até q seria defeito da placa de video se nao fosse o fato de tudo funcionar normalmente usando o Windows). Mesmo sem conseguir ler o q aparece na tela, eu consegui me logar usando o modo texto e dei o comando "startx". Funcionou e ele iniciou o Gnome. uma vez dentro do sistema pude ver q parece estar tudo normal, acessei as Configurações do Sistema e fui a Gerenciador de Inicio de Sessão, coloquei as configurações padrão e tentei reiniciar mas nada mudou.
Também tentei utilizar o Gparted através do livecd mas quando eu selecionava a partição do Linux a opção Corrigir estava desabilitada. O fato é q o Livecd q eu tenho aqui ainda é do Karmic, nao sei se tem alguma coisa a ver, nao tenho o cd do Lucid. Além do mais eu acho q o problema nao é propriamente na partição, nao sei bem.

Outro fato que talvez seja importante. Semana passada eu instalei o programa StartUp Manager para alterar a tela de inicialização do Ubuntu (o "splash"), nao gostei do resultado e entao desinstalei o programa de novo. Desde então o splash aparece todo estranho, com a imagem cheia de quadrinhos piscando, similar ao q acontece quando entro no modo texto. Mas mesmo assim o sistema iniciava sem problemas. O problema da inicialização do Ubuntu ocorreu mesmo depois q mexi naquela opção do Gerenciador de Inicio de Sessão e defini um outro tema para o splash.

Portanto, tenho 2 problemas: o Ubuntu nao inicia de jeito nenhum. E a questão do splash e modo texto estarem com a imagem completamente desconfigurada e irreconhecivel. O segundo problema nao afetava o uso do sistema uma vez q eu estava dentro dele, e nao me importo se nao resolver agora. O ruim é nao poder iniciar o sistema.

Bom, gostaria de saber quais os arquivos responsaveis pela inicialização do Ubuntu e como eu faço para "resetar" eles ao padrão.
Ou qualquer outra coisa q me ajude rs

Mais uma vez obrigado
« Última modificação: 14 de Agosto de 2010, 18:11 por dex19dt » Registrado
libonati
Visitante
« Responder #7 em: 14 de Agosto de 2010, 18:44 »


Bom, gostaria de saber quais os arquivos responsaveis pela inicialização do Ubuntu e como eu faço para "resetar" eles ao padrão.
Ou qualquer outra coisa q me ajude rs

Os arquivos de inicialização são vários mas o pai de todos é o init que por sua vez aciona outros como por exemplo o rc.local. Mas se você não conseguir bootar eles não iniciam ou alguns iniciam e outros não.
Os arquivos que controlam o boot são:
/boot/grub/grub.cfg ( que não deve ser editado )
/etc/grub.d/ estão os escripts que vão atuar no /boot/grub/grub.cfg
/etc/default/grub que é o arquivo que normalmente se altera para mudar o OS do boot, tempo de espera,etc...

Vamos tentar.
siga com muita atenção as instruções deste link:
http://www.youtube.com/watch?v=vvP_9l5As0I

Registrado
dex19dt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 76


Ver Perfil
« Responder #8 em: 14 de Agosto de 2010, 20:02 »

eu insisto que nao há problema com o Grub e nem com nenhuma partição do HD (tanto que eu consegui acessar o sistema usando o "startx" no modo texto).
o meu problema parece ser uma configuração errada que faz com que o sistema nao entre após o login normal.
Registrado
libonati
Visitante
« Responder #9 em: 14 de Agosto de 2010, 20:34 »

Então você consegue entrar no sistema?
Você tem cópia de segurança dos arquivos que alterou? (todo ubunteiro toma essas precauções)
Você não sabe nem o caminho que fez durante esta operação macabra em seu computador para poder fazer uma engenharia reversa. Quero dizer com isso para você seguir as instruções passadas se não fica difícil. É como enfrentar um exécito inimigo e o soldado não obedecer seu general. Longe de mim querer ser o general dessa história mas se você não seguir as instruções não adianta de nada eu estar aqui ajudando. Virando os olhos

Concorda ou não concorda?
Registrado
dex19dt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 76


Ver Perfil
« Responder #10 em: 15 de Agosto de 2010, 12:30 »

Como eu disse anteriormente, eu consigo entrar no sistema usando o modo texto (com a imagem toda embaralhada) com o "startx". Esse comando me permite entrar no sistema (Gnome) como root, mas nao no KDE q eu costumava usar, mas pelo menos eu tenho acesso aos arquivos dessa forma.
Não tenho cópia de segurança dos arquivos que alterei porque eu nem ao menos faço idéia de quais arquivos alterei já que, como também ja disse anteriormente, eu nao fiz a alteração nos arquivos de configuração usando o terminal, eu fiz as alterações usando um assistente do sistema.
Eu só quero alterar as configurações do boot para o padrão, de forma q nao dê erro.  Indeciso
Registrado
libonati
Visitante
« Responder #11 em: 15 de Agosto de 2010, 12:43 »

Ok amigo. Entendi. Tomara que você consiga resolver seu problema.
abandonando tópico....
Registrado
Tota
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 14.185



Ver Perfil
« Responder #12 em: 15 de Agosto de 2010, 13:39 »

Ola,

Pela regra V do forum, não são permitidos Up's em topicos, salvo se postar o que fez ou pesquisou na tentativa de resolver o problema.

Desta forma estou removendo seu up.

A moderação.


eu insisto que nao há problema com o Grub e nem com nenhuma partição do HD (tanto que eu consegui acessar o sistema usando o "startx" no modo texto).

------Conteúdo longo e aborrecido à frente--------

Bem, apenas um palpite:

Voce diz ser problema com o grub e que chega até o prompt de comando para digitar "start x" , ok?

Pelo meu entendimento, quando voce chega ao prompt de comandos, o sistema foi inteiramente carregado e está funcional.

O X11 não foi carregado por um erro de configuração, então ao digitar "start x" foi forçado o modo gráfico.

Por esta linha de raciocínio, nenhum problema existe no seu Grub, visto o mesmo ser apenas um "loader", que lê onde está seu kernel compactado, e as informações de seu sistema de arquivos.

Ao fazer isto, o Grub descompacta o kernel, e dá-se inicio ao processo INIT, que entrega ao kernel o comando do sistema ( seu computador ).

O processo INIT começa em runlevel 1 até o runlevel 5

No meio destes voce tem o runlevel3 ( modo texto ) e runlevel4 ( nodo grafico )

Tudo sob o comando do Kernel ( o grub já não existe mais no sistema )

Desta forma podemos verificar que seu sistema por algum motivo travou no runlevel 4, e o sistema voltou ao runlevel3 para lhe entregar em modo texto, alternativas para continuar.

Neste momento voce digitou "start x", e neste ponto não temos mais nada a ver com Grub, mas com parte gráfica, pois o sistema foi carregado e está operacional.

Lembremos que o GNU/Linux foi idealizado para trabalhar em modo texto. O X Consortium criou uma interface grafica ( o X11 ou X Window System ) para Unix e GNU/Linux.

Esta ou interface gráfica ( X11) é responsável pela manipulação de ambientes gráficos presentes no sistema ( Gnome, KDE, XFCE, LXDE, Enlightenment, Window Maker,  dentre outras ) fazendo a "ponte" entre o ambiente grafico ( Gnome, etc. ) e o shell do kernel que sempre foi e será em modo texto.

Sabendo então que seu problema é com parte gráfica, não com o Grub, podemos sim utilizar o grub na inicialização para forçar alguns parâmetros ao kernel, que os irá utilizar para passar do runlevel 3 ao 4 quando do processo INIT.

Existem vários argumentos ou parâmetros aceitos pelo kernel => http://www.mjmwired.net/kernel/Documentation/kernel-parameters.txt

------Fim de Conteúdo longo e aborrecido à frente--------

Veja o tópico => argumentos de instalação ( caso falhe ) aqui mesmo no forum.
experimente entrar com o argumento xforcevesa
Tente nas opções de inicialização ( No grub e não do grub ) o modo recovery, nele escolha nodo vga

Isto irá carregar o modo grafico vga padrão, dando ao sistema a opção de passar ao runlevel4, e então depois de fazer seu Login na parte gráfica consertar seu sistema de forma mais amigável.  

Como vimos, Seu problema pode estar no Grub mas não é o grub, são argumentos passados ao sistema que alterara a forma como o kernel está configurando seu sistema.

Para corrigir, várias alternativas existem.

Por exemplo, voce pode carregar o sistema via live cd, acessar como root a pasta /root/grub de seu hd, renomear a pasta grub para grub.qualquer_coisa ( não renomeie a pasta /boot, pois é lá que ficam seus kernels compactados, cuidado. ) e renomear o arquivo em /etc/defaults/grub ( é aqui que se configura o grub 'na unha" , ver mais a frente )


Localizar seu hd ( geralmente sda1 ) e com o comando grub-install sda1 reinstalar seu Grub com configurações padrão. => http://www.guiadohardware.net/comunidade/recuperar-grub/663986/

Pode alterar seu grub "na unha" via modo texto usando um editor de textos como o vi, o emacs, ou qualquer outro de sua preferência.

Um grub padrão poderia ser assim para sua comparação:

Citar
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


Minhas desculpas pelo longo texto, só para explicar que o grub só e apenas passa parâmetros ao kernel, mas com isto acredito estou dando uma luz a seu problema.

[]'s
Registrado
dex19dt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 76


Ver Perfil
« Responder #13 em: 15 de Agosto de 2010, 14:33 »

Mas eu disse desde o inicio que o problema nao é com o GRUB. A própria citação minha que vc fez diz isso.
Eu nao estou entendendo.
nos posts anteriores eu ja descrevi exatamente o q acontece e nao é tbm dessa forma como vc descreveu.
Ele nao inicia o modo texto automaticamente.
Eu escolho a opção no Menu da tela de login.
Se houvesse problema com o tal do runlevel4 eu acho q nem a tela de login (do modo grafico) iria aparecer.
Na verdade o Grub está normal, a tela de login esta normal e o proprio sistema esta normal (depois q entro dele com a opção do "startx")
O que acontece é entre o login e a "abertura" do sistema, digamos assim. Aquilo q acontece depois q digito a senha.

Bom vou tentar alguma coisa do q vc falou aí
De qualquer forma, obrigado.
Registrado
zekkerj
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 16.462


Sua imensa torcida é bem feliz...


Ver Perfil
« Responder #14 em: 15 de Agosto de 2010, 14:56 »

dex19dt, seu problema pode não ser do grub, mas é no grub.

Observe lá em cima, quando você postou o arquivo "grub.cfg", que as chamadas do kernel estão com a opção "vga=769". Isso, com quase toda a certeza é o motivo do seu terminal estar embaralhado, na inicialização.

Eu sugiro que você vá ao arquivo "/etc/default/grub" e modifique a linha "GRUB_CMDLINE_LINUX_DEFAULT", mudando onde está "vga=769" para "vga=normal". Depois rode o "update-grub" de novo, pra retirar esse "vga=769" do boot.
Registrado

Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? Sem Graça
Páginas: [1] 2 3 4   Ir para o topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Tema desenvolvido por FaBMak e n3t0
Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines
© 2014 Canonical Ltd. Ubuntu e Canonical são marcas registradas da Canonical Ltd.
XHTML 1.0 válido! CSS válido!