Autor Tópico: Microsystem Philips M779/M530 - Philips Audio Set - USB PC LINK  (Lida 11287 vezes)

Offline TM

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Microsystem Philips M779/M530 - Philips Audio Set - USB PC LINK
« Online: 07 de Maio de 2006, 21:02 »
Pessoal tenho apenas um Mini System da Philips (FWM 779) para ouvir músicas! Sua conexão com o PC é via USB!

1) Gostaria de saber se alguém sabe onde consigo os devidos drivers para instalá-lo no Ubuntu!

2) Digitando lsusb ele identifica o som assim: Bus 004 Device 005: ID 0471:0111 Philips qual o procedimento para fazê-lo funcionar?

3) Não somente o som mas quando coloco algum dispositivo USB como faço para deixá-lo funcionando? Sabendo que ele é identificado como no exemplo do item 2?

Todas questões, opniões, dicas são muito bem vindas!

Obrigado.
Ubuntu 5.10

Slackware 10

Offline TM

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Mini System USB
« Resposta #1 Online: 14 de Maio de 2006, 14:23 »
???
Ubuntu 5.10

Slackware 10

Offline mitsu

  • Usuário Ubuntu
  • *
  • Mensagens: 145
    • Ver perfil
Mini System USB
« Resposta #2 Online: 14 de Maio de 2006, 18:12 »
eu gosto de usar o dmesg pra saber se o dispositovo foi reconhecido.

ex: Ultimas linhas do meu dmesg agora:
Código: [Selecionar]
[4294728.700000] [drm] Initialized drm 1.0.0 20040925
[4294728.705000] ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 16
[4294728.706000] [drm] Initialized i915 1.2.0 20040405 on minor 0: Intel Corporation 82865G Integrated Graphics Controller
[4294728.707000] mtrr: base(0xf0020000) is not aligned on a size(0x800000) boundary


dmesg depois de plugar dvd-ramusb
Código: [Selecionar]
[4295764.404000] usb 5-5: new high speed USB device using ehci_hcd and address 5
[4295764.481000] scsi1 : SCSI emulation for USB Mass Storage devices
[4295764.482000] usb-storage: device found at 5
[4295764.482000] usb-storage: waiting for device to settle before scanning
[4295769.483000]   Vendor: MATSHITA  Model: DVD-RAM LF-P867   Rev: 1.00
[4295769.483000]   Type:   CD-ROM                             ANSI SCSI revision: 00
[4295769.486000] usb-storage: device scan complete
[4295769.568000] sr0: scsi3-mmc drive: 12x/12x writer dvd-ram cd/rw xa/form2 cdda tray
[4295769.569000] Attached scsi CD-ROM sr0 at scsi1, channel 0, id 0, lun 0 ---> acho que aqui e' o mais importante <---

sudo mkdir /mnt/usb
sudo chmod 777 /mnt/usb
-> pra qualquer um poder acessar
sudo mount /dev/sr0 /mnt/usb -> montagem manual, mas colocando os parametros corretos no fstab, da pra deixar automatico

se o seu som philips for reconhecido como "disco extero", acho que esses procedimentos devem funcionar

caso tenha sucesso, ensina nois ! :wink:

Offline TM

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Mini System USB
« Resposta #3 Online: 14 de Maio de 2006, 23:55 »
Citação de: "mitsu"
sudo mount /dev/sr0 /mnt/usb -> montagem manual, mas colocando os parametros corretos no fstab, da pra deixar automatico


Cara muito boa sua idéia!!!  :lol:

Entedi o que você quer fazer!!!!

Usei o dmesg e ele reconheceu o som! Vou colocando a baixo como foi reconhecido pra facilitar o entendimento!

Código: [Selecionar]
[4295785.666000] usb 4-1: new full speed USB device using uhci_hcd and address 2
[4295786.166000] usb 4-1: new full speed USB device using uhci_hcd and address 3
[4295787.092000] usbcore: registered new driver snd-usb-audio
[4295787.096000] usbcore: registered new driver hiddev
[4295787.137000] input: USB HID v1.00 Device [Philips Philips Audio Set] on usb-0000:00:13.1-1
[4295787.137000] usbcore: registered new driver usbhid
[4295787.137000] drivers/usb/input/hid-core.c: v2.01:USB HID core driver[b]


Beleza ao invés de colocar como vc o comando sudo mount /dev/sr0 /mnt/usb eu deveria colocar sudo mount /lib/drivers/usb/input/hid-core.c /mnt/usb correto? ou falei besteira? :oops:

Só que quando digito ele me aparece a mensagem:
mount: você precisa especificar o tipo do sistema de arquivos

Agora o estranho é que não tem este arquivo hid-core.c no diretório input

mitsu me dá essa força ai cara!!! Acho que estamos indo no caminho certo!!!

Cara muito obrigado pela força!!!  :wink:
Ubuntu 5.10

Slackware 10

Offline mitsu

  • Usuário Ubuntu
  • *
  • Mensagens: 145
    • Ver perfil
Mini System USB
« Resposta #4 Online: 15 de Maio de 2006, 12:48 »
Citação de: "TM"
[4295787.092000] usbcore: registered new driver snd-usb-audio
[4295787.096000] usbcore: registered new driver hiddev


"snd-usb-audio" - parece que foi reconhecido como "placa de som externa"
"hiddev" - Human Interface Device - Dispositivo de interface humana - Mouse, Teclado, controle remoto etc...

o "mount"  funciona apenas para dispositivos de armazenamento (CD, HD, rede etc), nao iria funcionar com o que foi reconhecido.

alias, esse mini-system, ligado na USB faz o que mesmo?

Offline TM

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Mini System USB
« Resposta #5 Online: 16 de Maio de 2006, 09:45 »
Citação de: "mitsu"
"snd-usb-audio" - parece que foi reconhecido como "placa de som externa"


Hmm... Vou procurar alguma coisa relacionado com placa de som externa então!

Citação de: "mitsu"
alias, esse mini-system, ligado na USB faz o que mesmo?


Ele é um som com saida USB para ligar no pc! O objetivo é ouvir música no som com as músicas do pc que é transferida pelo cabo USB, no Windows ele funciona normalmente pois junto com o som ja vem o cd de configuração com suporte apenas para o Rwin...  :?

Citação de: "mitsu"
caso tenha sucesso, ensina nois !


Com certeza!! Quando eu conseguir fazer ele funcionar (se conseguir), vou montar um tuto de como eu fiz!!!


Lembrando que quando abro o gerenciador de dispositivos, encontro ele por lá sendo reconhecido como: Philips Audio Set, logo abaixo está USB Audio ALSA Capture Device, Set ALSA Control Device e USB Audio ALSA Playback Device, se tiver mais uma idéia é bem vinda!!  :lol:

Cara valeu mesmo pela força!!!! :wink:
Ubuntu 5.10

Slackware 10

Offline ppvanzella

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
Mini System USB
« Resposta #6 Online: 23 de Maio de 2006, 17:12 »
Eu tenho um som desses, e quando to no KDE só tenho que selecionar o som OSS e dispositivo /dev/dsp1
Mas eu quero fazer isso pelo gstreamer, e num to conseguindo também =\
To usando ele com um cabo normal, ligado no meu som onboard, mas a qualidade de som não é a mesma...

Os módulos são carregados no boot (snd-usb-audio e outros q num lembro)

Offline Darcamo

  • Usuário Ubuntu
  • *
  • Mensagens: 1.315
    • Ver perfil
Mini System USB
« Resposta #7 Online: 23 de Maio de 2006, 20:52 »
Só um chute

Menu
Sistema/Preferências/Som

Tem uma opção "Placa de Som Padrão"
Será se como o seu Mini System foi reconhecido como uma placa de som externa não tem uma opção de "Placa de Som Padrão" que corresponda a ele?

Como eu disse, só um chute. Vê aí

Offline JeffersonX

  • Usuário Ubuntu
  • *
  • Mensagens: 442
  • Linux User: #364092
    • Ver perfil
Mini System USB
« Resposta #8 Online: 23 de Maio de 2006, 23:24 »
Oh, não sei como pode ser nesse Philips, mas talvez isso pode te ajudar. Um colega meu tem aquele Gradiente Toca Tudo que também possui conexão USB pra ouvir música. Ao plugá-lo no Ubuntu, apareceu do lado direito uma mensagem que uma nova placa de som foi configurada e que para usá-la, tem que ir nas preferências de som e mudar a placa de som, no caso para o som USB. Foi só mudar que o som passou a ser executado por ele.

Aí pra você nas opções de som mostra mais de uma placa de som? Ah, isso foi no Ubuntu 5.10 (Breezy). Nos outros não sei como é este tipo de configuração...
Linux Professional Institute Certified - Level 1, Novell CLA - Certified Linux Administrator, Microsoft Certified Professional - Windows Server 2003, ITIL Foundation Certified
Meu Blog: http://tibyjeffersonx.blogspot.com

Offline ppvanzella

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
Mini System USB
« Resposta #9 Online: 24 de Maio de 2006, 13:58 »
Então, no breezy isso não funcionava, mas eu num tinha testado ainda no dapper...
Dei uma olhada ontem aqui pelo fórum e achei essa dica ae, e num é que o bicho funcionou?
Os vizinhos que se cuidem, som com qualidade denovo \o/

Offline TM

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Mini System USB
« Resposta #10 Online: 25 de Maio de 2006, 00:26 »
Citação de: "Darcamo"
Menu
Sistema/Preferências/Som

Tem uma opção "Placa de Som Padrão"
Será se como o seu Mini System foi reconhecido como uma placa de som externa não tem uma opção de "Placa de Som Padrão" que corresponda a ele?


Realmente ele fica no padrão que é a placa de som, mas eu mudo para o som Philips (usb) e mesmo assim ele não funciona.

Citação de: "JeffersonX"
Oh, não sei como pode ser nesse Philips, mas talvez isso pode te ajudar. Um colega meu tem aquele Gradiente Toca Tudo que também possui conexão USB pra ouvir música. Ao plugá-lo no Ubuntu, apareceu do lado direito uma mensagem que uma nova placa de som foi configurada e que para usá-la, tem que ir nas preferências de som e mudar a placa de som, no caso para o som USB. Foi só mudar que o som passou a ser executado por ele.

Aí pra você nas opções de som mostra mais de uma placa de som? Ah, isso foi no Ubuntu 5.10 (Breezy). Nos outros não sei como é este tipo de configuração...


Pois é cara... isso acontece comigo também! Só que eu mudo pra opção do som (usb) e ele ainda assim não toca...

Eu sei que meu S.O. é o Ubuntu 5.10, mas como faço para saber se é Breezy?

Citação de: "ppvanzella"
Então, no breezy isso não funcionava, mas eu num tinha testado ainda no dapper...


Como assim no dapper???

Da uma ajuda ai!!!! Explica o que vc fez cara!!!

Valeu
Ubuntu 5.10

Slackware 10

Offline ppvanzella

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
Mini System USB
« Resposta #11 Online: 25 de Maio de 2006, 15:09 »
Eu atualizei o sistema pro beta (o 6.06).
faz assim:
$ sudo gedit /etc/apt/sources.list
[Troca todos os breezy por Dapper e salva]
$ sudo apt-get update
$ sudo dist-upgrade
[Ou usa o synaptics pros dois ultimos passos]

RSS_X3

  • Visitante
Mini System USB
« Resposta #12 Online: 25 de Maio de 2006, 18:06 »
Cara, to com o mesmo problema que você, tenho um Philips FWM589, e tambem não funciona no Ubuntu 6.06... ja tentei as dicas do pessoal ai e nada. Se alguem souber de algo ai...

Offline ppvanzella

  • Usuário Ubuntu
  • *
  • Mensagens: 61
    • Ver perfil
Mini System USB
« Resposta #13 Online: 25 de Maio de 2006, 18:13 »
Velho, o meu é um FWM777 e tá funcionando de boa...
Tenta instalar o pacote alsa-oss também.
Dae liga ele na USB que vai aparecer uma janelinha no canto da tela pedindo pra setar a placa de som padrão...

RSS_X3

  • Visitante
Mini System USB
« Resposta #14 Online: 26 de Maio de 2006, 16:35 »
Ja tentei instalar esse pacote e nada, o som é detectado normalmente, seleciono o Philips nas configuraçoes de audio mas na hora de tocar da erro, ja tentei configurar o XMMS também de varias formas e nada, as vezes o som até parece estar conectado certo (com os leds acesos) mas o som não toca de forma alguma...
Por enquanto to improvisando com um cabo e audio ligado na entrada auxiliar, mas o som não fica tao bom...