Fórum Ubuntu Linux - PT
28 de Novembro de 2014, 12:28 *
Olá, Visitante. Faça o login ou registre-se.
Perdeu o seu e-mail de ativação?

Login com nome de usuário, senha e duração da sessão
Notícias: Atenção usuários de email com anti-spam (Uol e Bol).
 
   Home   Ajuda Regras Pesquisa Login Registre-se  
Anúncios
Páginas: [1] 2 3 4   Ir para o fundo
  Imprimir  
Autor Tópico: [RESOLVIDO] tim web 3G no ubuntu com modem onda msa405hs/msa501hs e aiko 83D  (Lida 80683 vezes)
tayroni
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 6


Ver Perfil
« em: 09 de Fevereiro de 2009, 23:52 »

ATENÇÃO: VEJAM NO 5º POST UMA CONFIGURAÇÃO ALTERNATIVA MELHOR QUE ESTA, POIS USA HAL/UDEV E CONECTA ATRAVÉS DO GERENCIADOR DE REDE DO UBUNTU EM VEZ DO GNOME-PPP

ATENÇÃO 2: NO CASO DO MODEM ONDA MSA501HS, ONDE TIVER 0037, TROQUE POR 0001, COMO REPORTADO PELO USUÁRIO DTOMADON

ATENÇÃO 3: NO CASO DO MODEM AIKO 83D (VENDIDO PELA VIVO), basta mudar o 0037 por 0057 (em todos os scripts), COMO REPORTADO PELO USUARIO WILLIAMCO

Olá a todos;

Depois de alguma dificuldade, consegui configurar o modem onda msa405hs, estilo pendrive, no ubuntu.

Para isso fiz o seguinte:

1) Instalei o pacote usbmodeswitch deste endereço:

http://ppa.launchpad.net/pmarti/ppa/ubuntu/pool/main/u/usbmodeswitch/

Ele é necessário porque o modem tem duas funções: pendrive e modem 3G e sua função é alternar entre um e outro

Ao se conectar o modem no computador, aparece a seguinte linha no output do lsusb:

Código:
Bus <XXX> Device <YYY>: ID 19d2:2000 

este endereço 2000 corresponde a função pendrive.

para se mudar para a opção modem, após olhar os manuais do usbmodeswitch e o catálogo de dispositivos disponíveis, descobri que o seguinte comando o muda para a função modem:

Código:
sudo /usr/sbin/usb_modeswitch -v 0x19d2 -p 0x2000 -V 0x19d2 -P 0x0037 -m 0x01 -M 55534243123456782000000080000c85010101180101010101000000000001

Após isso o output do lsusb deve conter a linha

Código:
Bus <XXX> Device <YYY>: ID 19d2:0037 

se isto ocorrer, seu modem está habilitado. Para carregar o driver usbserial, faça o seguinte comando

Código:
sudo modprobe usbserial vendor=0x19d2 product=0x0037

2) Para repetir de forma fácil o procedimento, crie um arquivo chamado tim-web com as linhas abaixo, e copie para /usr/local/bin

Código:
#!/bin/bash

#Instale usbmodeswitch

echo " "
echo "Ativando modem..."
/usr/sbin/usb_modeswitch -v 0x19d2 -p 0x2000 -V 0x19d2 -P 0x0037 -m 0x01 -M 55534243123456782000000080000c85010101180101010101000000000001;
sleep 10;

echo " "
echo "Abrindo driver..."
modprobe usbserial vendor=0x19d2 product=0x0037;

echo " "
echo "Obtendo conexão..."
echo " "
wvdial;

ao final torne-o executável com o comando

Código:
chmod a+x /usr/local/bin/tim-web

3) Abra o arquivo /etc/wvdial.conf com o seguinte comando

Código:
sudo gedit /etc/wvdial.conf

e deixe-o somente com as seguintes linhas

Código:
[Dialer Defaults]
Modem = /dev/ttyUSB2
ISDN = 0
Baud = 460800
Init = ATZ
Init2 = AT+CGDCONT=1,"IP","tim.br"
Phone = *99#
Dial Command = ATD
Ask Password = 0
Password = tim
Username = tim
Stupid mode = 1

4) Se todos os passos acima foram feitos com sucesso, para conectar, ligue o modem na porta USB, aguarde a luz laranja acender e digite o comando

Código:
sudo tim-web

se aparecerem as linhas finais

Código:
--> local  IP address 189.119.245.123
--> remote IP address 10.64.64.64
--> primary   DNS address 189.40.224.5
--> secondary DNS address 10.223.246.102

no output do comando, você está conectado. Se não aparecerem, digite o comando novamente e veja se as linhas finais acima apareceram. Se o firefox der o erro Modo Offline, vá em arquivo > modo offline e desmarque a caixa para que você possa navegar. Para eliminar de vez este erro do modo offline, faça o próximo passo.

5) Para deixar o firefox sempre online em conexões discadas, abra o firefox, digite "about:config" na barra de endereços. Na barra localizar, digite "toolkit.networkmanager.disable" sem as aspas e mude o seu valor para "true" (basta dois cliques em cima).
« Última modificação: 05 de Abril de 2009, 12:44 por tayroni » Registrado
kakai-mambira
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 3


Ver Perfil
« Responder #1 em: 19 de Fevereiro de 2009, 01:03 »

Fala meu Brother,


Primeiramente parabens pela disposicao de compartilhar o conhecimento e a experiencia que tu teve ai.


Segui o roteiro com diz ai, as respostas vinham se confirmando de acordo com o seu tuto.
Mais o final não foi o final feliz, apareceu o seguinte:


root@kakai-laptop:/usr/local/bin# sudo tim-web
 
Ativando modem...

 * usb_modeswitch: tool for controlling "flip flop" mode USB devices
 * Version 0.9.6 (C) Josua Dietze 2009
 * Works with libusb 0.1.12 and probably other versions

Looking for target devices
 Found target devices (1)
Looking for default devices
 No default device found. Is it connected? Bye

 
Abrindo driver...
 
Obtendo conexão...
 
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB2: No such file or directory
--> Cannot open /dev/ttyUSB2: No such file or directory
--> Cannot open /dev/ttyUSB2: No such file or directory




Me diz ae o que é que pode ter acontecido..
Registrado
kakai-mambira
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 3


Ver Perfil
« Responder #2 em: 19 de Fevereiro de 2009, 01:12 »

Tayroni,



Repeti todos os passos novamente e deu o mesmo erro reportado anteriormente, porém dando uma olhada no
log, o mesmo demonstra o device como sendo scsi e não usb




Feb 19 01:07:44 kakai-laptop kernel: [ 4128.639801] usb 4-4: USB disconnect, address 19
Feb 19 01:07:50 kakai-laptop kernel: [ 4133.672153] usb 4-4: new high speed USB device using ehci_hcd and address 20
Feb 19 01:07:50 kakai-laptop kernel: [ 4133.820607] usb 4-4: configuration #1 chosen from 1 choice
Feb 19 01:07:50 kakai-laptop kernel: [ 4133.824977] scsi19 : SCSI emulation for USB Mass Storage devices
Feb 19 01:07:55 kakai-laptop kernel: [ 4138.826130] scsi 19:0:0:0: Direct-Access     ONDA     MMC Storage      2.31 PQ: 0 ANSI: 2
Feb 19 01:07:55 kakai-laptop kernel: [ 4138.828514] sd 19:0:0:0: [sdb] Attached SCSI removable disk
Feb 19 01:07:55 kakai-laptop kernel: [ 4138.829235] sd 19:0:0:0: Attached scsi generic sg2 type 0


Registrado
tayroni
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 6


Ver Perfil
« Responder #3 em: 21 de Fevereiro de 2009, 23:16 »

Parece que o usb_modemswitch funcionou, mas o módulo usbserial não gerou os /dev/ttyUSB do modem.

Isso acontece quando se roda o /sbin/modprobe usbserial product=0x0037 vendor=0x19d2

Rode os comandos manualmente do passo 1 e veja se o comando

ls /dev/ttyUSB2

retorna alguma coisa.

Se retornar, os scripts estão funcionando.

Qualquer coisa, tenta a configuração alternativa do próximo post.
« Última modificação: 21 de Fevereiro de 2009, 23:36 por tayroni » Registrado
tayroni
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 6


Ver Perfil
« Responder #4 em: 21 de Fevereiro de 2009, 23:28 »

ATENÇÃO: MODO ALTERNATIVO DE CONFIGURAÇÃO, DESSA VEZ USANDO O NETWORKMANAGER EM VEZ DO GNOME-PPP E COM O CARREGAMENTO DO DRIVER AUTOMATICO

ATENÇÃO 2: NO CASO DO MODEM ONDA MSA501HS, ONDE TIVER 0037, TROQUE POR 0001, COMO REPORTADO PELO USUÁRIO DTOMADON

ATENÇÃO 3: NO CASO DO MODEM AIKO 83D (VENDIDO PELA VIVO), basta mudar o 0037 por 0057 (em todos os scripts), COMO REPORTADO PELO USUARIO WILLIAMCO

DESSA VEZ FICOU SHOW DE BOLA!

VALIDA PARA VERSÃO DO UBUNTU = UBUNTU INTREPID

Não plugue o modem ainda. Faça os passos de 1 a 6 primeiro

1) Instale o pacote usbmodeswitch deste endereço:

http://ppa.launchpad.net/pmarti/ppa/ubuntu/pool/main/u/usbmodeswitch/

Ele é necessário porque o modem tem duas funções: pendrive e modem 3G e sua função é alternar entre um e outro.


2) Crie o script /sbin/tim-web com as linhas

Código:
#!/bin/bash
sleep 5;
/usr/sbin/usb_modeswitch -v 0x19d2 -p 0x2000 -V 0x19d2 -P 0x0037 -m 0x01 -M 55534243123456782000000080000c85010101180101010101000000000001;

e torne-o executável com o comando:

Código:
sudo chmod a+x /sbin/tim-web

3)Crie o arquivo /usr/share/hal/fdi/preprobe/20thirdparty/10-onda-msa420hs.fdi com o conteúdo:

Código:
<?xml version="1.0" encoding="UTF-8"?>

<deviceinfo version="0.2">
  <device>
    <match key="usb.vendor_id" int="0x19d2"> <!-- ONDA -->
      <match key="usb.product_id" int="0x2000"> <!-- MSA420HS -->
        <merge key="info.ignore" type="bool">true</merge>
      </match>
    </match>
    <match key="serial.device" string="/dev/ttyUSB2">
        <append key="info.capabilities" type="strlist">modem</append>
        <append key="modem.command_sets" type="strlist">GSM-07.07</append>
        <append key="modem.command_sets" type="strlist">GSM-07.05</append>
    </match>
  </device>
</deviceinfo>

4)Crie o arquivo /etc/udev/rules.d/45-onda-msa405hs.rules com as linhas

Código:
ACTION!="add", GOTO="ONDA_End"
SUBSYSTEM=="usb", SYSFS{idProduct}=="2000", SYSFS{idVendor}=="19d2", RUN+="/sbin/tim-web"
SUBSYSTEM=="usb", SYSFS{idProduct}=="0037", SYSFS{idVendor}=="19d2", RUN+="/sbin/modprobe usbserial vendor=0x19d2 product=0x0037"
LABEL="ONDA_End"

5) Insira você mesmo no grupo dialout com o comando: sudo adduser <seulogin> dialout


6) Dê reboot;


7) Após o Reboot, plugue o modem. O ubuntu detectará o modem e oferecerá um assistente para configuração. Escolha TIM na pergunta "Service Provider". Para conectar de agora em diante, é só plugar o modem, aguardar ~10s, clicar no Gerenciador de Rede e marcar a opção "TIM".

As vezes o networkmanager pede senha quando não consegue conectar, deixe em branco e insista. Isso acontece quando o sinal fica baixo.
« Última modificação: 05 de Abril de 2009, 12:45 por tayroni » Registrado
dtomadon
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 591


Fatec SCS,Segurança da Informação, BackTrack5


Ver Perfil WWW
« Responder #5 em: 22 de Fevereiro de 2009, 22:30 »

tayrone parabéns pelas dicas para quem usa 3g ( aqui mais 2g do que 3g )eu uso um modem MSA501HS e suas dicas funcionaram perfeitamente

ainda não testei o modo alternativo, quando comprovar posto aqui, bom carnaval.

lembrando testei também no BIG e ok.

minha dúvida era em relação a saída do lsusb   Bus 004 Device 003: ID 19d2:0001 ( a sua Bus <XXX> Device <YYY>: ID 19d2:0037  ) mas como disse tudo ok

« Última modificação: 22 de Fevereiro de 2009, 22:41 por dtomadon » Registrado

BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!
tayroni
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 6


Ver Perfil
« Responder #6 em: 23 de Fevereiro de 2009, 12:40 »

dtomadon;

O seu modem (MSA501HS), apos o usb_modeswitch, muda para 19d2:0001. Já o meu (MSA405HS), muda para 19d2:0037.

Editei o título do tópico pra contemplar seu modelo de modem. Se der, teste o modo alternativo com o seu modem porque ai ajuda um monte de gente que possui esses modems ai. Obrigado por ter reportado que as dicas originais funcionam com seu modelo de modem.

O modo alternativo até agora está melhor aqui, e o resultado final é melhor porque não precisa ficar digitando comando pra trocar de pendrive pra modem. Fica tudo automatizado e a conexão é identificada pelo sistema inteiro via networkmanager.

Um grande abraço e bom carnaval!

Tayroni
« Última modificação: 23 de Fevereiro de 2009, 12:56 por tayroni » Registrado
dtomadon
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 591


Fatec SCS,Segurança da Informação, BackTrack5


Ver Perfil WWW
« Responder #7 em: 25 de Fevereiro de 2009, 19:31 »

valeu pela dica, no modo alternativo no BIG linux não consigo instalar o networkmanager no synaptic aparece

a seguinte mensagem :

networkmanager:
 Depende: network-manager-kde mas não será instalado

aí peço para instalar o network-manager-kde e dá a seguinte mensagem:

network-manager-kde:
 Depende: libnm-util0 mas não será instalado
 Depende: network-manager mas não será instalado

o que está errado veja meu source-list:

#Repositorio Big Linux
deb http://www.las.ic.unicamp.br/pub/biglinux/biglinux-4/ BIGLINUX main

#Repositorios Ubuntu
deb http://br.archive.ubuntu.com/ubuntu/ hardy main restricted
#deb-src http://br.archive.ubuntu.com/ubuntu/ hardy main restricted

deb http://br.archive.ubuntu.com/ubuntu/ hardy-updates main restricted universe multiverse
#deb-src http://br.archive.ubuntu.com/ubuntu/ hardy-updates main restricted universe multiverse

deb http://br.archive.ubuntu.com/ubuntu/ hardy universe multiverse
#deb-src http://br.archive.ubuntu.com/ubuntu/ hardy universe multiverse

#deb http://br.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse
#deb-src http://br.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu hardy-security main restricted
#deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted

deb http://security.ubuntu.com/ubuntu hardy-security universe multiverse
#deb-src http://security.ubuntu.com/ubuntu hardy-security universe multiverse

#Alguns jogos e programas multimidia
#deb http://repositorios.nighto.net/ hardy/

#Programas comerciais para o Ubuntu
#deb http://archive.canonical.com/ubuntu hardy-commercial main

#Backports
deb http://br.archive.ubuntu.com/ubuntu hardy-backports main universe multiverse restricted

#Arquivos Multimídia
deb http://packages.medibuntu.org/ hardy free non-free
#deb-src http://packages.medibuntu.org/ hardy free non-free


#getdeb
#deb http://ubuntu.org.ua/ getdeb/

#Pacotes PLF
#deb http://packages.freecontrib.org/plf hardy free non-free
#deb-src http://packages.freecontrib.org/plf hardy free non-free

#Pacotes PLF alternativo
#deb http://ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/ hardy free non-free

#Stoq
#deb http://download.stoq.com.br/ubuntu ./

#Cinelerra
#deb http://www.kiberpipa.org/~gandalf/ubuntu/hardy/cinelerra/i686/ ./

# Cipherfunk multimedia packages (packages, GPG key: 33BAC1B3)
#deb http://ftp://cipherfunk.org/pub/packages/ubuntu/ hardy main

# Kanotix
#deb http://kanotix.com/files/debian sid non-free
#deb-src http://kanotix.com/files/debian sid non-free

# The Opera browser (packages)
#deb http://deb.opera.com/opera etch non-free

#Compiz Fusion
#deb http://download.tuxfamily.org/3v1deb hardy eyecandy
#deb-src http://download.tuxfamily.org/3v1deb hardy eyecandy

#Pacotes Compiz Fusion alternativo
#deb http://debs.vorian.org/ hardy extras
#deb-src http://debs.vorian.org/ hardy extras


#ZSNES/PSX
#deb http://packages.dfreer.org hardy main

#Kubuntu 3.5.9
#deb http://ppa.launchpad.net/kubuntu-kde-3.5.9/ubuntu hardy main


# wine
deb http://wine.budgetdedicated.com/apt hardy main #WineHQ - Ubuntu 7.04 "hardy Fawn"
#deb-src http://wine.budgetdedicated.com/apt gutsy main #WineHQ - Ubuntu 7.04 "hardy Fawn"

#Repositorio sidux, cuidado ao usar
#deb http://sidux.com/debian/ sid main contrib non-free firmware fix.main fix.contrib fix.non-free

#Plugins para o Gift (Apollon)
# deb http://apt.cerkinfo.be/ unstable main contrib non-free
# deb-src http://apt.cerkinfo.be/ unstable main contrib non-free

## enlightenment e17 beta, use at your own risk
## E17 is in Beta and may break or break your system
#deb http://edevelop.org/pkg-e/ubuntu hardy e17
#deb http://e17.dunnewind.net/ubuntu hardy e17
#deb-src http://edevelop.org/pkg-e/ubuntu hardy e17

agradeço desde já a ajuda!!!
Registrado

BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!
tayroni
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 6


Ver Perfil
« Responder #8 em: 25 de Fevereiro de 2009, 22:43 »

Parece que todos os seus pacotes são do Hardy.

O NetworkManager do Hardy não conecta em redes adsl, só o do intrepid.

Podes usar o Gnome-ppp no lugar do network manager vendo na dica original só a parte que envolve a configuração dele, que é salvar o arquivo .wvdial em seu diretório.

Pelo menos, você teria o modem carregado automático sem scripts. Só plugar e abrir o gnome-ppp.

Podes testar o passo de 1 a 6 da dica alternativa, instalar o gnome-ppp e testar se o modem é reconhecido automaticamente pelo mesmo?
Registrado
djphoenix
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 2


Ver Perfil
« Responder #9 em: 23 de Março de 2009, 22:51 »

Seguinte, fiz tudo que estava no posto, mas quando conecto o modem no pc nao aparece assistente nenhum, ele nao ta reconhecendo, e nem aparece no /dev...

o modem ta funcionando perfeitamente no windows...

o que pode estar acontecendo?
Registrado
djphoenix
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 2


Ver Perfil
« Responder #10 em: 24 de Março de 2009, 21:21 »

Ninguem Sabe???

entao tem como alguem me dizer onde eu posso encontrar entao?

Registrado
williamco
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 13


Ver Perfil
« Responder #11 em: 02 de Abril de 2009, 14:42 »

olah, para quem tem o modem da AIKO 83D (vendido pela VIVO) basta mudar o 0037 por 0057 (em todos os scripts). eu usei o modo alternativo e fiz as configurações manualmente no discador. funcionou perfeitamente.

embora este modem pareça ser produzido pela evadim, aiko ou zte ele é na verdade uma variação do onda msa405hs que é vendido pela TIM.

para facilitar execute o seguinte script (como root) após instalar o usb_modeswitch:

Código:
#!/bin/sh

# Regras para o UDEV

echo '
ACTION!="add", GOTO="ONDA_End"
SUBSYSTEM=="usb", SYSFS{idProduct}=="2000", SYSFS{idVendor}=="19d2", RUN+="/sbin/tim-web"
SUBSYSTEM=="usb", SYSFS{idProduct}=="0057", SYSFS{idVendor}=="19d2", RUN+="/sbin/modprobe usbserial vendor=0x19d2 product=0x0057"
LABEL="ONDA_End"
' > /etc/udev/rules.d/45-onda-msa405hs.rules

# tim-web

echo '#!/bin/bash
sleep 10;
/usr/sbin/usb_modeswitch -v 0x19d2 -p 0x2000 -V 0x19d2 -P 0x0057 -m 0x01 -M 55534243123456782000000080000c85010101180101010101000000000001;
' > /sbin/tim-web
chmod +x /sbin/tim-web

# Regras para o HAL
echo '<?xml version="1.0" encoding="UTF-8"?>

<deviceinfo version="0.2">
  <device>
    <match key="usb.vendor_id" int="0x19d2"> <!-- ONDA -->
      <match key="usb.product_id" int="0x2000"> <!-- MSA420HS -->
        <merge key="info.ignore" type="bool">true</merge>
      </match>
    </match>
    <match key="serial.device" string="/dev/ttyUSB2">
        <append key="info.capabilities" type="strlist">modem</append>
        <append key="modem.command_sets" type="strlist">GSM-07.07</append>
        <append key="modem.command_sets" type="strlist">GSM-07.05</append>
    </match>
  </device>
</deviceinfo>
' > /usr/share/hal/fdi/preprobe/20thirdparty/10-onda-msa420hs.fdi

# Deleta a rota padrão
#route del default

# Sem isso o ppp não consegue alterar o DNS ao conectar
chmod 666 /etc/resolv.conf

# Esta opção é ncessária para que o sistema consiga obter o DNS ao conectar
opt1=`cat /etc/ppp/options | sed -e '/^\#/D' | grep "ipcp-max-failure 30"`
[ -z "$opt1" ] && echo 'ipcp-max-failure 30' >> /etc/ppp/options
# E sem essas o Aiko 83D e outros modelos não conectam
opt2=`cat /etc/ppp/options | sed -e '/^\#/D' | grep "asyncmap 0xa0000"`
[ -z "$opt2" ] && echo 'asyncmap 0xa0000' >> /etc/ppp/options
opt3=`cat /etc/ppp/options | sed -e '/^\#/D' | grep "mru 1500"`
[ -z "$opt3" ] && echo 'mru 1500' >> /etc/ppp/options
opt4=`cat /etc/ppp/options | sed -e '/^\#/D' | grep "refuse-chap"`
[ -z "$opt4" ] && echo 'refuse-chap' >> /etc/ppp/options

# DNS
echo "echo \"nameserver 208.67.222.222\" > /etc/resolv.conf" > /etc/ppp/ip-up.local
echo "echo \"nameserver 208.67.220.220\" >> /etc/resolv.conf" >> /etc/ppp/ip-up.local
chmod +x /etc/ppp/ip-up.local

# Configurações wvdial
echo '
[Dialer 3g]
Modem = /dev/ttyUSB2
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = vivo
Password = vivo
Phone = *99#
Stupid mode = 1
Auto Reconnect = on
Auto DNS = off
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,\"IP\",\"zap.vivo.com.br\"
ISDN = 0
Modem Type = Analog Modem
' > /etc/wvdial.conf


reinicie o pc e use o networkmanager ou o wvdial.
no meu caso usei o networkmanager
« Última modificação: 22 de Abril de 2009, 16:10 por williamco » Registrado
tayroni
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 6


Ver Perfil
« Responder #12 em: 05 de Abril de 2009, 12:41 »

@ williamco

Obrigado por ter reportado. Editei o post original pra contemplar o seu modelo de modem e te dar os créditos.
Registrado
Jenny
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 16



Ver Perfil WWW
« Responder #13 em: 05 de Abril de 2009, 23:20 »

Olá amigos! Essa dica de configuração para o tim é excelente. Agradeço de antemão. Segui o passo-a-passo e funcionou. O problema foi no "day after"...o Ubuntu não reconhece mais minhas portas usb (tenho 7! - a com o tecladoe a com impressora ele reconhece) mas as demais, quando conecto qq dispositivo (tentei minha camera, um pen drive e o modem da tim) ele não dá mais nem sinal de vida!!!
Não tenho idéia do que fazer...me ajudem.
OBS: Percebi que, se deixar o minimodem conectado na USB, ao dar um boot, o teclado e o mouse não funcionam (não reconhece), se tirar o minimodem eles não dão problema, mas as demais entradas não se manifestam!!!
Registrado

A liberdade está em aprender sempre!
Jenny Horta
Usuária Linux Ubuntu nº #474916
oceano
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 5


Ver Perfil
« Responder #14 em: 21 de Abril de 2009, 02:52 »

[SOLUÇÃO ALTERNATIVA - sem usbmodeswitch]

Tayroni, agradeço muito por seu despreendimento postando as informações acima. Entretanto, elas não foram suficientes para resolver meu caso por completo. O sistema ficou muito instável - meu computador travava muitas vezes quando tentava conectar. E eu nao uso intrepid - entao nao pude aproveitar a conveniência do network manager.

Por isso, tive que buscar outra solução. Como é comum com linux, acho que acabei encontrando uma bem simples e rápida que, possivelmente, poderá ser utilizada em várias distribuições e versões. Recomendo para iniciantes.

Meu sistema é o seguinte:
Modem=msa405hs
SO=Ubuntu Hardy Heron (8.04) 32-bit
Carrier=Tim Web
Máquina=Notebook Dell Inspiron 1420

Eu não sou da área e sou bem novo no mundo do software livre então é possível que eu use uns termos incorretos. Mas acho que o resultado que importa.

#######

O dispositivo em questão possui ID dupla: ondamodem (ID 19d2:2000) e modem+memory_card (ID 19d2:0037).

Como se sabe, a Onda/TIM disponilizou software para SO Windows e Mac poder manejar essas duas IDs sem conflito mas não liberou nada pra Linux. A ID 19d2:2000 é justamente para acessar os softwares para esses sistemas suportados pelo fabricante... nao serve pra nada no linux... :/

O que eu faço então para conseguir a ID 19d2:0037 e poder acessar a net e usar o memory card (se houver) é montar e desmontar o aparelho até que ele monte com ID 19d2:0037 - que é quando ele não abre a pasta "ondamodem". Isso parece estressante de princípio, entretanto, uma técnica que tem funcionado mt bem é caso ele monte como ID 19d2:2000, EJETAR O APARELHO MAS NÃO DESENCAIXÁ-LO DO COMPUTADOR. Com isso, ele automaticamente remontará como ID 19d2:0037.. Funcionou 100% das vezes em meu sistema até agora.

Com o dispositivo montado com a ID 19d2:0037, deve-se informar ao computador que ele pode usá-lo como modem através do comando

sudo modprobe usbserial vendor=0x19d2 product=0x0037

Eu transformei esse comando em script pra facilitar a repetição. Ele só precisa ser aplicado uma vez a cada vez que o Ubuntu é iniciado. Não testei se reiniciar o X exigiria reaplicação do mesmo.

Com o dispositivo devidamente montado e autorizado a funcionar como modem, basta apenas configurar uma conexao.

Gostei do gnome-ppp

sudo apt-get install gnome-ppp.

As configuracoes de discagem que usei (abaixo) é um misto do que foi postado acima com o que achei na net pro kppp.  Gostaria que, quem soubesse de algo que possa melhorá-las respondesse a este post porque dei tiro no escuro mesmo.

<gnome-ppp gráfico><tela inicial>
username: tim
password: tim
phone number:*99***1#

<gnome-ppp gráfico><setup><aba modem>
device:/dev/ttyUSB2
type: usb modem
speed: 9600
phone line: tone
volume: high

<gnome-ppp gráfico><setup><aba modem><init strings>
init 2: AT+CGDCONT=1,"IP","tim.br"
Achei num post que é para colocar a string ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 no lugar desta acima. Ainda tô testando isso, mas alguém saberia de algo sobre isso de antemão?

<gnome-ppp gráfico><setup><networking>
Nao mudei nada. Alias, tudo que eu nao citar, eu nao mudei.

<gnome-ppp gráfico><setup><options><desktop integration>
on connection: dock in...

<gnome-ppp gráfico><setup><options><connection>
tudo marcado menos "abort connection if line is busy" e "send custom reply"
idle time: 0


Agora, repito o que o Tayroni escreveu:

Se o firefox der o erro Modo Offline, vá em arquivo > modo offline e desmarque a caixa para que você possa navegar. Para eliminar de vez este erro do modo offline, abra o firefox, digite "about:config" na barra de endereços. Na barra localizar, digite "toolkit.networkmanager.disable" sem as aspas e mude o seu valor para "true" (basta dois cliques em cima).

Flws.
« Última modificação: 21 de Abril de 2009, 11:40 por oceano » Registrado
Páginas: [1] 2 3 4   Ir para o topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Tema desenvolvido por FaBMak e n3t0
Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines
© 2014 Canonical Ltd. Ubuntu e Canonical são marcas registradas da Canonical Ltd.
XHTML 1.0 válido! CSS válido!