Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 612600 vezes)

Offline eng_ividal

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #30 Online: 28 de Março de 2006, 00:34 »
Citação de: "alarcon"
posta aqui o conteúdo do arquivo criado ativar-modem que deve se encontrar em /etc/init.d/ e veja se em /tec/rc2.d/ tem o arquivo S98ativar-modem também.

Agora pelo que vc tá mostrando aqui me parece tudo ok.


conteudo do ativar modem:
#!/bin/sh
modprobe -r nome_do_módulo
modprobe slamr
slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 &
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
"ativar-modem" [readonly] 4L, 105C                                                                         1,1           All
___________________________________________________________________________________________________
AQUI EH O CONTEUDO DA PASTA Q VC PEDIU P/ VERIFICAR

junior@ubuntu-Jr:~$ cd /etc/rc2.d
junior@ubuntu-Jr:/etc/rc2.d$ ls
S05vbesave                 S14ppp               S20powernowd      S89cron
S10acpid                     S19cupsys           S20rsync              S98ativar-modem
S10sysklogd                S19hplip              S20samba            S98usplash
S11klogd                     S20apmd             S25bluez-utils       S99acpi-support
S12dbus                      S20hotkey-setup  S25mdadm           S99fetchmail
S12sl-modem-daemon  S20makedev       S89anacron           S99rmnologin
S13gdm                       S20pcmcia          S89atd                  S99stop-bootlogd
junior@ubuntu-Jr:/etc/rc2.d$
___________________________________________________________________________________________________
ESSE EH O RESULTADO DO lsmod

junior@ubuntu-Jr:~$ lsmod
Module                  Size  Used by
isofs                  32824  1
udf                    75524  0
nls_cp437               5888  2
ntfs                   92016  1
ipv6                  217408  6
rfcomm                 34972  0
l2cap                  22404  5 rfcomm
bluetooth              43012  4 rfcomm,l2cap
cpufreq_userspace       4444  0
cpufreq_stats           5124  0
freq_table              4484  1 cpufreq_stats
cpufreq_powersave       1920  0
cpufreq_ondemand        5916  0
cpufreq_conservative     6820  0
video                  16004  0
tc1100_wmi              6916  0
sony_acpi               5516  0
pcc_acpi               11392  0
hotkey                  9508  0
dev_acpi               11396  0
i2c_acpi_ec             5760  0
button                  6672  0
battery                 9604  0
container               4608  0
ac                      4996  0
floppy                 52692  0
pcspkr                  3652  0
rtc                    11832  0
snd_intel8x0           30144  1
snd_ac97_codec         72188  1 snd_intel8x0
snd_pcm_oss            46368  0
snd_mixer_oss          16128  1 snd_pcm_oss
snd_pcm                78344  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              21764  1 snd_pcm
snd                    48644  8 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixe r_oss,snd_pcm,snd_timer
soundcore               9184  1 snd
snd_page_alloc         10120  2 snd_intel8x0,snd_pcm
slamr                 434088  2
i2c_sis96x              5252  0
i2c_core               19728  2 i2c_acpi_ec,i2c_sis96x
shpchp                 80612  0
pci_hotplug            24628  1 shpchp
sis_agp                 8452  1
agpgart                32328  1 sis_agp
dm_mod                 50364  1
tsdev                   7616  0
evdev                   9088  0
psmouse                26116  0
mousedev               10912  1
parport_pc             31812  1
lp                     11460  0
parport                32072  2 parport_pc,lp
md                     40656  0
ext3                  115976  1
jbd                    48536  1 ext3
thermal                13192  0
processor              23100  1 thermal
fan                     4740  0
sis900                 19456  0
mii                     5248  1 sis900
ehci_hcd               29448  0
ohci_hcd               18564  0
usbcore               104188  3 ehci_hcd,ohci_hcd
ide_cd                 36996  1
cdrom                  33952  1 ide_cd
ide_disk               16128  4
ide_generic             1664  0
sis5513                14472  1
ide_core              125268  4 ide_cd,ide_disk,ide_generic,sis5513
unix                   24624  662
vesafb                  8088  0
capability              5000  0
commoncap               6784  1 capability
vga16fb                12232  1
vgastate                8320  1 vga16fb
softcursor              2432  2 vesafb,vga16fb
cfbimgblt               2944  2 vesafb,vga16fb
cfbfillrect             3840  2 vesafb,vga16fb
cfbcopyarea             4480  2 vesafb,vga16fb
fbcon                  34176  72
tileblit                2560  1 fbcon
font                    8448  1 fbcon
bitblit                 5248  1 fbcon
junior@ubuntu-Jr:~$
__________________________________________________________________________________________________

"DESCULPA PELA QUANTIDADE DE ARQUIVOS POSTADOS EH Q AINDA TO UM POUCO AEREO NESSE ASSUNTO E ACHO Q ASSIM VC TERÁ MAIS INFORMACOES PARA ME AJUDAR. DESDE JA OBRIGADO"
Celeron D 2.66 G
Phitronics P7V800Pro-M (onboard)
1GB memoria DDR400
UBUNTU 6.10 em dual boot com XP

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #31 Online: 28 de Março de 2006, 10:24 »
Citação de: "botinha"
Caro Alacron olhe o seu tutorial este muito bom porém eu encontro dificuldade em ativar o modprobe -r nome do módulo, pois o meu #lsmod responde assim e eu não sei qual digitar....


Olha só pelo que pude ver não aparece nada do que relatei até agora, então no seu cado o passo modprobe -r nome_do_módulo não é para ser feito, pois vc não tem nenhum destes que podem atrapalhar no modem, pelo menos como disse nesta lista que vc colou aqui não aparece nada.

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #32 Online: 28 de Março de 2006, 10:33 »
Citação de: "eng_ividal"
conteudo do ativar modem:
#!/bin/sh
modprobe -r nome_do_módulo
modprobe slamr
slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 & ....


Vc entendeu errado, no arquivo ativar-modem a linha modprobe -r nome_do_módulo deveria ser substituida por modprobe -r snd_atiixp_modem ou modprobe -r snd_intel8x0m ou modprobe -r snd_via82xx_modem se pelo comando lsmod aparecesse um destes módulos aqui: snd_atiixp_modem, snd_intel8x0m ou snd_via82xx_modem e aí o que aparecesse, lá no ativar-modem vc colocarai assim por exemplo: se apareceu o snd_intel8x0m ou  então vc colocaria modprobe -r snd_intel8x0m e não modprobe -r nome_do_modulo como vc colocou aí.

Bom no seu caso deixe o ativar-modem deste jeito:

Citar

#!/bin/sh
modprobe -r snd_intel8x0m
modprobe slamr
slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 &
rm -f /dev/modem
ln -sf /dev/ttySL0 /dev/modem


Otra coisa eu pedi para vc ver se em /etc/rc2.d/ existia o arquivo S98ativar-modem e não para listar todo o conteúdo da pasta /etc/rc2.d/ ok.

Offline eng_ividal

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #33 Online: 28 de Março de 2006, 13:06 »
Caro colega,


                  obrigado pela rapidez na resposta hj a noite eu faço as modificaçoes necessarias e post no grupo. quanto a listar o conteudo da pasta achei melhor fazer isso pois naum tinha certeza do comando q e utilizei e naum tava vendo arquivo  :wink: . até mais
Celeron D 2.66 G
Phitronics P7V800Pro-M (onboard)
1GB memoria DDR400
UBUNTU 6.10 em dual boot com XP

Offline eng_ividal

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
ainda naum funfo
« Resposta #34 Online: 28 de Março de 2006, 23:24 »
1ª tentativa
- Olha só fiz o q vc pediu editei o ativar-modem e deixei da maneira descrita acima mas to com uma duvida naum entendi pq tem o comando: "modprobe -r snd_intel8x0m" ja que entre os arquivos listados pelo lsmod e q eu postei acima naum aparesse esse modulo. Naum sei se foi por isso q naum deu certo.

2ª tentativa
- Refazendo desde a 'Citação:
$ sudo su
Password: sua senha
# killall slmodemd
# modprobe -r slamr
# rm -rf /dev/slamr*'

seguindo todos os passos de forma q naum deu nenhum erro exceto depois q reinicializei e o gnome ainda assim naum reconheceu  o modem. o arquivo ativar-modem ficou desta maneira:


    Citação:

    #!/bin/sh
    modprobe slamr
    slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 &
Celeron D 2.66 G
Phitronics P7V800Pro-M (onboard)
1GB memoria DDR400
UBUNTU 6.10 em dual boot com XP

Offline Bode

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #35 Online: 29 de Março de 2006, 00:16 »
alarcon, fiz oq vc me passou mas não funfou!

tirei uma screen shot mais esqueci de "upa" porém tenho o make e o make install do seu pacote aqui:
Código: [Selecionar]
fabio@penelope:~/modem-arquivos$ sudo dpkg -i smartlink-ubuntu.deb
(Lendo banco de dados ... 74697 arquivos e diretórios atualmente instalados.)
Preparando para substituir smartlink-ubuntu 1.0 (usando smartlink-ubuntu.deb) ...
Descompactando substituto smartlink-ubuntu ...
Instalando smartlink-ubuntu (1.0) ...
slmodemd: nenhum processo abortado
make -C modem all
make[1]: Entrando no diretório `/tmp/slmodem-2.9.11-20051101/modem'
rebuild profile...
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_main.o -c modem_main.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_cmdline.o -c modem_cmdline.cgcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem.o -c modem.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_datafile.o -c modem_datafile.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_at.o -c modem_at.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_timer.o -c modem_timer.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_pack.o -c modem_pack.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_ec.o -c modem_ec.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_comp.o -c modem_comp.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_param.o -c modem_param.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_debug.o -c modem_debug.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o homolog_data.o -c homolog_data.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_sinus.o -c dp_sinus.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_dummy.o -c dp_dummy.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o sysdep_common.o -c sysdep_common.cgcc  -o slmodemd modem_main.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_test.o -c modem_test.c
gcc  -o modem_test modem_test.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o
make[1]: Saindo do diretório `/tmp/slmodem-2.9.11-20051101/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.12-9-386/build
make[1]: Entrando no diretório `/tmp/slmodem-2.9.11-20051101/drivers'
cc -I/lib/modules/2.6.12-9-386/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.12-9-386
make[2]: Entrando no diretório `/tmp/slmodem-2.9.11-20051101/drivers'
make modules -C /lib/modules/2.6.12-9-386/build SUBDIRS=/tmp/slmodem-2.9.11-20051101/drivers
make[3]: Entrando no diretório `/usr/src/linux-headers-2.6.12-9-386'
  CC [M]  /tmp/slmodem-2.9.11-20051101/drivers/amrmo_init.o
  CC [M]  /tmp/slmodem-2.9.11-20051101/drivers/sysdep_amr.o
  CC [M]  /tmp/slmodem-2.9.11-20051101/drivers/st7554.o
  LD [M]  /tmp/slmodem-2.9.11-20051101/drivers/slamr.o
  LD [M]  /tmp/slmodem-2.9.11-20051101/drivers/slusb.o
  Building modules, stage 2.
  MODPOST
Warning: could not find /tmp/slmodem-2.9.11-20051101/drivers/.amrlibs.o.cmd for /tmp/slmodem-2.9.11-20051101/drivers/amrlibs.o
  CC      /tmp/slmodem-2.9.11-20051101/drivers/slamr.mod.o
  LD [M]  /tmp/slmodem-2.9.11-20051101/drivers/slamr.ko
  CC      /tmp/slmodem-2.9.11-20051101/drivers/slusb.mod.o
  LD [M]  /tmp/slmodem-2.9.11-20051101/drivers/slusb.ko
make[3]: Saindo do diretório `/usr/src/linux-headers-2.6.12-9-386'
make[2]: Saindo do diretório `/tmp/slmodem-2.9.11-20051101/drivers'
make[1]: Saindo do diretório `/tmp/slmodem-2.9.11-20051101/drivers'
make -C modem all
make[1]: Entrando no diretório `/tmp/slmodem-2.9.11-20051101/modem'
make[1]: Saindo do diretório `/tmp/slmodem-2.9.11-20051101/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.12-9-386/build
make[1]: Entrando no diretório `/tmp/slmodem-2.9.11-20051101/drivers'
cc -I/lib/modules/2.6.12-9-386/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.12-9-386
make[2]: Entrando no diretório `/tmp/slmodem-2.9.11-20051101/drivers'
make modules -C /lib/modules/2.6.12-9-386/build SUBDIRS=/tmp/slmodem-2.9.11-20051101/drivers
make[3]: Entrando no diretório `/usr/src/linux-headers-2.6.12-9-386'
  Building modules, stage 2.
  MODPOST
Warning: could not find /tmp/slmodem-2.9.11-20051101/drivers/.amrlibs.o.cmd for /tmp/slmodem-2.9.11-20051101/drivers/amrlibs.o
make[3]: Saindo do diretório `/usr/src/linux-headers-2.6.12-9-386'
make[2]: Saindo do diretório `/tmp/slmodem-2.9.11-20051101/drivers'
make[1]: Saindo do diretório `/tmp/slmodem-2.9.11-20051101/drivers'
make install -C drivers KERNEL_DIR=/lib/modules/2.6.12-9-386/build
make[1]: Entrando no diretório `/tmp/slmodem-2.9.11-20051101/drivers'
cc -I/lib/modules/2.6.12-9-386/build/include -o kernel-ver kernel-ver.c
mkdir -p /dev
mknod -m 600 /dev/slamr0 c 242 0 ;   mknod -m 600 /dev/slamr1 c 242 1 ;   mknod -m 600 /dev/slamr2 c 242 2 ;   mknod -m 600 /dev/slamr3 c 242 3 ;  echo -n
mknod -m 600 /dev/slusb0 c 243 0 ;   mknod -m 600 /dev/slusb1 c 243 1 ;   mknod -m 600 /dev/slusb2 c 243 2 ;   mknod -m 600 /dev/slusb3 c 243 3 ;  echo -n
make install KERNEL_VER=2.6.12-9-386
make[2]: Entrando no diretório `/tmp/slmodem-2.9.11-20051101/drivers'
install -D -m 644 slamr.ko /lib/modules/2.6.12-9-386/extra/slamr.ko
install -D -m 644 slusb.ko /lib/modules/2.6.12-9-386/extra/slusb.ko
/sbin/depmod -a
make[2]: Saindo do diretório `/tmp/slmodem-2.9.11-20051101/drivers'
make[1]: Saindo do diretório `/tmp/slmodem-2.9.11-20051101/drivers'
install -D -m 755 modem/slmodemd /usr/sbin/slmodemd
rm -f -rf /var/lib/slmodem
install -d -D -m 755 /var/lib/slmodem
error: mdm setup: cannot open dev `/dev/slamr0': No such device
error: cannot setup device `/dev/slamr0'



vc viu a msg de warning???

será que pode ser por isso???




grato




depois posto a screenshot

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #36 Online: 29 de Março de 2006, 10:36 »
eng ividal e Bode é muito estranho o que ocorre com vcs pq se estão seguindo corretamente o que falei não era para ocorrer isso como tem o caso da gisele que tem o mesmo tipo de modem que um de vcs (não lembro agora quem) e foi tudo blz, mas eu já fiz um outro arquivo compactado com tudo dentro que é necessário para ativar o modem, inclusive os compiladores e testei numa outra partição onde tive que instalar novamente o Ubuntu 5.10 da fora original, pois o meu já está bastante modificado. Este novo pacote funcionou perfeitamente no meu teste aqui e o que os usuários teram de fazer é só descompactar o arquivo, entrar nele, dar permissão de execução para o script que tem lá e responder algumas perguntas no processo de instalação.

Bom este arquivo é semelhante ao anterior com algumas modificações, primeiro daquele erro de digitação e segundo, mudei uns passos no pacote Debian que fiz responsável pela ativação do modem propriamente dito( smartlink-ubuntu.deb ) que ficou mais genérico, pois da forma que estava ele era um pouco particular e não abrangia os seus modems que da forma como falo manualmente), não está dando certo, mas está do jeito que eu acho que daria certo, no entanto não é garantido ainda.

Agora só terei condições de fazer o upload no final de semana, então aguardem.

Queria saber de vcs dois qual foi a forma de obtenção do Ubuntu 5.10 e caso tiver sido pela ISO da internet vcs tiveram o cuidado de verificar o md5sum de sua ISO antes de gravar no CD para verificar a integridade do arquivo baixado.

Bom depois de pegar este novo arquivo que vou dizer o link depois, seria melhor reinstalar o Ubuntu 5.10 para que a chance de acerto seja melhor desta vez.

Se mais uma vez ainda não der certo, então como ultima opção para vcs restará a instalação do driver da Smartlink não mais da forma tradicional, mais sim da forma para  o caso ALSA. Qualquer coisa entrem em contato comigo via MSN no final de semana que estarei online.

wpinho

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #37 Online: 29 de Março de 2006, 10:51 »
Olá Alarcon !

Cara, estou seguindo seu tutorial para tentar instalar meu modem (intel 537ep), pelo menos a parte de preparação do ambiente (kernel-source, gcc, cpp ....) enfim, instalei os seguintes pacotes + o gcc 3.4

Citar

make
gcc
  -binutils
  -gcc-4.0
     
build-essential
 -dpkg-dev
 -g++
 -g++-4.0
 -libc6-dev
 -libstdc++6-4.0-dev
 -linux-kernel-headers

linux-headers-2.6.12-9-386
 -linux-headers-2.6.12-9


o problema cara é que nem consigo compilar o bendito driver   :?

o erro é o seguinte:


Citar

diff: /boot/vmlinuz.autoconf.h: Arquivo ou diretório não encontrado
   autoconf.h matches running kernel
diff: /boot/vmlinuz.version.h: Arquivo ou diretório não encontrado
   version.h matches running kernel
2.6.12-9-386


realmente não entendo, qual pacote preciso agora  :?:
seu eu conseguir pelo menos compilar o driver, a parte de instalação eu tentarei seguir tutoriais voltados para o modem intel, meu grande problema é a preparação do ambiente !

Se eu não conseguir cara, vou tomar uma atitude mais ousada e partir para outro modem, talvez o smartlink (esse seria o 3º modem, já saí do lucent v92 para o intel 537ep :cry:   )

meu SO é o Ubuntu 5.10 (32 bits)

cara, vai desculpando aí o incomodo mas se puder me ajudar, realmente ficarei muito agradecido  :)

[]'s

Offline eng_ividal

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #38 Online: 29 de Março de 2006, 12:06 »
Citação de: "alarcon"
eng ividal e Bode é muito estranho o que ocorre com vcs pq se estão seguindo corretamente o que falei não era para ocorrer isso como tem o caso da gisele que tem o mesmo tipo de modem que um de vcs (não lembro agora quem) e foi tudo blz, mas eu já fiz um outro arquivo compactado com tudo dentro que é necessário para ativar o modem, inclusive os compiladores e testei numa outra partição onde tive que instalar novamente o Ubuntu 5.10 da fora original, pois o meu já está bastante modificado. Este novo pacote funcionou perfeitamente no meu teste aqui e o que os usuários teram de fazer é só descompactar o arquivo, entrar nele, dar permissão de execução para o script que tem lá e responder algumas perguntas no processo de instalação.

Bom este arquivo é semelhante ao anterior com algumas modificações, primeiro daquele erro de digitação e segundo, mudei uns passos no pacote Debian que fiz responsável pela ativação do modem propriamente dito( smartlink-ubuntu.deb ) que ficou mais genérico, pois da forma que estava ele era um pouco particular e não abrangia os seus modems que da forma como falo manualmente), não está dando certo, mas está do jeito que eu acho que daria certo, no entanto não é garantido ainda.

Agora só terei condições de fazer o upload no final de semana, então aguardem.

Queria saber de vcs dois qual foi a forma de obtenção do Ubuntu 5.10 e caso tiver sido pela ISO da internet vcs tiveram o cuidado de verificar o md5sum de sua ISO antes de gravar no CD para verificar a integridade do arquivo baixado.

Bom depois de pegar este novo arquivo que vou dizer o link depois, seria melhor reinstalar o Ubuntu 5.10 para que a chance de acerto seja melhor desta vez.

Se mais uma vez ainda não der certo, então como ultima opção para vcs restará a instalação do driver da Smartlink não mais da forma tradicional, mais sim da forma para  o caso ALSA. Qualquer coisa entrem em contato comigo via MSN no final de semana que estarei online.



alarcom,

             obrigado pela assistencia infelizmente naum deu certo ainda ontem apos ter postado isso segui aquela sua 2ª orientaçao para instalar levando em consideraçao o a edicao do arquivo e instalando somente o o pacote necessário com aquele comando q vc me envio fiz todas as configurações necessarias infelizmente naum deu certo e vi uma msg na hora q estava reiniciando o ubuntu dizendo q o driver da smartlink naum seria carregado.

            quanto à forma q consegui o ubuntu foi por meio daqueles cd que eles dão no site.

            entao é isso vou reinstalar o sistema na sexta e esse final de semana lhe add no msn e se vc ja estiver postado o link eu tento novamente, "NAUM DESISTO NUNCA. RSRS". e levo isso como aprendizado.
Celeron D 2.66 G
Phitronics P7V800Pro-M (onboard)
1GB memoria DDR400
UBUNTU 6.10 em dual boot com XP

Carlos Costa

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #39 Online: 31 de Março de 2006, 01:25 »
Puxa! Valeu mesmo pela dica Alarcon!
MUITO OBRIGADO MESMO!

Meu modem é um LG (Netodragon) e já tava há dias tentando sem sucesso.
Sempre dava vários erros durante a compilação.
Segui a tua dica e finalmente instalou, mas tive o mesmo problema do Bode.
Este felizmente eu sabia resolver.
Tô postando agora usando o Ubuntu, conectado com o LG.
Aqui depois do dmesg também apareceu :
slamr: device 10b9:5459 is grabbed by another driver

Eu baixei este arquivo:
http://linmodems.technion.ac.il/packages/smartlink/ungrab-winmodem.tar.gz

Compilei o módulo usando
$make
$make install

Depois coloquei ele junto com os outros modulos:
$cp ungrab-winmodem.ko  /lib/modules/2.6.12-9-386/extra/
$depmod -a

E então segui a seqüencia da dica para carregar o módulo, carregando antes este módulo novo ungrab-winmodem

$modprobe -r slamr
$modprobe ungrab-winmodem
$modprobe slamr

Criei o link para /dev/modem:

$ln -sf /dev/ttySL0 /dev/modem

E finalmente consegui fazer o modem funcionar.

O conteúdo do arquivo ativar-modem no meu ficou assim:

$#!/bin/sh
modprobe -r slamr
modprobe ungrab-winmodem
modprobe slamr
slmodemd --country=BRAZIL --perm=0666 /dev/slamr0&
ln -sf /dev/ttySL0 /dev/modem


Alarcon, mais uma vez muito obrigado.

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #40 Online: 31 de Março de 2006, 10:16 »
Caro Carlos Costa, quando os dois usuários acima, Bode e eng ividal, falaram que não estavam conseguindo obter sucesso na instalação eu pedia a eles que postassem o resultado do comando dmesg | grep slamr justamente para ver se eles precisariam do arquivo ungrab-winmodem.tar.gz conforme a resposta retornada pelo comando anterior.

Só que esta resposta que dá, ...is grabbed by another drive, indica que outro driver estaria atrapalhando o slamr pq ele já estava em uso e que seria o módulo snd_atiixp_modem ou snd_intel8x0m ou mais ainda snd_via82xx_modem e por isso eu peço para os usuários verificarem qual está presente no seu sistema para desativar e usar o driver da Smartlink da maneira padrão, pois pode se usar da forma ALSA que passa a usar estes módulos aí.

Agora com relação ao ungrab-winmodem.tar.gz sempre achei que só deveria usar ele se ao dar o comando dmesg | grep slamr ele retornasse como resposta algo assim: ...is grabbed by driver serial e não isso ...is grabbed by another driver como é o caso em questão.

Até no meu caso ocorria isso, aparecia a mensagem ... is grabbed by another driver após o comando dmesg | grep slamr,  e eu cheguei a usar o ungrab-winmodem sem sucesso e foi aí que vi que o snd_via82xx_modem, pelo comando lsmod, estava ativo e atrapalhando a utilização do driver da Smartlink e foi só desativá-lo para  que desse tudo certo.

Por isso de cara eu não indiquei para estes outros usuários o ungrab-winmodem.tar.gz por não encontrar nas respostas do dmesg | grep slamr deles esta informação: ...is grabbed by driver serial que pelo menos é a que indica como o caso a se usar o arquivo ungrab-winmodem.tar.gz .

Mas vai entender né...

Se para vc funcionou assim, então vou falar para os outros tentarem isso caso eles mesmos já não tenham visto sua mensagem aqui.

Obrigado pelos agradecimentos e a comunidade está aqui é para isso mesmo, ou seja, ajudar uns aos outros. :-)

Por fim quero dizer que já preparei um pacote .tar.gz com tudo que é necessário para instalar o modem (driver Smartlink) para a forma padrão e a forma ALSA tudo de maneira automática e já testei aqui em outra partição com o Ubuntu 5.10 e comigo funcionou perfeitamente, portanto aguardem que somente no final de semana terei tempo de fazer o upload e disponibilizar o link para download e as instruções de uso Ok.

Offline eng_ividal

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
to quase lah ou ja cheguei???!!!!
« Resposta #41 Online: 31 de Março de 2006, 18:04 »
Alarcon,

           como eu faco pra saber se meu modem esta configurado, pois reinstalei o ubuntu segui o 1° tutorial e deu tudo certo reiniciei abri o gnome-ppp coloquei o numero e o meu login da oi mas naum consegui conectar apareceu essa msg no registro e também naum ouvi nem um som do modem.


--> WvDial: Internet dialer version 1.54.0
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L3DT15002031
--> Waiting for carrier.
ATM1L3DT15002031
CONNECT 49333
--> Carrier detected.  Waiting for prompt.
--> Connected, but carrier signal lost!  Retrying...
--> Sending: ATM1L3DT15002031
--> Waiting for carrier.
                              CE-AM-SAR58-02
             PROIBIDO ACESSO NAO AUTORIZADO
             FORBIDDEN UNAUTHORIZED ACCESS
UQKT2
User Access Verification
Username:
Username:
Username:
NO CARRIER
--> No Carrier!  Trying again.
--> Maximum Attempts Exceeded..Aborting!!
--> Disconnecting at Fri Mar 31 20:43:17 2006
Celeron D 2.66 G
Phitronics P7V800Pro-M (onboard)
1GB memoria DDR400
UBUNTU 6.10 em dual boot com XP

alarcon

  • Visitante
Re: to quase lah ou ja cheguei???!!!!
« Resposta #42 Online: 31 de Março de 2006, 23:51 »
Citação de: eng_ividal
Alarcon,
           como eu faco pra saber se meu modem esta configurado, pois reinstalei o ubuntu segui o 1° tutorial e deu tudo certo reiniciei abri o gnome-ppp coloquei o numero e o meu login da oi mas naum consegui conectar apareceu essa msg no registro e também naum ouvi nem um som do modem. ...
]

Bom veja este tópico aqui que eu tiro exatamente uma dúvida sobre a configuração do gnome-ppp:

http://ubuntuforum-pt.org/index.php?topic=15

Caso seguindo estas dicas aí continue sem conectar talvez seja preciso vc informar o DNS que não é automático, portanto entre em contato novamente.
« Última modificação: 01 de Julho de 2006, 21:05 por Perícope »

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #43 Online: 01 de Abril de 2006, 00:37 »
Como prometido o novo arquivo compactado com todos os compiladores necessários, o gnome-ppp e um script de instalação de tudo de forma automática e mais um pacote elaborado por mim cujo nome é smartlink-ubuntu.deb que contém o driver mais recente da Samrtlink e um script para instalação automática do modem para duas formas a padrão chamada por mim de Original e a ALSA se encontra no seguinte link:

http://www.ubuntuforum-pt.org/index.php?topic=4204&postdays=0&postorder=asc&start=20

Vejam lá todas as instruções de uso e etc.
« Última modificação: 01 de Julho de 2006, 21:20 por Perícope »

Offline Bode

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Tutorial para HSP56 MR driver Smartlink
« Resposta #44 Online: 01 de Abril de 2006, 00:43 »
Alarcon, cara estou mto grato pela sua ajuda, sem vc não teria consegido compilar o driver da SmartLink, vlw msm!  Por acaso vc é o alarcon do fórum do Kurumin também???



Carlos, vc! É, vc msm!


VC SALVOU MEU PC!


Meu modem, igual ao seu, tá funfano agora msm! Nesse instante! Vlw cara, vlw msm!