Autor Tópico: Impossibilidade de instalação de aplicações  (Lida 237 vezes)

Offline rafaelsa97

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Impossibilidade de instalação de aplicações
« Online: 01 de Outubro de 2017, 17:49 »
Boa noite!

Estou tendo problemas na instalação na instalação de qualquer aplicação. O exemplo mostrado abaixo é relativo a instalação do IDLE. Tentei instalar o programa usando o seguinte comando:

sudo apt-get install idle

Entretanto, eis aí a mensagem de erro obtida:

A ler as listas de pacotes... Pronto
A construir árvore de dependências
A ler a informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
linux-headers-4.2.0-36 linux-headers-4.2.0-36-generic
linux-image-4.2.0-36-generic linux-image-extra-4.2.0-36-generic
Utilize 'apt-get autoremove' para os remover.
Os seguintes pacotes extra serão instalados:
blt idle-python2.7 python-tk tk8.6-blt2.5
Pacotes sugeridos:
blt-demo tix python-tk-dbg
Serão instalados os seguintes NOVOS pacotes:
blt idle idle-python2.7 python-tk tk8.6-blt2.5
0 pacotes actualizados, 5 pacotes novos instalados, 0 a remover e 0 não actualizados.
É necessário obter 244 kB/850 kB de arquivos.
Após esta operação, serão utilizados 3.471 kB adicionais de espaço em disco.
Deseja continuar? [S/n] s
AVISO: Os seguintes pacotes não podem ser autenticados!
tk8.6-blt2.5 blt python-tk idle-python2.7 idle
Instalar estes pacotes sem verificação? s/N] s
Err http://br.archive.ubuntu.com/ubuntu/ wily/main idle-python2.7 all 2.7.10-4ubuntu1
404 Not Found [IP: "XXX"]
E: Falhou obter http://br.archive.ubuntu.com/ubuntu/pool/main/p/python2.7/idle-python2.7_2.7.10-4ubuntu1_all.deb 404 Not Found [IP: "XXX"]

E: Não foi possível obter alguns arquivos, tente talvez correr apt-get update ou tente com --fix-missing?

O que poderia estar causando este problema? Como posso corrigi-lo? Peço desculpas previamente, sou um usuário novo do Linux.

Caso seja necessário, minha versão é a 15.10
« Última modificação: 01 de Outubro de 2017, 17:53 por rafaelsa97 »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.232
    • Ver perfil
Re:Impossibilidade de instalação de aplicações
« Resposta #1 Online: 01 de Outubro de 2017, 21:07 »
Caso seja necessário, minha versão é a 15.10

A lista de repositórios no seu sistema está confusa, está enroscando numa entrada que menciona o "Wily", que corresponde à versão 15.10 do Ubuntu, que é uma versão vencida, acabou, já era, não tem mais suporte, não há mais manutenção.

Qual versão do Ubuntu tem aí instalada, você disse que é a 15.10, é isso mesmo?

Código: [Selecionar]
lsb_release -rd&&echo "${XDG_CURRENT_DESKTOP}"
Na escolha de qual versão instalar se deve levar em conta que:

O Ubuntu versão 17.04, codename Zesty, é uma versão transitória, não é algo para usar em produção real.
Em produção se usa versão LTS, Long Term Support, cujo prazo do suporte é de 5 anos.
As LTS atuais são as versões 14.04 e 16.04.
Versões transitórias extinguem-se em apenas 9 meses, é só confusão, é apenas experimento.
O que funciona bem é aproveitado numa próxima versão LTS, o que não funciona é descartado, é assim que funciona.

Isso na essência significa que **não** se deve usar uma versão transitória para assuntos sérios e instalações de produção no dia a dia de trabalho, sendo mais adequado optar sempre por versões LTS.

Na identificação numérica das versões os dois primeiros números referem-se ao ano, os dois últimos ao mês, assim, 14.04 é lançamento de abril de 2014, e então 16.04 é lançamento em abril de 2016 e assim por diante. O terceiro e último número, quando existe, refere-se ao release (14.04.5 ou 16.04.3).

Versões LTS são suportadas por 5 anos, versões  chamadas Regular (=Provisória) são suportadas por 9 meses.

Para entender melhor o calendário geral de validade e suporte de todas as versões

Ubuntu releases calendar

https://wiki.ubuntu.com/Releases

Complementarmente também esse:

https://wiki.ubuntu.com/LTS

Mais especificamente aqui:

https://www.ubuntu.com/info/release-end-of-life
« Última modificação: 01 de Outubro de 2017, 21:13 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline rafaelsa97

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re:Impossibilidade de instalação de aplicações
« Resposta #2 Online: 01 de Outubro de 2017, 21:43 »
Caso seja necessário, minha versão é a 15.10

A lista de repositórios no seu sistema está confusa, está enroscando numa entrada que menciona o "Wily", que corresponde à versão 15.10 do Ubuntu, que é uma versão vencida, acabou, já era, não tem mais suporte, não há mais manutenção.

Qual versão do Ubuntu tem aí instalada, você disse que é a 15.10, é isso mesmo?

Código: [Selecionar]
lsb_release -rd&&echo "${XDG_CURRENT_DESKTOP}"
Na escolha de qual versão instalar se deve levar em conta que:

O Ubuntu versão 17.04, codename Zesty, é uma versão transitória, não é algo para usar em produção real.
Em produção se usa versão LTS, Long Term Support, cujo prazo do suporte é de 5 anos.
As LTS atuais são as versões 14.04 e 16.04.
Versões transitórias extinguem-se em apenas 9 meses, é só confusão, é apenas experimento.
O que funciona bem é aproveitado numa próxima versão LTS, o que não funciona é descartado, é assim que funciona.

Isso na essência significa que **não** se deve usar uma versão transitória para assuntos sérios e instalações de produção no dia a dia de trabalho, sendo mais adequado optar sempre por versões LTS.

Na identificação numérica das versões os dois primeiros números referem-se ao ano, os dois últimos ao mês, assim, 14.04 é lançamento de abril de 2014, e então 16.04 é lançamento em abril de 2016 e assim por diante. O terceiro e último número, quando existe, refere-se ao release (14.04.5 ou 16.04.3).

Versões LTS são suportadas por 5 anos, versões  chamadas Regular (=Provisória) são suportadas por 9 meses.

Para entender melhor o calendário geral de validade e suporte de todas as versões

Ubuntu releases calendar

https://wiki.ubuntu.com/Releases

Complementarmente também esse:

https://wiki.ubuntu.com/LTS

Mais especificamente aqui:

https://www.ubuntu.com/info/release-end-of-life

Boa noite!

Sobre a versão e kernel:
Description:   Ubuntu 15.10
Release:   15.10
Unity

Linux 4.2.0-42-generic #49-Ubuntu SMP Tue Jun 28 21:26:26 UTC 2016 x86_64

Sobre o fim do suporte, o que você indica? Seria melhor instalar mesmo uma versão mais nova do Ubuntu? Em caso afirmativo, há alguma maneira fácil, utilizando o próprio terminal ou alguma outra funcionalidade do sistema?
« Última modificação: 01 de Outubro de 2017, 21:46 por rafaelsa97 »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.232
    • Ver perfil
Re:Impossibilidade de instalação de aplicações
« Resposta #3 Online: 01 de Outubro de 2017, 21:49 »
Description:   Ubuntu 15.10
Release:   15.10
Unity
Sobre o fim do suporte, o que você indica? Seria melhor instalar mesmo uma versão mais nova do Ubuntu? Em caso afirmativo, há alguma maneira fácil, utilizando o próprio terminal ou alguma outra funcionalidade do sistema?

Pois então, @rafaelsa97,

É imprescindível ir para uma versão atual.
Essa 15.10 não tem mais suporte, não serve mais para nada.
O melhor é sempre fazer uma atualização "limpa", para não levar problemas de uma para outra.
Porém, se não for mesmo conveniente no momento, pode atualizar dessa já instalada para a versão 16.04.
Preferencialmente use a versão 16.04 que é a LTS atual.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.232
    • Ver perfil
Re:Impossibilidade de instalação de aplicações
« Resposta #4 Online: 01 de Outubro de 2017, 21:53 »
Tem muito material por aí tratando de como fazer uma instalação ou upgrade de versão.

Como simples exemplo, consulte esse artigo:

Como Atualizar para o Ubuntu 16.04 LTS

https://www.digitalocean.com/community/tutorials/como-atualizar-para-o-ubuntu-16-04-lts-pt

« Última modificação: 01 de Outubro de 2017, 22:09 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.