Autor Tópico: Ubuntu 16.04 - Problema na atualização  (Lida 541 vezes)

Offline gwarah

  • Usuário Ubuntu
  • *
  • Mensagens: 77
    • Ver perfil
Ubuntu 16.04 - Problema na atualização
« Online: 21 de Setembro de 2017, 10:30 »
Aí turma, tive recentemente um problema na atualização e estou repassando como resolvi. Ao rodar a atualização padrão:

Código: [Selecionar]
# sudo apt-get update
# sudo apt-get dist-upgrade

Apareceu este erro relacionado ao java:

Código: [Selecionar]
Obter:1 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial/main amd64 oracle-java8-unlimited-jce-policy all 8u144-1~webupd8~0 [9.352 B]
Baixados 9.352 B em 0s (12,8 kB/s)                           
Pré-configurando pacotes ...
dpkg: problemas com dependências impedem o processamento de triggers para shared-mime-info:
 shared-mime-info depende de libxml2 (>= 2.7.4); porém:
  Pacote libxml2:amd64 não está configurado ainda.

dpkg: erro ao processar o arquivo /var/cache/apt/archives/oracle-java8-unlimited-jce-policy_8u144-1~webupd8~0_all.deb (--unpack):
 problemas com dependências - a deixar triggers por processar
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/oracle-java8-unlimited-jce-policy_8u144-1~webupd8~0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Só foi corrigido ao rodar esta atualização separadamente:

Código: [Selecionar]
# sudo apt-get install libxml2
Após este comando, ele também aplicou as atualizações pendentes do apt-get anterior.  Só depois disso foi que pude completar a atualização do java:

Código: [Selecionar]
# sudo apt-get dist-upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os pacotes a seguir serão atualizados:
  oracle-java8-unlimited-jce-policy
1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 0 B/9.352 B de arquivos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Pré-configurando pacotes ...
(Lendo banco de dados ... 304174 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../oracle-java8-unlimited-jce-policy_8u144-1~webupd8~0_all.deb ...
oracle-license-v1-1 license has already been accepted
A descompactar oracle-java8-unlimited-jce-policy (8u144-1~webupd8~0) sobre (8u131-1~webupd8~2) ...
Configurando oracle-java8-unlimited-jce-policy (8u144-1~webupd8~0) ...
Installing from local file /var/cache/oracle-jdk8-installer/jce_policy-8.zip
Removing outdated cached downloads...
removido 'UnlimitedJCEPolicyJDK8/local_policy.jar'
removido 'UnlimitedJCEPolicyJDK8/US_export_policy.jar'
removido 'UnlimitedJCEPolicyJDK8/README.txt'
removed directory 'UnlimitedJCEPolicyJDK8'
Archive:  jce_policy-8.zip
   creating: UnlimitedJCEPolicyJDK8/
  inflating: UnlimitedJCEPolicyJDK8/local_policy.jar 
  inflating: UnlimitedJCEPolicyJDK8/README.txt 
  inflating: UnlimitedJCEPolicyJDK8/US_export_policy.jar 
Unlimited JCE Policy for Oracle Java 8 istalled

Só não me perguntem por que esta atualização teve de ser aplicada separadamente. Espero ter ajudado.

Um abraço.  ;)
« Última modificação: 23 de Setembro de 2017, 17:53 por gwarah »
"Cantar a beleza de ser um eterno aprendiz" (Gonzaguinha)