Autor Tópico: Libreoffice Base  (Lida 1650 vezes)

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.855
    • Ver perfil
Re:Libreoffice Base
« Resposta #45 Online: 28 de Julho de 2017, 01:29 »
Dando seguimento ao raciocínio, supondo que tenha feito o quanto consta do post #41 e #42.
Se mais adiante vier a ter algum problema ou sei lá o que e queira ir para o kernel 4.4 mencionado pelo @galactus, então é fazer:

Código: [Selecionar]
sudo apt install linux-generic-lts-xenial
Isso irá instalar o kernel 4.4

Por via das dúvidas faça também:

Código: [Selecionar]
sudo update-grub
Reinicie o sistema, inicie pelo kernel 4.4 recém-instalado, escolhendo ele lá no menu do grub.

Agora atualize tudo fazendo:

Código: [Selecionar]
sudo apt update
Código: [Selecionar]
sudo apt dist-upgrade
Se tudo estiver funcionando à contento, então remova o kernel 4.8.0-36 da era anterior.

Código: [Selecionar]
sudo apt-get remove --purge linux-image-4.8.0-36-generic
Mesma coisa que antes, confirme se removeu mesmo:

Código: [Selecionar]
dpkg-query -l | awk '/linux-image-*/ {print $2}'
Atualize o grub:

Código: [Selecionar]
sudo update-grub
O kernel 4.8.0.36 deverá ter desaparecido lá da lista do menu do grub, a tela inicial do sistema.

« Última modificação: 28 de Julho de 2017, 01:37 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.855
    • Ver perfil
Re:Libreoffice Base
« Resposta #46 Online: 28 de Julho de 2017, 01:34 »
Finalmente, esquece tudo isso que foi feito e faz uma nova instalação a partir do live-iso (pendrive ou cdrom) da versão 16.04.1, a qual tem por base o kernel 4.4 e *não* irá atualizar para a versão 4.8.

Estará, então, feita a solução nuclear.  :)

Mas sinceramente acho que o sistema sobrevive sem a solução nuclear, adotando qualquer um dos dois procedimentos anteriores, questão de ver e testar.

Claro que se é mesmo um ambiente de trabalho, em que a segurança e continuidade disso é importante, então a solução nuclear, propiciando uma nova instalação, é realmente a mais adequada.

Independentemente disso, lembre-se sempre que **só o backup salva, o resto é tentativa**

Instalar um sistema assim e assado sempre será possível, é apenas uma questão de umas horinhas a mais ou a menos, porém os seus dados, os arquivos pessoais, esses são essenciais e não podem ser obtidos de outra forma, então tenha sempre um backup **externo** seguro e confiável para que possa ter a tranquilidade de instalar e desinstalar qualquer coisa sempre.

É isso!  :)

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #47 Online: 28 de Julho de 2017, 01:42 »
Druidaobelix, Galacticus,

vcs são demais. Vou continuar com a versão 4.8 que não está com problemas. Já bloquiei a atualização do 4.8, desinstalei a versão 4.10, e meu sistema entra direto na versão 4.8.

Caso apareça algum problema, vou para versão 4.4 como dito no post anterior

Mais uma vez obrigado por tudo

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.390
    • Ver perfil
Re:Libreoffice Base
« Resposta #48 Online: 28 de Julho de 2017, 02:28 »
Favor colocar um resolvido no tópico!
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.855
    • Ver perfil
Re:Libreoffice Base
« Resposta #49 Online: 28 de Julho de 2017, 03:41 »
Favor colocar um resolvido no tópico!

He, he, aí já vai ser mais difícil, o tópico não é dele, não é do @loalexandre77  :)
O tópico foi originalmente criado pelo @Marcio Cruz
Ele pegou 'carona' no tópico a partir do post #3.

Aproveitando a deixa:

Então @loalexandre77, como você tem cadastro e abriu um tópico lá no Fórum do LibreOffice, que aliás, diga-se de passagem, o mérito da solução veio de lá, da valiosa contribuição do @grafeno que indicou o 'caminho das pedras', nós aqui apenas operacionalizamos a dica que ele deu, baseado na importante experiência pessoal dele, pois bem, será de potencial utilidade se lá naquela tópico do Fórum LibreOffice você fizer a gentileza de levar para lá a informação que o assunto foi também tratado aqui e indicar o link deste tópico.
Ou seja, faça um post lá informando isso e o link deste tópico daqui.
Esse cruzamento de informações pode facilitar a vida de outras pessoas que venham a enfrentar idêntico problema e que venham a consultar aquele importante Fórum.
É uma forma de contribuir com a comunidade opensource, facilitando a difusão do conhecimento.
« Última modificação: 28 de Julho de 2017, 03:42 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.390
    • Ver perfil
Re:Libreoffice Base
« Resposta #50 Online: 28 de Julho de 2017, 06:20 »
Nossa druidaobelix, você está certo mesmo! 

Deixa que eu arrumo!
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.855
    • Ver perfil
Re:Libreoffice Base
« Resposta #51 Online: 28 de Julho de 2017, 15:42 »
Então, @loalexandre77

Mais uma pitada de acabamento, por cautela, faça o "pinning" também dos arquivos abaixos, **adicione** ao conteúdo daquele arquivo "preferences" do apt criado no post #41 o conteúdo adiante.

Para abrir o arquivo para poder editar:

Código: [Selecionar]
sudo gedit /etc/apt/preferences.d/preferences
Então adicione, copie aqui e cole lá:

Código: [Selecionar]
Package: linux-generic-hwe-16.04
Pin: version 4.10.0.28.31
Pin-Priority: 1000

Package: xserver-xorg-core-hwe-16.04
Pin: version 2:1.19.3-1ubuntu1~16.04.2
Pin-Priority: 1000

Package: xserver-xorg-input-all-hwe-16.04
Pin: version 1:7.7+16ubuntu3~16.04.1
Pin-Priority: 1000

Package: xserver-xorg-video-all-hwe-16.04
Pin: version 1:7.7+16ubuntu3~16.04.1
Pin-Priority: 1000

Salvar e sair
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.855
    • Ver perfil
Re:Libreoffice Base
« Resposta #52 Online: 28 de Julho de 2017, 16:23 »
Talvez a questão de fundo esteja associada ao motor Java e o bug seja esse:


linux-image-4.10.0-24-generic, linux-image-4.8.0-56-generic, linux-image-4.4.0-81-generic, linux-image-3.13.0-121-generic Regression: many user-space apps crashing

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1699772

Vários dos relatos no bug descrevem a ocorrência no LibreOffice Base, embora não apenas nele, a regressão é mais ampla, afeta vários e vários programas.

Citar
Damjan Jovanovic (damjan-jov) wrote on 2017-06-23:

This is a ***MASSIVE REGRESSION*** affecting many or even all native applications that use the Java Invocation API, including at least Eclipse (crashes a few seconds after startup), and LibreOffice Base with any JDBC database connector (instant crash as soon as it tries to load the JVM).

Damjan Jovanovic (damjan-jov) wrote on 2017-06-29:

4.4.0-83 fixes Eclipse, but LibreOffice Base still crashes with JDBC drivers.

Norbert (nrbrtx) wrote on 2017-07-05:

I can confirm that LibreOffice Base is crashing on Ubuntu 17.04 during database creation (launched Base, in 'Database Wizard' selected 'Create a new database', 'Embedded database:' -> 'HSQLDB Embedded', click 'Next', click 'Finish', save database file in /tmp/db.odb). After that Base is crashing silently.
I can't install libreoffice-dbg package on zesty (I reported bug 1702556 about it).
LibreOffice Writer does not crash in Zesty.

Todavia, há uma nota indicando que o team Kernel já está ciente e providenciando um patch:

Citar
Norbert (nrbrtx) wrote on 2017-06-24:

Current state of the problem: Ubuntu kernel developers will prepare new patch in a few days (see https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2017-June/017507.html).

John Johansen:
"The kernel team is aware of the issue, and will be releasing updated
kernels when they are available.

There are currently no plans to revert the kernel patch until the
replacement patches are ready due to the nature of the security
vulnerability. If the regression is preventing you from using the
applications you require then we currently recommend you reboot into
the previous kernel."
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.390
    • Ver perfil
Re:Libreoffice Base
« Resposta #53 Online: 28 de Julho de 2017, 17:00 »
Essa segunda resposta sobre o patch é ótima!

Basicamente eles não vão mexer em nada até atingir um caráter de segurança e você que volte a usar o kernel que funcionava!

Uma correção de vulnerabilidade do kernel quebrou com as aplicações que usam Java!

Afeta muitas versões de kerneis diferentes, novos e antigos.

Para as empresas a correção saiu primeiro né!  Já tem uma lista dos kerneis corrigidos para o 16.04:

linux-image-4.4.0-83-generic 4.4.0-83.106
linux-image-powerpc-e500mc 4.4.0.83.89
linux-image-4.4.0-1063-snapdragon 4.4.0-1063.68
linux-image-aws 4.4.0.1022.25
linux-image-4.4.0-83-powerpc-smp 4.4.0-83.106
linux-image-4.4.0-83-powerpc-e500mc 4.4.0-83.106
linux-image-4.4.0-1022-aws 4.4.0-1022.31
linux-image-4.4.0-1061-raspi2 4.4.0-1061.69
linux-image-snapdragon 4.4.0.1063.56
linux-image-powerpc64-emb 4.4.0.83.89
linux-image-gke 4.4.0.1018.20
linux-image-generic 4.4.0.83.89
linux-image-4.4.0-83-generic-lpae 4.4.0-83.106
linux-image-4.4.0-83-powerpc64-smp 4.4.0-83.106
linux-image-4.4.0-83-lowlatency 4.4.0-83.106
linux-image-raspi2 4.4.0.1061.62
linux-image-powerpc-smp 4.4.0.83.89
linux-image-4.4.0-1018-gke 4.4.0-1018.18
linux-image-generic-lpae 4.4.0.83.89
linux-image-powerpc64-smp 4.4.0.83.89
linux-image-4.4.0-83-powerpc64-emb 4.4.0-83.106
linux-image-lowlatency 4.4.0.83.89

Veja que arrumaram primeiro o kernel 4.4 LTS! 

A notícia da correção, com a lista acima, esta aqui: https://usn.ubuntu.com/usn/usn-3344-1/

* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #54 Online: 01 de Agosto de 2017, 23:49 »
boa noite senhores.

Fiz alguns testes no meu sistema e por incrível que pareça, meu LO Base não funcionou com kernel 4.4 LTS, somente com a versão 4.8.0-36.

Contudo nesta versão do kernel, ocorre um erro no LO write em que a tela do programa fica piscando.

Pelo jeito, vou ter que ficar na versão 4.8 ou então instalar uma versão mais antiga do lubuntu.

Outra coisa, não fui eu quem abriu o tópico no outro forum, não sei nem fazer isso! kkkkkk. Sou muito leigo

até mais
« Última modificação: 02 de Agosto de 2017, 00:21 por loalexandre77 »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.855
    • Ver perfil
Re:Libreoffice Base
« Resposta #55 Online: 02 de Agosto de 2017, 15:03 »
[...] somente com a versão 4.8.0-36.
Contudo nesta versão do kernel, ocorre um erro no LO write em que a tela do programa fica piscando.

Olá @loalexandre77,

Acho que não entendi muito bem.  :-\

Está funcionando ou não está funcionando do modo como havíamos deixado, com o kernel 4.8.0.36 ?

Fiquei confuso com a expressão "ocorre um erro no LO write em que a tela do programa fica piscando."

Esse problema com a tela piscando é com o kernel da série 4.4 ou com o kernel 4.8.0.36 ?

Em resumo, o kernel 4.8.0.36 resolveu a questão ou não resolveu?
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re:Libreoffice Base
« Resposta #56 Online: 04 de Agosto de 2017, 00:05 »
Desculpa se não fui claro Druidaobelix,

O sistema está funcionando perfeitamente na versão do kernel 4.8.0-36.

Na versão 4.4 não abre o LO Base. Cheguei a instalar a versão 4.4 LTS do kernel, mas como não funcionou desinstalei.

Não voltei para a versão 16.04.1 porque está tudo funcionando bem com o kernel 4.8.0-36.

Entrei no site de download do Lubuntu e vi que tem uma nova versão 17.04. Vocês sabem me dizer se esta nova versão apresenta o mesmo problema de kernel do que a versão 16.04.2?

Mais uma vez obrigado por tudo.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.855
    • Ver perfil
Re:Libreoffice Base
« Resposta #57 Online: 04 de Agosto de 2017, 00:30 »
O sistema está funcionando perfeitamente na versão do kernel 4.8.0-36.
Entrei no site de download do Lubuntu e vi que tem uma nova versão 17.04. [...]

Ok, agora entendi, então apenas deixe como estava, funcionando com o kernel 4.8.0-36.

O Ubuntu versão 17.04, codename Zesty, é uma versão transitória, não é algo para usar em produção real.
Em produção se usa versão LTS, Long Term Support, cujo prazo do suporte é de 5 anos.
As LTS atuais são as versões 14.04 e 16.04.
Versões transitórias extinguem-se em apenas 9 meses, é só confusão, é apenas experimento.
O que funciona bem é aproveitado numa próxima versão LTS, o que não funciona é descartado, é assim que funciona.

Isso na essência significa que **não** se deve usar uma versão transitória para assuntos sérios e instalações de produção no dia a dia de trabalho, sendo mais adequado optar sempre por versões LTS.

Na identificação numérica das versões os dois primeiros números referem-se ao ano, os dois últimos ao mês, assim, 14.04 é lançamento de abril de 2014, e então 16.04 é lançamento em abril de 2016 e assim por diante. O terceiro e último número, quando existe, refere-se ao release (14.04.5 ou 16.04.2).

Versões LTS são suportadas por 5 anos, versões  chamadas Regular (=Provisória) são suportadas por 9 meses.

Para entender melhor o calendário geral de validade e suporte de todas as versões

Ubuntu releases calendar

https://wiki.ubuntu.com/Releases

Complementarmente também esse:

https://wiki.ubuntu.com/LTS

Mais especificamente aqui:

https://www.ubuntu.com/info/release-end-of-life
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.