Autor Tópico: Libreoffice Base  (Lida 2968 vezes)

Offline Marcio Cruz

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Libreoffice Base
« Online: 16 de Julho de 2017, 17:01 »
Uso Ubuntu 16.04 32 bits.
Há um mês instalei o LibreOffice Base, e agora não funciona mais direito. O aplicativo chega a abrir, mas basta clicar em ver tabelas que ele fecha sem nenhum aviso. Quando tento abrir o arquivo novamente, aparece a Janela de Recuperação de Arquivos. Quando recupero, o problema inicial se repete.
Tentei desinstalar e reinstalar o Base pelo Ubuntu Software, também tentei instalar o LibreOffice pelo repositório, mas continua tudo igual.
Em algumas dessas tentativas, o sistema gerou avisos de problema no sistema, enviando relatório de erros.
Instalei também o aplicativo BaseX, e tive um problema semelhante. Tentei criar uma base de dados e obtive a seguinte mensagem:
Command:
CREATE DB XX "/home/marcio/Área de Trabalho"
Error:
"..." (Line 1): Fim prematuro do arquivo.
Agradeço a atenção.
« Última modificação: 28 de Julho de 2017, 06:20 por galactus »

Offline Rafael431168

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re:Libreoffice Base
« Resposta #1 Online: 16 de Julho de 2017, 23:10 »
A melhor solução que vejo para seu problema é desinstalar o BASE, depois deletar a pasta oculta por ele gerada durante a instalação que deve estar em sua pasta /home/ ante de tentar reinstalar.
De todo modo, creio que a melhor forma de manipular banco de dados no ubuntu seja o Firebird.

Offline Marcio Cruz

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:Libreoffice Base
« Resposta #2 Online: 19 de Julho de 2017, 17:29 »
Rafael, agradeço a resposta rápida, mas não encontrei nenhuma pasta oculta do Base ou do LibreOffice na pasta /home, pelo menos não reconheci a pasta pelo nome, nenhuma das pastas ocultas tem nome parecido com Base ou LibreOffice.
Encontrei uma pasta (que não é oculta) criada pelo Base X e a pasta oculta criada pelo FlameRobin, que instalei para usar o Firebird, mas com esse também não consegui criar um novo arquivo de banco de dados, deu o erro abaixo:

*** IBPP::SQLException ***
Context: Database::Create
Message: isc_dsql_execute_immediate failed

SQL Message : -902
Unsuccessful execution caused by a system error that precludes successful execution of subsequent statements

Engine Code    : 335544721
Engine Message :
Unable to complete network request to host "localhost".
Failed to establish a connection.

Há algum tempo tive um problema parecido com o LibreOffice Impress, que não conseguia abrir arquivos, que depois precisavam ser recuperados, mas continuavam não abrindo. Se me lembro bem, isso foi pouco antes de instalar o Ubuntu 16, o que acabou resolvendo sem que eu soubesse o que aconteceu.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Libreoffice Base
« Resposta #3 Online: 26 de Julho de 2017, 03:00 »
Marcio,
bom dia. Estou há três dias sem dormir devido a este problema. Meu sistema é Lubuntu, 32 bits. Eu utilizava o base normalmente até este mês apresentar este bug. Já instalei três sistemas operacionais: Ubuntu, Kubuntu e Lubuntu e o problema é o mesmo. Não sei mais o que fazer, estou tentando buscar solução em sites estrangeiros e não encontro nada.
Tenho um pequeno comércio e preciso urgente do sistema operando. Caso encontre solução, favor compartilhar; e se conseguir resolver posto aqui.
Grande abraço.
Obs: Na plataforma 64bits não ocorre este problema.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Libreoffice Base
« Resposta #4 Online: 26 de Julho de 2017, 06:42 »
Marcio,
bom dia. Estou há três dias sem dormir devido a este problema. Meu sistema é Lubuntu, 32 bits. Eu utilizava o base normalmente até este mês apresentar este bug. Já instalei três sistemas operacionais: Ubuntu, Kubuntu e Lubuntu e o problema é o mesmo. Não sei mais o que fazer, estou tentando buscar solução em sites estrangeiros e não encontro nada.
Tenho um pequeno comércio e preciso urgente do sistema operando. Caso encontre solução, favor compartilhar; e se conseguir resolver posto aqui.
Grande abraço.
Obs: Na plataforma 64bits não ocorre este problema.

Qual a versão do Lubuntu 32bits?

Quando você chama o Libre Office Base pelo terminal, qual o erro que aparece ?  Copie cole ele aqui por favor!

Qual a configuração completa do PC em questão?

então o sistema funcionava normalmente e depois, do nada, começou com este problema ou foi feita alguma alteração, como uma atualização do sistema ou do LibreOffice?
« Última modificação: 26 de Julho de 2017, 06:47 por galactus »
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Libreoffice Base
« Resposta #5 Online: 26 de Julho de 2017, 12:00 »
LUbuntu 16.04 LTS.
Netbook Acer Aspire-one
Modelo: acer aspire kav60
Processador: atom 1.6 Ghz
Memória: 2Giga Ram
HD: 160 GB
Video: Intel Gma950- 256 MB
Ele funcionava normalmente. Contudo, sempre atualizo o sistema e deixou de funcionar. Não consigo criar qualquer banco de dados no Base. Quanto tento abrir um banco existente, ele permite. Mas ao tentar abrir qualquer formulário, ou tabela, ou consulta, todos os aplicativos libreoffice fecham simultaneamente, sem qualquer mensagem de erro.
A versão do Libreoffice que uso atualmente é 5.3.4.2, mas já usei a 5.1.6 e o problema continua o mesmo.
Já instalei os sistemas operacionais Ubuntu 16.04 LTS, Kubuntu 16.04 LTS e o LUbuntu 16.04 LTS e o problema é o mesmo. Não sei o que fazer.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.409
    • Ver perfil
Re:Libreoffice Base
« Resposta #6 Online: 26 de Julho de 2017, 17:13 »
Então, @loalexandre77,

Vi seu post e a resposta dada pelo @grafeno lá no Fórum do LibreOffice, sugerindo iniciar por uma versão anterior do kernel.

https://ask.libreoffice.org/pt-br/question/112773/recuperacao-de-documentos-no-base/

Na réplica você manifesta dúvida sobre "onde posso encontrar orientações sobre como iniciar o Ubuntu com uma versão anterior do kernel? "

No menu inicial do sistema, conhecido como menu do grub, basta entrar em "Opções avançadas para Ubuntu".
Na lista que se segue é só se movimentar com a seta direcional e ir escolhendo o kernel.





Apenas anoto que uma outra possibilidade é, ao invés de ir para um kernel anterior, também se pode experimentar ir para algum kernel mais atual, no qual eventualmente o problema não se manifeste, instalando ele no sistema.

Para ver a versão atualmente utilizada no sistema é fazer:

Código: [Selecionar]
uname -srvm
Para ver, a partir de um terminal, as versões de kernel disponíveis no sistema é fazer:

Código: [Selecionar]
dpkg-query -l | awk '/linux-image-*/ {print $2}'
Traga ao tópico o resultado de ambos os comandos acima.
« Última modificação: 26 de Julho de 2017, 17:20 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.409
    • Ver perfil
Re:Libreoffice Base
« Resposta #7 Online: 26 de Julho de 2017, 17:22 »
Adicionalmente, **antes** de partir para experimentar outra versão de kernel, experimente a sugestão dada lá no Fórum LibreOffice pelo @Jose Eduardo, pois eventualmente apenas a mudança do motor do banco de dados pode ser que resolva a questão com o mesmo kernel atual.

Citar
A partir da versão 4.2 do Libre Office, há a opção de se utilizar o Firebird como motor do banco de dados do Base no lugar do HSQLDB padrão. Entre no Base, selecionar banco de dados, banco de dados incorporado e selecione Firebird. Faça um teste. http://www.firebirdnews.org/libreoffi...
imagem do gravatar de José EduardoJosé Eduardo ( há 5 horas )
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Libreoffice Base
« Resposta #8 Online: 26 de Julho de 2017, 20:39 »
loalexandre77, tentei de tudo, resolvi de uma maneira radical!  Eu tenho o Lubuntu 32bits instalado em duas máquinas.  Eu não sabia que o Base não funcionava na versão 32bits.

Impressionante!  Descobri que a versão 64bits instala muito mais dependências que a 32bits e funciona de primeira.  Instalei as mesmas coisas no 32bits, nada!

Troquei o java, seja o livre ou o da Oracle e nada!

Tentei o Libreoffice do site do LibreOffice, a versão estável mais nova 5.2.7.2 e nada!

Procurei nos fóruns internacionais, achei um monte de gente com este problema, até no Windows. Mas nada que ajudasse, até que achei um tópico interessante, este resolveu!

O que fiz?

Remova o Libreoffice e instale o OpenOffice!

Não importa o java, kernel nem o raio que o parta! Funciona!

Agora, achei muita documentação desatualizada, principalmente em português.  Documentação atualizada só em inglês.  Daí achei que o Libreoffice recomenda usar o JAVA 7!   Não fala nada do kernel.  Mas mudar kernel eu não tentei.  Vou tentar!

 Depois digo o que virou!
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Libreoffice Base
« Resposta #9 Online: 26 de Julho de 2017, 21:04 »
Funcionou!!!

Libreoffice Base do Lubuntu 32bits, dos repositórios oficiais!

Com kernel LTS 4.4.9 do Mainline kernel:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.9-xenial/

Com o kernel 4.10 não funciona!

Vou testar com o 4.8.

## Atualizando! ###

Depois de abrir com o 4.4.9 abriu com o 4.8!

« Última modificação: 26 de Julho de 2017, 21:11 por galactus »
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.409
    • Ver perfil
Re:Libreoffice Base
« Resposta #10 Online: 26 de Julho de 2017, 23:27 »
Vou testar com o 4.8.
## Atualizando! ###
Depois de abrir com o 4.4.9 abriu com o 4.8!

Excelente, e já que está com a mão na massa, se puder e for viável atualizar esse sistema Lubuntu aí instalado, experimente com o kernel hwe (kernel rolling), isto é sair do 4.4 original e ir para o 4.8 hwe, que na verdade vai acabar indo também para o 4.10 hwe, enfim, é apenas para estabelecer e registrar o que dá certo e o que não dá.

Refiro-me a usar essa atualização de kernel:

Código: [Selecionar]
sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04



« Última modificação: 26 de Julho de 2017, 23:35 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Libreoffice Base
« Resposta #11 Online: 27 de Julho de 2017, 00:07 »
Então, @loalexandre77,

Vi seu post e a resposta dada pelo @grafeno lá no Fórum do LibreOffice, sugerindo iniciar por uma versão anterior do kernel.

https://ask.libreoffice.org/pt-br/question/112773/recuperacao-de-documentos-no-base/

Na réplica você manifesta dúvida sobre "onde posso encontrar orientações sobre como iniciar o Ubuntu com uma versão anterior do kernel? "

No menu inicial do sistema, conhecido como menu do grub, basta entrar em "Opções avançadas para Ubuntu".
Na lista que se segue é só se movimentar com a seta direcional e ir escolhendo o kernel.





Apenas anoto que uma outra possibilidade é, ao invés de ir para um kernel anterior, também se pode experimentar ir para algum kernel mais atual, no qual eventualmente o problema não se manifeste, instalando ele no sistema.

Para ver a versão atualmente utilizada no sistema é fazer:

Código: [Selecionar]
uname -srvm
Para ver, a partir de um terminal, as versões de kernel disponíveis no sistema é fazer:

Código: [Selecionar]
dpkg-query -l | awk '/linux-image-*/ {print $2}'
Traga ao tópico o resultado de ambos os comandos acima.

Linux 4.10.0-27-generic #30~16.04.2-Ubuntu SMP Thu Jun 29 16:09:18 UTC 2017 i686

linux-image-4.10.0-27-generic
linux-image-4.8.0-36-generic
linux-image-extra-4.10.0-27-generic
linux-image-extra-4.8.0-36-generic
linux-image-generic-hwe-16.04


Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Libreoffice Base
« Resposta #12 Online: 27 de Julho de 2017, 00:14 »
Funcionou!!!

Libreoffice Base do Lubuntu 32bits, dos repositórios oficiais!

Com kernel LTS 4.4.9 do Mainline kernel:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.9-xenial/

Com o kernel 4.10 não funciona!

Vou testar com o 4.8.

## Atualizando! ###

Depois de abrir com o 4.4.9 abriu com o 4.8!

Sou iniciante, como mudar o kernel?
Somente utilizar este código?
sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

Eu já tinha usado este comando e recebi a mensagem de que minha versão do kernel era a mais atual
« Última modificação: 27 de Julho de 2017, 00:26 por loalexandre77 »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.409
    • Ver perfil
Re:Libreoffice Base
« Resposta #13 Online: 27 de Julho de 2017, 00:18 »
Sou iniciante, como mudar o kernel?
Somente utilizar este código?
sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

Olá @ loalexandre77

Não faça isso!

Não use esse comando para atualizar nada, ao menos não por enquanto, não é por aí a primeira opção, no momento.
Deixe antes, se o caso, o @galactus testar se também funciona daquela forma.

Vamos inicialmente pelo caminho mais simples.

Traga, por favor, o resultado daqueles dois comandos que pedi no post anterior.

editando:
só agora que vi que você já havia postado as saídas daqueles comandos anteriores.  :-[
« Última modificação: 27 de Julho de 2017, 00:55 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline loalexandre77

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Libreoffice Base
« Resposta #14 Online: 27 de Julho de 2017, 00:23 »
Eu já havia testado esta linha de comando: sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

e recebi a mensagem de que meu kernel era a versão mais atual