Autor Tópico: Virtaula box 5.1 - Ubuntu 16.04  (Lida 222 vezes)

Offline ArmandoGF

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Virtaula box 5.1 - Ubuntu 16.04
« Online: 11 de Julho de 2017, 18:27 »
Boa noite a todos!

Primeiro lugar, sou novo na comunidade Linux, então me desculpe erros primarios.

Estou testando uma maquina Ubuntu, com consiga rodar virtual MAC e WIN, para eventual suporte a produto.

Ao instalat o VMBox5.1 "sudo apt-get install -f"
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 virtualbox-5.1 : Depende: libvpx1 (>= 1.0.0) mas não é instalável
                  Recomenda: libsdl-ttf2.0-0 mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

O que fazer?


Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.430
    • Ver perfil
Re:Virtaula box 5.1 - Ubuntu 16.04
« Resposta #1 Online: 11 de Julho de 2017, 23:27 »
ArmandoGF, não sei de que maneira você está tentando instalar o Virtualbox. Não sei o que você fez aí com sua lista de repositórios, mas o Ubuntu 16.04 já tem uma versão bem mais nova do libvpx do que essa 1.0.  Nele já existe a versão 1.5. Resumindo, não era pra dar este tipo de erro!

Você está com todos os repositórios ativos?

Vá até o Ubuntu Software Center > Editar > Software Sources (fontes)

E certifique-se que os 4 principais repositórios estão marcados: Main / Universe / Restricted / Multiverse 

Se não estavam todos ativos, marque todos, atualize a lista de repositórios e atualize o seu sistema.

Você instalou o "dkms" antes?

Se fosse eu a querer a versão mais nova,  a maneira mais simples para mim seria instalar as chaves de autenticação da Oracle para o virtualBox e depois a lista do seu repositório, você pode ver esse ótimo tutorial aqui:   http://www.edivaldobrito.com.br/virtualbox-no-linux/

Sugiro fortemente que procure aprender como funciona o gerenciamento de pacotes no Ubuntu, vai te poupar muita dor de cabeça!

Procure aprender em modo gráfico e em modo texto!  Existe documentação e tutoriais  aos montes pela internet e Youtube.  Procure aprender sobre os repositórios, o Software Center, o Synaptic e o apt-get ou apt. Você vai precisar!







* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.