Autor Tópico: Erro ao atualizar o Ubuntu (RESOLVIDO)  (Lida 1817 vezes)

Offline MatrixBrave

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #30 Online: 06 de Julho de 2017, 08:14 »
Bom dia,
Seguem os registros conforme me pediu:

icebrave@Workstation:~$ cat/etc/apt/sourceslist
bash: cat/etc/apt/sourceslist: Arquivo ou diretório não encontrado
icebrave@Workstation:~$



icebrave@Workstation:~$ egrep -v '^#|^ *$' /etc/apt/sources.list /etc/apt/sources.list.d/*
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ vivid main restricted
/etc/apt/sources.list:deb-src http://br.archive.ubuntu.com/ubuntu/ vivid main restricted
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ vivid-updates main restricted
/etc/apt/sources.list:deb-src http://br.archive.ubuntu.com/ubuntu/ vivid-updates main restricted
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ vivid universe
/etc/apt/sources.list:deb-src http://br.archive.ubuntu.com/ubuntu/ vivid universe
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ vivid-updates universe
/etc/apt/sources.list:deb-src http://br.archive.ubuntu.com/ubuntu/ vivid-updates universe
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ vivid multiverse
/etc/apt/sources.list:deb-src http://br.archive.ubuntu.com/ubuntu/ vivid multiverse
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ vivid-updates multiverse
/etc/apt/sources.list:deb-src http://br.archive.ubuntu.com/ubuntu/ vivid-updates multiverse
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu vivid-security main restricted
/etc/apt/sources.list:deb-src http://security.ubuntu.com/ubuntu vivid-security main restricted
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu vivid-security universe
/etc/apt/sources.list:deb-src http://security.ubuntu.com/ubuntu vivid-security universe
/etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu vivid-security multiverse
/etc/apt/sources.list:deb-src http://security.ubuntu.com/ubuntu vivid-security multiverse
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu trusty partner
/etc/apt/sources.list:deb-src http://archive.canonical.com/ubuntu trusty partner
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu utopic partner
/etc/apt/sources.list:deb-src http://archive.canonical.com/ubuntu utopic partner
/etc/apt/sources.list:deb http://br.archive.ubuntu.com/ubuntu/ vivid-proposed restricted multiverse universe main
/etc/apt/sources.list.d/opera.list:deb http://deb.opera.com/opera/ stable non-free #Opera Browser (final releases)
/etc/apt/sources.list.d/opera-stable.list:deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
icebrave@Workstation:~$




Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.355
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #31 Online: 06 de Julho de 2017, 08:34 »
MatrixBrave, você digitou o comando errado. 

O Druida colocou o comando correto, que seria:

cat /etc/apt/sources.list


Você tem uma mistura de versões do Ubuntu no seu source.list!  vivid,  trusty e utopic.  Quem fez a obra?

No aguardo da saída do comando correta!
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline MatrixBrave

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #32 Online: 06 de Julho de 2017, 13:08 »
Boa tarde,
Quanto a mistura de versões não sei responder. Aqui o Ubuntu só foi instalado uma vez. Me perdoe se isso não responde a sua pergunta.

Segue o registro que estava faltando:

icebrave@Workstation:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 14.10 _Utopic Unicorn_ - Release amd64 (20141022.1)]/ utopic main restricted
# deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Release i386 (20140417)]/ trusty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://br.archive.ubuntu.com/ubuntu/ vivid main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ vivid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://br.archive.ubuntu.com/ubuntu/ vivid-updates main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ vivid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ vivid universe
deb-src http://br.archive.ubuntu.com/ubuntu/ vivid universe
deb http://br.archive.ubuntu.com/ubuntu/ vivid-updates universe
deb-src http://br.archive.ubuntu.com/ubuntu/ vivid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://br.archive.ubuntu.com/ubuntu/ vivid multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ vivid multiverse
deb http://br.archive.ubuntu.com/ubuntu/ vivid-updates multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ vivid-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://security.ubuntu.com/ubuntu vivid-security main restricted
deb-src http://security.ubuntu.com/ubuntu vivid-security main restricted
deb http://security.ubuntu.com/ubuntu vivid-security universe
deb-src http://security.ubuntu.com/ubuntu vivid-security universe
deb http://security.ubuntu.com/ubuntu vivid-security multiverse
deb-src http://security.ubuntu.com/ubuntu vivid-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner


# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.


## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu utopic partner
deb-src http://archive.canonical.com/ubuntu utopic partner
deb http://br.archive.ubuntu.com/ubuntu/ vivid-proposed restricted multiverse universe main

icebrave@Workstation:~$
icebrave@Workstation:~$



Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #33 Online: 06 de Julho de 2017, 16:53 »
Novidades, novidades, muito curioso, acabei de constatar que o repositório http://old-releases.ubuntu.com/ubuntu/dists/ não existe mais para a 15.04 vivid e para a 15.10 wily    :-[

Nada como essas obscuras mudanças de rota, não fiquei sabendo disso antes.  >:(

Isso, na prática, quer dizer que, pelo menos para essas duas versões, não adianta mais substituir o endereço do repositório para old-releases.ubuntu.com para fazer o upgrade de versão, porque não tem nada lá dessas duas versões.

Então tudo aquilo que estava lá no tópico 114.978 antes indicado no post #3 cai por terra, não mais se aplica.

O upgrade de versão vai ter que ser feito de outro modo, da forma como o "galactus" tinha indicado no post #4.

Vou analisar melhor aqui essa mudança.
« Última modificação: 06 de Julho de 2017, 19:58 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #34 Online: 06 de Julho de 2017, 17:10 »
De toda forma, antes de mais nada, antes de qualquer atualização, corrija a atual sources.list e repositórios adicionais.

Comece desmarcando a ppa que existe, que no caso é a do navegador Opera.

Entre em:

Citar
Configurações do sistema/Programas e atualizações

Na janela que se abriu clik na aba "Outros programas"

Desmarque o que houver lá de ppa

Mas vamos ser mais radicais.

Faça:

Código: [Selecionar]
mkdir ~/prov
Código: [Selecionar]
sudo mv /etc/apt/sources.list.d/* ~/prov

Agora abra o arquivo:

Código: [Selecionar]
sudo gedit /etc/apt/sources.list
Apague tudo o que há atualmente nele diferente de vivid, isto é, apague as linhas que contenham trusty e utopic, que segundo observo no seu post #32, são essas:

Citar
# deb cdrom:[Ubuntu 14.10 _Utopic Unicorn_ - Release amd64 (20141022.1)]/ utopic main restricted
# deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Release i386 (20140417)]/ trusty main restricted

Essas duas acima já estão inutilizadas, pois se vê o caracter # (tralha, jogo da velha), antes da linha, o que a inutiliza, porém apague mesmo assim para não ficar apenas como 'sujeira' inútil no arquivo.

Apague especialmente essas que estão erroneamente ativas:

Citar
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

E ainda essas:

Citar
deb http://archive.canonical.com/ubuntu utopic partner
deb-src http://archive.canonical.com/ubuntu utopic partner

Enfim, caso eu não tenha visto alguma mais, se encontrar algo diferente de vivid, inutilize a linha.
« Última modificação: 06 de Julho de 2017, 17:14 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.355
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #35 Online: 06 de Julho de 2017, 19:16 »
Ao que parece MatrixBrave, você ou alguém instalou o Ubuntu 14.04 e vem atualizando quando pipoca o aviso de nova versão do Ubuntu.

Siga as dicas do druidaobelix para arrumar o seu source.list e poder fazer o upgrade como já havia indicado!
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 943
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #36 Online: 06 de Julho de 2017, 19:47 »
Qual a saida do comando:

Código: [Selecionar]
lsb_release -dc
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 943
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #37 Online: 06 de Julho de 2017, 20:08 »
O repositório da versão vivid e da wily ainda continuam em "archive.ubuntu.com" e "security.ubuntu.com", isto é, eles ainda não foram pra o old-releases. Por isso não é preciso mexer no sources.list.
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #38 Online: 06 de Julho de 2017, 20:29 »
O repositório da versão vivid e da wily ainda continuam em "archive.ubuntu.com" e "security.ubuntu.com", isto é, eles ainda não foram pra o old-releases. Por isso não é preciso mexer no sources.list.

Muito bom, muito bom, mas então mudou-se mesmo o método de atualização, já que não vão mais para o old-release.

Por isso é que irá funcionar o update e upgrade que o "galactus" mencionou lá no post #4 e que estava achando estranho.  :)
Agora explicou, blz.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 943
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #39 Online: 06 de Julho de 2017, 21:12 »
Muito bom, muito bom, mas então mudou-se mesmo o método de atualização, já que não vão mais para o old-release.

Acredito que a sequência natural é que mudem para o old-releases. Mas acho que dão um tempo necessário para que os retardatários possam fazer o upgrade.
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline MatrixBrave

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #40 Online: 06 de Julho de 2017, 22:33 »
Pessoal,

Qual o procedimento então ??
Resumindo: A idéia então seria atualizar ou fazer uma instalação limpa ?

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #41 Online: 06 de Julho de 2017, 22:45 »
Qual o procedimento então ??
Resumindo: A idéia então seria atualizar ou fazer uma instalação limpa ?

Atualize, agora até por curiosidade.

Corrigido o sources.list conforme indicado no post #34, siga o procedimento que o "galactus" postou no post #4.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline MatrixBrave

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #42 Online: 06 de Julho de 2017, 23:35 »
De toda forma, antes de mais nada, antes de qualquer atualização, corrija a atual sources.list e repositórios adicionais.

Comece desmarcando a ppa que existe, que no caso é a do navegador Opera.

Entre em:

Citar
Configurações do sistema/Programas e atualizações

Na janela que se abriu clik na aba "Outros programas"

Desmarque o que houver lá de ppa

Mas vamos ser mais radicais.

Faça:

Código: [Selecionar]
mkdir ~/prov
Código: [Selecionar]
sudo mv /etc/apt/sources.list.d/* ~/prov

Agora abra o arquivo:

Código: [Selecionar]
sudo gedit /etc/apt/sources.list
Apague tudo o que há atualmente nele diferente de vivid, isto é, apague as linhas que contenham trusty e utopic, que segundo observo no seu post #32, são essas:

Citar
# deb cdrom:[Ubuntu 14.10 _Utopic Unicorn_ - Release amd64 (20141022.1)]/ utopic main restricted
# deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Release i386 (20140417)]/ trusty main restricted

Essas duas acima já estão inutilizadas, pois se vê o caracter # (tralha, jogo da velha), antes da linha, o que a inutiliza, porém apague mesmo assim para não ficar apenas como 'sujeira' inútil no arquivo.

Apague especialmente essas que estão erroneamente ativas:

Citar
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

E ainda essas:

Citar
deb http://archive.canonical.com/ubuntu utopic partner
deb-src http://archive.canonical.com/ubuntu utopic partner

Enfim, caso eu não tenha visto alguma mais, se encontrar algo diferente de vivid, inutilize a linha.


Qdo vc menciona o navegador OPERA nesso post, será que é por isso que tenho ele instalado, mas náo consigo abri-lo ?

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.692
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #43 Online: 07 de Julho de 2017, 00:14 »
Qdo vc menciona o navegador OPERA nesso post, será que é por isso que tenho ele instalado, mas náo consigo abri-lo ?

Provavelmente não, mas isso é irrelevante para a questão central do tópico, que é o upgrade de versão.

Depois que estiver na nova versão você desinstala e instala novamente o Opera.


« Última modificação: 07 de Julho de 2017, 00:27 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline MatrixBrave

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re:Erro ao atualizar o Ubuntu
« Resposta #44 Online: 07 de Julho de 2017, 08:33 »
Qual a saida do comando:

Código: [Selecionar]
lsb_release -dc


Retornando o que me pediu:

icebrave@Workstation:~$ lsb_release -dc
Description:   Ubuntu 15.04
Codename:   vivid
icebrave@Workstation:~$