Autor Tópico: Demora na inicialização - Ubuntu 16.04.2 LTS - Dell Inspiron 15R SE  (Lida 667 vezes)

Offline MidasTouchBR

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Pessoal,

Estou com a percepção de que meu notebook com Ubuntu está demorando demais para inicializar e, uma vez inicializado, está demorando demais para carregar o Firefox. Já pesquisei em outros tópicos e não identifiquei problemas similares na saída do dmesg que pudessem explicar a demora na minha máquina, então as soluções propostas não puderam ser aplicadas.

Já coloquei em logon automático. Cronometrando, do GRUB à disponibilização da interface gráfica demora 01m27s. Clicando imediatamente no atalho do Firefox, ele demora mais 01m09s para abrir (ele abre bem mais rápido que isso depois que o sistema já está rodando há algum tempo, então a demora deve ser por conta de coisas sendo carregadas após a inicialização).

Seguindo as orientações desse tópico aqui http://ubuntuforum-br.org/index.php/topic,120917.msg663879.html#msg663879, seguem as informações sobre meu note, bem como os resultados de algumas análises, na esperança de que vocês tenham mais sorte que eu para identificar o problema. Sei que as informações abaixo vão ajudar somente a agilizar a inicialização, mas já é um começo.

Meu notebook é um Dell Inspiron 15R SE rodando Ubuntu 16.04.2 LTS, completamente atualizado (apt update e upgrade sem erros)

Informações sobre a máquina (inxi -FxZ): https://pastebin.com/Vu4NZ0V3

Resultado do systemd-analyze: Startup finished in 4.585s (firmware) + 4.425s (loader) + 6.185s (kernel) + 45.099s (userspace) = 1min 296ms

Resultado do systemd-analyze critical-chain:
graphical.target @45.081s
└─multi-user.target @45.081s
  └─getty.target @43.848s
    └─getty@tty1.service @43.847s
      └─rc-local.service @43.831s +5ms
        └─network-online.target @43.820s
          └─NetworkManager-wait-online.service @36.855s +6.964s
            └─NetworkManager.service @33.279s +3.562s
              └─dbus.service @31.260s
                └─basic.target @31.233s
                  └─sockets.target @31.233s
                    └─snapd.socket @31.183s +43ms
                      └─sysinit.target @31.159s
                        └─apparmor.service @18.663s +12.475s
                          └─local-fs.target @18.647s
                            └─run-vmblock\x2dfuse.mount @45.073s
                              └─local-fs-pre.target @8.219s
                                └─systemd-remount-fs.service @8.070s +148ms
                                  └─system.slice @2.592s
                                    └─-.slice @2.499s

Resultado do systemd-analyze blame: http://paste.ubuntu.com/25007187/

Resultado do dmesg: http://paste.ubuntu.com/25007189/

Resultado do systemd-analyze plot: https://drive.google.com/file/d/0B-fzI5QMGrzoMXh5ZEpBelJyMDg/view?usp=sharing

Muito obrigado por qualquer ajuda!

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.467
    • Ver perfil
Re:Demora na inicialização - Ubuntu 16.04.2 LTS - Dell Inspiron 15R SE
« Resposta #1 Online: 03 de Julho de 2017, 00:34 »
Você faz questão de usar o apparmor?  Se não faz, desative ele. Ele está consumindo quase 12,5 segundos do seu boot! Não sabe o que é o Apparmor?  Aqui explica: https://wiki.ubuntu.com/AppArmor

Como usuário root execute os seguintes comandos na seguinte ordem:

Código: [Selecionar]
# service apparmor stop
# service apparmor teardown
# update-rc.d -f apparmor remove

Reinicie o sistema o veja se melhora os 12 segundos.

Verificou a saúde do HD?

Instale o  GsmartControl:

Código: [Selecionar]
sudo apt install gsmartcontrol

Depois execute o mesmo e clique duas vezes no ícone do seu disco rígido.  Veja se ele já não apresenta erros. Se quiser faça um teste curto dentro da aba "Perform Test". Se tiver alguma coisa de errado grave, você vai ver cores vermelhas no relatório da saúde do disco.  Se houver linhas marcadas de rosa,  anote quais são elas e diga pra gente aqui.

Teste a velocidade do HD, deixe todos os programas fechados para executar este teste:

Código: [Selecionar]
sudo hdparm -Tt /dev/sda


Copie e cole o resultado pra gente aqui.

No aguardo de sua resposta!
« Última modificação: 03 de Julho de 2017, 00:37 por galactus »
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.249
    • Ver perfil
Re:Demora na inicialização - Ubuntu 16.04.2 LTS - Dell Inspiron 15R SE
« Resposta #2 Online: 03 de Julho de 2017, 18:47 »
Um primeiro aspecto que consta do inxi postado e que não entendi muito bem: há um disco SSD de 32GB (MZMPC032HBCD) no sistema?

Essa referência é de um mSATA SSD Samsung. Sabe dizer o que é isso aí?

https://www.amazon.com/Samsung-PM830-MZMPC032HBCD-Ultraslim-Notebooks/dp/B00EKGL47I

http://www.samsung.com/us/business/oem-solutions/pdfs/PM830_mSATA%20SSD_32_64_128_256GB_Spec_1.0.pdf

Se o caso traga ao tópico o resultado para:

Código: [Selecionar]
sudo fdisk -lu | grep sd
Código: [Selecionar]
sudo parted -l
sinal de hífen mais letra ele no final dos comandos acima.

Também esse:

Código: [Selecionar]
sudo hdparm -I /dev/sd?
O parâmetro -I é a vogal i (com na palavra india) em maiúscula ( I )
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.249
    • Ver perfil
Re:Demora na inicialização - Ubuntu 16.04.2 LTS - Dell Inspiron 15R SE
« Resposta #3 Online: 03 de Julho de 2017, 18:50 »
O systemd que foi projetado para usar paralelismo no processamento e, por isso, ser mais rápido, frequentemente surpreende negativamente, se coloca essa mesma máquina o Ubuntu 14.04 ele sobe em 30 segundos, creio.

Esse é um computador bom, com bom índice no benchmark, algo como 4000 pontos, não deveria estar demorando tanto para carregar.

Antes de detonar o AppArmor, que é um recurso importante de segurança do sistema, embora como muito bem apontado no post do colega "galactus" esteja de fato 'comendo' tempo excessivo do boot, se já não o fez, deixe como última opção, sugiro experimentar antes:

Código: [Selecionar]
sudo systemctl edit apt-daily.timer
Acrescente ao arquivo:

Citar
# apt-daily timer configuration override
[Timer]
OnBootSec=15min
OnUnitActiveSec=1d
AccuracySec=1h
RandomizedDelaySec=30min

Use a tecla Ctrl mais O (vogal o) para salvar e Ctrl mais X para sair do editor de texto.

Como é apenas uma experiência (e uma cisma minha, sem muito fundamento), faça essa alteração de forma isolada para se poder analisar se de fato produziu algum efeito.

Reinicie o sistema e analise novamente o tempo de boot através do systemd-analyze para ver se de fato produziu algum resultado.

Isso posto, se vê que o plymouth está igualmente demorando na carga.

Como o plymouth tem apenas um efeito estético, é aquela tela inicial quando da carga do sistema, na qual aparecem as bolinhas se movimentando, então compensa ver se produz efeito razoável desabilitar.

Altere o arquivo:

Código: [Selecionar]
sudo gedit /etc/default/grub
Comente a linha abaixo, isto é, coloque um símbolo de # antes dela.

Citar
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Salvar e sair

Atualize o grub fazendo:

Código: [Selecionar]
sudo update-grub
Agora faça:

Código: [Selecionar]
systemctl mask plymouth-quit-wait.service
Código: [Selecionar]
systemctl mask plymouth-read-write.service
Código: [Selecionar]
systemctl disable plymouth-start.service
reinicie o sistema

Veja se realmente todos os serviços do plymouth foram de fato desabilitados.

Código: [Selecionar]
systemd-analyze blame | grep plymouth
O resultado do comando acima deve ser nenhum, vazio, caso contrário algo deu errado e não desabilitou.

Traga ao tópico o resultado final do sytemd-analize, se ocorreu algum ganho ou não.

« Última modificação: 03 de Julho de 2017, 19:41 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.