Autor Tópico: Problema no apt-get  (Lida 315 vezes)

Offline Farrista

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • Bebo-o pq é líquido, se fosse sólido, comê-lo-ia
    • Ver perfil
Problema no apt-get
« Online: 01 de Julho de 2017, 15:19 »
Galera, isso já vem acontecendo há algum tempo, mas só agora resolvi colocar as mãos na massa.

O problema é que, sempre ao digitar "sudo apt-get update" ou ao tentar instalar algum pacote pelo "install", o terminal fica tentando se conectar e não consegue.

Aqui, uma cópia do que retorna o comando:

Atingido:1 http://ppa.launchpad.net/atareao/atareao/ubuntu xenial InRelease   
Atingido:2 http://repo.steampowered.com/steam precise InRelease               
Atingido:3 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial InRelease
Atingido:4 http://ppa.launchpad.net/deluge-team/ppa/ubuntu xenial InRelease   
Atingido:5 http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu xenial InRelease
Atingido:6 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial InRelease
Atingido:7 http://ppa.launchpad.net/pipelight/stable/ubuntu xenial InRelease   
Atingido:8 http://ppa.launchpad.net/snwh/pulp/ubuntu xenial InRelease         
Atingido:9 http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu xenial InRelease
0% [Conectando em archive.ubuntu.com (2001:67c:1560:8001::14)] [Conectando em download.opensuse.org (2001:67c:2178:8::13)] [Conectando em dl.goo


E nesse 0% ele fica por um bom tempo, até que, depois de vários minutos, ocorre isso:


Ign:10 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                   
Ign:11 http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  InRelease                                                       
Atingido:12 http://dl.google.com/linux/chrome/deb stable Release                                                     
Obter:14 http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release [1.007 B]                   
Obter:15 http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release.gpg [481 B]
Ign:15 http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release.gpg     
Atingido:16 http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Packages
Atingido:17 http://archive.ubuntu.com/ubuntu xenial InRelease                                                                                   
Obter:18 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Obter:19 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Baixados 206 kB em 8min 8s (421 B/s)                                                                                                           
Lendo listas de pacotes... Pronto
W: Erro GPG: http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release: As seguintes assinaturas eram inválidas: KEYEXPIRED 1496576244
W: The repository 'http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.


Enfim... Conto com a ajuda de vocês! Não consigo atualizar meus pacotes, tampouco instalar algo novo.



« Última modificação: 01 de Julho de 2017, 15:25 por Farrista »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.573
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Problema no apt-get
« Resposta #1 Online: 01 de Julho de 2017, 15:32 »
Desative o ipv6 temporariamente.

sudo sysctl net.ipv6.conf.all.disable_ipv6=1

Depois é só carregar novamente (apt-get update/dist-upgrade). Reiniciando a máquina, volta ao normal (habilitado).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Farrista

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • Bebo-o pq é líquido, se fosse sólido, comê-lo-ia
    • Ver perfil
Re:Problema no apt-get
« Resposta #2 Online: 01 de Julho de 2017, 15:40 »
Desative o ipv6 temporariamente.

sudo sysctl net.ipv6.conf.all.disable_ipv6=1

Depois é só carregar novamente (apt-get update/dist-upgrade). Reiniciando a máquina, volta ao normal (habilitado).

Velho, eu nem acredito que era tão simples assim! putz que pariu! KKKKKK.

Resolvido demais.

E quanto a este erro no final?

W: Erro GPG: http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04 Release: As seguintes assinaturas eram inválidas: KEYEXPIRED 1496576244
W: The repository 'http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04 Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Se puder, ainda, explicar-me o porquê de este problema com o ipv6 ter ocorrido, seria de grande ajuda.
« Última modificação: 01 de Julho de 2017, 15:45 por Farrista »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.573
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Problema no apt-get
« Resposta #3 Online: 02 de Julho de 2017, 02:08 »
Repositório externo, né? Eu verificaria se ele ainda é mantido --- se é que é realmente necessário --- e se ainda há uma chave válida. Talvez seja só o caso de remover e reinserir o repositório, da mesma forma que fez da primeira vez. Se ele ainda estiver sendo mantido, isso vai trazer a chave atual.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Farrista

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • Bebo-o pq é líquido, se fosse sólido, comê-lo-ia
    • Ver perfil
Re:Problema no apt-get
« Resposta #4 Online: 02 de Julho de 2017, 08:32 »
Repositório externo, né? Eu verificaria se ele ainda é mantido --- se é que é realmente necessário --- e se ainda há uma chave válida. Talvez seja só o caso de remover e reinserir o repositório, da mesma forma que fez da primeira vez. Se ele ainda estiver sendo mantido, isso vai trazer a chave atual.

Essa questão do repositório eu já resolvi. Bastou excluí-lo mesmo, mas e quanto ao fato de que preciso desativar o ipv6 sempre que reinicio a máquina?

Será que existe uma solução definitiva?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.573
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Problema no apt-get
« Resposta #5 Online: 02 de Julho de 2017, 12:03 »
Vc pode desativar definitivamente o IPv6 em sua máquina, adicionando essa diretiva ao arquivo "/etc/sysctl.conf", mas eu não acho que valha a pena. Minha máquina passa pelo mesmo problema de vez em quando, e assim como aparece some.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Farrista

  • Usuário Ubuntu
  • *
  • Mensagens: 7
  • Bebo-o pq é líquido, se fosse sólido, comê-lo-ia
    • Ver perfil
Re:Problema no apt-get
« Resposta #6 Online: 02 de Julho de 2017, 16:47 »
Problema resolvido.