Autor Tópico: mensagem para desligar o notebook ao conectar/desconectar a fonte de energia  (Lida 537 vezes)

Offline Serginho Satanás

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Sempre que conecto ou desconecto a fonte de energia aparece uma mensagem para desligar o notebook. como faço para que ela não apareçanovamente?

a imagem em questão é esta abaixo
 

o kernel que uso:
Linux 3.13.0-119-generic #166-Ubuntu SMP Wed May 3 12:18:55 UTC 2017 x86_64

versão da distribuição:
Ubuntu 14.04.5 LTS

ambiente gráfico:
Gnome Classic


abraços.

« Última modificação: 25 de Junho de 2017, 21:34 por Serginho Satanás »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.249
    • Ver perfil
Re:mensagem para desligar o notebook ao conectar/desconectar a fonte de energia
« Resposta #1 Online: 24 de Junho de 2017, 14:17 »
obs: tentei enviar uma imagem com a mensagem que aparece mas nao consegui.

Saber qual é a mensagem que aparece é importante.

Quando for necessário (normalmente é melhor postar o texto mesmo) e quiser disponibilizar uma imagem da tela, use um servidor externo de imagens, postando no tópico um link da miniatura da imagem, pois há uma regra de limitação de tamanho de imagens que se pode postar no Fórum, que é de 40Kb.

Para aprender como anexar uma imagem em miniatura ao tópico (porque há limite nas regras do Fórum) através de um servidor de imagens externo, veja esse tópico e nele especialmente o post #2 do colega /Creto/:

Anexar uma imagem ao tópico

http://ubuntuforum-br.org/index.php/topic,117916.msg649065.html#msg649065

http://imgur.com
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.249
    • Ver perfil
Re:mensagem para desligar o notebook ao conectar/desconectar a fonte de energia
« Resposta #2 Online: 25 de Junho de 2017, 19:28 »
obrigado pela dica, já modifiquei o tópico da pergunta.

Então, veja só, a imagem da interface de desligamento que você postou indica que sua instalação não é o Ubuntu padrão (=Unity), pois que a tela de saída dele é outra, então você tem aí instalado alguma outra coisa.

Se a base da sua interface gráfica for o gnome, então para resolver isso talvez funcione modificar a chave 'use-time-for-policy" de 'true' para 'false', questão de ver.

Forneça mais informações para que se tenhha mais elementos para tentar avaliar e talvez encontrar uma solução, só com o que foi fornecido está muito genérico, indica o problema, mas não indica o cenário em que ele ocorre.

1) qual versão está usando:

Código: [Selecionar]
lsb_release -rd
2) qual interface/sabor ?
Mint, Mate, Cinnamonm, Lubuntu, Gnome, Kubuntu, etc.. qual?
Essa não é a interface de desligamento do Ubuntu padrão (=Unity)

3) kernel?

Código: [Selecionar]
uname -srvm
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.249
    • Ver perfil
Re:mensagem para desligar o notebook ao conectar/desconectar a fonte de energia
« Resposta #3 Online: 26 de Junho de 2017, 00:52 »
Ok, então é o próprio Gnome, bem, assim sendo experimente executar:

Código: [Selecionar]
gsettings set org.gnome.settings-daemon.plugins.power 'use-time-for-policy' 'false'
Se executou corretamente ao fazer:

Código: [Selecionar]
gsettings list-recursively org.gnome.settings-daemon.plugins.power
a linha correspondente deverá realmente aparecer como 'false' e não 'true'

Teste para ver se resolve e se alteração fica de fato gravada ao reiniciar a sessão/sistema, caso não fique será necessária acrescentá-la nos "Aplicativos inicias de sessão", dependendo do caso adicionando um delay (=atraso) para poder compatibilizar com a execução do systemd.

Vamos ver, teste aí e vamos observar o que resulta.
« Última modificação: 26 de Junho de 2017, 00:54 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.