Autor Tópico: Erro ao instalar o Lamp no ubuntu desktop 14.04  (Lida 586 vezes)

Offline ismaelbonifacio

  • Usuário Ubuntu
  • *
  • Mensagens: 101
    • Ver perfil
Erro ao instalar o Lamp no ubuntu desktop 14.04
« Online: 18 de Junho de 2017, 20:29 »
Viva!
Ao colocar no terminal o cmd : sudo apt-get install lamp-server^ aparece o erro que vai em anexo. Tinha anteriormenete instalado o 14.04, a seguir instalei o ubuntu 16.04 formatei os discos, vim instalar de novo a versão 14.04 com lamp não consigo instalar. Alguém tem uma solução?

Os pacotes a seguir têm dependências não satisfeitas:
 apache2-bin : Depende: libapr1 (>= 1.5.0) mas não é instalável
               Depende: libaprutil1 (>= 1.5.0) mas não é instalável
               Depende: libaprutil1-dbd-sqlite3 mas não é instalável ou
                        libaprutil1-dbd-mysql mas não é instalável ou
                        libaprutil1-dbd-odbc mas não é instalável ou
                        libaprutil1-dbd-pgsql mas não é instalável ou
                        libaprutil1-dbd-freetds mas não é instalável
               Depende: libaprutil1-ldap mas não é instalável
 libdbd-mysql-perl : Depende: perl-dbdabi-94 mas não é instalável
                     Depende: libdbi-perl mas não é instalável
 mysql-client-5.5 : Depende: libdbi-perl mas não é instalável
                    Depende: libterm-readkey-perl mas não é instalável
 mysql-server-5.5 : Depende: libdbi-perl mas não é instalável
                    Recomenda: libhtml-template-perl mas não é instalável
 mysql-server-core-5.5 : Depende: libaio1 (>= 0.3.93) mas não é instalável
 php5-common : Depende: php5-json mas não é instalável
E: Não foi possível corrigir problemas, você tem pacotes mantidos (hold) estragados.


Obrigado

Offline xGrind

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re:Erro ao instalar o Lamp no ubuntu desktop 14.04
« Resposta #1 Online: 18 de Junho de 2017, 20:38 »
Já tentou trocar de espelho e atualizar os repositórios pra ver se instala?

Offline ismaelbonifacio

  • Usuário Ubuntu
  • *
  • Mensagens: 101
    • Ver perfil
Re:Erro ao instalar o Lamp no ubuntu desktop 14.04
« Resposta #2 Online: 18 de Junho de 2017, 20:50 »
Tentei instalar todas dependências e veio esta mensagem:
Alguns pacotes não puderam ser instalados. Isso pode significar que
você solicitou uma situação impossível ou se você está a usar a
distribuição unstable em que alguns pacotes pedidos ainda não foram
criados ou foram movidos do Incoming.

Depois tentei de novo sudo apt-get install lamp-server^

deu os mesmos erros

Tentei instalar individualmente apache, msql-client e deu estes erros:
Os pacotes a seguir têm dependências não satisfeitas:
 mysql-client : Depende: mysql-client-5.5 mas não vai ser instalado
 mysql-server : Depende: mysql-server-5.5 mas não vai ser instalado
E: Não foi possível corrigir problemas, você tem pacotes mantidos (hold) estragados.

Offline ismaelbonifacio

  • Usuário Ubuntu
  • *
  • Mensagens: 101
    • Ver perfil
Re:Erro ao instalar o Lamp no ubuntu desktop 14.04
« Resposta #3 Online: 18 de Junho de 2017, 21:03 »
Já está! Tem que se ir a sistema, atualização de software, e mudar o servidor padrão para servidor principal. Está a rolar!! Abraço pessoal! Obrigado.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.632
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Erro ao instalar o Lamp no ubuntu desktop 14.04
« Resposta #4 Online: 18 de Junho de 2017, 21:45 »
Estou estranhando esse pacote "lamp-server". Nunca tinha visto ele em lugar nenhum, quando eu precisava instalar o Apache com MySQL e PHP, simplesmente mandava instalar o phpMyAdmin...

Tá com cara de que você está usando repositórios fora do padrão.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.245
    • Ver perfil
Re:Erro ao instalar o Lamp no ubuntu desktop 14.04
« Resposta #5 Online: 18 de Junho de 2017, 22:03 »
Estou estranhando esse pacote "lamp-server". Nunca tinha visto ele em lugar nenhum,...

Não é bem que o pacote seja realmente o lamp-server, que não existe, mas observe que ele está usando a notação lamp-server^ (circunflexo no final), o que acaba por selecionar todos os pacotes necessários.

« Última modificação: 18 de Junho de 2017, 22:05 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.632
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Erro ao instalar o Lamp no ubuntu desktop 14.04
« Resposta #6 Online: 18 de Junho de 2017, 22:33 »
Essa é totalmente novidade pra mim, druida. Vivendo e aprendendo...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D