Autor Tópico: [RESOLVIDO] ]Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k  (Lida 1728 vezes)

Offline Tom.net

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
[RESOLVIDO] ]Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Online: 18 de Junho de 2017, 17:23 »
Olá pessoal, primeiramente, passei o final de semana todo procurando uma solução na internet, em várias comunidades muitos relatos, mas não vi uma real solução, pq todos consideraram que 3mbps de transferência estava bom. Porém essa placa de rede wifi TL-881ND é 300M, oq me daria por volta dos 10~12mbps de transferência de arquivos (em minha rede local). Acontece que eu instalei o windows em outro HD pra tirar a dúvida, e eis que a placa funciona em sua total capacidade, consigo transferir arquivos grandes com a média de velocidade boa 10~12mbps entre computadores em minha rede.
Preciso da ajuda de vocês, ou se alguém já passou por isso... por favor, me ajudem. Já fiz o que mais sugerem nos forums que é colocar "options ath9k nohwcrypt=1" no arquivo "/etc/modprobe.d/ath9k.conf" e não mudou nada.
Estava usando ubuntu gnome 16.04LTS, e troquei para o Linux Mint 18.1 mas continuou com o mesmo problema.


Código: [Selecionar]
$uname -a
Linux tom-mint 4.10.0-22-generic #24~16.04.1-Ubuntu SMP Tue May 23 17:03:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Código: [Selecionar]
#sudo iwconfig
wlp11s0   IEEE 802.11  ESSID:"UNSC" 
          Mode:Managed  Frequency:2.427 GHz  Access Point: (mac)   
          Bit Rate=240 Mb/s   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=69/70  Signal level=-41 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1478   Missed beacon:0

Código: [Selecionar]
#sudo lshw -c ntework
  *-network
       descrição: Interface sem fio
       produto: AR9287 Wireless Network Adapter (PCI-Express)
       fabricante: Qualcomm Atheros
       ID físico: 0
       informações do barramento: pci@0000:0b:00.0
       nome lógico: wlp11s0
       versão: 01
       serial: (mac)
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=ath9k driverversion=4.10.0-22-generic firmware=N/A ip=192.168.0.163 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       recursos: irq:18 memória:f7800000-f780ffff


Código: [Selecionar]
lspci
0b:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

meu arquivo "/etc/modprobe.d/ath9k.conf
Código: [Selecionar]
options ath9k nohwcrypt=1 bt_ant_diversity=1 btcoex_enable=0 ps_enable=0 enable_diversity=1

Abri o WAVEMON para verificar a wifi durante a transferência do arquivo.
Vejam que o wavemon ele mostra a taxa de transferência a 300M, mas está transferindo apenas a 3mbps ao invés de 10~12mbps

Código: [Selecionar]
Interface──────────────────────────────────────────────────────────────────────────────────┐
│wlp11s0 (IEEE 802.11, WPA/WPA2), phy 0, reg: US (DFS-FCC)                                   │
├─Levels─────────────────────────────────────────────────────────────────────────────────────┤
│link quality: 96%  (67/70)                                                                  │
│========================================================================================    │
│                                                                                            │
│signal level: -43 dBm (0,05 uW)                                                             │
│==========================================================                                  │
│noise level:  -95 dBm (0,32 pW)                                                             │
│============================                                                                │
│SNR:           52 dB                                                                        │
├─Statistics─────────────────────────────────────────────────────────────────────────────────┤
│RX: 251.143 (25,17 MiB), rate: 300.0 MBit/s MCS 15 40MHz short GI (exp: 54,6 MB/s), drop: 767
│TX: 508.274 (732,08 MiB), rate: 300.0 MBit/s MCS 15 40MHz short GI, retries: 109.770        │
├─Info───────────────────────────────────────────────────────────────────────────────────────┤
│mode: Managed, connected to: (MAC editado), time: 4:24m, inactive: 0,0s                 │
│freq: 2427 MHz, ctr1: 2437 MHz, channel: 4 (width: 40 MHz)                                  │
│channel active: 4:20m, busy: 1:42m, rx: 36 sec, tx: 49 sec                                  │
│beacons: 2.467, avg sig: -43 dBm, interval: 0,1s, DTIM: 1                                   │
│power mgt: off,  tx-power: 16 dBm (39,81 mW)                                                │
│retry: short limit 7,  rts/cts: off,  frag: off                                             │
│encryption: n/a (requires CAP_NET_ADMIN permissions)                                        │
├─Network────────────────────────────────────────────────────────────────────────────────────┤
│wlp11s0 (UP RUNNING BROADCAST MULTICAST)                                                    │
│mac: (mac editado), qlen: 1000                                                          │
│ip: 192.168.0.163/24                                                                        │
└────────────────────────────────────────────────────────────────────────────────────────────┘


A Configuração em meu Roteador TP-Link Archer C60


===========================
SOLUÇÃO [RESOLVIDO]
===========================
Obrigado a todos, o problema foi resolvido com ajuda dos post abaixo:
galactus : http://ubuntuforum-br.org/index.php/topic,121906.msg669716.html#msg669716
(Instalado Kernel Xanmod)
druidaobelix : http://ubuntuforum-br.org/index.php/topic,121906.msg669721.html#msg669721
(sudo iw reg set BR) depois, tornar permanente colocando no final do arquivo : sudo gedit /etc/default/crda
« Última modificação: 11 de Agosto de 2017, 19:40 por Tom.net »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.681
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #1 Online: 18 de Junho de 2017, 17:59 »
Cara, eu não consegui entender suas contas. Vc está transferindo o quê, e pra onde? ? ?

Está fazendo transferências pela internet, ou pra rede local?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Tom.net

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #2 Online: 18 de Junho de 2017, 18:22 »
Cara, eu não consegui entender suas contas. Vc está transferindo o quê, e pra onde? ? ?

Está fazendo transferências pela internet, ou pra rede local?

Esqueci de especificar esse detalhe rsrsrs.

Transferência entre computadores em minha rede local.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.681
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #3 Online: 18 de Junho de 2017, 18:26 »
Mais um detalhe esquecido, o computador de destino é cabeado ou wifi também? Transferência direta entre dois computadores em wifi tem comportamento radicalmente diferente de quando um dos computadores é cabeado.

Outra coisa a ver... e os HDs onde você está lendo/gravando esses arquivos, aguenta essas taxas de transferência?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Tom.net

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #4 Online: 18 de Junho de 2017, 20:18 »
Mais um detalhe esquecido, o computador de destino é cabeado ou wifi também? Transferência direta entre dois computadores em wifi tem comportamento radicalmente diferente de quando um dos computadores é cabeado.

Outra coisa a ver... e os HDs onde você está lendo/gravando esses arquivos, aguenta essas taxas de transferência?
Fiz testes em vários cenários para poder constatar que o problema está no Linux com esse driver ath9k na minha placa.
Vou citar os dois principais,

1 Meu pc c/ Linux com SSD wifi N (ath9k) -->> Pc Linux rede Cabeada com HD Sata2 == 3mbps de transferência.

2 Meu pc c/ Linux com SSD wifi N (ath9k) -->> Raspberry pi3 rede wifi AC com MicroSD UltraClasse10 XD. == 3mbps de transferência de arquivos.

Agora... Os mesmos periféricos porém Meu PC com Windows com a mesma placa de rede wifi. A transferência do cenário 1 foi de 9 a 10mbps e no cenário 2 foi de 10 a 12mbps.

Coloquei a placa de rede Wifi AC no meu pc com Linux e deixei o raspberry cabeado, mas aí só consegui 6mbps.
Ta muito estranho a Wifi no meu PC, msm com placa wifi diferente, a transferência de arquivos nele fica lenta. Mesmo com instalação limpa do Linux e Kernel mais recente.
No raspberry está com osmc kernel 4.9 e não tem esse problema.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.681
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #5 Online: 18 de Junho de 2017, 21:47 »
Tentou colocar essa máquina Ubuntu cabeada, pra ver a quanto vai a transferência?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Tom.net

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #6 Online: 18 de Junho de 2017, 22:00 »
Tentou colocar essa máquina Ubuntu cabeada, pra ver a quanto vai a transferência?

Sim, via cabo em todas as máquinas transferência é de 9 a 10mbps, oq considero normal pq a rede cabeada é 10/100.

Online galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.518
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #7 Online: 18 de Junho de 2017, 22:28 »
Olha só, eu não sei vocês, mas eu sempre tive diferenças enormes na velocidade de transferência de arquivos entre Linux e Windows.  Com o mesmo hardware, só trocando o sistema operacional, não importa se cabeada ou Wifi.

Realmente a diferença pode ser do dobro da velocidade.  Atingir 3 mb/s na Wifi de uma rede 10/100 pelo Linux tá ótimo.  Eu aqui consigo no máximo 5,7 mb/s pela wifi no meu notebook.  Minha rede é Gigabit, o Switch e o roteador, mas o Notebook é 10/100. 

E a distância do notebook para o Roteador é muito importante na velocidade final no Linux, eu diria que é crítica até.

Pela cabeada a coisa é feia também, pelo samba no Linux não passa de 70mb/s enquanto que no Windows 10 vai para 112mb/s.  Trocando apenas o SO! 

Contudo, a navegação pela internet é mais rápida no Linux do que Windows.  Vai entender!


Há sim, se trocar o kernel por um experimental e usar o protocolo tcp/ip WESTWOOD+  dá um gás bem maior no Linux!
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.681
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #8 Online: 18 de Junho de 2017, 22:31 »
Tentou colocar essa máquina Ubuntu cabeada, pra ver a quanto vai a transferência?

Sim, via cabo em todas as máquinas transferência é de 9 a 10mbps, oq considero normal pq a rede cabeada é 10/100.
Certo, isso praticamente descarta a possibilidade de ser o HD amarrando a transferência.

Qual versão do kernel vc está usando?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.407
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #9 Online: 18 de Junho de 2017, 22:59 »
Qual versão do kernel vc está usando?

Ele havia postado no tópico inicial:

$uname -a
Linux tom-mint 4.10.0-22-generic #24~16.04.1-Ubuntu SMP Tue May 23 17:03:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Há ainda a observação que a mesma questão se manifestava no Ubuntu-Gnome 16.04

"Estava usando ubuntu gnome 16.04LTS..."

« Última modificação: 18 de Junho de 2017, 23:02 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Tom.net

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #10 Online: 18 de Junho de 2017, 23:44 »
Olha só, eu não sei vocês, mas eu sempre tive diferenças enormes na velocidade de transferência de arquivos entre Linux e Windows.  Com o mesmo hardware, só trocando o sistema operacional, não importa se cabeada ou Wifi.

Realmente a diferença pode ser do dobro da velocidade.  Atingir 3 mb/s na Wifi de uma rede 10/100 pelo Linux tá ótimo.  Eu aqui consigo no máximo 5,7 mb/s pela wifi no meu notebook.  Minha rede é Gigabit, o Switch e o roteador, mas o Notebook é 10/100. 

E a distância do notebook para o Roteador é muito importante na velocidade final no Linux, eu diria que é crítica até.

Pela cabeada a coisa é feia também, pelo samba no Linux não passa de 70mb/s enquanto que no Windows 10 vai para 112mb/s.  Trocando apenas o SO! 

Contudo, a navegação pela internet é mais rápida no Linux do que Windows.  Vai entender!


Há sim, se trocar o kernel por um experimental e usar o protocolo tcp/ip WESTWOOD+  dá um gás bem maior no Linux!

É uma pena não ter o mesmo desempenho, mas acredito que possa ser problema no Linux, pois no raspberry com OSMC a wifi AC (USB) está funcionando bem.

Estou usando o Kernel 4.10 e adicionei o Westwood e setei ele com "sudo sysctl net.ipv4.tcp_congestion_control=westwood"
Serie esse ou existe o Westwood+? Não encontrei muita coisa no google. Qual seria o Kernel que teria suporte a ele?

Online galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.518
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #11 Online: 18 de Junho de 2017, 23:53 »


É uma pena não ter o mesmo desempenho, mas acredito que possa ser problema no Linux, pois no raspberry com OSMC a wifi AC (USB) está funcionando bem.

Estou usando o Kernel 4.10 e adicionei o Westwood e setei ele com "sudo sysctl net.ipv4.tcp_congestion_control=westwood"
Serie esse ou existe o Westwood+? Não encontrei muita coisa no google. Qual seria o Kernel que teria suporte a ele?

O Xanmod Kernel tem suporte nativo ao westwood+, não precisa colocar no sysctl se usar o xanmod kernel!

Se quiser testar por sua conta e risco:  https://xanmod.org/

Aí você encontra as versões 4.4, 4.9 e 4.11!  Se quiser, instale a versão linux-firmware do kernel correspondente!  Nem sempre a versão mais nova do kernel é a que funciona melhor no seu hardware! Faça os seus testes.
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline Tom.net

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #12 Online: 19 de Junho de 2017, 00:55 »


É uma pena não ter o mesmo desempenho, mas acredito que possa ser problema no Linux, pois no raspberry com OSMC a wifi AC (USB) está funcionando bem.

Estou usando o Kernel 4.10 e adicionei o Westwood e setei ele com "sudo sysctl net.ipv4.tcp_congestion_control=westwood"
Serie esse ou existe o Westwood+? Não encontrei muita coisa no google. Qual seria o Kernel que teria suporte a ele?

O Xanmod Kernel tem suporte nativo ao westwood+, não precisa colocar no sysctl se usar o xanmod kernel!

Se quiser testar por sua conta e risco:  https://xanmod.org/

Aí você encontra as versões 4.4, 4.9 e 4.11!  Se quiser, instale a versão linux-firmware do kernel correspondente!  Nem sempre a versão mais nova do kernel é a que funciona melhor no seu hardware! Faça os seus testes.

Instalei e setei o Kernel 4.9 Xanmod, não fiz mais nada, primeiro teste já deu 5mbps, não é os 100% mas já chegou nos 50%.
Obrigado galactus.  ;)

Melhorou a conexão, mas não é o que a placa/rede pode entregar. Agradeço se tiverem mais dicas pra testarmos.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.407
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #13 Online: 19 de Junho de 2017, 01:00 »
[...] Acontece que eu instalei o windows em outro HD pra tirar a dúvida, e eis que a placa funciona em sua total capacidade, consigo transferir arquivos grandes com a média de velocidade boa 10~12mbps entre computadores em minha rede.

Como é que você está concretamente medindo isso no Windows?

Editando:

Estou questionando a precisão do específico termômetro ao medir a febre do paciente.

Essa informação, para ser minimamente confiável, precisa vir de uma bateria de testes bem planejada e bem executada, usando coisas realmente comparáveis entre si.

O uso do wget é um bom caminho para isso, o mais confiável, vez que se pode usar o mesmo software tanto para o Linux como para o Windows, fazendo uma medição real, independente da interface do sistema operacional comercial e do próprio Linux.

O critério de média usado na interface padrão do Windows é bastante questionável, então precisa checar com um bom planejamento numa bateria de testes de fato representativa.

« Última modificação: 19 de Junho de 2017, 01:13 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Tom.net

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Wifi lenta no Linux TP-Link TL-881ND Modulo ath9k
« Resposta #14 Online: 19 de Junho de 2017, 01:14 »
[...] Acontece que eu instalei o windows em outro HD pra tirar a dúvida, e eis que a placa funciona em sua total capacidade, consigo transferir arquivos grandes com a média de velocidade boa 10~12mbps entre computadores em minha rede.

Como é que você está concretamente medindo isso no Windows?

Instalei o Windows no meu PC e fiz a mesma transferência de arquivo pra outra máquina com a mesma placa wifi e olhei a taxa de transferência, além de ser notável o tempo que o arquivo de 1GB transfere, na janela de transferência aparece a taxa da velocidade.

só acompanhei a tela igual a essa:




EDITADO:
O Wget funciona para rede interna? Não sei como se faz, se sim, por favor me explica como eu faço.
« Última modificação: 19 de Junho de 2017, 01:17 por Tom.net »