Autor Tópico: Problemas de atualização Ubuntu 16.04.2 LTS 64-bit(segunda vez que ocorre???)  (Lida 506 vezes)

Offline maximus_7

  • Usuário Ubuntu
  • *
  • Mensagens: 94
    • Ver perfil
Estou tendo problemas de atualização não somente do sistema como de todos os outros. Ele inicia a fazer a atualização mas chegando a metade dela, o processo congela, pensei que era devido ao tamanho dos arquivos e até já deixei o laptop ligado um dia inteiro mas de nada adiantou pois continuou parado no mesmo ponto todo o processo. Alguém poderia me ajudar?
Já tentei através do terminal:
$ sudo apt-get install -f
$ sudo apt-get upgrade -f
$ sudo apt-get dist-upgrade -f
$ sudo dpkg --configure -a
aptitude clean -f
aptitude autoremove
aptitude update
aptitude upgrade.
Mas a cada comando o erro era o mesmo:
Sub-process /usr/bin/dpkg returned an error code (1)
Agradeço pela ajuda que poderem me dar. Ah sim inicialmente todo o processo foi tentado através do aplicativo Software Gnome!
« Última modificação: 31 de Maio de 2017, 06:42 por maximus_7 »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.430
    • Ver perfil
Re:Problemas de atualização Ubuntu 16.04.2 LTS 64-bit(segunda vez que ocorre???)
« Resposta #1 Online: 01 de Junho de 2017, 19:53 »
Já tentou essa dica?

https://www.vivaolinux.com.br/dica/apt-E-Sub-process-usrbindpkg-returned-an-error-code-1-Resolvido

Eu só uso duas coisas para instalar, remover ou atualizar meu sistema, que são:  Synaptic e o bom e velho terminal!  Só! Nada de loja, boutique, shopping, feiras e afins!
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.068
    • Ver perfil
Re:Problemas de atualização Ubuntu 16.04.2 LTS 64-bit(segunda vez que ocorre???)
« Resposta #2 Online: 01 de Junho de 2017, 22:56 »
Já tentou essa dica?
https://www.vivaolinux.com.br/dica/apt-E-Sub-process-usrbindpkg-returned-an-error-code-1-Resolvido

Se me permitem,  dois centavos de contribuição ao tópico.

Sugiro que façamos uma reflexão quanto ao que é proposto naquele tópico lá no VOL, que na essência é apagar **integralmente** o conteúdo do diretório /var/lib/dpkg/info

Algum tempo atrás, meados de março próximo passado, num outro tópico, havia me manifestado a respeito disso, confira-se aqui, especialmente no post #6:

http://ubuntuforum-br.org/index.php/topic,121535.msg667716.html#msg667716

Os arquivos existentes dentro do diretório dpkg/info se constituem na base de dados que o dpkg usa para trabalhar.
Não parece prudente apagar indiscriminadamente aquele conteúdo, como é sugerido lá naquele tópico do VOL.

Isso parece querer curar a febre do paciente quebrando o termômetro.

Salvo engano, pode não ser por aí, mas seria interessante debatermos isso.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.068
    • Ver perfil
Re:Problemas de atualização Ubuntu 16.04.2 LTS 64-bit(segunda vez que ocorre???)
« Resposta #3 Online: 02 de Junho de 2017, 01:18 »
Apenas para ilustrar algumas das consequências, subindo um live-iso do Ubuntu padrão (=Unity), tornando-se root, apaguei totalmente o diretório /var/lib/dpkg/info como proposto lá no tópico do VOL.

Em seguida, usando o apt, instalei um pacote qualquer, no caso o htop, o qual cria arquivos naquele diretório, a saber:

format  htop.list  htop.md5sums

Nada obstante a instalação ocorra, a própria saída da instalação do htop, que seria algo trivial, já agora começa a ser problemática, enorme e confusa (eliminei um quilo e meio de linhas porque não consegue postar aqui no Fórum, de tão extensa que é "A mensagem excede o número máximo de caracteres permitido (20000 caracteres."), confira-se:

Código: [Selecionar]
ubuntu@ubuntu:~$ sudo apt install htop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  htop
0 upgraded, 1 newly installed, 0 to remove and 226 not upgraded.
Need to get 76.4 kB of archives.
After this operation, 215 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 htop amd64 2.0.1-1ubuntu1 [76.4 kB]
Fetched 76.4 kB in 0s (94.1 kB/s)
Selecting previously unselected package htop.
dpkg: warning: files list file for package 'fonts-sil-abyssinica' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'mokutil' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'thunderbird-locale-fr' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libatk-adaptor:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libvorbisfile3:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libquadmath0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libxkbfile1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'linux-sound-base' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'python-apt-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libgs9-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'language-pack-pt-base' missing; assuming package has no files currently installed
files currently installed
files currently installed
dpkg: warning: files list file for package 'imagemagick' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'lintian' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libhtml-form-perl' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'gedit' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'jayatana' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'netpbm' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'zenity-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libvisual-0.4-0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libice6:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'fwupd' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libegl1-mesa:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libtotem-plparser18:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'network-manager-pptp-gnome' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libpcap0.8:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'fwupdate' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'gir1.2-totem-plparser-1.0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libwayland-server0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'netbase' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libunity-protocol-private0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libxklavier16:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'qtdeclarative5-test-plugin:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'language-pack-it-base' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'liboxideqt-qmlplugin:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libsnmp-base' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libjpeg8:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xserver-xorg-video-qxl-hwe-16.04' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'python-talloc' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'gnome-session-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'adwaita-icon-theme' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'software-properties-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libdbusmenu-qt2:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'myspell-pt-pt' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'python-ldb' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libxcb-xkb1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libavahi-core7:amd64' missing; assuming package has no files currently installed
(Reading database ... 87 files and directories currently installed.)
Preparing to unpack .../htop_2.0.1-1ubuntu1_amd64.deb ...
Unpacking htop (2.0.1-1ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up htop (2.0.1-1ubuntu1) ...
ubuntu@ubuntu:~$


Repetindo apagar novamente o diretório /var/lib/dpkg/info (que agora só tem os arquivos de instalação do htop) e em seguida tentando desinstalar o htop resulta numa nova confusa saída (novamente eliminei um quilo e meio de linhas porque de novo não consegue postar aqui no Fórum, de tão extensa que é "A mensagem excede o número máximo de caracteres permitido (20000 caracteres.") e, pior ainda, apenas não desinstala:

Código: [Selecionar]
ubuntu@ubuntu:~$ sudo apt remove htop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  htop
0 upgraded, 0 newly installed, 1 to remove and 226 not upgraded.
After this operation, 215 kB disk space will be freed.
Do you want to continue? [Y/n] y
dpkg: warning: files list file for package 'fonts-sil-abyssinica' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'mokutil' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'thunderbird-locale-fr' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libatk-adaptor:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libvorbisfile3:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libquadmath0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libxkbfile1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'linux-sound-base' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libnm-glib-vpn1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'cpp' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'ubiquity-casper' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libwinpr-synch0.1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xserver-xorg-video-nouveau-hwe-16.04' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'lupin-casper' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'gstreamer1.0-clutter-3.0' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'a11y-profile-manager' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'fonts-tlwg-garuda' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libcairo2:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'console-setup' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libnss-mdns:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'gnome-accessibility-themes' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libsbc1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'language-pack-pt-base' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'gstreamer1.0-plugins-base:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libtinfo5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libapt-inst2.0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'kpartx-boot' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'usbmuxd' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libnotify4:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libgdbm3:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libnet-libidn-perl' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libwinpr-input0.1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libfontconfig1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'manpages' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libcairomm-1.0-1v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'perl-base' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libudev1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'gconf2-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'mountall' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'strace' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'python3-speechd' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libhybris' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libnettle6:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libreoffice-avmedia-backend-gstreamer' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libtdb1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libxinerama1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libgeocode-glib0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'language-pack-gnome-fr-base' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'aptdaemon-data' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'cpio' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libdee-1.0-4:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'wbritish' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libicu55:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'keyboard-configuration' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libappstream-glib8:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libpopt0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libsecret-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libwbclient0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'firefox-locale-ru' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libexiv2-14:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'xserver-xorg-video-radeon-hwe-16.04' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'qml-module-qtquick2:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'gnome-software-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'powermgmt-base' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'plymouth-theme-ubuntu-logo' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'wogerman' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libxcb-dri3-0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libatasmart4:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'kmod' missing; assuming package has no files currently installed
[...]
dpkg: warning: files list file for package 'adwaita-icon-theme' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'software-properties-common' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libdbusmenu-qt2:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'myspell-pt-pt' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'python-ldb' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libxcb-xkb1:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libavahi-core7:amd64' missing; assuming package has no files currently installed
(Reading database ... 81 files and directories currently installed.)
Removing htop (2.0.1-1ubuntu1) ...

Como dito, isso é apenas para ilustrar que pode não ser tão simples assim eliminar integralmente o conteúdo do diretório /var/lib/dpkg/info, pois pode acabar trazendo mais problema do que solução, desorganizando ainda mais a instalação.
« Última modificação: 02 de Junho de 2017, 01:22 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 945
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re:Problemas de atualização Ubuntu 16.04.2 LTS 64-bit(segunda vez que ocorre???)
« Resposta #4 Online: 02 de Junho de 2017, 15:04 »
Sub-process /usr/bin/dpkg returned an error code (1)

Coloque novamente o erro com no mínimo 10 a 20 linhas antes dele. Isso ajuda bastante.
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049