Autor Tópico: Problema com adaptador Wireless Tp-link  (Lida 313 vezes)

Offline Striker_Hero

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Problema com adaptador Wireless Tp-link
« Online: 20 de Maio de 2017, 15:01 »
Boa Tarde

Uso Ubuntu 16.04 LTS, 64 bit

Pluguei um adaptador wireless TP-link e não funcionou, então fui na internet pesquisar e depois de muito tentar e nada dar certo encontrei esse procedimento:
https://github.com/pvaret/rtl8192cu-fixes

Fiz e deu certo, funcionou normal.
Ocorre que depois de um tempo utilizando, do nada, a internet fica super lenta, (praticamente inoperante), no começo pensei que era instabilidade da rede, até reclamei com a operadora, mas na verdade é do PC mesmo, pois em outros aparelhos a internet está normal, além de eu estar usando uma conexão cabeada agora e estar normal (mesmo PC)
Se eu desconecto e conecto o adaptador dá pau, se eu reinicio o PC, às vezes ele volta funcionando normal, e cai depois de um tempo.
Notei que quando o iconezinho la em cima está aparecendo como conexão cabeada (apesar de estar na wireless) a internet funciona, e quando está com aqueles risquinhos típicos da wireless, não funciona.
Já rodei a internet inteira pesquisando e não consegui arrumar.
Alguém me ajuda plsss

sudo ifconfig
infos: enp2s0    Link encap:Ethernet  Endereço de HW 1c:1b:0d:61:a3:c8 
          inet end.: 192.168.5.101  Bcast:192.168.5.255  Masc:255.255.255.0
          endereço inet6: fe80::83f6:212b:f750:139e/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:395923 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:283129 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:548107680 (548.1 MB) TX bytes:25347337 (25.3 MB)
          IRQ:43 Endereço de E/S:0x8000

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:3834 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:3834 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1
          RX bytes:503705 (503.7 KB) TX bytes:503705 (503.7 KB)

wlx18a6f71754b4 Link encap:Ethernet  Endereço de HW 18:a6:f7:17:54:b4 
          inet end.: 192.168.5.102  Bcast:192.168.5.255  Masc:255.255.255.0
          endereço inet6: fe80::c4f6:9685:7cd5:3e33/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:93 erros:0 descartados:76 excesso:0 quadro:0
          Pacotes TX:61 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:23498 (23.4 KB) TX bytes:10412 (10.4 KB)


 lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 Graphics] (rev d6)
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri HDMI/DP Audio Controller
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1424
00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1424
00:03.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Root Port
00:03.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Root Port
00:04.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1424
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 09)
00:10.1 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 09)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 16)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 30h-3fh) Processor Function 5
01:00.0 USB controller: ASMedia Technology Inc. Device 1343
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.500
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #1 Online: 20 de Maio de 2017, 18:42 »
Olá @Striker_hero, execute os comandos abaixo com o seu adaptador plugado e funcionando, cole o resultado aqui.

sudo lshw -c network
iwconfig
nmcli dev wifi
lsusb


Quando o problema ocorrer, execute os comandos abaixo:

iwconfig
nmcli dev wifi
rfkill list wifi


Novamente, cole os resultados aqui pra gente comparar os resultados.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Striker_Hero

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #2 Online: 25 de Maio de 2017, 20:22 »
Segue:
Wireless normal
sudo lshw -c network
[sudo] senha para striker:
  *-network               
       descrição: Ethernet interface
       produto: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:02:00.0
       nome lógico: enp2s0
       versão: 0c
       serial: 1c:1b:0d:61:a3:c8
       tamanho: 10Mbit/s
       capacidade: 1Gbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.041.00-NAPI duplex=half latency=0 link=no multicast=yes port=twisted pair speed=10Mbit/s
       recursos: irq:43 porta de E/S:e000(tamanho=256) memória:fe900000-fe900fff memória:d0800000-d0803fff
  *-network
       descrição: Interface sem fio
       ID físico: 1
       informações do barramento: usb@4:3
       nome lógico: wlx18a6f71754b4
       serial: 18:a6:f7:17:54:b4
       capacidades: ethernet physical wireless
       configuração: broadcast=yes driver=rtl8192cu ip=192.168.5.102 multicast=yes wireless=IEEE 802.11bgn
striker@Ander:~$ iwconfig
enp2s0    no wireless extensions.

lo        no wireless extensions.

wlx18a6f71754b4  IEEE 802.11bgn  ESSID:"Striker"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1A:3F:88:A1:6E   
          Bit Rate:150 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=100/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

striker@Ander:~$ nmcli dev wifi
*  SSID     MODO   CANAL  TAXA       SINAL  BARRAS  SEGURANÇA
*  Striker  Infra  11     22 Mbit/s  100    ▂▄▆█    WPA2     
striker@Ander:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 007: ID 0781:5571 SanDisk Corp. Cruzer Fit
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 2357:0100 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse
Bus 003 Device 008: ID 1a2c:0e24 China Resource Semico Co., Ltd
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 011 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 010 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


wireless ruim (fica carregando por minutos, às vezes carrega a página, às vezes não)


striker@Ander:~$ iwconfig
enp2s0    no wireless extensions.

lo        no wireless extensions.

wlx18a6f71754b4  IEEE 802.11bgn  ESSID:"Striker"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1A:3F:88:A1:6E   
          Bit Rate:150 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=100/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

striker@Ander:~$ sudo lshw -c network
[sudo] senha para striker:
  *-network               
       descrição: Ethernet interface
       produto: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:02:00.0
       nome lógico: enp2s0
       versão: 0c
       serial: 1c:1b:0d:61:a3:c8
       tamanho: 10Mbit/s
       capacidade: 1Gbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.041.00-NAPI duplex=half latency=0 link=no multicast=yes port=twisted pair speed=10Mbit/s
       recursos: irq:44 porta de E/S:e000(tamanho=256) memória:fe900000-fe900fff memória:d0800000-d0803fff
  *-network
       descrição: Interface sem fio
       ID físico: 1
       informações do barramento: usb@1:4
       nome lógico: wlx18a6f71754b4
       serial: 18:a6:f7:17:54:b4
       capacidades: ethernet physical wireless
       configuração: broadcast=yes driver=rtl8192cu ip=192.168.5.102 multicast=yes wireless=IEEE 802.11bgn
striker@Ander:~$ nmcli dev wifi
*  SSID     MODO   CANAL  TAXA       SINAL  BARRAS  SEGURANÇA
*  Striker  Infra  11     22 Mbit/s  100    ▂▄▆█    WPA2     
striker@Ander:~$ rfkill list wifi


esse último comando não aparece nada no terminal...

Offline Striker_Hero

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #3 Online: 25 de Maio de 2017, 20:29 »
seguinte, depois de dar o problema eu despluguei o adaptador e pluguei novamente. voltou funcionando normal, mas houve uma mudança no ícone, antes aparecia o ícone com duas flexinhas (como se fosse conexão cabeada - e funcionava normal até dar o problema- ) agora voltou com os risquinhos típicos da wireless mesmo
no começo pensei que a origem do problema pudesse ser um mal contato no adaptador, ai qualquer encostada que eu dava nele poderia ocasionar o problema, mas não é isso. parece que dá problema do nada mesmo
« Última modificação: 25 de Maio de 2017, 20:31 por Striker_Hero »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.500
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #4 Online: 25 de Maio de 2017, 21:33 »
Quando você desplugou o adaptador e plugou de novo, usou a mesma porta USB?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Striker_Hero

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #5 Online: 25 de Maio de 2017, 22:17 »
Quando você desplugou o adaptador e plugou de novo, usou a mesma porta USB?

sim, e agora está difícil usar a internet. ora funciona um pouqinho, ora fica só carregando..

agora quando eu plugo e desplugo funciona alguns segundos e já fica travada de novo

pq não deu certo aquele ultimo comando?
« Última modificação: 25 de Maio de 2017, 22:19 por Striker_Hero »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.500
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #6 Online: 26 de Maio de 2017, 10:27 »
pq não deu certo aquele ultimo comando?
Pq esse adaptador externo não implementa a interface completa. O "rfkill" funciona melhor com a interface wireless onboard.

Um coisa que eu estou estranhando é que no primeiro comando "lshw -C network", apareceu uma indicação que o adaptador estava na porta usb@4:3. Mas logo em seguida, no "lsusb", o modem apareceu em "Bus 004 Device 002". Já na segunda consulta ao "lshw", apareceu como "usb@1:4". É como se vc tivesse trocado o aparelho de porta várias vezes... então talvez teu problema esteja na forma como o sistema está tratando as portas USB, e não na wireless em si.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.216
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #7 Online: 26 de Maio de 2017, 12:25 »
Está usando alguma das portas USB traseiras ou um USB frontal do Gabinete?
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline Striker_Hero

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #8 Online: 27 de Maio de 2017, 01:36 »
Está usando alguma das portas USB traseiras ou um USB frontal do Gabinete?

Estou usando porta USB traseira, mas já tentei usar a frontal também. Uma das frontais está com um pen drive.


striker@Ander:~$ sudo lshw -c network
[sudo] senha para striker:
  *-network               
       descrição: Ethernet interface
       produto: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:02:00.0
       nome lógico: enp2s0
       versão: 0c
       serial: 1c:1b:0d:61:a3:c8
       tamanho: 10Mbit/s
       capacidade: 1Gbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.041.00-NAPI duplex=half latency=0 link=no multicast=yes port=twisted pair speed=10Mbit/s
       recursos: irq:44 porta de E/S:e000(tamanho=256) memória:fe900000-fe900fff memória:d0800000-d0803fff
  *-network
       descrição: Interface sem fio
       ID físico: 1
       informações do barramento: usb@1:4
       nome lógico: wlx18a6f71754b4
       serial: 18:a6:f7:17:54:b4
       capacidades: ethernet physical wireless
       configuração: broadcast=yes driver=rtl8192cu ip=192.168.5.102 multicast=yes wireless=IEEE 802.11bgn
striker@Ander:~$ iwconfig
enp2s0    no wireless extensions.

lo        no wireless extensions.

wlx18a6f71754b4  IEEE 802.11bgn  ESSID:"Striker"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1A:3F:88:A1:6E   
          Bit Rate:150 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=100/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 
striker@Ander:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0781:5571 SanDisk Corp. Cruzer Fit
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 010: ID 2357:0100 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 019: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse
Bus 003 Device 021: ID 1a2c:0e24 China Resource Semico Co., Ltd
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 011 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 010 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

/\ é normal ficar tudo embaralhado assim? diferente dos outros de cima...

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.500
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #9 Online: 27 de Maio de 2017, 06:39 »
deixa eu mudar um pouco o rumo da conversa... já deu pra perceber que essa máquina é um desktop.
Pq ela está sendo usada com wireless, em vez de cabo?
E, se não há condição de usar cabo, pq não está com uma placa wireless PCI, em vez de um adaptador USB?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Striker_Hero

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Problema com adaptador Wireless Tp-link
« Resposta #10 Online: 27 de Maio de 2017, 12:02 »
deixa eu mudar um pouco o rumo da conversa... já deu pra perceber que essa máquina é um desktop.
Pq ela está sendo usada com wireless, em vez de cabo?
E, se não há condição de usar cabo, pq não está com uma placa wireless PCI, em vez de um adaptador USB?

Realmente, fica ruim puxar um cabo.
Confesso que nem sabia desse lance de placa wireless PCI.
Ainda bem que tu falou, pois já estava pensando em comprar um outro adaptador.. kkkk
Vou comprar uma dessas. Alguma dica de alguma que o Ubuntu já possua os drivers?