Autor Tópico: Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3 (RESOLVIDO)  (Lida 1141 vezes)

Offline tav

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Ola!
estive lendo o topico em busca de correção para o problema com libreoffice, pois foi feita uma atualização e o mesmo apresentava algumas falhas como ao clicar para selecionar uma celula não aparecia a marca de seleção a redor da mesma, assim tentei algumas reinstalações pelo terminal e acabei provocando esse erro apresentado no terminal.
/usr/lib/libreoffice/program/oosplash: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory

Preciso de uma ajuda pois uso no trabalho e outras pessoas estão precisando também.
agradeço.
« Última modificação: 03 de Maio de 2017, 19:39 por tav »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #1 Online: 29 de Abril de 2017, 19:52 »
Dividi o tópico!  Aquele já estava resolvido!  Seu erro é outro!

O que foi que vocẽ já fez?
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline tav

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #2 Online: 29 de Abril de 2017, 19:58 »
Opa! Obrigado.
Estava procurando um opção para reabri-lo.

Apliquei o procedimento descrito no tópico anterior, também já desinstalei pela central de programas e reinstalei pelo mesmo, também fiz o procedimento pelo terminal usando os métodos de purgar (sudo apt-get purge libreoffice*) (apt-get remove --purge libreoffice)  e atualizar o cache do apt-get (apt-cache search libreoffice), métodos que googlei.
Alguns pedem para atualizar, instalar esta biblioteca  libuno_sal.so.3 mas não encontrei como faço, como neste forum https://www.vivaolinux.com.br/topico/LibreOffice/Libreoffice-nao-inicia

abraço.
« Última modificação: 29 de Abril de 2017, 20:08 por tav »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #3 Online: 29 de Abril de 2017, 20:17 »
Tá bem estranho esse erro. Tudo que encontro é sobre versões antigas do LibreOffice, versão 3.0 e mais relacionada com distros baseadas em .rpm .

Você instalou esse LibreOffice como?

Então você remove tudo e não dá  nenhum erro. Reinstala tudo e não dá nenhum erro. Mas na hora de abrir o programa toda vez mostra o erro:
/usr/lib/libreoffice/program/oosplash: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory


É isso?
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline tav

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #4 Online: 30 de Abril de 2017, 13:53 »
Olá Galactus!
Uma das tentativas de instalação foi por este link http://softwarelivre.org/negromonte/comunidade-linux-sempreupdate/como-instalar-o-libreoffice-5.0.2-no-ubuntu-linux-mint-duzeru-kaiana-e-derivados, baseado em pacotes .deb outras foi utilizando passo a passo do blog do Edivaldo neste link http://www.edivaldobrito.com.br/libreoffice-no-linux/ outras pelo próprio instaldor de programas do ubuntu.

Quanto a remover é isso ai não apresenta erro e na reinstalação não apresenta erro, pelo menos não tenho percebido. Quando abro o programa ele fica como carregando e depois some sem iniciar, alguem indicou iniciar pelo terminal para ver a mensagem de erro foi ai que descobri essa msg da falta de biblioteca libuno_sal.so.3

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #5 Online: 30 de Abril de 2017, 21:00 »
Eu já tava desconfiado mesmo!

Você está baixando uma versão fora dos repositórios e pior, instalando um pacote .rpm numa distro .deb!

A versão que vem no Ubuntu não serve?

Tem que remover tudo dessas instalações fora do repositório e tentar voltar para versão oficial do repositório.

Esse erro acontece muito exatamente nesses dois casos: 1) instalação fora do repositório e 2) Esse erro da biblioteca libuno_sal.so.3 é de conflito das bibliotecas 32bits rodando em sistema 64 bits .rpm! Pode pesquisar na sua lista de repositório, não existe esse pacote libuno_sal.so.3!  Ele é de distros .rpm!
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline tav

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #6 Online: 01 de Maio de 2017, 11:17 »
A versão serve sim, o caso é que teve uma atualização e como disse apresentou um problema que não mostrava a seleção de celula em uma planilha, aquelas bordas mais escuras e clica para arrastar uma seleção, ai fui tentar reinstalar para ver se corrigia e comecei a ter a dor de cabeça.
Mas bem, leite derramado não se chora, como limpo tudo, usando os comandos para purgar ou tem algum outro metodo, se puder poste o passo como faço.
Agradeço.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #7 Online: 01 de Maio de 2017, 18:41 »
Código: [Selecionar]
sudo apt-get remove --purge libreoffice*

sudo apt-get clean

sudo apt-get autoremove

sudo apt-get install libreoffice
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline tav

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #8 Online: 02 de Maio de 2017, 07:26 »
Bom dia galactus!
apliquei os procedimentos descrito, mas não resolveu. Continua do mesmo jeito e apresenta a mesma mensagem da biblioteca libuno_sal.so.3.
O que posso tentar mais?

Offline tav

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #9 Online: 02 de Maio de 2017, 09:16 »
opa! fiz mais algumas pesquisas no google e vi em um forum do Linux Mint falando sobre o problema e que conseguiu instalar novamente usando os pacotes .deb do proprio site do libreoffice, então como estou precisando para o trabalho tentei reinstalar usando os pacotes do libreoffice e consegui instalar, so que continua com o problema de não aparecer a alça de seleção da celula para arrastar. Mas serve para ir trabalhando. Se souber como resolver este problema?

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.526
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3
« Resposta #10 Online: 02 de Maio de 2017, 14:57 »
Não sei do que se trata esse erro. Não uso o Calc.  Mas para selecionar várias células não precisa selecionar uma e segurar o SHIFT junto com o botão esquerdo do MOUSE?

Favor colocar um resolvido então no tópico!

Melhor você explicar direito como conseguiu resolver o erro do libuno_sal.so.3, para quem tiver o mesmo problema resolver mais rápido.
OpenSuse  42.3 64bits / Windows 10 64bits - PC * CentOS 7 64bits Servidor Samba/DNS * MacOS High Sierra * Kbuntu 17.10 64bits - Note1 * Ubuntu 17.10 64bits - Note 2

Offline tav

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Libreoffice 5 não abre no Ubuntu 16.04 LTS erro com libuno_sal.so.3 RESOLVIDO
« Resposta #11 Online: 02 de Maio de 2017, 17:30 »
Esta seleção é útil para copiar formatos e outros.

Quanto ao passo para resolver é o seguinte:

Baixar o pacote .deb direto do site libreoffice e seguir os procedimentos de instalação do proprio site libreoffice.

obrigado pela ajuda.