Autor Tópico: Vpython 6  (Lida 345 vezes)

Offline larag

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Vpython 6
« Online: 25 de Março de 2017, 19:41 »
Prezados, boa noite.

Sou usuária do Ubuntu 14.06 e do Vpythpn. Gostaria de instalar o VPython 6 (http://vpython.org/contents/download_linux.html). Tentei seguir a "receita " descrita no enderenço:
     https://github.com/katanachan/installer/blob/master/VisualPythonInstaller.sh

Obtive a seguinte mensagem de erro:
wxPython-src-2.9.5.0.patch
./VisualPythonInstaller.sh: 95: cd: can't cd to vpython-wx-src.6.11/
Traceback (most recent call last):
  File "setup.py", line 51, in <module>
    raise RuntimeError("Sorry.. you need to install wxPython (at least 2.9.x) to build this version of vpython")

O objetivo da mensagem é averiguar se algum usuário domina a técnica de instalação do Vpython 6.

Agradeço pela atenção.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.291
    • Ver perfil
Re:Vpython 6
« Resposta #1 Online: 26 de Março de 2017, 01:40 »
Sou usuária do Ubuntu 14.06 e do Vpythpn. [...]

Há um possível erro de digitação no seu post inicial vez que Ubuntu 14.06 não existe, muito possivelmente será o Ubuntu 14.04, porém é importante confirmar já que o script do indiano Aishwarya Unnikrishnan, que você referencia e está no github katanachan, para fazer a instalação do VisualPython, faz expressamente uma restrição ao Ubuntu 14.04, Trusty, dizendo que para ele não deu certo nessa versão usando o apt-get.

Via apt-get, this works on Xenial and Utopic, did not work for me when I was using Trusty

Daí que é importante saber exatamente qual é a versão instalada do seu Ubuntu, para que se possa escolher o método conforme.

« Última modificação: 26 de Março de 2017, 01:43 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.291
    • Ver perfil
Re:Vpython 6
« Resposta #2 Online: 26 de Março de 2017, 02:21 »
Apenas para contextualizar, o VisualPython (vpython-wx) está no github em:

https://github.com/BruceSherwood/vpython-wx/blob/master/INSTALL.txt


Ele próprio indica através de um link o script github katanachan como uma hipótese possível para a instalação, que é o que você está seguindo:

https://github.com/katanachan/installer

O script, embora sem dúvida útil já que indica um roteiro, é um pouco confuso.

Consegui instalar no Ubuntu l6.04.2 Xenial e no 16.10 Yakkety, que é o que estava aqui á mão, usando exclusivamente o apt.
Funcionou, apesar de alguns dribles.





Depois, mais tarde, irei tentar instalar usando o Ubuntu 14.04, Trusty.

Embora muito possivelmente não seja direta e imediatamente útil para você, já que fiz e para não perder a viagem, permita-me registrar aqui algumas observações que eventualmente podem ser úteis para alguém que tenha o Ubuntu 16.04 Xenial ou o 16.10 Yakkety e queira igualmente instalar usando o método do apt-get.

1) A primeira parte do script é confusa, esqueça aquilo, o que ele quiz dizer ainda que de uma forma complicada, é que o repositório universe precisa estar habilitado.

Apenas vá pela interface gráfica da forma habitual em:

Citar
Configurações do sistema/Programas e atualizações/Aplicativos Ubuntu

ou então mais diretamente, fazendo numa janela de terminal:

Código: [Selecionar]
sudo software-properties-gtk
E certificando-se que estejam devidamente assinalados os checkbox:

main universe restricted multiverse

Na verdade precisa mesmo é do main e do universe, mas geralmente se deixa os quatro assinalados.

É verdade que ele diz lá no início "Changes for different distros", mas o fato é que mais confundiu do que ajudou.

Aproveite dessa primeira parte apenas as indicações do que deve ser inicialmente instalado:

Evidentemente vamos sempre supor que seu sistema está devidamente atualizado:

sudo apt update

sudo apt upgrade

Os dois comandos acima devem terminar sem erros de quaisquer espécie.

Isso posto, a parte aproveitável são essas instalações iniciais de dependências:

sudo apt-get install libwxgtk3.0-dev

sudo apt-get install virtualenv swig build-essential python-dev

sudo apt-get install python-wxgtk3.0 python wxgtk3.0-dev

Descarte o restante

2) Todo o bloco 1 e 2 que estão indicados para eventual Uncomment (=descomentar) caso necessário, evidentemente não se aplica a quem vai fazer a instalação usando o apt-get;

3) O restante é apenas ir executando, vai sem problemas, embora pessoalmente ao invés de fazer isso em cd ~/ prefiro fazer dentro de ~/Downloads e, melhor ainda, em algum diretório especialmente criado para isso dentro de ~/Downloads, para não deixar "resíduos" post instalação e ficar mais fácil de remover.

Assim, uma boa prática é, por exemplo, algo assim:

mkdir ~/Downloads/vphyton

cd ~/Downloads/vphyton

Então lá no script onde estiver cd ~/ entenda como cd ~/Downloads/vphyton

4) Na linha 74 aquilo de usar o pip é desnecessário, instale usando o apt-get mesmo já que a biblioteca fonttools está disponível no repositório padrão e a ferramenta padrão é o apt-get e não o pip, portanto facilite a vida fazendo:

sudo apt install fonttools


5) A linha 95 vai dar um erro porque ao descompactar o .tgz não foi criado aquele diretório assinalado e na verdade nem mesmo é preciso.

Assegurando-se estar dentro do diretório onde .tgz foi baixado, o que é evidentemente para poder executar, apenas comente a linha 95 omitindo-a, por desnecessário:

#cd vpython-wx-src.6.11/

Se quiser mesmo individualizar essa parte do processamento, que é a mais pesada da instalação, já que faz a compilação propriamente dita, então use assim, considerando o bloco como um todo (93 em diante):

mkdir ~/Downloads/vphyton/vpython-wx-src.6.11/

cd ~/Downloads/vphyton/vpython-wx-src.6.11/

wget http://sourceforge.net/projects/vpythonwx/files/6.11-release/vpython-wx-src.6.11.tgz

tar -xvzf vpython-wx-src.6.11.tgz

python setup.py build && sudo python setup.py install


6) Não está no script, porém será necessário, sem o que irá dar erro ao iniciar, então instale também o pacote:

sudo apt install python-tk

7) Ao executar para abrir a IDE note que o comando que ele indica na verdade não tem aquele (.) ponto no final, aquilo é apenas ponto de acentuação da frase e não do comando, entretanto, induz à erro, logo, considere apenas:

sudo python2.7 /usr/local/lib/python2.7/dist-packages/VPython-6.11-py2.7-linux-x86_64.egg/vidle/idle.py

Aqui funcionou, como disse, na versão Ubuntu 16.04 e 16.10 usando o apt-get como método de instalação.
Vou tentar agora com o Trusty e vamos ver o que dá.  :)

« Última modificação: 26 de Março de 2017, 05:10 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.291
    • Ver perfil
Re:Vpython 6
« Resposta #3 Online: 26 de Março de 2017, 04:44 »
Na essência dessa forma para Ubuntu 16.04.2 Xenial e 16.10 Yakkety .
Se for transformar em script não esqueça de atribuir permissão para executar.

chmod +x nome_do_scrip.sh


Código: [Selecionar]
#!/bin/sh

#title       : vpythonlinuxinstall-ubuntubr-larag.sh
#description : A shell script to install VPython on Linux
#author      : Aishwarya Unnikrishnan (github.com/katanachan)
#email id    : shwarya.unnikrishnan@gmail.com
#github      : https://github.com/katanachan/installer/blob/master/VisualPythonInstaller.sh
#initial     : https://github.com/BruceSherwood/vpython-wx/blob/master/INSTALL.txt
#rewritten   : druidaobelix-Forum Ubuntu-BR
#topic       : http://ubuntuforum-br.org/index.php/topic,121607.msg668252.html#msg668252
#author topic: larag
#date        : 2017-03-26
#scope       : only tested on Ubuntu 16.04.2 Xenial and 16.10 Yakkety - Unity
#method      : using package manager apt-get
##usage      : sudo bash vpythonlinuxinstall-ubuntubr-larag.sh or sudo ./vpythonlinuxinstall-ubuntubr-larag.sh

echo "Instala VisualPython"
echo "Testado apenas no Ubuntu 16.04.2 Xenial e 16.10 Yakkety -Unity- em 2017/mar/26"
echo "Usa o método de instalação através do apt-get"
echo "Habilite o repositório universe"
echo
echo "Tecle <enter> para continuar e iniciar a instalação"
echo "ou use as teclas Ctrl C para abortar"

(   trap "stty $(stty -g;stty -icanon)" EXIT
    LC_ALL=C dd bs=1 count=1 >/dev/null 2>&1
)   </dev/tty

echo
echo "Iniciando a instalação..."
echo


echo
echo "Instalando dependências iniciais..."
echo

apt install -y libwxgtk3.0-dev

apt install -y virtualenv swig build-essential python-dev

apt install -y python-wxgtk3.0 python wxgtk3.0-dev

mkdir ~/Downloads/vphyton

cd ~/Downloads/vphyton

echo
echo "instalando bloco 01..."
echo

wget https://pypi.python.org/packages/dd/69/a6d5ba016f4e15a83e49471bcf91a7b8fbdf818e5acb002f554027d47650/TTFQuery-1.0.5.tar.gz
tar -xvzf TTFQuery-1.0.5.tar.gz
cd ~/Downloads/vphyton/TTFQuery-1.0.5/
python setup.py build && python setup.py install

echo
echo "instalando dependência complementar fonttools..."
echo

apt install -y fonttools

echo
echo "instalando bloco 02..."
echo

wget https://pypi.python.org/packages/73/9e/fe761e03de28b51b445ddf01ddae87441b7e7040df7d830b86db8f945808/Polygon2-2.0.8.tar.gz#md5=3349a6dfc4cda2a1bcc9bf6c9d411470
tar -xvzf Polygon2-2.0.8.tar.gz
cd ~/Downloads/vphyton/Polygon2-2.0.8/
python setup.py build && python setup.py install

echo
echo "instalando bloco 03..."
echo

cd ~/Downloads/vphyton
apt install -y git
apt install -y libgtk2.0-dev
apt install -y libgtkglextmm-x11-1.2-dev
apt install -y libgtkmm-2.4-dev
apt install -y python-setuptools
apt install -y python-numpy
apt install -y libboost-python-dev
apt install -y libboost-signals-dev
apt install -y tk

echo
echo "instalando bloco 04..."
echo

mkdir ~/Downloads/vphyton/vpython-wx-src.6.11/
cd ~/Downloads/vphyton/vpython-wx-src.6.11/
wget http://sourceforge.net/projects/vpythonwx/files/6.11-release/vpython-wx-src.6.11.tgz
tar -xvzf vpython-wx-src.6.11.tgz
python setup.py build && python setup.py install

echo
echo "instalando dependência final para executar..."
echo

apt install -y python-tk

echo
echo "para utilizar chame a IDE através do seguinte comando:"
echo "sudo python2.7 /usr/local/lib/python2.7/dist-packages/VPython-6.11-py2.7-linux-x86_64.egg/vidle/idle.py"
echo "Melhores informações em:"
echo "http://ubuntuforum-br.org/index.php/topic,121607.msg668252.html#msg668252"
echo "Você pode criar um ícone para isso e colocar no Desktop"
echo "Autorizando a execução do ícone no sudoers"
echo "Enjoy!"
echo
« Última modificação: 26 de Março de 2017, 05:15 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline larag

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:Vpython 6
« Resposta #4 Online: 26 de Março de 2017, 19:01 »
Agradeço muitíssimo pelas informações detalhadas e compreensíveis. Fiz todos os passos sugeridos. Houve apenas um problema:
tests/test_installation.py
wxPython-src-2.9.5.0.patch
Traceback (most recent call last):
  File "setup.py", line 51, in <module>
    raise RuntimeError("Sorry.. you need to install wxPython (at least 2.9.x) to build this version of vpython")
RuntimeError: Sorry.. you need to install wxPython (at least 2.9.x) to build this version of vpython

Acredito que tenha que baixar wxPython3.0 ou tentar (antes de prosseguir) acessar o repositório de uma versão mais nova do ubuntu. Gostaria de sua opinião sobre isso.

Agradeço por sua dedicação e paciência.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.291
    • Ver perfil
Re:Vpython 6
« Resposta #5 Online: 26 de Março de 2017, 19:46 »
A boa notícia é que deu certo também instalar no Ubuntu 14.04, Trusty, usando o release 5 (Ubuntu 14.04.5), com o kernel 4.4.0-31 (fiz num live-iso), porém o método é outro, não dá para seguir aquele roteiro da versão 16.04/16.10.

O problema é que me perdi nas anotações depois de tantas idas e vindas e vou ter que refazer para fixar um roteiro, mas o fato é que está funcionando também na 14.04, só que não dá para usar exclusivamente o apt-get, precisa combinar com os comandos do bloco 1 do script do katanachan (linhas 35 à 49), mas agora é uma questão de fixar, se deu certo uma vez, com método será possível refazer e fixar o caminho correto para instalar.

Agora um detalhe importante, você não disse qual é realmente a versão do Ubuntu que está usando, pois como anotei antes, no seu post inicial consta 14.06 e versão 14.06 não existe no Ubuntu.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.291
    • Ver perfil
Re:Vpython 6
« Resposta #6 Online: 26 de Março de 2017, 19:55 »
Acredito que tenha que baixar wxPython3.0 ou tentar (antes de prosseguir) acessar o repositório de uma versão mais nova do ubuntu. Gostaria de sua opinião sobre isso.

Então, "larag",

Esse é o ponto, dependendo de qual versão do Ubuntu você esteja usando (possivelmente a 14.04), não dá para baixar e instalar a biblioteca wxPython3.0, isso não dá certo dessa forma, vira um emaranhado de dependências que não se resolve sem quebrar sistema ou pelo menos com uma ginástica descomunal para contornar a situação via apt-get.

Daí que, por isso mesmo, o autor do script, o katanachan, colocou a opção de instalar uma parte via arquivos tar.bz2, ou seja, exatamente para sair fora das inconsistências das dependências no apt-get.

A questão que precisa ser entendida nas distribuições Linux em geral e em especial no Ubuntu, é que o sistema é pensado como um conjunto orgânico de dependências e pacotes de aplicativos, isto é, o pacote de aplicativos tem como base a específica versão do sistema operacional, o que significa que nem sempre dará para simplesmente mudar de versão do aplicativo.

É um "ecossistema" criado que envolve as bibliotecas do sistema operacional e os requerimentos dos softwares aplicativos.

Essa versão que você está querendo instalar no VPython não é a mais adequada para o ambiente do Ubuntu 14.04 Trusty.

Dá para instalar, pois positivamente consegui instalar aqui, porém o malabarismo é decorrente exatamente desse descasamento.

Mas vamos lá, vou refazer aqui para conseguir fixar um roteiro prático de instalação.

Se deu certo uma vez tem que dar certo de novo, não é mesmo?  :)


« Última modificação: 26 de Março de 2017, 20:01 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.